You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
43 lines
1.3 KiB
43 lines
1.3 KiB
--- src/Makefile 2008-03-09 22:59:51.000000000 +0100
|
|
+++ src/Makefile.new 2009-04-09 12:31:38.669457918 +0200
|
|
@@ -6,9 +6,7 @@
|
|
#### CFLAGS Flags to pass to C compiler.
|
|
|
|
INCDIR = .
|
|
-CC = cc
|
|
|
|
-CFLAGS = -O
|
|
LIBS = -lm
|
|
|
|
all: psipred psipass2 seq2mtx pfilt
|
|
@@ -20,13 +18,13 @@
|
|
/bin/rm -f psipred psipass2 seq2mtx pfilt
|
|
|
|
psipred: sspred_avpred.c ssdefs.h sspred_net.h
|
|
- $(CC) $(CFLAGS) sspred_avpred.c $(LIBS) -o psipred
|
|
+ $(CC) $(CFLAGS) $(LDFLAGS) sspred_avpred.c $(LIBS) -o psipred
|
|
|
|
psipass2: sspred_hmulti.c ssdefs.h sspred_net2.h
|
|
- $(CC) $(CFLAGS) sspred_hmulti.c $(LIBS) -o psipass2
|
|
+ $(CC) $(CFLAGS) $(LDFLAGS) sspred_hmulti.c $(LIBS) -o psipass2
|
|
|
|
seq2mtx: seq2mtx.c
|
|
- $(CC) $(CFLAGS) seq2mtx.c $(LIBS) -o seq2mtx
|
|
+ $(CC) $(CFLAGS) $(LDFLAGS) seq2mtx.c $(LIBS) -o seq2mtx
|
|
|
|
pfilt: pfilt.c
|
|
- $(CC) $(CFLAGS) pfilt.c $(LIBS) -o pfilt
|
|
+ $(CC) $(CFLAGS) $(LDFLAGS) pfilt.c $(LIBS) -o pfilt
|
|
--- src/Makefile 2009-04-09 12:34:41.636939862 +0200
|
|
+++ src/Makefile.new 2009-04-09 12:36:03.796098341 +0200
|
|
@@ -12,7 +12,8 @@
|
|
all: psipred psipass2 seq2mtx pfilt
|
|
|
|
install:
|
|
- /bin/cp psipred psipass2 seq2mtx pfilt ../bin
|
|
+ /bin/mkdir -p $(DESTDIR)/usr/bin
|
|
+ /bin/cp psipred psipass2 seq2mtx pfilt $(DESTDIR)/usr/bin
|
|
|
|
clean:
|
|
/bin/rm -f psipred psipass2 seq2mtx pfilt
|