220 lines
8.6 KiB
Diff
220 lines
8.6 KiB
Diff
# Fix gcc-4.6
|
|
diff -ur xen-4.2.0.orig/extras/mini-os/minios.mk xen-4.2.0/extras/mini-os/minios.mk
|
|
--- extras/mini-os/minios.mk 2012-09-17 18:21:17.000000000 +0800
|
|
+++ extras/mini-os/minios.mk 2012-12-05 14:01:10.653260260 +0800
|
|
@@ -6,7 +6,7 @@
|
|
|
|
# Define some default flags.
|
|
# NB. '-Wcast-qual' is nasty, so I omitted it.
|
|
-DEF_CFLAGS += -fno-builtin -Wall -Werror -Wredundant-decls -Wno-format -Wno-redundant-decls
|
|
+DEF_CFLAGS += -fno-builtin -Wall -Wredundant-decls -Wno-format -Wno-redundant-decls
|
|
DEF_CFLAGS += $(call cc-option,$(CC),-fno-stack-protector,)
|
|
DEF_CFLAGS += $(call cc-option,$(CC),-fgnu89-inline)
|
|
DEF_CFLAGS += -Wstrict-prototypes -Wnested-externs -Wpointer-arith -Winline
|
|
diff -ur xen-4.2.0.orig/tools/libxc/Makefile xen-4.2.0/tools/libxc/Makefile
|
|
--- tools/libxc/Makefile 2012-09-17 18:21:18.000000000 +0800
|
|
+++ tools/libxc/Makefile 2012-12-05 14:01:10.653260260 +0800
|
|
@@ -85,7 +85,7 @@
|
|
|
|
-include $(XEN_TARGET_ARCH)/Makefile
|
|
|
|
-CFLAGS += -Werror -Wmissing-prototypes
|
|
+CFLAGS += -Wmissing-prototypes
|
|
CFLAGS += -I. $(CFLAGS_xeninclude)
|
|
|
|
# Needed for posix_fadvise64() in xc_linux.c
|
|
# Drop .config
|
|
diff -ur xen-4.2.0.orig/Config.mk xen-4.2.0/Config.mk
|
|
--- Config.mk 2012-09-17 18:23:12.000000000 +0800
|
|
+++ Config.mk 2012-12-05 14:01:10.641260261 +0800
|
|
@@ -7,7 +7,6 @@ Drop .config
|
|
# fallback for older make
|
|
realpath = $(wildcard $(foreach file,$(1),$(shell cd -P $(dir $(file)) && echo "$$PWD/$(notdir $(file))")))
|
|
|
|
--include $(XEN_ROOT)/.config
|
|
|
|
# A debug build of Xen and tools?
|
|
debug ?= n
|
|
@@ -24,7 +24,7 @@
|
|
|
|
# Tools to run on system hosting the build
|
|
HOSTCC = gcc
|
|
-HOSTCFLAGS = -Wall -Werror -Wstrict-prototypes -O2 -fomit-frame-pointer
|
|
+HOSTCFLAGS = -Wstrict-prototypes -O2 -fomit-frame-pointer
|
|
HOSTCFLAGS += -fno-strict-aliasing
|
|
|
|
DISTDIR ?= $(XEN_ROOT)/dist
|
|
@@ -156,7 +156,7 @@
|
|
|
|
CFLAGS += -std=gnu99
|
|
|
|
-CFLAGS += -Wall -Wstrict-prototypes
|
|
+CFLAGS += -Wstrict-prototypes
|
|
|
|
# Clang complains about macros that expand to 'if ( ( foo == bar ) ) ...'
|
|
# and is over-zealous with the printf format lint
|
|
diff -ur xen-4.2.1.orig/tools/blktap2/drivers/Makefile xen-4.2.1/tools/blktap2/drivers/Makefile
|
|
--- tools/blktap2/drivers/Makefile 2012-12-17 23:00:11.000000000 +0800
|
|
+++ tools/blktap2/drivers/Makefile 2013-01-30 12:31:43.539941099 +0800
|
|
@@ -9,7 +9,7 @@
|
|
LOCK_UTIL = lock-util
|
|
INST_DIR = $(SBINDIR)
|
|
|
|
-CFLAGS += -Werror -g
|
|
+CFLAGS += -g
|
|
CFLAGS += -Wno-unused
|
|
CFLAGS += -fno-strict-aliasing
|
|
CFLAGS += -I$(BLKTAP_ROOT)/include -I$(BLKTAP_ROOT)/drivers
|
|
diff -ur xen-4.2.1.orig/tools/debugger/gdbsx/Rules.mk xen-4.2.1/tools/debugger/gdbsx/Rules.mk
|
|
--- tools/debugger/gdbsx/Rules.mk 2012-12-17 23:00:22.000000000 +0800
|
|
+++ tools/debugger/gdbsx/Rules.mk 2013-01-30 12:31:43.516941098 +0800
|
|
@@ -1,4 +1,4 @@
|
|
include $(XEN_ROOT)/tools/Rules.mk
|
|
|
|
-CFLAGS += -Werror -Wmissing-prototypes
|
|
+CFLAGS += -Wmissing-prototypes
|
|
# (gcc 4.3x and later) -Wconversion -Wno-sign-conversion
|
|
diff -ur xen-4.2.1.orig/tools/libaio/harness/Makefile xen-4.2.1/tools/libaio/harness/Makefile
|
|
--- tools/libaio/harness/Makefile 2012-12-17 23:00:35.000000000 +0800
|
|
+++ tools/libaio/harness/Makefile 2013-01-30 12:31:43.541941099 +0800
|
|
@@ -4,7 +4,7 @@
|
|
HARNESS_SRCS:=main.c
|
|
# io_queue.c
|
|
|
|
-CFLAGS=-Wall -Werror -g -O -laio
|
|
+CFLAGS=-Wall -g -O -laio
|
|
#-lpthread -lrt
|
|
|
|
all: $(PROGS)
|
|
diff -ur xen-4.2.1.orig/tools/libfsimage/Rules.mk xen-4.2.1/tools/libfsimage/Rules.mk
|
|
--- tools/libfsimage/Rules.mk 2012-12-17 23:00:36.000000000 +0800
|
|
+++ tools/libfsimage/Rules.mk 2013-01-30 12:31:43.515941097 +0800
|
|
@@ -1,7 +1,7 @@
|
|
include $(XEN_ROOT)/tools/Rules.mk
|
|
|
|
CFLAGS += -Wno-unknown-pragmas -I$(XEN_ROOT)/tools/libfsimage/common/ -DFSIMAGE_FSDIR=\"$(FSDIR)\"
|
|
-CFLAGS += -Werror -D_GNU_SOURCE
|
|
+CFLAGS += -D_GNU_SOURCE
|
|
LDFLAGS += -L../common/
|
|
|
|
PIC_OBJS := $(patsubst %.c,%.opic,$(LIB_SRCS-y))
|
|
diff -ur xen-4.2.1.orig/tools/libxl/Makefile xen-4.2.1/tools/libxl/Makefile
|
|
--- tools/libxl/Makefile 2012-12-17 23:01:08.000000000 +0800
|
|
+++ tools/libxl/Makefile 2013-01-30 12:31:43.541941099 +0800
|
|
@@ -11,7 +11,7 @@
|
|
XLUMAJOR = 1.0
|
|
XLUMINOR = 1
|
|
|
|
-CFLAGS += -Werror -Wno-format-zero-length -Wmissing-declarations \
|
|
+CFLAGS += -Wno-format-zero-length -Wmissing-declarations \
|
|
-Wno-declaration-after-statement -Wformat-nonliteral
|
|
CFLAGS += -I. -fPIC
|
|
|
|
diff -ur xen-4.2.1.orig/tools/qemu-xen/pc-bios/optionrom/Makefile xen-4.2.1/tools/qemu-xen/pc-bios/optionrom/Makefile
|
|
--- tools/qemu-xen/pc-bios/optionrom/Makefile 2012-09-11 02:10:52.000000000 +0800
|
|
+++ tools/qemu-xen/pc-bios/optionrom/Makefile 2013-01-30 12:31:43.528941098 +0800
|
|
@@ -9,7 +9,7 @@
|
|
|
|
.PHONY : all clean build-all
|
|
|
|
-CFLAGS := -Wall -Wstrict-prototypes -Werror -fomit-frame-pointer -fno-builtin
|
|
+CFLAGS := -Wall -Wstrict-prototypes -fomit-frame-pointer -fno-builtin
|
|
CFLAGS += -I$(SRC_PATH)
|
|
CFLAGS += $(call cc-option, $(CFLAGS), -fno-stack-protector)
|
|
QEMU_CFLAGS = $(CFLAGS)
|
|
diff -ur xen-4.2.1.orig/tools/xenstat/xentop/Makefile xen-4.2.1/tools/xenstat/xentop/Makefile
|
|
--- tools/xenstat/xentop/Makefile 2012-12-17 23:01:35.000000000 +0800
|
|
+++ tools/xenstat/xentop/Makefile 2013-01-30 12:31:43.535941098 +0800
|
|
@@ -18,7 +18,7 @@
|
|
all install xentop:
|
|
else
|
|
|
|
-CFLAGS += -DGCC_PRINTF -Wall -Werror $(CFLAGS_libxenstat)
|
|
+CFLAGS += -DGCC_PRINTF -Wall $(CFLAGS_libxenstat)
|
|
LDLIBS += $(LDLIBS_libxenstat) $(CURSES_LIBS) $(SOCKET_LIBS)
|
|
CFLAGS += -DHOST_$(XEN_OS)
|
|
|
|
diff -ur xen-4.2.1.orig/xen/arch/arm/Rules.mk xen-4.2.1/xen/arch/arm/Rules.mk
|
|
--- xen/arch/arm/Rules.mk 2012-12-17 23:01:37.000000000 +0800
|
|
+++ xen/arch/arm/Rules.mk 2013-01-30 12:31:43.498941097 +0800
|
|
@@ -9,7 +9,7 @@
|
|
HAS_DEVICE_TREE := y
|
|
|
|
CFLAGS += -fno-builtin -fno-common -Wredundant-decls
|
|
-CFLAGS += -iwithprefix include -Werror -Wno-pointer-arith -pipe
|
|
+CFLAGS += -iwithprefix include -Wno-pointer-arith -pipe
|
|
CFLAGS += -I$(BASEDIR)/include
|
|
|
|
# Prevent floating-point variables from creeping into Xen.
|
|
diff -ur xen-4.2.1.orig/xen/arch/x86/Rules.mk xen-4.2.1/xen/arch/x86/Rules.mk
|
|
--- xen/arch/x86/Rules.mk 2012-12-17 23:01:37.000000000 +0800
|
|
+++ xen/arch/x86/Rules.mk 2013-01-30 12:31:43.490941096 +0800
|
|
@@ -24,7 +24,7 @@
|
|
endif
|
|
|
|
CFLAGS += -fno-builtin -fno-common -Wredundant-decls
|
|
-CFLAGS += -iwithprefix include -Werror -Wno-pointer-arith -pipe
|
|
+CFLAGS += -iwithprefix include -Wno-pointer-arith -pipe
|
|
CFLAGS += -I$(BASEDIR)/include
|
|
CFLAGS += -I$(BASEDIR)/include/asm-x86/mach-generic
|
|
CFLAGS += -I$(BASEDIR)/include/asm-x86/mach-default
|
|
diff -ur xen-4.2.1.orig/xen/include/Makefile xen-4.2.1/xen/include/Makefile
|
|
--- xen/include/Makefile 2012-12-17 23:01:55.000000000 +0800
|
|
+++ xen/include/Makefile 2013-01-30 12:31:43.502941097 +0800
|
|
@@ -78,7 +78,7 @@
|
|
all: headers.chk
|
|
|
|
headers.chk: $(filter-out public/arch-% public/%ctl.h public/xsm/% public/%hvm/save.h, $(wildcard public/*.h public/*/*.h) $(public-y)) Makefile
|
|
- for i in $(filter %.h,$^); do $(CC) -ansi -include stdint.h -Wall -W -Werror -S -o /dev/null -xc $$i || exit 1; echo $$i; done >$@.new
|
|
+ for i in $(filter %.h,$^); do $(CC) -ansi -include stdint.h -Wall -W -S -o /dev/null -xc $$i || exit 1; echo $$i; done >$@.new
|
|
mv $@.new $@
|
|
|
|
endif
|
|
diff -ur xen-4.2.1.orig/tools/tests/mce-test/tools/Makefile xen-4.2.1/tools/tests/mce-test/tools/Makefile
|
|
--- tools/tests/mce-test/tools/Makefile 2012-12-17 23:01:35.000000000 +0800
|
|
+++ tools/tests/mce-test/tools/Makefile 2013-01-30 13:01:44.890020152 +0800
|
|
@@ -1,7 +1,7 @@
|
|
XEN_ROOT=$(CURDIR)/../../../..
|
|
include $(XEN_ROOT)/tools/Rules.mk
|
|
|
|
-CFLAGS += -Werror
|
|
+CFLAGS +=
|
|
CFLAGS += $(CFLAGS_libxenctrl)
|
|
CFLAGS += $(CFLAGS_libxenguest)
|
|
CFLAGS += $(CFLAGS_libxenstore)
|
|
diff -ur xen-4.2.1.orig/tools/tests/mem-sharing/Makefile xen-4.2.1/tools/tests/mem-sharing/Makefile
|
|
--- tools/tests/mem-sharing/Makefile 2012-12-17 23:01:35.000000000 +0800
|
|
+++ tools/tests/mem-sharing/Makefile 2013-01-30 13:01:44.890020152 +0800
|
|
@@ -1,7 +1,7 @@
|
|
XEN_ROOT=$(CURDIR)/../../..
|
|
include $(XEN_ROOT)/tools/Rules.mk
|
|
|
|
-CFLAGS += -Werror
|
|
+CFLAGS +=
|
|
|
|
CFLAGS += $(CFLAGS_libxenctrl)
|
|
CFLAGS += $(CFLAGS_xeninclude)
|
|
diff -ur xen-4.2.1.orig/tools/tests/xen-access/Makefile xen-4.2.1/tools/tests/xen-access/Makefile
|
|
--- tools/tests/xen-access/Makefile 2012-12-17 23:01:35.000000000 +0800
|
|
+++ tools/tests/xen-access/Makefile 2013-01-30 13:01:44.891020152 +0800
|
|
@@ -1,7 +1,7 @@
|
|
XEN_ROOT=$(CURDIR)/../../..
|
|
include $(XEN_ROOT)/tools/Rules.mk
|
|
|
|
-CFLAGS += -Werror
|
|
+CFLAGS +=
|
|
|
|
CFLAGS += $(CFLAGS_libxenctrl)
|
|
CFLAGS += $(CFLAGS_libxenguest)
|
|
diff -ur xen-4.3.0.orig/tools/firmware/Rules.mk xen-4.3.0/tools/firmware/Rules.mk
|
|
--- tools/firmware/Rules.mk 2013-07-09 18:46:56.000000000 +0800
|
|
+++ ttools/firmware/Rules.mk 2013-07-20 20:28:57.811836505 +0800
|
|
@@ -11,8 +11,6 @@
|
|
CFLAGS += -DNDEBUG
|
|
endif
|
|
|
|
-CFLAGS += -Werror
|
|
-
|
|
$(call cc-options-add,CFLAGS,CC,$(EMBEDDED_EXTRA_CFLAGS))
|
|
|
|
# Extra CFLAGS suitable for an embedded type of environment.
|