You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
80 lines
1.7 KiB
80 lines
1.7 KiB
aclocal.m4 | 6 +++---
|
|
configure.in | 38 +++-----------------------------------
|
|
2 files changed, 6 insertions(+), 38 deletions(-)
|
|
|
|
diff --git a/aclocal.m4 b/aclocal.m4
|
|
index 7441d3d..b86a6b2 100644
|
|
--- a/aclocal.m4
|
|
+++ b/aclocal.m4
|
|
@@ -11,11 +11,11 @@ if test "$cross_compiling" = yes; then
|
|
else
|
|
cat > conftest.$ac_ext <<EOF
|
|
[#]line __oline__ "configure"
|
|
-#include "confdefs.h"
|
|
-ifelse(AC_LANG, CPLUSPLUS, [#ifdef __cplusplus
|
|
+[#include "confdefs.h"
|
|
+#ifdef __cplusplus
|
|
extern "C" void exit(int);
|
|
#endif
|
|
-])dnl
|
|
+]dnl
|
|
[$2]
|
|
EOF
|
|
eval $ac_link
|
|
diff --git a/configure.in b/configure.in
|
|
index adde26d..b57eaa9 100644
|
|
--- a/configure.in
|
|
+++ b/configure.in
|
|
@@ -83,35 +83,9 @@ PWD=`pwd`
|
|
#
|
|
# -----------------------------------------------------------------------
|
|
|
|
-BLT_ENV_CC=$CC
|
|
-
|
|
-#
|
|
-# CC search order
|
|
-#
|
|
-# 1. command line (--with-cc)
|
|
-# 2. environment variable ($CC)
|
|
-# 3. cached variable ($blt_cv_prog_cc)
|
|
-# 4. check for program (AC_PROG_CC)
|
|
-# 4. default to cc
|
|
-#
|
|
-
|
|
-AC_MSG_CHECKING([which C compiler])
|
|
-if test "x${blt_with_cc}" != "x" ; then
|
|
- CC=${blt_with_cc}
|
|
- unset ac_cv_prog_CPP
|
|
- unset ac_cv_prog_CC
|
|
-elif test "x${BLT_ENV_CC}" != "x" ; then
|
|
- unset ac_cv_prog_CPP
|
|
- unset ac_cv_prog_CC
|
|
-elif test "x${blt_cv_prog_cc}" != "x" ; then
|
|
- CC=${blt_cv_prog_cc}
|
|
- unset ac_cv_prog_CC
|
|
-else
|
|
- AC_PROG_CC
|
|
-fi
|
|
-if test "x${CC}" = "x" ; then
|
|
- CC=cc
|
|
-fi
|
|
+AC_PROG_CC
|
|
+AC_PROG_CPP
|
|
+AC_PROG_EGREP
|
|
|
|
case $target in
|
|
*-*-cygwin*|*-*-mingw*)
|
|
@@ -121,12 +95,6 @@ case $target in
|
|
;;
|
|
esac
|
|
|
|
-AC_MSG_RESULT([$CC])
|
|
-
|
|
-unset blt_cv_prog_cc
|
|
-AC_CACHE_VAL(blt_cv_prog_cc, blt_cv_prog_cc=$CC)
|
|
-AC_SUBST(CC)
|
|
-AC_PROG_CPP
|
|
if test "x${GCC}" != "x" ; then
|
|
blt_have_gcc="yes"
|
|
else
|