You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

20 lines
650 B

http://bugs.gentoo.org/194921
--- configure.ac
+++ configure.ac
@@ -757,11 +757,9 @@
dnl *************************************
dnl (already done) enable_werror=no
-AC_ARG_ENABLE(compile-werror,
- [ --enable-compile-werror
- Causes warnings to be treated as errors in GCC],
- enable_werror=yes)
-if test "x$GCC" = "xyes" -a "x$enable_werror" = "xyes"; then
+AC_ARG_ENABLE([compile-werror], AS_HELP_STRING([--enable-compile-werror], [Causes warnings to be treated as errors in GCC (default: disabled)]))
+
+if test "x$GCC" = "xyes" -a "x$enable_compile_werror" = "xyes"; then
CFLAGS="$CFLAGS -Werror"
fi