You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

44 lines
1.8 KiB

diff -Nur netcdf-3.6.3.orig/cxx/Makefile.am netcdf-3.6.3/cxx/Makefile.am
--- netcdf-3.6.3.orig/cxx/Makefile.am 2008-04-04 18:05:25.000000000 +0100
+++ netcdf-3.6.3/cxx/Makefile.am 2009-01-15 14:46:15.895277408 +0000
@@ -105,6 +105,6 @@
# Library source.
libnetcdf_c___la_SOURCES = netcdf.cpp ncvalues.cpp
-
+libnetcdf_c___la_LIBADD = $(top_builddir)/libsrc/libnetcdf.la
test: check
diff -Nur netcdf-3.6.3.orig/fortran/Makefile.am netcdf-3.6.3/fortran/Makefile.am
--- netcdf-3.6.3.orig/fortran/Makefile.am 2008-04-22 22:52:04.000000000 +0100
+++ netcdf-3.6.3/fortran/Makefile.am 2009-01-15 14:47:03.426443772 +0000
@@ -60,6 +60,7 @@
# (it's generated by the configure script from nfconfig.in), or if
# netcdf.inc has changed.
libnetcdff_la_DEPENDENCIES = nfconfig.inc netcdf.inc
+libnetcdff_la_LIBADD = $(top_builddir)/libsrc/libnetcdf.la
# Is the user building netCDF-4?
if USE_NETCDF4
@@ -92,7 +93,7 @@
# If F90 is built, include it's convenience library.
if BUILD_F90
-libnetcdff_la_LIBADD = ../f90/libnetcdff90.la
+libnetcdff_la_LIBADD += ../f90/libnetcdff90.la
endif
# If we are building the dll (under MinGW) then set the correct flags.
diff -Nur netcdf-3.6.3.orig/Makefile.am netcdf-3.6.3/Makefile.am
--- netcdf-3.6.3.orig/Makefile.am 2008-06-27 14:15:13.000000000 +0100
+++ netcdf-3.6.3/Makefile.am 2009-01-15 14:48:04.594871206 +0000
@@ -88,7 +88,7 @@
# $(DAPDIR) $(NCDAPDIR) $(LIBSRC4_DIR) \
# $(V2_TEST) $(NCGEN) $(NCDUMP) $(F77_TEST) ${CXX_DIR} $(CXX4) \
# $(NC_TEST_DIR) $(NC_TEST4) $(MAN) $(EXAMPLES) win32
-SUBDIRS = $(F90_DIR) $(F77_DIR) $(LIBSRC_DIR) $(LIBSRC4_DIR) \
+SUBDIRS = $(LIBSRC_DIR) $(F90_DIR) $(F77_DIR) $(LIBSRC4_DIR) \
$(V2_TEST) $(NCGEN) $(NCDUMP) $(F77_TEST) ${CXX_DIR} $(CXX4) \
$(NC_TEST_DIR) $(NC_TEST4) $(MAN) $(EXAMPLES) win32