gentoo-full-overlay/dev-python/logilab-common/files/logilab-common-0.59.1-zipsafe.patch

13 lines
398 B
Diff

Make sure setuptools does not create a zip file in python_test; this is buggy
and causes tests to fail.
--- a/setup.py
+++ b/setup.py
@@ -179,6 +179,7 @@
ext_modules = ext_modules,
cmdclass = {'install_lib': MyInstallLib,
'build_py': MyBuildPy},
+ zip_safe = False,
**kwargs
)