You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-full-overlay/sys-libs/pwdb/files/pwdb-0.62-disable-static.patch

20 lines
531 B

--- a/libpwdb/Makefile
+++ b/libpwdb/Makefile
@@ -46,7 +46,7 @@
%.o : %.c $(HEADERS)
$(CC) $(CFLAGS) $(DYNAMIC) $(CPPFLAGS) $(TARGET_ARCH) -c $< -o $@
-all: $(LIBSTATIC) $(LIBDYNAME)
+all: $(LIBDYNAME)
$(LIBDYNAME): $(LIBOBJ)
@@ -70,7 +70,6 @@
$(INSTALL) -m 755 $(LIBFILENAME) $(LIBDIR)
ln -sf $(LIBFILENAME) $(LIBDIR)/$(LIBSONAME)
ln -sf $(LIBFILENAME) $(LIBDIR)/$(LIBDYNAME)
- $(INSTALL) -m 644 $(LIBSTATIC) $(LIBDIR)
clean:
@rm -f *.so *.a core a.out `find . -name "*.o" -print` `find . -name "*~" -print`