You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-full-overlay/dev-lang/ispc/files/ispc-1.19.0-curses-cmake.patch

17 lines
597 B

--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -598,11 +598,8 @@ else()
target_link_libraries(${PROJECT_NAME} pthread tinfo.a curses.a)
else()
find_package(Curses REQUIRED)
- if (CURSES_EXTRA_LIBRARY)
- # this contains the tinfo library, if found
- target_link_libraries(${PROJECT_NAME} ${CURSES_EXTRA_LIBRARY})
- endif()
- target_link_libraries(${PROJECT_NAME} pthread ${CURSES_CURSES_LIBRARY})
+ set(CURSES_NEED_NCURSES ON)
+ target_link_libraries(${PROJECT_NAME} pthread ${CURSES_LIBRARIES})
endif()
endif()