46 lines
1.1 KiB
Diff
46 lines
1.1 KiB
Diff
--- libptp2-1.1.10/configure.in.orig 2007-12-28 10:28:36.000000000 +1100
|
|
+++ libptp2-1.1.10/configure.in 2007-12-28 10:36:14.000000000 +1100
|
|
@@ -25,6 +25,10 @@
|
|
|
|
# Checks for programs.
|
|
AC_PROG_CC
|
|
+AC_PROG_INSTALL
|
|
+AC_PROG_LN_S
|
|
+AC_PROG_MAKE_SET
|
|
+AC_PROG_RANLIB
|
|
|
|
# turn on warnings for gcc
|
|
if test "$ac_cv_prog_gcc" = "yes"; then
|
|
@@ -36,19 +40,29 @@
|
|
|
|
# Checks for header files.
|
|
AC_HEADER_STDC
|
|
-AC_CHECK_HEADERS([libintl.h stdlib.h string.h])
|
|
+AC_CHECK_HEADERS([arpa/inet.h fcntl.h libintl.h stdint.h stdlib.h string.h sys/ioctl.h unistd.h utime.h])
|
|
|
|
# Checks for typedefs, structures, and compiler characteristics.
|
|
AC_C_CONST
|
|
AC_C_INLINE
|
|
+AC_TYPE_INT16_T
|
|
+AC_TYPE_INT32_T
|
|
+AC_TYPE_INT8_T
|
|
AC_STRUCT_TM
|
|
+AC_TYPE_UINT16_T
|
|
+AC_TYPE_UINT32_T
|
|
+AC_TYPE_UINT64_T
|
|
+AC_TYPE_UINT8_T
|
|
|
|
# Checks for library functions.
|
|
-AC_FUNC_ERROR_AT_LINE
|
|
+AC_PROG_GCC_TRADITIONAL
|
|
AC_FUNC_MALLOC
|
|
AC_FUNC_MKTIME
|
|
+AC_FUNC_MMAP
|
|
+AC_TYPE_SIGNAL
|
|
+AC_FUNC_UTIME_NULL
|
|
AC_FUNC_VPRINTF
|
|
-AC_CHECK_FUNCS([memset strchr strdup strtol getopt_long])
|
|
+AC_CHECK_FUNCS([memset munmap strdup strncasecmp strtol utime])
|
|
|
|
hostos=any
|
|
case $host in
|