You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

34 lines
1.5 KiB

--- a/Makefile
+++ b/Makefile
@@ -30,7 +30,7 @@ endif
# changed if desired.
CPPFLAGS ?= -pedantic
-CXXFLAGS ?= -Wall -Wextra -Wshadow -Werror -O3 $(MINGW_CXXFLAGS)
+CXXFLAGS ?= -Wall -Wextra -Wshadow $(MINGW_CXXFLAGS)
HEADERS := $(shell find include -name '*.hpp')
SOURCES := $(shell find src -name '*.cpp')
--- a/src/example/pegtl/CMakeLists.txt
+++ b/src/example/pegtl/CMakeLists.txt
@@ -60,7 +60,7 @@ foreach(examplesourcefile ${example_sources})
if(MSVC)
target_compile_options(${exename} PRIVATE /W4 /WX /utf-8)
else()
- target_compile_options(${exename} PRIVATE -pedantic -Wall -Wextra -Wshadow -Werror)
+ target_compile_options(${exename} PRIVATE -pedantic -Wall -Wextra -Wshadow )
endif()
endforeach()
--- a/src/test/pegtl/CMakeLists.txt
+++ b/src/test/pegtl/CMakeLists.txt
@@ -150,7 +150,7 @@ foreach(testsourcefile ${test_sources})
if(MSVC)
target_compile_options(${exename} PRIVATE /W4 /WX /utf-8)
else()
- target_compile_options(${exename} PRIVATE -pedantic -Wall -Wextra -Wshadow -Werror)
+ target_compile_options(${exename} PRIVATE -pedantic -Wall -Wextra -Wshadow )
endif()
if(ANDROID)
add_test(NAME ${exename} WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${CMAKE_COMMAND} "-DANDROID_NDK=${ANDROID_NDK}" "-DTEST_RESOURCES_DIR=${CMAKE_SOURCE_DIR}" "-DTEST_RESOURCES=src/test/pegtl/data;src/test/pegtl/file_data.txt;Makefile" "-DUNITTEST=${exename}" -P ${CMAKE_CURRENT_SOURCE_DIR}/ExecuteOnAndroid.cmake)