You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

19 lines
490 B

Fix Makefile to respect user variables
--- a/Makefile
+++ b/Makefile
@@ -3,9 +3,8 @@
# by default, you probably need to add -I/usr/whereever/flac to CFLAGS and
# -L/usr/lib/whereever to the link step.
-CFLAGS="-Wall -g"
-
flac-image: flac-image.o
- gcc -o flac-image -lFLAC flac-image.o
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ -lFLAC
-flac-image: flac-image.c flac-image.h
\ No newline at end of file
+flac-image.o: flac-image.c flac-image.h
+ $(CC) $(CFLAGS) $(CPPFLAGS) -c -o $@ $<