You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
71 lines
1.9 KiB
71 lines
1.9 KiB
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -1,6 +1,3 @@
|
|
-
|
|
-CC = gcc
|
|
-
|
|
c_sources = \
|
|
common.c \
|
|
encode.c \
|
|
@@ -26,29 +23,8 @@
|
|
|
|
OBJ = $(c_sources:.c=.o)
|
|
|
|
-#Uncomment this if you want to do some profiling/debugging
|
|
-#PG = -g -pg
|
|
-PG = -fomit-frame-pointer
|
|
-
|
|
-# Optimize flag. 3 is about as high as you can sanely go with GCC3.2.
|
|
-OPTIM = -O3
|
|
-
|
|
# These flags are pretty much mandatory
|
|
-REQUIRED = -DNDEBUG -DINLINE=inline
|
|
-
|
|
-#pick your architecture
|
|
-ARCH = -march=pentium
|
|
-#Possible x86 architectures
|
|
-#gcc3.2 => i386, i486, i586, i686, pentium, pentium-mmx
|
|
-# pentiumpro, pentium2, pentium3, pentium4, k6, k6-2, k6-3,
|
|
-# athlon, athlon-tbird, athlon-4, athlon-xp and athlon-mp.
|
|
-
|
|
-#TWEAK the hell out of the compile. Some of these are real dodgy
|
|
-# and will cause program instability
|
|
-#TWEAKS = -finline-functions -fexpensive-optimizations -ffast-math \
|
|
-# -malign-double \
|
|
-# -mfancy-math-387 -funroll-loops -funroll-all-loops -pipe \
|
|
-# -fschedule-insns2 -fno-strength-reduce
|
|
+REQUIRED = -DNDEBUG -DINLINE=
|
|
|
|
#Set a stack of warnings to overcome my atrocious coding style . MFC.
|
|
WARNINGS = -Wall
|
|
@@ -56,7 +32,7 @@
|
|
|
|
NEW_02L_FIXES = -DNEWENCODE -DNEWATAN
|
|
|
|
-CC_SWITCHES = $(OPTIM) $(REQUIRED) $(ARCH) $(PG) $(TWEAKS) $(WARNINGS) $(NEW_02L_FIXES)
|
|
+CC_SWITCHES = $(CFLAGS) $(CPPFLAGS) $(REQUIRED) $(WARNINGS) $(NEW_02L_FIXES)
|
|
|
|
PGM = toolame
|
|
|
|
@@ -75,16 +51,16 @@
|
|
$(CC) $(CC_SWITCHES) -c $< -o $@
|
|
|
|
$(PGM): $(OBJ) Makefile
|
|
- $(CC) $(PG) -o $(PGM) $(OBJ) $(LIBS)
|
|
+ $(CC) $(LDFLAGS) -o $(PGM) $(OBJ) $(LIBS)
|
|
|
|
clean:
|
|
- -rm $(OBJ) $(DEP)
|
|
+ -rm $(OBJ) $(DEP) 2>/dev/null
|
|
|
|
megaclean:
|
|
- -rm $(OBJ) $(DEP) $(PGM) \#*\# *~
|
|
+ -rm $(OBJ) $(DEP) $(PGM) \#*\# *~ 2>/dev/null
|
|
|
|
distclean:
|
|
- -rm $(OBJ) $(DEP) $(PGM) \#* *~ gmon.out gprof* core *shit* *.wav *.mp2 *.c.* *.mp2.* *.da *.h.* *.d *.mp3 *.pcm *.wav logfile
|
|
+ -rm $(OBJ) $(DEP) $(PGM) \#* *~ gmon.out gprof* core *shit* *.wav *.mp2 *.c.* *.mp2.* *.da *.h.* *.d *.mp3 *.pcm *.wav logfile 2>/dev/null
|
|
|
|
tags: TAGS
|
|
|