You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
17 lines
686 B
17 lines
686 B
http://bugs.gentoo.org/189671
|
|
http://lists.gnu.org/archive/html/bug-bash/2007-08/msg00081.html
|
|
|
|
--- bash-3.2/Makefile.in
|
|
+++ bash-3.2/Makefile.in
|
|
@@ -584,7 +584,9 @@
|
|
@( { test "${RL_LIBDIR}" = "${libdir}" && exit 0; } || \
|
|
cd ${RL_LIBDIR} && $(MAKE) $(MFLAGS) libreadline.a) || exit 1
|
|
|
|
-$(HISTORY_LIBRARY): config.h $(HISTORY_SOURCE)
|
|
+# prevent parallel build race conditions in the lib/readline/ subdir
|
|
+# by depending on libreadline.a when applicable
|
|
+$(HISTORY_LIBRARY): config.h $(HISTORY_SOURCE) $(READLINE_DEP)
|
|
@echo making $@ in ${HIST_LIBDIR}
|
|
@( { test "${HIST_LIBDIR}" = "${libdir}" && exit 0; } || \
|
|
cd ${HIST_LIBDIR} && $(MAKE) $(MFLAGS) libhistory.a) || exit 1
|