You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

14 lines
921 B

Index: harvid-0.8.3/src/Makefile
===================================================================
--- harvid-0.8.3.orig/src/Makefile
+++ harvid-0.8.3/src/Makefile
@@ -16,7 +16,7 @@ ifeq ($(shell PKG_CONFIG_PATH=$(PKG_CONF
$(error "libpng is required - install libpng-dev")
endif
-ifeq ($(shell $(ECHO) "\#include <stdio.h>\n\#include <jpeglib.h>\nint main() { struct jpeg_error_mgr jerr; jpeg_std_error(&jerr); return 0; }" | $(CC) -pipe -x c -o $(CONFIGTEMP) $(ARCHINCLUDES) $(LDFLAGS) - -ljpeg 2>/dev/null || echo no; $(RM) -f $(CONFIGTEMP)), no)
+ifeq ($(shell printf "#include <stdio.h>\n#include <jpeglib.h>\nint main() { struct jpeg_error_mgr jerr; jpeg_std_error(&jerr); return 0; }" | $(CC) -pipe -x c -o $(CONFIGTEMP) $(ARCHINCLUDES) $(LDFLAGS) - -ljpeg 2>/dev/null || echo no; $(RM) -f $(CONFIGTEMP)), no)
$(error "libjpeg is required - install libjpeg-dev, libjpeg8-dev or libjpeg62-dev")
endif