You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

26 lines
658 B

diff --git a/Makefile.in b/Makefile.in
index 328016c..f8cc6aa 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -36,7 +36,7 @@ LIBS= @LIBS@
all: $(TARGET)
$(TARGET): $(TARGET).c config.h
- $(CC) $(CFLAGS) -o $@ $(@:%=%.c) $(LIBS)
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(@:%=%.c) $(LIBS)
rebuild: cleanall $(TARGET)
@@ -59,9 +59,10 @@ cleanall: clean
mrproper: cleanall
distclean: cleanall
+BUILD_ROOT=$(DESTDIR)
install:
$(INSTALL) -d -m 755 $(BUILD_ROOT)$(BIN_DIR)
- $(INSTALL) -m 755 -s $(TARGET) $(BUILD_ROOT)$(BIN_DIR)
+ $(INSTALL) -m 755 $(TARGET) $(BUILD_ROOT)$(BIN_DIR)
tarball:
$(INSTALL) -d -m 755 ./$(PACKAGE_NAME)-$(PACKAGE_VERSION)