25 lines
964 B
Diff
25 lines
964 B
Diff
diff -Nuar yaz-4.2.30.orig/configure.ac yaz-4.2.30/configure.ac
|
|
--- yaz-4.2.30.orig/configure.ac 2012-03-23 10:20:20.000000000 +0000
|
|
+++ yaz-4.2.30/configure.ac 2012-04-22 20:56:41.118691087 +0000
|
|
@@ -372,14 +372,13 @@
|
|
|
|
dnl
|
|
dnl
|
|
-AC_CHECK_ICU([3.4],[
|
|
- if test "$xml_enabled" = "true"; then
|
|
- ICU_CPPFLAGS="$ICU_CPPFLAGS -D YAZ_HAVE_ICU=1"
|
|
- else
|
|
- ICU_CPPFLAGS=""
|
|
- AC_MSG_WARN([ICU support disabled because XML support is unavailable])
|
|
- fi
|
|
-])
|
|
+AC_ARG_ENABLE(icu, [ --enable-icu enable ICU support],[enable_icu=$enableval],[enable_icu=no])
|
|
+if test "$enable_icu" = "yes"; then
|
|
+ AC_CHECK_ICU([3.4],[
|
|
+ ICU_CPPFLAGS="$ICU_CPPFLAGS -D YAZ_HAVE_ICU=1"],[
|
|
+ AC_MSG_ERROR([For ICU support please install libicu34-dev or similar])
|
|
+ ])
|
|
+fi
|
|
dnl ------ versioning
|
|
dnl
|
|
WIN_FILEVERSION=`echo $PACKAGE_VERSION | $AWK 'BEGIN { FS = "."; } { m = $4; printf("%d,%d,%d,%d", $1, $2, $3 == "" ? "0" : $3, $4 == "" ? "1" : $4);}'`
|