You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-full-overlay/dev-lang/ispc/files/ispc-1.7.0-llvm-version.patch

14 lines
499 B

diff --git a/Makefile b/Makefile
index de0aa1a..abf042f 100644
--- a/Makefile
+++ b/Makefile
@@ -86,7 +86,7 @@ endif
ARCH_TYPE = $(shell arch)
LLVM_CXXFLAGS=$(shell $(LLVM_CONFIG) --cppflags)
-LLVM_VERSION=LLVM_$(shell $(LLVM_CONFIG) --version | sed -e s/\\./_/ -e s/svn// -e s/\.0//)
+LLVM_VERSION=LLVM_$(shell $(LLVM_CONFIG) --version | sed -e 's/svn//' -e 's/\./_/' -e 's/\..*//')
LLVM_VERSION_DEF=-D$(LLVM_VERSION)
LLVM_COMPONENTS = engine ipo bitreader bitwriter instrumentation linker