gentoo-full-overlay/app-mobilephone/yaps/files/yaps-0.96-gentoo.diff

56 lines
1.5 KiB
Diff

--- Config.orig 2005-06-02 20:28:35.000000000 +0200
+++ Config 2005-10-16 15:13:32.000000000 +0200
@@ -24,9 +24,9 @@
# Name of local configuration file (location is $HOME.)
YAPS_LCFGFILE = .yapsrc
# Directory for installing the binary
-YAPS_BINDIR = /usr/local/bin
+YAPS_BINDIR = /usr/bin
# Directory for optional support files
-YAPS_LIBDIR = /usr/local/lib/yaps
+YAPS_LIBDIR = /usr/lib/yaps
# User/Group/Mode for yaps
YAPS_USER = bin
YAPS_GROUP = uucp
@@ -43,12 +43,12 @@
ifdef SLANG
LDEFS += -DSCRIPT_SLANG
LLIBS += -lslang
-MATH = True
+#MATH = True
endif
ifdef LUA
LDEFS += -DSCRIPT_LUA
-LLIBS += -llualib -llua
-MATH = True
+LLIBS += `pkg-config --libs lua`
+#MATH = True
endif
ifdef MATH
LLIBS += -lm
--- Makefile.orig 2005-06-02 20:33:27.000000000 +0200
+++ Makefile 2005-10-16 15:13:32.000000000 +0200
@@ -33,19 +33,19 @@
lynx -cfg=/dev/null -nolist -dump $< > $@
install: $(DSTFLE) $(CFGFILE)
- if [ ! -d $(YAPS_LIBDIR) ]; then \
- install -d -m 755 -o $(YAPS_USER) -g $(YAPS_GROUP) $(YAPS_LIBDIR) ; \
+ if [ ! -d $(DESTDIR)$(YAPS_LIBDIR) ]; then \
+ install -d -m 755 $(DESTDIR)$(YAPS_LIBDIR) ; \
fi
@if [ -f contrib/Makefile ]; then \
$(MAKE) -C contrib install ; \
fi
$(DSTFLE): yaps
- install -o $(YAPS_USER) -g $(YAPS_GROUP) -m $(YAPS_MODE) -s yaps $@
+ install -m $(YAPS_MODE) -s yaps $(DESTDIR)$@
$(CFGFILE): yaps.rc
@if [ ! -f $@ ]; then \
- install -o $(YAPS_RCUSER) -g $(YAPS_RCGROUP) -m $(YAPS_RCMODE) -s yaps.rc $@ ; \
+ install -m $(YAPS_RCMODE) -s yaps.rc $(DESTDIR)$@ ; \
fi
clean: