You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
33 lines
878 B
33 lines
878 B
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -26,7 +26,7 @@
|
|
endif
|
|
endif
|
|
|
|
-KVER := $(shell $(CC) $(CFLAGS) -E -dM $(VERSION_FILE) | \
|
|
+KVER := $(shell $(CC) $(CFLAGS) $(LDFLAGS) -E -dM $(VERSION_FILE) | \
|
|
grep UTS_RELEASE | awk '{ print $$3 }' | sed 's/\"//g')
|
|
|
|
KMOD := /lib/modules/$(KVER)/extra
|
|
--- a/usr/Makefile
|
|
+++ b/usr/Makefile
|
|
@@ -1,4 +1,4 @@
|
|
-CFLAGS += -O2 -fno-inline -Wall -Wstrict-prototypes -g -I../include
|
|
+CFLAGS += -fno-inline -Wall -Wstrict-prototypes -I../include
|
|
CFLAGS += -D_GNU_SOURCE # required for glibc >= 2.8
|
|
PROGRAMS = ietd ietadm
|
|
LIBS =
|
|
@@ -7,10 +7,10 @@
|
|
|
|
ietd: ietd.o iscsid.o conn.o session.o target.o message.o ctldev.o log.o chap.o event.o param.o plain.o isns.o md5.o sha1.o
|
|
|
|
- $(CC) $^ -o $@ $(LIBS)
|
|
+ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
|
|
|
|
ietadm: ietadm.o param.o
|
|
- $(CC) $^ -o $@
|
|
+ $(CC) $(LDFLAGS) $^ -o $@
|
|
|
|
clean:
|
|
rm -f *.o $(PROGRAMS)
|