gentoo-full-overlay/dev-ros/image_proc/files/gcc6.patch

32 lines
1.1 KiB
Diff

commit 6c2d65452bd5fe62723988a1a570789921900d59
Author: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Fri Sep 30 15:39:47 2016 +0200
address gcc6 build error
With gcc6, compiling fails with `stdlib.h: No such file or directory`,
as including '-isystem /usr/include' breaks with gcc6, cf.,
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129.
This commit addresses this issue for this package in the same way
it was addressed in various other ROS packages. A list of related
commits and pull requests is at:
https://github.com/ros/rosdistro/issues/12783
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
diff --git a/image_proc/CMakeLists.txt b/image_proc/CMakeLists.txt
index a13371f..34905f0 100755
--- a/image_proc/CMakeLists.txt
+++ b/image_proc/CMakeLists.txt
@@ -17,8 +17,7 @@ catkin_package(
LIBRARIES ${PROJECT_NAME}
)
-include_directories(SYSTEM ${catkin_INCLUDE_DIRS} ${OpenCV_INCLUDE_DIRS})
-include_directories(include)
+include_directories(include ${catkin_INCLUDE_DIRS} ${OpenCV_INCLUDE_DIRS})
# Nodelet library
add_library(${PROJECT_NAME} src/libimage_proc/processor.cpp