33 lines
1.1 KiB
Diff
33 lines
1.1 KiB
Diff
--- configure
|
|
+++ configure
|
|
@@ -3748,7 +3748,7 @@
|
|
# For an installed makeinfo, we require it to be from texinfo 4.4 or
|
|
# higher, else we use the "missing" dummy.
|
|
if ${MAKEINFO} --version \
|
|
- | egrep 'texinfo[^0-9]*([1-3][0-9]|4\.[4-9]|[5-9])' >/dev/null 2>&1; then
|
|
+ | egrep 'texinfo[^0-9]*([1-3][0-9]|4\.[4-9]|4\.[1-9][0-9]|[5-9])' >/dev/null 2>&1; then
|
|
:
|
|
else
|
|
MAKEINFO="$MISSING makeinfo"
|
|
--- gcc/configure.ac
|
|
+++ gcc/configure.ac
|
|
@@ -882,7 +882,7 @@
|
|
# that we can use it.
|
|
gcc_AC_CHECK_PROG_VER(MAKEINFO, makeinfo, --version,
|
|
[GNU texinfo.* \([0-9][0-9.]*\)],
|
|
- [4.[4-9]*])
|
|
+ [4.[4-9]*|4.[1-9][0-9]])
|
|
if test $gcc_cv_prog_makeinfo_modern = no; then
|
|
MAKEINFO="$MISSING makeinfo"
|
|
AC_MSG_WARN([
|
|
--- libgomp/configure.ac
|
|
+++ libgomp/configure.ac
|
|
@@ -135,7 +135,7 @@
|
|
# that we can use it.
|
|
ACX_CHECK_PROG_VER([MAKEINFO], [makeinfo], [--version],
|
|
[GNU texinfo.* \([0-9][0-9.]*\)],
|
|
- [4.[4-9]*])
|
|
+ [4.[4-9]*|4.[1-9][0-9]])
|
|
AM_CONDITIONAL(BUILD_INFO, test $gcc_cv_prog_makeinfo_modern = "yes")
|
|
|
|
|