You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-full-overlay/sys-cluster/ucx/files/ucx-1.13.0-no-rpm-sandbox.p...

13 lines
751 B

https://bugs.gentoo.org/790338
--- a/src/uct/ib/Makefile.am
+++ b/src/uct/ib/Makefile.am
@@ -13,7 +13,7 @@ libuct_ib_la_CFLAGS = $(BASE_CFLAGS)
libuct_ib_la_LIBADD = $(top_builddir)/src/ucs/libucs.la \
$(top_builddir)/src/uct/libuct.la
libuct_ib_la_LDFLAGS = $(IBVERBS_LDFLAGS) $(NUMA_LIBS) -version-info $(SOVERSION)
-libmlx5_ver = $(shell (rpm -qf $(IBVERBS_DIR)/include/infiniband/mlx5_hw.h &>/dev/null && rpm -qf /usr/include/infiniband/mlx5_hw.h) | grep -v 'not owned' | head -1)
+libmlx5_ver = $(shell (false -qf $(IBVERBS_DIR)/include/infiniband/mlx5_hw.h &>/dev/null && false -qf /usr/include/infiniband/mlx5_hw.h) | grep -v 'not owned' | head -1)
noinst_HEADERS = \
base/ib_device.h \