You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-full-overlay/dev-libs/xmlrpc-c/files/xmlrpc-c-1.32.05-Wimplicit....

21 lines
593 B

--- a/common.mk
+++ b/common.mk
@@ -17,7 +17,7 @@
# fully made.
.DELETE_ON_ERROR:
-GCC_WARNINGS = -Wall -W -Wno-uninitialized -Wundef -Wimplicit \
+GCC_WARNINGS = -Wall -W -Wno-uninitialized -Wundef \
-Wno-unknown-pragmas
# We need -Wwrite-strings after we fix all the missing consts
#
@@ -27,7 +27,7 @@
# on -Wuninitialized for all the others.
GCC_C_WARNINGS = $(GCC_WARNINGS) \
- -Wmissing-declarations -Wstrict-prototypes -Wmissing-prototypes
+ -Wmissing-declarations -Wstrict-prototypes -Wmissing-prototypes -Wimplicit
GCC_CXX_WARNINGS = $(GCC_WARNINGS) -Wsynth