You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
28 lines
886 B
28 lines
886 B
diff -urN a/configure.ac b/configure.ac
|
|
--- a/configure.ac 2014-02-25 18:49:15.000000000 -0600
|
|
+++ b/configure.ac 2014-03-07 18:19:53.718147847 -0600
|
|
@@ -639,23 +639,6 @@
|
|
AC_DEFINE([JEMALLOC_IVSALLOC], [ ])
|
|
fi
|
|
|
|
-dnl Only optimize if not debugging.
|
|
-if test "x$enable_debug" = "x0" -a "x$no_CFLAGS" = "xyes" ; then
|
|
- dnl Make sure that an optimization flag was not specified in EXTRA_CFLAGS.
|
|
- optimize="no"
|
|
- echo "$CFLAGS $EXTRA_CFLAGS" | grep '\-O' >/dev/null || optimize="yes"
|
|
- if test "x${optimize}" = "xyes" ; then
|
|
- if test "x$GCC" = "xyes" ; then
|
|
- JE_CFLAGS_APPEND([-O3])
|
|
- JE_CFLAGS_APPEND([-funroll-loops])
|
|
- elif test "x$je_cv_msvc" = "xyes" ; then
|
|
- JE_CFLAGS_APPEND([-O2])
|
|
- else
|
|
- JE_CFLAGS_APPEND([-O])
|
|
- fi
|
|
- fi
|
|
-fi
|
|
-
|
|
dnl Enable statistics calculation by default.
|
|
AC_ARG_ENABLE([stats],
|
|
[AS_HELP_STRING([--disable-stats],
|