gentoo-full-overlay/dev-db/sqlite/files/sqlite-3.8.1-autoconf-dlopen_check.patch

12 lines
361 B
Diff

--- configure.ac
+++ configure.ac
@@ -70,6 +70,9 @@
[], [enable_dynamic_extensions=yes])
if test x"$enable_dynamic_extensions" != "xno"; then
AC_SEARCH_LIBS(dlopen, dl)
+ if test "${ac_cv_search_dlopen}" = "no" ; then
+ DYNAMIC_EXTENSION_FLAGS=-DSQLITE_OMIT_LOAD_EXTENSION=1
+ fi
else
DYNAMIC_EXTENSION_FLAGS=-DSQLITE_OMIT_LOAD_EXTENSION=1
fi