108 lines
3.9 KiB
Diff
108 lines
3.9 KiB
Diff
diff -Naurp sqlite-2.8.16.orig/Makefile.in sqlite-2.8.16/Makefile.in
|
|
--- sqlite-2.8.16.orig/Makefile.in 2005-02-14 00:22:04.000000000 +0000
|
|
+++ sqlite-2.8.16/Makefile.in 2005-02-17 18:22:50.174537727 +0000
|
|
@@ -187,12 +187,12 @@ last_change: $(SRC)
|
|
| awk '{print $$5,$$6}' >last_change
|
|
|
|
libsqlite.la: $(LIBOBJ)
|
|
- $(LTLINK) -o libsqlite.la $(LIBOBJ) ${RELEASE} -rpath @exec_prefix@/lib \
|
|
+ $(LTLINK) -o libsqlite.la $(LIBOBJ) ${RELEASE} -rpath @libdir@ \
|
|
-version-info "8:6:8"
|
|
|
|
libtclsqlite.la: tclsqlite.lo libsqlite.la
|
|
$(LTLINK) -o libtclsqlite.la tclsqlite.lo \
|
|
- libsqlite.la $(LIBTCL) -rpath @exec_prefix@/lib/sqlite \
|
|
+ libsqlite.la $(LIBTCL) -rpath @libdir@/sqlite \
|
|
-version-info "8:6:8"
|
|
|
|
sqlite@TARGET_EXEEXT@: $(TOP)/src/shell.c libsqlite.la sqlite.h
|
|
@@ -465,14 +465,14 @@ doc: $(DOC)
|
|
mv $(DOC) doc
|
|
|
|
install: sqlite libsqlite.la sqlite.h
|
|
- $(INSTALL) -d $(DESTDIR)$(exec_prefix)/lib
|
|
- $(LTINSTALL) libsqlite.la $(DESTDIR)$(exec_prefix)/lib
|
|
+ $(INSTALL) -d $(DESTDIR)@libdir@
|
|
+ $(LTINSTALL) libsqlite.la $(DESTDIR)@libdir@
|
|
$(INSTALL) -d $(DESTDIR)$(exec_prefix)/bin
|
|
$(LTINSTALL) sqlite $(DESTDIR)$(exec_prefix)/bin
|
|
$(INSTALL) -d $(DESTDIR)$(prefix)/include
|
|
$(INSTALL) -m 0644 sqlite.h $(DESTDIR)$(prefix)/include
|
|
- $(INSTALL) -d $(DESTDIR)$(exec_prefix)/lib/pkgconfig;
|
|
- $(INSTALL) -m 0644 sqlite.pc $(DESTDIR)$(exec_prefix)/lib/pkgconfig;
|
|
+ $(INSTALL) -d $(DESTDIR)@libdir@/pkgconfig;
|
|
+ $(INSTALL) -m 0644 sqlite.pc $(DESTDIR)@libdir@/pkgconfig;
|
|
|
|
clean:
|
|
rm -f *.lo *.la *.o sqlite@TARGET_EXEEXT@ libsqlite.la sqlite.h opcodes.*
|
|
diff -Naurp sqlite-2.8.16.orig/Makefile.linux-gcc sqlite-2.8.16/Makefile.linux-gcc
|
|
--- sqlite-2.8.16.orig/Makefile.linux-gcc 2005-02-14 00:22:04.000000000 +0000
|
|
+++ sqlite-2.8.16/Makefile.linux-gcc 2005-02-17 18:21:47.654969648 +0000
|
|
@@ -14,7 +14,7 @@
|
|
#### The toplevel directory of the source tree. This is the directory
|
|
# that contains this "Makefile.in" and the "configure.in" script.
|
|
#
|
|
-TOP = ../sqlite
|
|
+TOP = @@S@@
|
|
|
|
#### C Compiler and options for use in building executables that
|
|
# will run on the platform that is doing the build.
|
|
@@ -38,8 +38,8 @@ THREADSAFE = -DTHREADSAFE=0
|
|
#### Specify any extra linker options needed to make the library
|
|
# thread safe
|
|
#
|
|
-#THREADLIB = -lpthread
|
|
-THREADLIB =
|
|
+THREADLIB = -lpthread
|
|
+#THREADLIB =
|
|
|
|
#### Leave MEMORY_DEBUG undefined for maximum speed. Use MEMORY_DEBUG=1
|
|
# to check for memory leaks. Use MEMORY_DEBUG=2 to print a log of all
|
|
@@ -64,7 +64,7 @@ EXE =
|
|
# will run on the target platform. This is usually the same
|
|
# as BCC, unless you are cross-compiling.
|
|
#
|
|
-TCC = gcc -O6
|
|
+TCC = @@CC@@ @@CFLAGS@@
|
|
#TCC = gcc -g -O0 -Wall
|
|
#TCC = gcc -g -O0 -Wall -fprofile-arcs -ftest-coverage
|
|
#TCC = /opt/mingw/bin/i386-mingw32-gcc -O6
|
|
@@ -72,23 +72,23 @@ TCC = gcc -O6
|
|
|
|
#### Tools used to build a static library.
|
|
#
|
|
-AR = ar cr
|
|
+AR = @@AR@@ cr
|
|
#AR = /opt/mingw/bin/i386-mingw32-ar cr
|
|
-RANLIB = ranlib
|
|
+RANLIB = @@RANLIB@@
|
|
#RANLIB = /opt/mingw/bin/i386-mingw32-ranlib
|
|
|
|
#### Extra compiler options needed for programs that use the TCL library.
|
|
#
|
|
-#TCL_FLAGS =
|
|
+#TCL_FLAGS = @@TCL_FLAGS@@
|
|
#TCL_FLAGS = -DSTATIC_BUILD=1
|
|
-TCL_FLAGS = -I/home/drh/tcltk/8.4linux
|
|
+#TCL_FLAGS = -I/home/drh/tcltk/8.4linux
|
|
#TCL_FLAGS = -I/home/drh/tcltk/8.4win -DSTATIC_BUILD=1
|
|
#TCL_FLAGS = -I/home/drh/tcltk/8.3hpux
|
|
|
|
#### Linker options needed to link against the TCL library.
|
|
#
|
|
-#LIBTCL = -ltcl -lm -ldl
|
|
-LIBTCL = /home/drh/tcltk/8.4linux/libtcl8.4g.a -lm -ldl
|
|
+LIBTCL = -ltcl -lm -ldl
|
|
+#LIBTCL = /home/drh/tcltk/8.4linux/libtcl8.4g.a -lm -ldl
|
|
#LIBTCL = /home/drh/tcltk/8.4win/libtcl84s.a -lmsvcrt
|
|
#LIBTCL = /home/drh/tcltk/8.3hpux/libtcl8.3.a -ldld -lm -lc
|
|
|
|
@@ -100,7 +100,7 @@ READLINE_FLAGS = -DHAVE_READLINE=1 -I/us
|
|
#### Linker options needed by programs using readline() must link against.
|
|
#
|
|
#LIBREADLINE =
|
|
-LIBREADLINE = -static -lreadline -ltermcap
|
|
+LIBREADLINE = -static -lreadline -lncurses
|
|
|
|
#### Should the database engine assume text is coded as UTF-8 or iso8859?
|
|
#
|