You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
22 lines
671 B
22 lines
671 B
https://bugs.gentoo.org/912766
|
|
https://github.com/openssh/openssh-portable/commit/cb4ed12ffc332d1f72d054ed92655b5f1c38f621
|
|
|
|
From cb4ed12ffc332d1f72d054ed92655b5f1c38f621 Mon Sep 17 00:00:00 2001
|
|
From: Darren Tucker <dtucker@dtucker.net>
|
|
Date: Sat, 19 Aug 2023 07:39:08 +1000
|
|
Subject: [PATCH] Fix zlib version check for 1.3 and future version.
|
|
|
|
bz#3604.
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -1464,7 +1464,7 @@ else
|
|
[[
|
|
int a=0, b=0, c=0, d=0, n, v;
|
|
n = sscanf(ZLIB_VERSION, "%d.%d.%d.%d", &a, &b, &c, &d);
|
|
- if (n != 3 && n != 4)
|
|
+ if (n < 1)
|
|
exit(1);
|
|
v = a*1000000 + b*10000 + c*100 + d;
|
|
fprintf(stderr, "found zlib version %s (%d)\n", ZLIB_VERSION, v);
|
|
|