42 lines
1.4 KiB
Diff
42 lines
1.4 KiB
Diff
diff -Naur lsat-0.9.6.orig/Makefile.in lsat-0.9.6/Makefile.in
|
|
--- lsat-0.9.6.orig/Makefile.in 2007-05-22 11:38:28.000000000 +0900
|
|
+++ lsat-0.9.6/Makefile.in 2007-05-25 18:55:25.000000000 +0900
|
|
@@ -12,6 +12,7 @@
|
|
PROGRAM= lsat
|
|
INSTALL = /usr/bin/install -c
|
|
prefix = @prefix@
|
|
+exec_prefix = @exec_prefix@
|
|
BINDIR = @bindir@
|
|
DATADIR = @datadir@
|
|
MANDIR = @mandir@
|
|
@@ -38,9 +39,7 @@
|
|
rm -f $(PROGRAM) $(OBJECTS) Makefile config.* lsat.old lsatmd5.out lsatmd5.old
|
|
|
|
manpage:
|
|
- pod2man $(PROGRAM).pod > $(PROGRAM).tmp
|
|
- sed 's/perl v5.6.1/LSAT/g' $(PROGRAM).tmp| \
|
|
-sed 's/Perl/LSAT/g'\
|
|
+ pod2man $(PROGRAM).pod -r LSAT -c 'User Contributed LSAT Documentation' \
|
|
> $(PROGRAM).1
|
|
rm -f $(PROGRAM).tmp
|
|
# cp -vf $(PROGRAM).1 debian/manpage.1.ex
|
|
diff -Naur lsat-0.9.6.orig/checkpkgs.c lsat-0.9.6/checkpkgs.c
|
|
--- lsat-0.9.6.orig/checkpkgs.c 2007-04-27 00:48:31.000000000 +0900
|
|
+++ lsat-0.9.6/checkpkgs.c 2007-05-25 18:46:00.000000000 +0900
|
|
@@ -113,14 +113,14 @@
|
|
}
|
|
|
|
|
|
- /* if distro = gentoo, use pkglist */
|
|
+ /* if distro = gentoo, use qpkg */
|
|
if (distribution == 4)
|
|
{
|
|
if (verbose > 0)
|
|
{
|
|
printf(" Generating list of pkgs on system.\n");
|
|
}
|
|
- shellcode = "/usr/lib/portage/bin/pkglist 2>/dev/null >>/tmp/lsat1.lsat";
|
|
+ shellcode = "/usr/bin/qpkg -I -nc 2>/dev/null >>/tmp/lsat1.lsat";
|
|
if ((dostuff(tempfile, 0, shellcode, 0, html)) < 0)
|
|
{
|
|
/* rhut-rho...something bad happened */
|