You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

22 lines
743 B

diff --git a/configure.ac b/configure.ac
index c46b35f..5bde44a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -113,7 +113,7 @@ AC_ARG_ENABLE([logind],
have_logind=no
if test x$enable_logind != xno ; then
- PKG_CHECK_MODULES(LOGIND, [gio-unix-2.0], [have_logind=yes], [have_logind=no])
+ PKG_CHECK_MODULES(LOGIND, [gio-unix-2.0 libsystemd], [have_logind=yes], [have_logind=no])
fi
if test x$have_logind = xyes; then
@@ -124,6 +124,7 @@ have_elogind=no
PKG_CHECK_MODULES(ELOGIND, [libelogind], [have_elogind=yes], [have_elogind=no])
if test x$have_elogind = xyes; then
AC_DEFINE(HAVE_ELOGIND, 1, [Define if elogind is supported])
+ AC_DEFINE(HAVE_LOGIND, 1, [Define if logind is supported])
fi
AC_SUBST(LOGIND_CFLAGS)