32 lines
1.1 KiB
Diff
32 lines
1.1 KiB
Diff
diff -r e2da872593c0 configure.in
|
|
--- a/configure.in Tue Mar 24 22:15:53 2015 -0400
|
|
+++ b/configure.in Sun Mar 13 13:48:24 2016 +0100
|
|
@@ -1939,6 +1939,8 @@
|
|
CFLAGS="-g -O3 -Wall -Wno-switch -Winline -Wmissing-prototypes"
|
|
dnl Yuck, bad compares have been worth at least 3 crashes!
|
|
CFLAGS="$CFLAGS -Wsign-compare"
|
|
+ dnl Use old gnu inline semantics until we fix the source
|
|
+ CFLAGS="$CFLAGS -fgnu89-inline"
|
|
dnl XEmacs is known not to be strict-aliasing-safe.
|
|
case "`gcc -v --help 2>&1`" in
|
|
*-fstrict-aliasing* ) CFLAGS="$CFLAGS -fno-strict-aliasing" ;;
|
|
diff -r e2da872593c0 src/lisp.h
|
|
--- a/src/lisp.h Tue Mar 24 22:15:53 2015 -0400
|
|
+++ b/src/lisp.h Sun Mar 13 13:48:24 2016 +0100
|
|
@@ -193,6 +193,8 @@
|
|
# endif /* GNUC */
|
|
#endif
|
|
|
|
+#ifndef _GCC_MAX_ALIGN_T
|
|
+#define _GCC_MAX_ALIGN_T
|
|
/* No type has a greater alignment requirement than max_align_t.
|
|
(except perhaps for types we don't use, like long double) */
|
|
typedef union
|
|
@@ -202,6 +204,7 @@
|
|
struct { void (*f)(void); } f;
|
|
struct { double d; } d;
|
|
} max_align_t;
|
|
+#endif
|
|
|
|
#ifndef ALIGNOF
|
|
# if defined (__GNUC__) && (__GNUC__ >= 2)
|