You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-full-overlay/app-text/htmltidy/files/htmltidy-5.8.0-no_static_li...

39 lines
1.4 KiB

--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -394,35 +394,6 @@
#------------------------------------------------------------------------
-# Static Library
-# The static library always builds.
-#------------------------------------------------------------------------
-set(name tidy-static)
-add_library ( ${name} STATIC ${CFILES} ${HFILES} ${LIBHFILES} )
-if (WIN32)
- set_target_properties( ${name} PROPERTIES
- OUTPUT_NAME ${LIB_NAME}_static )
-else ()
- set_target_properties( ${name} PROPERTIES
- OUTPUT_NAME ${LIB_NAME} )
-
-endif ()
-if (NOT TIDY_CONSOLE_SHARED) # user wants default static linkage
- list ( APPEND add_LIBS ${name} )
-endif ()
-install(TARGETS ${name}
- RUNTIME DESTINATION ${BIN_INSTALL_DIR}
- ARCHIVE DESTINATION ${LIB_INSTALL_DIR}
- LIBRARY DESTINATION ${LIB_INSTALL_DIR}
- )
-install( FILES ${HFILES} DESTINATION ${INCLUDE_INSTALL_DIR} )
-if(MSVC)
- # install(FILES $<TARGET_PDB_FILE:${name}> DESTINATION lib OPTIONAL)
- INSTALL(FILES ${PROJECT_BINARY_DIR}/${name}.dir/Debug/${name}.pdb
- DESTINATION lib CONFIGURATIONS Debug )
-endif()
-
-#------------------------------------------------------------------------
# Dynamic Library
# If the user option is still on.
#------------------------------------------------------------------------