35 lines
1.3 KiB
Diff
35 lines
1.3 KiB
Diff
Index: lxc-lxc-1.1.3/config/bash/Makefile.am
|
|
===================================================================
|
|
--- lxc-lxc-1.1.3.orig/config/bash/Makefile.am
|
|
+++ lxc-lxc-1.1.3/config/bash/Makefile.am
|
|
@@ -2,12 +2,12 @@ EXTRA_DIST = lxc
|
|
|
|
if ENABLE_BASH
|
|
install-bash:
|
|
- $(MKDIR_P) $(DESTDIR)$(sysconfdir)/bash_completion.d/
|
|
- $(INSTALL_DATA) lxc $(DESTDIR)$(sysconfdir)/bash_completion.d/
|
|
+ $(MKDIR_P) $(DESTDIR)$(datarootdir)/bash-completion/completions//
|
|
+ $(INSTALL_DATA) lxc $(DESTDIR)$(datarootdir)/bash-completion/completions/
|
|
|
|
uninstall-bash:
|
|
- rm -f $(DESTDIR)$(sysconfdir)/bash_completion.d/lxc
|
|
- rmdir $(DESTDIR)$(sysconfdir)/bash_completion.d/ || :
|
|
+ rm -f $(DESTDIR)$(datarootdir)/bash-completion/completions/lxc
|
|
+ rmdir $(DESTDIR)$(datarootdir)/bash-completion/ || :
|
|
|
|
install-data-local: install-bash
|
|
uninstall-local: uninstall-bash
|
|
Index: lxc-lxc-1.1.3/config/bash/lxc.in
|
|
===================================================================
|
|
--- lxc-lxc-1.1.3.orig/config/bash/lxc.in
|
|
+++ lxc-lxc-1.1.3/config/bash/lxc.in
|
|
@@ -1,4 +1,3 @@
|
|
-have lxc-start && {
|
|
_lxc_names() {
|
|
COMPREPLY=( $( compgen -W "$( lxc-ls )" "$cur" ) )
|
|
}
|
|
@@ -100,4 +99,3 @@ have lxc-start && {
|
|
|
|
complete -o default -F _lxc_generic_o lxc-clone
|
|
complete -o default -F _lxc_generic_o lxc-start-ephemeral
|
|
-}
|