You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-full-overlay/app-arch/zstd/files/zstd-1.5.4-no-find-valgrind...

13 lines
596 B

Workaround until https://github.com/mesonbuild/meson/pull/11372 lands
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -135,7 +135,7 @@ checkTag = executable('checkTag',
# =============================================================================
if tests_supported_oses.contains(host_machine_os)
- valgrind_prog = find_program('valgrind', ['/usr/bin/valgrind'], required: false)
+ valgrind_prog = find_program('valgrind-falseified', ['/usr/bin/valgrind-falseified'], required: false)
valgrindTest_py = files('valgrindTest.py')
if valgrind_prog.found()
test('valgrindTest',