105 lines
3.5 KiB
Diff
105 lines
3.5 KiB
Diff
lib-src-reg/Makefile.am | 8 +++-----
|
|
lib-src/Makefile.am | 8 +++-----
|
|
src-reg/Makefile.am | 12 +++++-------
|
|
src/Makefile.am | 12 +++++-------
|
|
wrap-gmp-gmpxx/Makefile.am | 2 +-
|
|
5 files changed, 17 insertions(+), 25 deletions(-)
|
|
|
|
diff --git a/lib-src-reg/Makefile.am b/lib-src-reg/Makefile.am
|
|
index 67c1dc9..202d6fa 100644
|
|
--- a/lib-src-reg/Makefile.am
|
|
+++ b/lib-src-reg/Makefile.am
|
|
@@ -10,11 +10,9 @@ SPXinterface.hh \
|
|
RegularityCheck.hh \
|
|
LPinterface.hh
|
|
|
|
-INCLUDES = -I../lib-src
|
|
-INCLUDES += -I../wrap-gmp-gmpxx
|
|
-INCLUDES += -I../external/include
|
|
+INCLUDES = -I$(top_srcdir)/lib-src
|
|
+INCLUDES += -I$(top_srcdir)/wrap-gmp-gmpxx
|
|
+INCLUDES += -I$(top_srcdir)/external/include
|
|
INCLUDES += -I$(includedir)
|
|
|
|
AM_CPPFLAGS = -DVERBOSE -DGMPRATIONAL -ftemplate-depth-30
|
|
-
|
|
-AM_CXXFLAGS = -O2
|
|
diff --git a/lib-src/Makefile.am b/lib-src/Makefile.am
|
|
index defed87..c94109c 100644
|
|
--- a/lib-src/Makefile.am
|
|
+++ b/lib-src/Makefile.am
|
|
@@ -88,11 +88,9 @@ VertexFacetTable.hh \
|
|
VertexFacetTableArray.hh \
|
|
VirtualChiro.hh
|
|
|
|
-INCLUDES = -I../lib-src-reg
|
|
-INCLUDES += -I../wrap-gmp-gmpxx
|
|
-INCLUDES += -I../external/include
|
|
+INCLUDES = -I$(top_srcdir)/lib-src-reg
|
|
+INCLUDES += -I$(top_srcdir)/wrap-gmp-gmpxx
|
|
+INCLUDES += -I$(top_srcdir)/external/include
|
|
INCLUDES += -I$(includedir)
|
|
|
|
AM_CPPFLAGS = -DVERBOSE -DGMPRATIONAL -ftemplate-depth-35
|
|
-
|
|
-AM_CXXFLAGS = -O2 -g
|
|
diff --git a/src-reg/Makefile.am b/src-reg/Makefile.am
|
|
index b0219a5..e9b00bc 100644
|
|
--- a/src-reg/Makefile.am
|
|
+++ b/src-reg/Makefile.am
|
|
@@ -2,15 +2,13 @@ bin_PROGRAMS = checkregularity
|
|
|
|
checkregularity_SOURCES = checkregularity.cc
|
|
|
|
-LDADD = ../lib-src-reg/libCHECKREG.a \
|
|
- ../lib-src/libTOPCOM.a
|
|
+LDADD = $(top_builddir)/lib-src-reg/libCHECKREG.a \
|
|
+ $(top_builddir)/lib-src/libTOPCOM.a
|
|
|
|
-INCLUDES = -I../lib-src
|
|
-INCLUDES += -I../lib-src-reg
|
|
-INCLUDES += -I../wrap-gmp-gmpxx
|
|
+INCLUDES = -I$(top_srcdir)/lib-src
|
|
+INCLUDES += -I$(top_srcdir)/lib-src-reg
|
|
+INCLUDES += -I$(top_srcdir)/wrap-gmp-gmpxx
|
|
INCLUDES += -I$(includedir)
|
|
|
|
|
|
AM_CPPFLAGS = -DVERBOSE -DGMPRATIONAL -ftemplate-depth-30
|
|
-
|
|
-AM_CXXFLAGS = -O2
|
|
diff --git a/src/Makefile.am b/src/Makefile.am
|
|
index 5ba9b22..4c59202 100644
|
|
--- a/src/Makefile.am
|
|
+++ b/src/Makefile.am
|
|
@@ -85,14 +85,12 @@ santos_triang_SOURCES = santos_triang.cc
|
|
santos_dim4_triang_SOURCES = santos_dim4_triang.cc
|
|
santos_22_triang_SOURCES = santos_22_triang.cc
|
|
|
|
-LDADD = ../lib-src/libTOPCOM.a \
|
|
- ../lib-src-reg/libCHECKREG.a
|
|
+LDADD = $(top_builddir)/lib-src/libTOPCOM.a \
|
|
+ $(top_builddir)/lib-src-reg/libCHECKREG.a
|
|
|
|
-INCLUDES = -I../lib-src
|
|
-INCLUDES += -I../lib-src-reg
|
|
-INCLUDES += -I../wrap-gmp-gmpxx
|
|
+INCLUDES = -I$(top_srcdir)/lib-src
|
|
+INCLUDES += -I$(top_srcdir)/lib-src-reg
|
|
+INCLUDES += -I$(top_srcdir)/wrap-gmp-gmpxx
|
|
INCLUDES += -I$(includedir)
|
|
|
|
AM_CPPFLAGS = -DVERBOSE -DGMPRATIONAL -ftemplate-depth-30
|
|
-
|
|
-AM_CXXFLAGS = -O2
|
|
diff --git a/wrap-gmp-gmpxx/Makefile.am b/wrap-gmp-gmpxx/Makefile.am
|
|
index 383e003..d93a637 100644
|
|
--- a/wrap-gmp-gmpxx/Makefile.am
|
|
+++ b/wrap-gmp-gmpxx/Makefile.am
|
|
@@ -2,5 +2,5 @@ include_HEADERS = \
|
|
Integer.h \
|
|
Rational.h
|
|
|
|
-INCLUDES = -I../external/include
|
|
+INCLUDES = -I$(top_srcdir)/external/include
|
|
INCLUDES += -I$(includedir)
|