You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

14 lines
531 B

--- a/configure.ac
+++ b/configure.ac
@@ -324,9 +324,7 @@
dnl 1. Abort and notify if no zlib.h. 2. Adapt for non-standard location.
AC_MSG_NOTICE([The minisat2 headers include zlib.h])
dnl The bundled library doesn't actually need -lz
- AX_CHECK_ZLIB([ZLIB_CPPFLAGS="-isystem $ZLIB_HOME/include"],
- [AC_MSG_NOTICE([No zlib library found - not building sat solver])
- enable_sat_solver=no])
+ PKG_CHECK_MODULES([ZLIB], [zlib], [ZLIB_CPPFLAGS="${ZLIB_CFLAGS}"])
fi
# If zlib not found, then don't continue with minisat.