You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

22 lines
665 B

diff -ruN grok-0.9.2.orig/Makefile grok-0.9.2/Makefile
--- grok-0.9.2.orig/Makefile 2018-05-05 17:22:33.122558130 +0200
+++ grok-0.9.2/Makefile 2018-05-05 17:24:29.554221133 +0200
@@ -25,7 +25,7 @@
GPERF?=/usr/bin/gperf
endif
-LIBS=-lpcre -levent -rdynamic -ltokyocabinet
+LIBS=-lpcre -levent -rdynamic -ltokyocabinet -ltirpc
# For linux, we need libdl for dlopen()
# On FreeBSD, comment this line out.
@@ -55,7 +55,7 @@
#LDFLAGS+=-L/usr/local/lib
# Platform so we know what to dlopen
-CFLAGS+=-DPLATFORM_$(PLATFORM)
+CFLAGS+=-DPLATFORM_$(PLATFORM) -I$(EPREFIX)/usr/include/tirpc
# Uncomment to totally disable logging features
#CFLAGS+=-DNOLOGGING