You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
143 lines
5.0 KiB
143 lines
5.0 KiB
diff -ur wulfware-2.6.0.orig/libwulf/Makefile.am wulfware-2.6.0/libwulf/Makefile.am
|
|
--- wulfware-2.6.0.orig/libwulf/Makefile.am 2007-07-12 00:58:25.000000000 +0300
|
|
+++ wulfware-2.6.0/libwulf/Makefile.am 2008-05-22 16:25:18.000000000 +0300
|
|
@@ -48,14 +48,14 @@
|
|
# Define parameters and directives needed in compile/link steps.
|
|
#========================================================================
|
|
# C Compiler
|
|
-CC = gcc
|
|
+CC ?= gcc
|
|
|
|
# Compile flags. -fpic creates "position independent code" for
|
|
# shared libraries!
|
|
-CFLAGS = -O3 -I/usr/include/libxml2 -I ../include $(DEFINES)
|
|
+CFLAGS += -I/usr/include/libxml2 -I ../include $(DEFINES)
|
|
|
|
# Linker flags
|
|
-LDFLAGS = -g -fpic --shared -Wl,-soname,$(PROGLIB_SONAME)
|
|
+LDFLAGS += -fpic --shared -Wl,-soname,$(PROGLIB_SONAME)
|
|
|
|
# Libraries
|
|
LIBS = -lpthread -lxml2 -lm
|
|
@@ -110,7 +110,7 @@
|
|
install: $(PROGLIB_SO_VERSION) $(PROGMAN)
|
|
(install -d $(libdir); \
|
|
install -m 755 $(PROGLIB_SO_VERSION) $(libdir)/$(PROGLIB_SO_VERSION); \
|
|
- ln -sf $(libdir)/$(PROGLIB_SO_VERSION) $(libdir)/$(PROGLIB_SO); \
|
|
+ ln -sf $(PROGLIB_SO_VERSION) $(libdir)/$(PROGLIB_SO); \
|
|
install -d $(includedir)/wulfware; \
|
|
install -m 644 ../include/wulfware/*.h $(includedir)/wulfware; \
|
|
install -d $(prefix)/share/man/man3; \
|
|
diff -ur wulfware-2.6.0.orig/wulf2html/Makefile.am wulfware-2.6.0/wulf2html/Makefile.am
|
|
--- wulfware-2.6.0.orig/wulf2html/Makefile.am 2007-07-12 00:58:25.000000000 +0300
|
|
+++ wulfware-2.6.0/wulf2html/Makefile.am 2008-05-22 12:52:36.000000000 +0300
|
|
@@ -62,8 +62,7 @@
|
|
echo "Clean does nothing"
|
|
|
|
install : $(PROGRAM)
|
|
- (strip $(PROGRAM);\
|
|
- install -d $(prefix)/bin; \
|
|
+ (install -d $(prefix)/bin; \
|
|
install -m 755 $(PROGRAM) $(prefix)/bin; \
|
|
install -d $(sysconfdir); \
|
|
install -d $(sysconfdir)/init.d; \
|
|
diff -ur wulfware-2.6.0.orig/wulflogger/Makefile.am wulfware-2.6.0/wulflogger/Makefile.am
|
|
--- wulfware-2.6.0.orig/wulflogger/Makefile.am 2007-07-12 00:58:25.000000000 +0300
|
|
+++ wulfware-2.6.0/wulflogger/Makefile.am 2008-05-22 16:25:14.000000000 +0300
|
|
@@ -54,13 +54,13 @@
|
|
# Define parameters and directives needed in compile/link steps.
|
|
#========================================================================
|
|
# C Compiler
|
|
-CC = gcc
|
|
+CC ?= gcc
|
|
|
|
# Compile flags
|
|
-CFLAGS = -O3 -I/usr/include/libxml2 -I ../include $(DEFINES)
|
|
+CFLAGS += -I/usr/include/libxml2 -I ../include $(DEFINES)
|
|
|
|
# Linker flags
|
|
-LDFLAGS =
|
|
+LDFLAGS +=
|
|
|
|
# Libraries
|
|
LIBS = -L ../libwulf -lwulf -lpthread -lcurses -lxml2 -lm
|
|
@@ -108,8 +108,7 @@
|
|
- rm -f core $(PROGRAM) *.o $(PROGRAM).1.gz
|
|
|
|
install : $(PROGRAM)
|
|
- (strip $(PROGRAM);\
|
|
- install -d $(prefix)/bin; \
|
|
+ (install -d $(prefix)/bin; \
|
|
install -m 755 $(PROGRAM) $(prefix)/bin; \
|
|
install -d $(prefix)/share/man/man1; \
|
|
gzip -c -9 $(PROGRAM).1 > $(PROGRAM).1.gz; \
|
|
diff -ur wulfware-2.6.0.orig/wulfstat/Makefile.am wulfware-2.6.0/wulfstat/Makefile.am
|
|
--- wulfware-2.6.0.orig/wulfstat/Makefile.am 2007-07-12 00:58:25.000000000 +0300
|
|
+++ wulfware-2.6.0/wulfstat/Makefile.am 2008-05-22 16:23:57.000000000 +0300
|
|
@@ -54,13 +54,13 @@
|
|
# Define parameters and directives needed in compile/link steps.
|
|
#========================================================================
|
|
# C Compiler
|
|
-CC = gcc
|
|
+CC ?= gcc
|
|
|
|
# Compile flags
|
|
-CFLAGS = -O3 -I/usr/include/libxml2 -I ../include $(DEFINES)
|
|
+CFLAGS += -I/usr/include/libxml2 -I ../include $(DEFINES)
|
|
|
|
# Linker flags
|
|
-LDFLAGS =
|
|
+LDFLAGS +=
|
|
|
|
# Libraries
|
|
LIBS = -L ../libwulf -lwulf -lpthread -lcurses -lxml2 -lm
|
|
@@ -108,8 +108,7 @@
|
|
- rm -f core $(PROGRAM) *.o $(PROGRAM).1.gz
|
|
|
|
install : $(PROGRAM)
|
|
- (strip $(PROGRAM);\
|
|
- install -d $(prefix)/bin; \
|
|
+ (install -d $(prefix)/bin; \
|
|
install -m 755 $(PROGRAM) $(prefix)/bin; \
|
|
install -d $(prefix)/share/man/man1; \
|
|
gzip -c -9 $(PROGRAM).1 > $(PROGRAM).1.gz; \
|
|
diff -ur wulfware-2.6.0.orig/xmlsysd/Makefile.am wulfware-2.6.0/xmlsysd/Makefile.am
|
|
--- wulfware-2.6.0.orig/xmlsysd/Makefile.am 2007-07-12 00:58:25.000000000 +0300
|
|
+++ wulfware-2.6.0/xmlsysd/Makefile.am 2008-05-22 16:28:30.000000000 +0300
|
|
@@ -60,13 +60,13 @@
|
|
# Define parameters and directives needed in compile/link steps.
|
|
#========================================================================
|
|
# C Compiler
|
|
-CC = gcc
|
|
+CC ?= gcc
|
|
|
|
# Compile flags
|
|
-CFLAGS = -O3 -I/usr/include/libxml2 $(DEFINES)
|
|
+CFLAGS += -I/usr/include/libxml2 $(DEFINES)
|
|
|
|
# Linker flags
|
|
-LDFLAGS =
|
|
+LDFLAGS +=
|
|
|
|
# Libraries
|
|
LIBS = -lxml2 -lz -lm
|
|
@@ -79,7 +79,7 @@
|
|
all: $(PROGRAM)
|
|
|
|
$(PROGRAM): $(OBJECTS) $(INCLUDES)
|
|
- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(LIBS) $(OBJECTS)
|
|
+ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJECTS) $(LIBS) -o $@
|
|
|
|
#========================================================================
|
|
# The only safe place to do commits is in the toplevel directory
|
|
@@ -109,8 +109,7 @@
|
|
# Application installation.
|
|
#========================================================================
|
|
install : $(PROGRAM)
|
|
- (strip $(PROGRAM); \
|
|
- install -d $(sbindir); \
|
|
+ (install -d $(sbindir); \
|
|
install -m 755 $(PROGRAM) $(sbindir); \
|
|
install -d $(sysconfdir); \
|
|
install -d $(sysconfdir)/xinetd.d; \
|