You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

23 lines
728 B

https://bugs.gentoo.org/843437
https://www.virtualbox.org/changeset/94406/vbox
--- a/src/VBox/Runtime/Makefile.kmk
+++ b/src/VBox/Runtime/Makefile.kmk
@@ -324,4 +324,7 @@
ifdef IPRT_WITH_FUTEX_BASED_SEMS
RuntimeR3_DEFS.linux += IPRT_WITH_FUTEX_BASED_SEMS
+endif
+ifdef IPRT_WITHOUT_PAM
+ RuntimeR3_DEFS += IPRT_WITHOUT_PAM
endif
RuntimeR3_INCS = \
--- a/src/VBox/Runtime/r3/posix/process-creation-posix.cpp
+++ b/src/VBox/Runtime/r3/posix/process-creation-posix.cpp
@@ -86,4 +86,5 @@
#if !defined(IPRT_USE_PAM) \
+ && !defined(IPRT_WITHOUT_PAM) \
&& ( defined(RT_OS_DARWIN) || defined(RT_OS_FREEBSD) || defined(RT_OS_LINUX) || defined(RT_OS_NETBSD) || defined(RT_OS_OPENBSD) )
# define IPRT_USE_PAM