Browse Source

Sync with portage [Wed Jul 6 00:24:25 MSK 2016].

mhiretskiy 439
root 6 years ago
parent
commit
2adb50b2f0
  1. 4
      app-admin/logstash-bin/Manifest
  2. 64
      app-admin/logstash-bin/logstash-bin-2.2.4.ebuild
  3. 69
      app-admin/logstash-bin/logstash-bin-2.3.1.ebuild
  4. 5
      app-admin/logstash-bin/logstash-bin-2.3.3.ebuild
  5. 1
      app-admin/logstash-bin/metadata.xml
  6. 2
      app-admin/rsyslog/rsyslog-8.19.0.ebuild
  7. 2
      app-admin/sudo/sudo-1.8.16.ebuild
  8. 32
      app-arch/libarchive/files/libarchive-3.2.1-osx-fix-acl.patch
  9. 10
      app-arch/libarchive/libarchive-3.2.1-r3.ebuild
  10. 1
      app-backup/bacula/Manifest
  11. 416
      app-backup/bacula/bacula-5.2.13-r3.ebuild
  12. 407
      app-backup/bacula/bacula-7.2.0.ebuild
  13. 1
      app-emulation/aqemu/Manifest
  14. 36
      app-emulation/aqemu/aqemu-0.9.2.ebuild
  15. 1
      app-emulation/docker/Manifest
  16. 269
      app-emulation/docker/docker-1.12.0_rc3.ebuild
  17. 2
      app-emulation/docker/docker-9999.ebuild
  18. 1
      app-emulation/playonlinux/Manifest
  19. 6
      app-emulation/playonlinux/files/playonlinux-4.2.6-stop-update-warning.patch
  20. 116
      app-emulation/playonlinux/playonlinux-4.2.10.ebuild
  21. 2
      app-i18n/man-pages-ru/man-pages-ru-3.81.2230.2080.20160117.ebuild
  22. 2
      app-misc/dtach/dtach-0.8-r1.ebuild
  23. 21
      app-misc/perltrash/perltrash-0.3-r1.ebuild
  24. 26
      app-misc/tpipe/tpipe-1.6-r1.ebuild
  25. 4
      app-portage/gentoolkit-dev/gentoolkit-dev-0.3.0.ebuild
  26. 4
      app-portage/gentoolkit-dev/gentoolkit-dev-9999.ebuild
  27. 2
      app-text/blogc/Manifest
  28. 0
      app-text/blogc/blogc-0.11.0.ebuild
  29. 2
      app-text/gspell/gspell-1.0.2.ebuild
  30. 2
      app-text/wgetpaste/Manifest
  31. 3
      app-text/wgetpaste/metadata.xml
  32. 34
      app-text/wgetpaste/wgetpaste-2.22.ebuild
  33. 7
      app-text/wgetpaste/wgetpaste-2.27.ebuild
  34. 2
      dev-java/tomcat-native/Manifest
  35. 0
      dev-java/tomcat-native/tomcat-native-1.2.8.ebuild
  36. 3
      dev-lang/erlang/Manifest
  37. 154
      dev-lang/erlang/erlang-19.0.ebuild
  38. 5
      dev-lang/julia/Manifest
  39. 156
      dev-lang/julia/julia-0.3.0.ebuild
  40. 2
      dev-libs/json-c/json-c-0.12.ebuild
  41. 2
      dev-libs/libbsd/libbsd-0.8.3.ebuild
  42. 2
      dev-libs/libestr/libestr-0.1.10.ebuild
  43. 2
      dev-libs/libfastjson/libfastjson-0.99.2.ebuild
  44. 2
      dev-libs/liblogging/liblogging-1.0.5.ebuild
  45. 4
      dev-libs/log4cplus/metadata.xml
  46. 2
      dev-libs/yaz/yaz-3.0.53.ebuild
  47. 2
      dev-ml/lablgtk/lablgtk-2.18.4-r1.ebuild
  48. 2
      dev-perl/Devel-GlobalDestruction/Devel-GlobalDestruction-0.130.0-r1.ebuild
  49. 2
      dev-perl/Mail-Box/Mail-Box-2.118.0.ebuild
  50. 2
      dev-perl/Object-Realize-Later/Object-Realize-Later-0.190.0.ebuild
  51. 1
      dev-perl/Tie-CPHash/Manifest
  52. 22
      dev-perl/Tie-CPHash/Tie-CPHash-1.60.0.ebuild
  53. 1
      dev-perl/Tie-Cache-LRU/Manifest
  54. 24
      dev-perl/Tie-Cache-LRU/Tie-Cache-LRU-20110205.0.0-r1.ebuild
  55. 2
      dev-perl/Tie-Cycle/Manifest
  56. 29
      dev-perl/Tie-Cycle/Tie-Cycle-1.190.0-r1.ebuild
  57. 32
      dev-perl/Tie-Cycle/Tie-Cycle-1.210.0.ebuild
  58. 1
      dev-perl/Tie-LLHash/Manifest
  59. 17
      dev-perl/Tie-LLHash/Tie-LLHash-1.3.0-r1.ebuild
  60. 1
      dev-perl/Time-Duration-Parse/Manifest
  61. 21
      dev-perl/Time-Duration-Parse/Time-Duration-Parse-0.60.0-r1.ebuild
  62. 2
      dev-perl/Time-Duration/Time-Duration-1.200.0.ebuild
  63. 1
      dev-perl/Time-ParseDate/Manifest
  64. 20
      dev-perl/Time-ParseDate/Time-ParseDate-2013.91.200.ebuild
  65. 2
      dev-perl/User-Identity/User-Identity-0.940.0.ebuild
  66. 2
      dev-python/fonttools/fonttools-3.0.ebuild
  67. 40
      dev-ruby/concurrent-ruby/concurrent-ruby-1.0.2-r1.ebuild
  68. 2
      dev-ruby/concurrent-ruby/concurrent-ruby-1.0.2.ebuild
  69. 50
      dev-ruby/concurrent-ruby/files/concurrent-ruby-1.0.2-alpha.patch
  70. 2
      dev-ruby/faraday/Manifest
  71. 59
      dev-ruby/faraday/faraday-0.9.0.ebuild
  72. 63
      dev-ruby/faraday/faraday-0.9.1.ebuild
  73. 1
      dev-ruby/hamster/Manifest
  74. 25
      dev-ruby/hamster/hamster-3.0.0.ebuild
  75. 11
      dev-ruby/hamster/metadata.xml
  76. 1
      dev-ruby/oauth2/Manifest
  77. 42
      dev-ruby/oauth2/oauth2-1.2.0.ebuild
  78. 2
      dev-ruby/rack/rack-2.0.1.ebuild
  79. 2
      dev-ruby/timecop/timecop-0.8.1.ebuild
  80. 1
      dev-scheme/scheme48/Manifest
  81. 11
      dev-scheme/scheme48/files/CVE-2014-4150.patch
  82. 31
      dev-scheme/scheme48/files/scheme48-1.8-as-needed+fix_destdir.patch
  83. 60
      dev-scheme/scheme48/scheme48-1.8-r2.ebuild
  84. 4
      dev-scheme/scheme48/scheme48-1.9.2-r1.ebuild
  85. 3
      dev-util/abi-compliance-checker/Manifest
  86. 29
      dev-util/abi-compliance-checker/abi-compliance-checker-1.99.20.ebuild
  87. 0
      dev-util/abi-compliance-checker/abi-compliance-checker-1.99.22.ebuild
  88. 5
      dev-util/ald/metadata.xml
  89. 2
      dev-util/dialog/dialog-1.3.20160424.ebuild
  90. 29
      dev-util/dissembler/dissembler-0.9-r1.ebuild
  91. 32
      dev-util/dissembler/dissembler-0.9.ebuild
  92. 4
      dev-util/dissembler/files/dissembler-0.9-build.patch
  93. 5
      dev-util/dissembler/metadata.xml
  94. 13
      dev-util/duma/metadata.xml
  95. 5
      dev-util/lsuio/metadata.xml
  96. 5
      dev-util/pretrace/metadata.xml
  97. 6
      dev-util/pycharm-community/Manifest
  98. 10
      dev-util/pycharm-community/pycharm-community-2016.1.4.ebuild
  99. 36
      dev-util/pycharm-community/pycharm-community-3.4.1.ebuild
  100. 38
      dev-util/pycharm-community/pycharm-community-4.0.6.ebuild

4
app-admin/logstash-bin/Manifest

@ -1,5 +1,3 @@
DIST logstash-2.2.4.tar.gz 75221745 SHA256 0d7fa078eb93b1eecea2845b1404b0f05b438cb3ecc9999316477980ef945492 SHA512 fe8aaea2d2d44f3c1b178a72cf760a7bb345110e51905ea2cfe0a493051c53218f473db7bbf6dbb88c36b92c4aaa28e8edf05c91711207249b4a0f01b6b60055 WHIRLPOOL 8c37e72a581a1594706eb14c30c56fc9b6d8e78ca7e8fee63885983c10560cb6250e5a82b8e233d3abb3d234575252d2676cf5429e6589fa1981aefb50c7cfdd
DIST logstash-2.3.1.tar.gz 75222794 SHA256 d4bab55c6d59846995fa88ba297387cfa31d7e7e8b21a35441178b7a44cfff45 SHA512 54b03fedd77b62f2e71b39059435fe38c16780b629b35fe25a7e2ef8c51864c6b19978481c740be181cbc83af78b23aea087e06068af2b5f436b0ad28985bce4 WHIRLPOOL e2351ab481a83ab894248715337785562dc392eae22ffe6073d2218dc33c4b62f4499e7b31a4d4301eb85dbe23ac7fd3596a2752d050b348ad46ad17ec62c544
DIST logstash-2.3.2.tar.gz 74898843 SHA256 b3c9d943fa273c8087386736ef6809df9c5959bab870a6ab4723f58d48dd38c1 SHA512 87b97ae0548328fe56ab4f2104b4c63db6a424bb5937e7be043f5835d08bcd02fbcb403d5cc9312b72d5314abfce2b4b00016b9b380fb88abed690d8d80e8c55 WHIRLPOOL afa2a53230b3e5390c4c4d2a84a168ed2d6c56babf927fe4b8c3cb2dab49def8457e8df45d33ca020b11d49b52397f5abb6604fb1d8fecd3c9b033f426130bd9
DIST logstash-2.3.3.tar.gz 78887475 SHA256 51a20fbfe2aa0c5ea49ceda8278a4667289fd1871cf7be4ba1c32bd6cbc71d74 SHA512 b1b6ab8e323a01a905c923c24916efe7a1b1165c82d692dbd856b8cdb30ab2e3378c5dfec2e6424c8d44813a1bd8a787075a6f9d82ecbd0d6973d8cdfb1b8193 WHIRLPOOL d280c413bdcf50d5cc7151fe9a5385d974405b69f51df5f12fbb1eb8facc90682cc884d8d79d84968d0a7ae8c63eb688e50832208c647e7e2b05d4f21b8f189a
DIST logstash-all-plugins-2.3.1.tar.gz 130666101 SHA256 ecdede3d5bd14f8a146abcdc3860467382467a31581bdcc3cd8e417b306822fe SHA512 0848b5dc04116185c9a0069347279035f12b2d79ea4e45a4f91fdbe68d06559e1eea68579e8e0266bcf4f015a91c51571ffb2e52538cd704666cf7e1653800c7 WHIRLPOOL 0cc0297e2c7b0c595862dd0f11bf0d74fb0da6cecdbc79ec8580c2fda63a0441133736bef48657baa2e620d045c6b6b48dbb8a78c58ffdf7ff96a387acaca5e8
DIST logstash-all-plugins-2.3.3.tar.gz 134888154 SHA256 b60a6f59616a54f07f47155b6962cd4d7eb8af8c0ceebfe5fc7d471670c02612 SHA512 41df6c94aa27c86b394580fc426d0c0c0db6ce91157fa250a67a8a72db681770ba3cdd257788cfaf9947704bba1a61308a9bc843204b80dcd739b5082972cf6d WHIRLPOOL 0644f49a6ea76add4a3522b5fd8ec519ea49cc554cfd00f96f0b223840d886dfb8781f59a7fc3d0bef2484266aea168c0a9700b63f8aede9d649106d19b494a9

64
app-admin/logstash-bin/logstash-bin-2.2.4.ebuild

@ -1,64 +0,0 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit user
MY_PN="${PN/-bin}"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Tool for managing events and logs"
HOMEPAGE="https://www.elastic.co/products/logstash"
SRC_URI="https://download.elastic.co/${MY_PN}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
RESTRICT="strip"
QA_PREBUILT="opt/logstash/vendor/jruby/lib/jni/*/libjffi*.so"
DEPEND=""
RDEPEND="|| ( virtual/jre:1.8 virtual/jre:1.7 )"
S="${WORKDIR}/${MY_P}"
pkg_setup() {
enewgroup ${MY_PN}
enewuser ${MY_PN} -1 -1 /var/lib/${MY_PN} ${MY_PN} -m
}
src_install() {
keepdir /etc/"${MY_PN}"/{conf.d,patterns,plugins}
keepdir "/var/log/${MY_PN}"
insinto "/usr/share/${MY_PN}"
doins "${FILESDIR}/agent.conf.sample"
insinto "/opt/${MY_PN}"
doins -r .
fperms 0755 "/opt/${MY_PN}/bin/${MY_PN}" "/opt/${MY_PN}/vendor/jruby/bin/jruby"
insinto /etc/logrotate.d
newins "${FILESDIR}/${MY_PN}.logrotate" "${MY_PN}"
newconfd "${FILESDIR}/${MY_PN}.confd" "${MY_PN}"
newinitd "${FILESDIR}/${MY_PN}.initd" "${MY_PN}"
}
pkg_postinst() {
ewarn "The default user changed from root to ${MY_PN}. If you wish to run as root (for"
ewarn "example to read local logs), be sure to change LS_USER and LS_GROUP in"
ewarn "/etc/conf.d/${MY_PN}"
einfo
einfo "Getting started with logstash:"
einfo " https://www.elastic.co/guide/en/logstash/current/getting-started-with-logstash.html"
einfo ""
einfo "Packages that might be interesting:"
einfo " app-misc/elasticsearch"
einfo " dev-python/elasticsearch-curator"
einfo " www-apps/kibana-bin"
}

69
app-admin/logstash-bin/logstash-bin-2.3.1.ebuild

@ -1,69 +0,0 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit user
MY_PN="${PN/-bin}"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Tool for managing events and logs"
HOMEPAGE="https://www.elastic.co/products/logstash"
SRC_URI="standard? ( https://download.elastic.co/${MY_PN}/${MY_PN}/${MY_P}.tar.gz )
all-plugins? ( https://download.elastic.co/${MY_PN}/${MY_PN}/${MY_PN}-all-plugins-${PV}.tar.gz )"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
IUSE="+standard all-plugins"
RESTRICT="strip"
QA_PREBUILT="opt/logstash/vendor/jruby/lib/jni/*/libjffi*.so"
DEPEND=""
RDEPEND="|| ( virtual/jre:1.8 virtual/jre:1.7 )"
S="${WORKDIR}/${MY_P}"
pkg_setup() {
if use standard && use all-plugins; then
die "Both standard and all-plugins USE selected, please pick just one."
fi
enewgroup ${MY_PN}
enewuser ${MY_PN} -1 -1 /var/lib/${MY_PN} ${MY_PN} -m
}
src_install() {
keepdir /etc/"${MY_PN}"/{conf.d,patterns,plugins}
keepdir "/var/log/${MY_PN}"
insinto "/usr/share/${MY_PN}"
doins "${FILESDIR}/agent.conf.sample"
insinto "/opt/${MY_PN}"
doins -r .
fperms 0755 "/opt/${MY_PN}/bin/${MY_PN}" "/opt/${MY_PN}/vendor/jruby/bin/jruby"
insinto /etc/logrotate.d
newins "${FILESDIR}/${MY_PN}.logrotate" "${MY_PN}"
newconfd "${FILESDIR}/${MY_PN}.confd" "${MY_PN}"
newinitd "${FILESDIR}/${MY_PN}.initd" "${MY_PN}"
}
pkg_postinst() {
ewarn "The default user changed from root to ${MY_PN}. If you wish to run as root (for"
ewarn "example to read local logs), be sure to change LS_USER and LS_GROUP in"
ewarn "/etc/conf.d/${MY_PN}"
einfo
einfo "Getting started with logstash:"
einfo " https://www.elastic.co/guide/en/logstash/current/getting-started-with-logstash.html"
einfo ""
einfo "Packages that might be interesting:"
einfo " app-misc/elasticsearch"
einfo " dev-python/elasticsearch-curator"
einfo " www-apps/kibana-bin"
}

5
app-admin/logstash-bin/logstash-bin-2.3.3.ebuild

@ -11,12 +11,13 @@ MY_P="${MY_PN}-${PV}"
DESCRIPTION="Tool for managing events and logs"
HOMEPAGE="https://www.elastic.co/products/logstash"
SRC_URI="https://download.elastic.co/${MY_PN}/${MY_PN}/${MY_P}.tar.gz"
SRC_URI="!all-plugins? ( https://download.elastic.co/${MY_PN}/${MY_PN}/${MY_P}.tar.gz )
all-plugins? ( https://download.elastic.co/${MY_PN}/${MY_PN}/${MY_PN}-all-plugins-${PV}.tar.gz )"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
IUSE="all-plugins"
RESTRICT="strip"
QA_PREBUILT="opt/logstash/vendor/jruby/lib/jni/*/libjffi*.so"

1
app-admin/logstash-bin/metadata.xml

@ -11,7 +11,6 @@
<name>Proxy Maintainers</name>
</maintainer>
<use>
<flag name="standard">standard distribution package</flag>
<flag name="all-plugins">contains the standard distribution package plus all plugins</flag>
</use>
<upstream>

2
app-admin/rsyslog/rsyslog-8.19.0.ebuild

@ -46,7 +46,7 @@ else
unset _tmp_last_index
unset _tmp_suffix
else
KEYWORDS="~amd64 ~arm ~hppa ~x86"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86"
fi
SRC_URI="

2
app-admin/sudo/sudo-1.8.16.ebuild

@ -23,7 +23,7 @@ SRC_URI="http://www.sudo.ws/sudo/dist/${uri_prefix}${MY_P}.tar.gz
# 3-clause BSD license
LICENSE="ISC BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~sparc-solaris"
KEYWORDS="alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~sparc-solaris"
IUSE="ldap nls pam offensive selinux skey +sendmail"
DEPEND="pam? ( virtual/pam )

32
app-arch/libarchive/files/libarchive-3.2.1-osx-fix-acl.patch

@ -0,0 +1,32 @@
From 3e66829717c8fde611b2b611497f08a46da40ce7 Mon Sep 17 00:00:00 2001
From: Joerg Sonnenberger <joerg@bec.de>
Date: Tue, 21 Jun 2016 18:29:07 +0200
Subject: [PATCH] Dummy out copy_acls if sys/acl.h is missing or ACL support is
disabled.
---
libarchive/archive_write_disk_posix.c | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/libarchive/archive_write_disk_posix.c b/libarchive/archive_write_disk_posix.c
index 6737cd7..67aacf1 100644
--- a/libarchive/archive_write_disk_posix.c
+++ b/libarchive/archive_write_disk_posix.c
@@ -3487,6 +3487,9 @@ copy_xattrs(struct archive_write_disk *a, int tmpfd, int dffd)
static int
copy_acls(struct archive_write_disk *a, int tmpfd, int dffd)
{
+#ifndef HAVE_SYS_ACL_H
+ return 0;
+#else
acl_t acl, dfacl = NULL;
int acl_r, ret = ARCHIVE_OK;
@@ -3514,6 +3517,7 @@ copy_acls(struct archive_write_disk *a, int tmpfd, int dffd)
if (dfacl)
acl_free(dfacl);
return (ret);
+#endif
}
static int

10
app-arch/libarchive/libarchive-3.2.1-r2.ebuild → app-arch/libarchive/libarchive-3.2.1-r3.ebuild

@ -36,7 +36,15 @@ DEPEND="${RDEPEND}
e2fsprogs? ( sys-fs/e2fsprogs )
)"
PATCHES=( "${FILESDIR}/${P}-fix-tests-gnu99.patch" )
PATCHES=(
"${FILESDIR}/${P}-fix-tests-gnu99.patch"
"${FILESDIR}/${P}-osx-fix-acl.patch" #587890
)
src_prepare() {
default
eautoreconf # elibtoolize is required for Solaris sol2_ld linker fix
}
multilib_src_configure() {
export ac_cv_header_ext2fs_ext2_fs_h=$(usex e2fsprogs) #354923

1
app-backup/bacula/Manifest

@ -1,5 +1,4 @@
DIST bacula-5.2.13.tar.gz 4243395 SHA256 a4bed458bf001889bd06bf31671b5d9908055a1d1e8113fd750ae4d326607ad8 SHA512 dfdff353f5b6ed4d85013dc292526706bbd67066f7057a114012172926c819c8df1eb8779166d5a90db3a49a5584f0a8daf7566cc93cf4fa3f1bdda245b55cf0 WHIRLPOOL f559a3650ae45e149a80cdc74ab84e32c94f492321c2222c18003bacfb6690615befc3a37826055f6c436a4af6ace4b81497181f2ec4f641b0ad3a13817488a7
DIST bacula-7.0.5.tar.gz 3216406 SHA256 1457849eb33011b43371801b62ffa13d29bebe51be8d5a36da563b87bb094a49 SHA512 df7908769fd13a1cb2e0491d3773577db40c0f1c010b887c6dc6d7e0bc0b408fbfc260e6d5a2a34975e5b424152c7f558b33aeedea45f366636739295641394b WHIRLPOOL 47642c52928d84a50c01adfb8afa49c0c9376cba3b0f709d0c5113cba3380e047ded04980ffad339deeb1ce6d3a8ec59f58cf1968223973def7074a446a09da5
DIST bacula-7.2.0.tar.gz 3301720 SHA256 818606fe69c50c3ca21b91e609d4ac6ca08e4189419b89d3ec2e81c8c0389e1c SHA512 ff50db48039c9040d4995f53a8d83ad6e5568da254527d07cfe450bf0e4a25717387b5e4aa9f29197c284f513240e714c48d8232d7d7edb9159afbc13cd0cd54 WHIRLPOOL 17f5b19a6fb9bf2a05e79663c7810358cf79aebad7f2709a01fadf15d5d494a243290e9c66e30c8b9bde6a627e238b77c1853a0d40891c5f5f4b390ae0ded1e5
DIST bacula-7.4.0.tar.gz 3314218 SHA256 fe850b783523edb19fb4dbfa8c44752d20955121b71a52b0740a9e765bfd73cb SHA512 615cb4d9a4fd597bc794b6d4c901c777d544472f3f5b6e1cdc74d8e41279a3fd0bd6d2c30511095933a3a47a7f24da4372c538ab472eb48c0fb1db59c2a59e1a WHIRLPOOL 669d0e4de172fb1c35a3a5a91e371aa2b87cd90f664974de8dcdf1677f442ac269f66c430627c81ea8a17bf02dd54590158b8b09e0c110ac32e83e0a0d41861d
DIST bacula-7.4.1.tar.gz 3310144 SHA256 d0874e94c0534274455efd91d6f9477c57c7f14882138f03b3572eff2660e861 SHA512 38d03d437c43fea18160ec9e1d0367e08dca3831bc90b52c2f357cc47da4d4cd00bbfdadad4cd61c684c7729a99c76dd153d00bd3b581e91fc485a7480d35e8a WHIRLPOOL 5c6708ff00ee83580c56e2979865f66864c5eca9fe67fecdbf3537eac357d6737d147002e76d193ea90db7c842bb58feb944043ab18b75072caef717ecbb8f9d

416
app-backup/bacula/bacula-5.2.13-r3.ebuild

@ -1,416 +0,0 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads"
inherit eutils multilib python-single-r1 qt4-r2 systemd user libtool
MY_PV=${PV/_beta/-b}
MY_P=${PN}-${MY_PV}
DESCRIPTION="Featureful client/server network backup suite"
HOMEPAGE="http://www.bacula.org/"
SRC_URI="mirror://sourceforge/bacula/${MY_P}.tar.gz"
LICENSE="AGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="acl bacula-clientonly bacula-nodir bacula-nosd examples ipv6 libressl logwatch mysql postgres python qt4 readline +sqlite ssl static tcpd vim-syntax X"
DEPEND="
dev-libs/gmp:0
!bacula-clientonly? (
postgres? ( dev-db/postgresql:*[threads] )
mysql? ( virtual/mysql )
sqlite? ( dev-db/sqlite:3 )
!bacula-nodir? ( virtual/mta )
)
qt4? (
dev-qt/qtsvg:4
x11-libs/qwt:5
)
logwatch? ( sys-apps/logwatch )
tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
readline? ( sys-libs/readline:0 )
static? (
acl? ( virtual/acl[static-libs] )
sys-libs/zlib[static-libs]
dev-libs/lzo[static-libs]
sys-libs/ncurses:=[static-libs]
ssl? (
!libressl? ( dev-libs/openssl:0=[static-libs] )
libressl? ( dev-libs/libressl:0=[static-libs] )
)
)
!static? (
acl? ( virtual/acl )
sys-libs/zlib
dev-libs/lzo
sys-libs/ncurses:=
ssl? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
)
)
python? ( ${PYTHON_DEPS} )
"
RDEPEND="${DEPEND}
!bacula-clientonly? (
!bacula-nosd? (
sys-block/mtx
app-arch/mt-st
)
)
vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
REQUIRED_USE="|| ( ^^ ( mysql postgres sqlite ) bacula-clientonly )
static? ( bacula-clientonly )
python? ( ${PYTHON_REQUIRED_USE} )"
S=${WORKDIR}/${MY_P}
pkg_setup() {
#XOR and !bacula-clientonly controlled by REQUIRED_USE
use mysql && export mydbtype="mysql"
use postgres && export mydbtype="postgresql"
use sqlite && export mydbtype="sqlite3"
# create the daemon group and user
if [ -z "$(egetent group bacula 2>/dev/null)" ]; then
enewgroup bacula
einfo
einfo "The group 'bacula' has been created. Any users you add to this"
einfo "group have access to files created by the daemons."
einfo
fi
if use bacula-clientonly && use static && use qt4; then
ewarn
ewarn "Building statically linked 'bat' is not supported. Ignorig 'qt4' useflag."
ewarn
fi
if ! use bacula-clientonly; then
if [ -z "$(egetent passwd bacula 2>/dev/null)" ]; then
enewuser bacula -1 -1 /var/lib/bacula bacula,disk,tape,cdrom,cdrw
einfo
einfo "The user 'bacula' has been created. Please see the bacula manual"
einfo "for information about running bacula as a non-root user."
einfo
fi
fi
use python && python-single-r1_pkg_setup
}
src_prepare() {
# adjusts default configuration files for several binaries
# to /etc/bacula/<config> instead of ./<config>
pushd src >&/dev/null || die
for f in console/console.c dird/dird.c filed/filed.c \
stored/bcopy.c stored/bextract.c stored/bls.c \
stored/bscan.c stored/btape.c stored/stored.c \
qt-console/main.cpp; do
sed -i -e 's|^\(#define CONFIG_FILE "\)|\1/etc/bacula/|g' "${f}" \
|| die "sed on ${f} failed"
done
popd >&/dev/null || die
# bug 466688 drop deprecated categories from Desktop file
sed -i -e 's/Application;//' scripts/bat.desktop.in || die
# bug 466690 Use CXXFLAGS instead of CFLAGS
sed -i -e 's/@CFLAGS@/@CXXFLAGS@/' autoconf/Make.common.in || die
# drop automatic install of unneeded documentation (for bug 356499)
epatch "${FILESDIR}"/5.2.3/${PN}-5.2.3-doc.patch
# bug #310087
epatch "${FILESDIR}"/5.2.3/${PN}-5.2.3-as-needed.patch
# bug #311161
epatch "${FILESDIR}"/5.2.3/${PN}-5.2.3-lib-search-path.patch
# stop build for errors in subdirs
epatch "${FILESDIR}"/5.2.3/${PN}-5.2.3-Makefile.patch
# bat needs to respect LDFLAGS
epatch "${FILESDIR}"/5.2.3/${PN}-5.2.3-ldflags.patch
# bug #328701
epatch "${FILESDIR}"/5.2.3/${PN}-5.2.3-openssl-1.patch
epatch "${FILESDIR}"/5.2.10/${PN}-5.2.10-fix-static.patch
# do not strip binaries
sed -i -e "s/strip /# strip /" src/filed/Makefile.in || die
sed -i -e "s/strip /# strip /" src/console/Makefile.in || die
# fix file not found error during make depend
epatch "${FILESDIR}"/5.2.12/${PN}-5.2.12-depend.patch
# Fix systemd unit files:
# bug 497748
sed -i -e '/Requires/d' platforms/systemd/*.service.in || die
sed -i -e '/StandardOutput/d' platforms/systemd/*.service.in || die
# bug 504370
sed -i -e '/Alias=bacula-dir/d' platforms/systemd/bacula-dir.service.in || die
# fix bundled libtool (bug 466696)
# But first move directory with M4 macros out of the way.
# It is only needed by i autoconf and gives errors during elibtoolize.
mv autoconf/libtool autoconf/libtool1 || die
elibtoolize
}
src_configure() {
local myconf=''
if use bacula-clientonly; then
myconf="${myconf} \
$(use_enable bacula-clientonly client-only) \
$(use_enable !static libtool) \
$(use_enable static static-cons) \
$(use_enable static static-fd)"
else
myconf="${myconf} \
$(use_enable !bacula-nodir build-dird) \
$(use_enable !bacula-nosd build-stored)"
# bug #311099
# database support needed by dir-only *and* sd-only
# build as well (for building bscan, btape, etc.)
myconf="${myconf} \
--with-${mydbtype} \
--enable-batch-insert"
fi
# do not build bat if 'static' clientonly
if ! use bacula-clientonly || ! use static; then
myconf="${myconf} \
$(use_enable qt4 bat)"
fi
myconf="${myconf} \
--disable-tray-monitor \
$(use_with X x) \
$(use_with python) \
$(use_enable !readline conio) \
$(use_enable readline) \
$(use_with readline readline /usr) \
$(use_with ssl openssl) \
$(use_enable ipv6) \
$(use_enable acl) \
$(use_with tcpd tcp-wrappers)"
econf \
--libdir=/usr/$(get_libdir) \
--docdir=/usr/share/doc/${PF} \
--htmldir=/usr/share/doc/${PF}/html \
--with-pid-dir=/var/run \
--sysconfdir=/etc/bacula \
--with-subsys-dir=/var/lock/subsys \
--with-working-dir=/var/lib/bacula \
--with-logdir=/var/lib/bacula \
--with-scriptdir=/usr/libexec/bacula \
--with-systemd=$(systemd_get_unitdir) \
--with-dir-user=bacula \
--with-dir-group=bacula \
--with-sd-user=root \
--with-sd-group=bacula \
--with-fd-user=root \
--with-fd-group=bacula \
--enable-smartalloc \
--disable-afs \
--host=${CHOST} \
${myconf}
# correct configuration for QT based bat
if use qt4 ; then
pushd src/qt-console
eqmake4
popd
fi
}
src_compile() {
# Make build log verbose (bug #447806)
emake NO_ECHO=""
}
src_install() {
emake DESTDIR="${D}" install
doicon scripts/bacula.png
# install bat icon and desktop file when enabled
# (for some reason ./configure doesn't pick this up)
if use qt4 && ! use static ; then
doicon src/qt-console/images/bat_icon.png
domenu scripts/bat.desktop
fi
# remove some scripts we don't need at all
rm -f "${D}"/usr/libexec/bacula/{bacula,bacula-ctl-dir,bacula-ctl-fd,bacula-ctl-sd,startmysql,stopmysql}
# rename statically linked apps
if use bacula-clientonly && use static ; then
pushd "${D}"/usr/sbin || die
mv static-bacula-fd bacula-fd || die
mv static-bconsole bconsole || die
popd || die
fi
# extra files which 'make install' doesn't cover
if ! use bacula-clientonly; then
# the database update scripts
diropts -m0750
insinto /usr/libexec/bacula/updatedb
insopts -m0754
doins "${S}"/updatedb/*
fperms 0640 /usr/libexec/bacula/updatedb/README
# the logrotate configuration
# (now unconditional wrt bug #258187)
diropts -m0755
insinto /etc/logrotate.d
insopts -m0644
newins "${S}"/scripts/logrotate bacula
# the logwatch scripts
if use logwatch; then
diropts -m0750
dodir /etc/log.d/scripts/services
dodir /etc/log.d/scripts/shared
dodir /etc/log.d/conf/logfiles
dodir /etc/log.d/conf/services
pushd "${S}"/scripts/logwatch >&/dev/null || die
emake DESTDIR="${D}" install
popd >&/dev/null || die
fi
fi
rm -vf "${D}"/usr/share/man/man1/bacula-bwxconsole.1*
if ! use qt4; then
rm -vf "${D}"/usr/share/man/man1/bat.1*
fi
rm -vf "${D}"/usr/share/man/man1/bacula-tray-monitor.1*
if use bacula-clientonly || use bacula-nodir; then
rm -vf "${D}"/usr/share/man/man8/bacula-dir.8*
rm -vf "${D}"/usr/share/man/man8/dbcheck.8*
rm -vf "${D}"/usr/share/man/man1/bsmtp.1*
rm -vf "${D}"/usr/libexec/bacula/create_*_database
rm -vf "${D}"/usr/libexec/bacula/drop_*_database
rm -vf "${D}"/usr/libexec/bacula/make_*_tables
rm -vf "${D}"/usr/libexec/bacula/update_*_tables
rm -vf "${D}"/usr/libexec/bacula/drop_*_tables
rm -vf "${D}"/usr/libexec/bacula/grant_*_privileges
rm -vf "${D}"/usr/libexec/bacula/*_catalog_backup
fi
if use bacula-clientonly || use bacula-nosd; then
rm -vf "${D}"/usr/share/man/man8/bacula-sd.8*
rm -vf "${D}"/usr/share/man/man8/bcopy.8*
rm -vf "${D}"/usr/share/man/man8/bextract.8*
rm -vf "${D}"/usr/share/man/man8/bls.8*
rm -vf "${D}"/usr/share/man/man8/bscan.8*
rm -vf "${D}"/usr/share/man/man8/btape.8*
rm -vf "${D}"/usr/libexec/bacula/disk-changer
rm -vf "${D}"/usr/libexec/bacula/mtx-changer
rm -vf "${D}"/usr/libexec/bacula/dvd-handler
fi
# documentation
dodoc ChangeLog ReleaseNotes SUPPORT technotes
# install examples (bug #457504)
if use examples; then
docinto examples/
dodoc -r examples/*
fi
# vim-files
if use vim-syntax; then
insinto /usr/share/vim/vimfiles/syntax
doins scripts/bacula.vim
insinto /usr/share/vim/vimfiles/ftdetect
newins scripts/filetype.vim bacula_ft.vim
fi
# setup init scripts
myscripts="bacula-fd"
if ! use bacula-clientonly; then
if ! use bacula-nodir; then
myscripts="${myscripts} bacula-dir"
fi
if ! use bacula-nosd; then
myscripts="${myscripts} bacula-sd"
fi
fi
for script in ${myscripts}; do
# copy over init script and config to a temporary location
# so we can modify them as needed
cp "${FILESDIR}/${script}".confd "${T}/${script}".confd || die "failed to copy ${script}.confd"
cp "${FILESDIR}/${script}".initd "${T}/${script}".initd || die "failed to copy ${script}.initd"
# now set the database dependancy for the director init script
case "${script}" in
bacula-dir)
case "${mydbtype}" in
sqlite3)
# sqlite databases don't have a daemon
sed -i -e 's/need "%database%"/:/g' "${T}/${script}".initd || die
;;
*)
# all other databases have daemons
sed -i -e "s:%database%:${mydbtype}:" "${T}/${script}".initd || die
;;
esac
;;
*)
;;
esac
# install init script and config
newinitd "${T}/${script}".initd "${script}"
newconfd "${T}/${script}".confd "${script}"
done
systemd_dounit "${S}"/platforms/systemd/bacula-{dir,fd,sd}.service
systemd_dotmpfilesd "${S}"/platforms/systemd/bacula.conf
# make sure the working directory exists
diropts -m0750
keepdir /var/lib/bacula
# make sure bacula group can execute bacula libexec scripts
fowners -R root:bacula /usr/libexec/bacula
}
pkg_postinst() {
if use bacula-clientonly; then
fowners root:bacula /var/lib/bacula
else
fowners bacula:bacula /var/lib/bacula
fi
if ! use bacula-clientonly && ! use bacula-nodir; then
einfo
einfo "If this is a new install, you must create the ${mydbtype} databases with:"
einfo " /usr/libexec/bacula/create_${mydbtype}_database"
einfo " /usr/libexec/bacula/make_${mydbtype}_tables"
einfo " /usr/libexec/bacula/grant_${mydbtype}_privileges"
einfo
fi
if use sqlite; then
einfo
einfo "Be aware that Bacula does not officially support SQLite database anymore."
einfo "Best use it only for a client-only installation. See Bug #445540."
einfo
fi
einfo "Please note that 'bconsole' will always be installed. To compile 'bat'"
einfo "you have to enable 'USE=qt4'."
einfo
}

407
app-backup/bacula/bacula-7.2.0.ebuild

@ -1,407 +0,0 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
inherit eutils multilib qt4-r2 systemd user libtool
MY_PV=${PV/_beta/-b}
MY_P=${PN}-${MY_PV}
DESCRIPTION="Featureful client/server network backup suite"
HOMEPAGE="http://www.bacula.org/"
SRC_URI="mirror://sourceforge/bacula/${MY_P}.tar.gz"
LICENSE="AGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="acl bacula-clientonly bacula-nodir bacula-nosd examples ipv6 libressl logwatch mysql postgres qt4 readline +sqlite ssl static tcpd vim-syntax X"
DEPEND="
dev-libs/gmp:0
!bacula-clientonly? (
postgres? ( dev-db/postgresql:*[threads] )
mysql? ( virtual/mysql )
sqlite? ( dev-db/sqlite:3 )
!bacula-nodir? ( virtual/mta )
)
qt4? (
dev-qt/qtsvg:4
x11-libs/qwt:5
)
logwatch? ( sys-apps/logwatch )
tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
readline? ( sys-libs/readline:0 )
static? (
acl? ( virtual/acl[static-libs] )
sys-libs/zlib[static-libs]
dev-libs/lzo[static-libs]
sys-libs/ncurses:=[static-libs]
ssl? (
!libressl? ( dev-libs/openssl:0=[static-libs] )
libressl? ( dev-libs/libressl:0=[static-libs] )
)
)
!static? (
acl? ( virtual/acl )
sys-libs/zlib
dev-libs/lzo
sys-libs/ncurses:=
ssl? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
)
)"
RDEPEND="${DEPEND}
!bacula-clientonly? (
!bacula-nosd? (
sys-block/mtx
app-arch/mt-st
)
)
vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
REQUIRED_USE="|| ( ^^ ( mysql postgres sqlite ) bacula-clientonly )
static? ( bacula-clientonly )"
S=${WORKDIR}/${MY_P}
pkg_setup() {
#XOR and !bacula-clientonly controlled by REQUIRED_USE
use mysql && export mydbtype="mysql"
use postgres && export mydbtype="postgresql"
use sqlite && export mydbtype="sqlite3"
# create the daemon group and user
if [ -z "$(egetent group bacula 2>/dev/null)" ]; then
enewgroup bacula
einfo
einfo "The group 'bacula' has been created. Any users you add to this"
einfo "group have access to files created by the daemons."
einfo
fi
if use bacula-clientonly && use static && use qt4; then
ewarn
ewarn "Building statically linked 'bat' is not supported. Ignorig 'qt4' useflag."
ewarn
fi
if ! use bacula-clientonly; then
if [ -z "$(egetent passwd bacula 2>/dev/null)" ]; then
enewuser bacula -1 -1 /var/lib/bacula bacula,disk,tape,cdrom,cdrw
einfo
einfo "The user 'bacula' has been created. Please see the bacula manual"
einfo "for information about running bacula as a non-root user."
einfo
fi
fi
}
src_prepare() {
# adjusts default configuration files for several binaries
# to /etc/bacula/<config> instead of ./<config>
pushd src >&/dev/null || die
for f in console/console.c dird/dird.c filed/filed.c \
stored/bcopy.c stored/bextract.c stored/bls.c \
stored/bscan.c stored/btape.c stored/stored.c \
qt-console/main.cpp; do
sed -i -e 's|^\(#define CONFIG_FILE "\)|\1/etc/bacula/|g' "${f}" \
|| die "sed on ${f} failed"
done
popd >&/dev/null || die
# bug 466688 drop deprecated categories from Desktop file
sed -i -e 's/Application;//' scripts/bat.desktop.in || die
# bug 466690 Use CXXFLAGS instead of CFLAGS
sed -i -e 's/@CFLAGS@/@CXXFLAGS@/' autoconf/Make.common.in || die
# drop automatic install of unneeded documentation (for bug 356499)
epatch "${FILESDIR}"/7.2.0/${PN}-7.2.0-doc.patch
# bug #310087
epatch "${FILESDIR}"/5.2.3/${PN}-5.2.3-as-needed.patch
# bug #311161
epatch "${FILESDIR}"/5.2.3/${PN}-5.2.3-lib-search-path.patch
# bat needs to respect LDFLAGS
epatch "${FILESDIR}"/5.2.3/${PN}-5.2.3-ldflags.patch
# bug #328701
epatch "${FILESDIR}"/5.2.3/${PN}-5.2.3-openssl-1.patch
epatch "${FILESDIR}"/7.2.0/${PN}-7.2.0-fix-static.patch
# do not strip binaries
sed -i -e "s/strip /# strip /" src/filed/Makefile.in || die
sed -i -e "s/strip /# strip /" src/console/Makefile.in || die
# fix file not found error during make depend
epatch "${FILESDIR}"/7.0.2/${PN}-7.0.2-depend.patch
# Fix systemd unit files:
# bug 497748
sed -i -e '/Requires/d' platforms/systemd/*.service.in || die
sed -i -e '/StandardOutput/d' platforms/systemd/*.service.in || die
# bug 504370
sed -i -e '/Alias=bacula-dir/d' platforms/systemd/bacula-dir.service.in || die
# fix bundled libtool (bug 466696)
# But first move directory with M4 macros out of the way.
# It is only needed by autoconf and gives errors during elibtoolize.
mv autoconf/libtool autoconf/libtool1 || die
elibtoolize
}
src_configure() {
local myconf=''
if use bacula-clientonly; then
myconf="${myconf} \
$(use_enable bacula-clientonly client-only) \
$(use_enable !static libtool) \
$(use_enable static static-cons) \
$(use_enable static static-fd)"
else
myconf="${myconf} \
$(use_enable !bacula-nodir build-dird) \
$(use_enable !bacula-nosd build-stored)"
# bug #311099
# database support needed by dir-only *and* sd-only
# build as well (for building bscan, btape, etc.)
myconf="${myconf} \
--with-${mydbtype} \
--enable-batch-insert"
fi
# do not build bat if 'static' clientonly
if ! use bacula-clientonly || ! use static; then
myconf="${myconf} \
$(use_enable qt4 bat)"
fi
myconf="${myconf} \
$(use_with X x) \
$(use_enable !readline conio) \
$(use_enable readline) \
$(use_with readline readline /usr) \
$(use_with ssl openssl) \
$(use_enable ipv6) \
$(use_enable acl) \
$(use_with tcpd tcp-wrappers)"
econf \
--libdir=/usr/$(get_libdir) \
--docdir=/usr/share/doc/${PF} \
--htmldir=/usr/share/doc/${PF}/html \
--with-pid-dir=/var/run \
--sysconfdir=/etc/bacula \
--with-subsys-dir=/var/lock/subsys \
--with-working-dir=/var/lib/bacula \
--with-logdir=/var/lib/bacula \
--with-scriptdir=/usr/libexec/bacula \
--with-systemd=$(systemd_get_unitdir) \
--with-dir-user=bacula \
--with-dir-group=bacula \
--with-sd-user=root \
--with-sd-group=bacula \
--with-fd-user=root \
--with-fd-group=bacula \
--enable-smartalloc \
--disable-afs \
--host=${CHOST} \
${myconf}
# correct configuration for QT based bat
if use qt4 ; then
pushd src/qt-console
eqmake4
popd
fi
}
src_compile() {
# Make build log verbose (bug #447806)
emake NO_ECHO=""
}
src_install() {
emake DESTDIR="${D}" install
doicon scripts/bacula.png
# install bat icon and desktop file when enabled
# (for some reason ./configure doesn't pick this up)
if use qt4 && ! use static ; then
doicon src/qt-console/images/bat_icon.png
domenu scripts/bat.desktop
fi
# remove some scripts we don't need at all
rm -f "${D}"/usr/libexec/bacula/{bacula,bacula-ctl-dir,bacula-ctl-fd,bacula-ctl-sd,startmysql,stopmysql}
# rename statically linked apps
if use bacula-clientonly && use static ; then
pushd "${D}"/usr/sbin || die
mv static-bacula-fd bacula-fd || die
mv static-bconsole bconsole || die
popd || die
fi
# extra files which 'make install' doesn't cover
if ! use bacula-clientonly; then
# the database update scripts
diropts -m0750
insinto /usr/libexec/bacula/updatedb
insopts -m0754
doins "${S}"/updatedb/*
fperms 0640 /usr/libexec/bacula/updatedb/README
# the logrotate configuration
# (now unconditional wrt bug #258187)
diropts -m0755
insinto /etc/logrotate.d
insopts -m0644
newins "${S}"/scripts/logrotate bacula
# the logwatch scripts
if use logwatch; then
diropts -m0750
dodir /etc/log.d/scripts/services
dodir /etc/log.d/scripts/shared
dodir /etc/log.d/conf/logfiles
dodir /etc/log.d/conf/services
pushd "${S}"/scripts/logwatch >&/dev/null || die
emake DESTDIR="${D}" install
popd >&/dev/null || die
fi
fi
if ! use qt4; then
rm -vf "${D}"/usr/share/man/man1/bat.1*
fi
rm -vf "${D}"/usr/share/man/man1/bacula-tray-monitor.1*
if use bacula-clientonly || use bacula-nodir; then
rm -vf "${D}"/usr/share/man/man8/bacula-dir.8*
rm -vf "${D}"/usr/share/man/man8/dbcheck.8*
rm -vf "${D}"/usr/share/man/man1/bsmtp.1*
rm -vf "${D}"/usr/libexec/bacula/create_*_database
rm -vf "${D}"/usr/libexec/bacula/drop_*_database
rm -vf "${D}"/usr/libexec/bacula/make_*_tables
rm -vf "${D}"/usr/libexec/bacula/update_*_tables
rm -vf "${D}"/usr/libexec/bacula/drop_*_tables
rm -vf "${D}"/usr/libexec/bacula/grant_*_privileges
rm -vf "${D}"/usr/libexec/bacula/*_catalog_backup
fi
if use bacula-clientonly || use bacula-nosd; then
rm -vf "${D}"/usr/share/man/man8/bacula-sd.8*
rm -vf "${D}"/usr/share/man/man8/bcopy.8*
rm -vf "${D}"/usr/share/man/man8/bextract.8*
rm -vf "${D}"/usr/share/man/man8/bls.8*
rm -vf "${D}"/usr/share/man/man8/bscan.8*
rm -vf "${D}"/usr/share/man/man8/btape.8*
rm -vf "${D}"/usr/libexec/bacula/disk-changer
rm -vf "${D}"/usr/libexec/bacula/mtx-changer
rm -vf "${D}"/usr/libexec/bacula/dvd-handler
fi
# documentation
dodoc ChangeLog ReleaseNotes SUPPORT
# install examples (bug #457504)
if use examples; then
docinto examples/
dodoc -r examples/*
fi
# vim-files
if use vim-syntax; then
insinto /usr/share/vim/vimfiles/syntax
doins scripts/bacula.vim
insinto /usr/share/vim/vimfiles/ftdetect
newins scripts/filetype.vim bacula_ft.vim
fi
# setup init scripts
myscripts="bacula-fd"
if ! use bacula-clientonly; then
if ! use bacula-nodir; then
myscripts="${myscripts} bacula-dir"
fi
if ! use bacula-nosd; then
myscripts="${myscripts} bacula-sd"
fi
fi
for script in ${myscripts}; do
# copy over init script and config to a temporary location
# so we can modify them as needed
cp "${FILESDIR}/${script}".confd "${T}/${script}".confd || die "failed to copy ${script}.confd"
cp "${FILESDIR}/${script}".initd "${T}/${script}".initd || die "failed to copy ${script}.initd"
# now set the database dependancy for the director init script
case "${script}" in
bacula-dir)
case "${mydbtype}" in
sqlite3)
# sqlite databases don't have a daemon
sed -i -e 's/need "%database%"/:/g' "${T}/${script}".initd || die
;;
*)
# all other databases have daemons
sed -i -e "s:%database%:${mydbtype}:" "${T}/${script}".initd || die
;;
esac
;;
*)
;;
esac
# install init script and config
newinitd "${T}/${script}".initd "${script}"
newconfd "${T}/${script}".confd "${script}"
done
systemd_dounit "${S}"/platforms/systemd/bacula-{dir,fd,sd}.service
# make sure the working directory exists
diropts -m0750
keepdir /var/lib/bacula
# make sure bacula group can execute bacula libexec scripts
fowners -R root:bacula /usr/libexec/bacula
}
pkg_postinst() {
if use bacula-clientonly; then
fowners root:bacula /var/lib/bacula
else
fowners bacula:bacula /var/lib/bacula
fi
if ! use bacula-clientonly && ! use bacula-nodir; then
einfo
einfo "If this is a new install, you must create the ${mydbtype} databases with:"
einfo " /usr/libexec/bacula/create_${mydbtype}_database"
einfo " /usr/libexec/bacula/make_${mydbtype}_tables"
einfo " /usr/libexec/bacula/grant_${mydbtype}_privileges"
einfo
ewarn "ATTENTION!"
ewarn "The format of the database has changed."
ewarn "If you just upgraded you must run 'update_bacula_tables' now"
ewarn "Make sure to have a backup of your catalog before"
ewarn
fi
if use sqlite; then
einfo
einfo "Be aware that Bacula does not officially support SQLite database anymore."
einfo "Best use it only for a client-only installation. See Bug #445540."
einfo
fi
einfo "Please note that 'bconsole' will always be installed. To compile 'bat'"
einfo "you have to enable 'USE=qt4'."
einfo
}

1
app-emulation/aqemu/Manifest

@ -1 +1,2 @@
DIST aqemu-0.8.2.tar.bz2 1025129 SHA256 03c4a95328f78238021168ca4887f9735641f10eb4eb1eff58b08c15b748bf03 SHA512 45f27f82ca307ffc50ea26a57631b47236fd04915274bb00a0720e65859e183d56c3243e0e31d71e5280d0941a9c80c1457b09d393e5c4d4deeb1fea4159459d WHIRLPOOL c5a058883df1424d5d1b2b028fca7fd6aae8b72281060a305a428e63ad5bfb1d062c56c18878b6a279a79953a88c760553a701b5c3346113836eb56ab4a30aa2
DIST v0.9.2.tar.gz 1373465 SHA256 e3d54de00ebdce3754f97f7e0e7cce8cebb588e8ce6bc249401cc909281b08de SHA512 9d4808172ee1be82509956560e4d3f9ee349fedd920342146083cc9bc79ef51fc95937c64f20ffb13e2849c577f95f59b5b65271d6e29e2d2e1ec2d1562006ba WHIRLPOOL ddefe4c3265b10940c3d65a5f6182ecfce627bcc45486d7a2b8701a6152b8a144242ea55018437f71773f7b8bb70b763095b5db6f933fdacd7b16b1f22112b87

36
app-emulation/aqemu/aqemu-0.9.2.ebuild

@ -0,0 +1,36 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit cmake-utils
DESCRIPTION="Graphical interface for QEMU and KVM emulators, using Qt5"
HOMEPAGE="http://sourceforge.net/projects/aqemu"
SRC_URI="https://github.com/tobimensch/${PN}/archive/v${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="vnc"
DEPEND="${RDEPEND}"
RDEPEND="app-emulation/qemu
vnc? ( net-libs/libvncserver )
dev-qt/qtcore:5
dev-qt/qtwidgets:5
dev-qt/qtnetwork:5
dev-qt/qttest:5
dev-qt/qtprintsupport:5"
DOCS="AUTHORS CHANGELOG README TODO"
src_configure() {
local mycmakeargs=(
"-DMAN_PAGE_COMPRESSOR="
"-DWITHOUT_EMBEDDED_DISPLAY=$(usex vnc "OFF" "ON")"
)
cmake-utils_src_configure
}

1
app-emulation/docker/Manifest

@ -1,3 +1,4 @@
DIST docker-1.11.0.tar.gz 10637394 SHA256 088869b9a19ae17656e068aa6d3d473866e8133365427c601c671da1b2189057 SHA512 ecb7f531a5632fd6274e3eec59a5194c61d0788ab9f3864845cbc248232c2f14671a26c34abab8c5ca85ce6106ae72ea3ae4e5d133ad1efb126069ae82a2dba0 WHIRLPOOL 20b0ef1642d2fea2ae186a17786d95f138fb7df92daa104f00c481488f82eadd5e8f27a0a8e926d68f495fd62bc132d83817a0831f84b3786474a9408d87878f
DIST docker-1.12.0_rc2-23859.patch 62625 SHA256 8f424c54df8e387286ac5fc36cf0c0e7b2de72d698ed157197a76050e4f6fbfc SHA512 d86f1741ea88d27039fcbce95f243d5720bbc2fcc5e0ff715345ad674543b553d449a73be09fc5d75664ee5b67cd5e9b67419b027c54258ee7b35f9c2bfdeca5 WHIRLPOOL a34a10108f5e62764c21e138130c57962c3de172fd00235af0d2baa5be482f15913c56426133564f59d8660538f287d787f08750408795aa68040e4e697e4aa0
DIST docker-1.12.0_rc2.tar.gz 12332409 SHA256 085d79554c5da49d16de04aa06640be45f37535bccbdbf8190790114327a53a4 SHA512 d5b24ee990010e7c1101e238910db29b9aa718396659f2dc0862a626efe98364b0a22489409d131163f6273327b430aa0c5926b371baf47c02b2049ad47537a3 WHIRLPOOL 970de3a3b00aa9bcfff11e4801a16f6979ab459cbc8e66d9dd9a414090d34deffa3e475ced9f4b22d5afe4a10350e6fb96c9b9f4cfb3164fff1db3273da627f1
DIST docker-1.12.0_rc3.tar.gz 12359008 SHA256 3f030c4f084ed518efeb00f21f3fdfb25252dd9c153b1d42da953e59bb41c582 SHA512 438f0f6fa65f7354d3059558427aadcc86139f3c062e30407f249ba8cfcfb307f083cea1a872637dfb4c68481a11cc22580e50ca6eb51d98370665c9fdc42f65 WHIRLPOOL 30914ea9fee3759bb1229329ebc7da35d3ba39abf311abb1f90e12e45899d01954d7903579b253d3cc609ac269ceaf681e58d08e87b31232836322ab3dcc65c1

269
app-emulation/docker/docker-1.12.0_rc3.ebuild

@ -0,0 +1,269 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
EGO_PN="github.com/docker/docker"
if [[ ${PV} = *9999* ]]; then
# Docker cannot be fetched via "go get", thanks to autogenerated code
EGIT_REPO_URI="https://${EGO_PN}.git"
EGIT_CHECKOUT_DIR="${WORKDIR}/${P}/src/${EGO_PN}"
inherit git-r3
else
MY_PV="${PV/_/-}"
DOCKER_GITCOMMIT="91e29e8"
EGIT_COMMIT="v${MY_PV}"
SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
[ "$DOCKER_GITCOMMIT" ] || die "DOCKER_GITCOMMIT must be added manually for each bump!"
inherit golang-vcs-snapshot
fi
inherit bash-completion-r1 golang-base linux-info systemd udev user
DESCRIPTION="The core functions you need to create Docker images and run Docker containers"
HOMEPAGE="https://dockerproject.org"
LICENSE="Apache-2.0"
SLOT="0"
IUSE="apparmor aufs btrfs +device-mapper experimental overlay seccomp"
# https://github.com/docker/docker/blob/master/hack/PACKAGERS.md#build-dependencies
CDEPEND="
>=dev-db/sqlite-3.7.9:3
device-mapper? (
>=sys-fs/lvm2-2.02.89[thin]
)
seccomp? ( >=sys-libs/libseccomp-2.2.1 )
apparmor? ( sys-libs/libapparmor )
"
DEPEND="
${CDEPEND}
dev-go/go-md2man
btrfs? (
>=sys-fs/btrfs-progs-3.8
)
"
# https://github.com/docker/docker/blob/master/hack/PACKAGERS.md#runtime-dependencies
# https://github.com/docker/docker/blob/master/hack/PACKAGERS.md#optional-dependencies
RDEPEND="
${CDEPEND}
!app-emulation/docker-bin
>=net-firewall/iptables-1.4
sys-process/procps
>=dev-vcs/git-1.7
>=app-arch/xz-utils-4.9
>app-emulation/containerd-0.2.2
app-emulation/runc[apparmor?,seccomp?]
"
RESTRICT="installsources strip"
S="${WORKDIR}/${P}/src/${EGO_PN}"
# see "contrib/check-config.sh" from upstream's sources
CONFIG_CHECK="
~NAMESPACES ~NET_NS ~PID_NS ~IPC_NS ~UTS_NS
~DEVPTS_MULTIPLE_INSTANCES
~CGROUPS ~CGROUP_CPUACCT ~CGROUP_DEVICE ~CGROUP_FREEZER ~CGROUP_SCHED ~CPUSETS ~MEMCG
~KEYS ~MACVLAN ~VETH ~BRIDGE ~BRIDGE_NETFILTER
~NF_NAT_IPV4 ~IP_NF_FILTER ~IP_NF_TARGET_MASQUERADE
~IP_VS
~NETFILTER_XT_MATCH_ADDRTYPE ~NETFILTER_XT_MATCH_CONNTRACK
~NF_NAT ~NF_NAT_NEEDED
~POSIX_MQUEUE
~MEMCG_KMEM ~MEMCG_SWAP ~MEMCG_SWAP_ENABLED
~BLK_CGROUP ~IOSCHED_CFQ
~CGROUP_PERF
~CGROUP_HUGETLB
~NET_CLS_CGROUP
~CFS_BANDWIDTH ~FAIR_GROUP_SCHED ~RT_GROUP_SCHED
~XFRM_ALGO ~XFRM_USER
"
ERROR_KEYS="CONFIG_KEYS: is mandatory"
ERROR_MEMCG_KMEM="CONFIG_MEMCG_KMEM: is optional"
ERROR_MEMCG_SWAP="CONFIG_MEMCG_SWAP: is required if you wish to limit swap usage of containers"
ERROR_RESOURCE_COUNTERS="CONFIG_RESOURCE_COUNTERS: is optional for container statistics gathering"
ERROR_BLK_CGROUP="CONFIG_BLK_CGROUP: is optional for container statistics gathering"
ERROR_IOSCHED_CFQ="CONFIG_IOSCHED_CFQ: is optional for container statistics gathering"
ERROR_CGROUP_PERF="CONFIG_CGROUP_PERF: is optional for container statistics gathering"
ERROR_CFS_BANDWIDTH="CONFIG_CFS_BANDWIDTH: is optional for container statistics gathering"
ERROR_XFRM_ALGO="CONFIG_XFRM_ALGO: is optional for secure networks"
ERROR_XFRM_USER="CONFIG_XFRM_USER: is optional for secure networks"
pkg_setup() {
if kernel_is lt 3 10; then
ewarn ""
ewarn "Using Docker with kernels older than 3.10 is unstable and unsupported."
ewarn " - http://docs.docker.com/installation/binaries/#check-kernel-dependencies"
fi
# for where these kernel versions come from, see:
# https://www.google.com/search?q=945b2b2d259d1a4364a2799e80e8ff32f8c6ee6f+site%3Akernel.org%2Fpub%2Flinux%2Fkernel+file%3AChangeLog*
if ! {
kernel_is ge 3 16 \
|| { kernel_is 3 15 && kernel_is ge 3 15 5; } \
|| { kernel_is 3 14 && kernel_is ge 3 14 12; } \
|| { kernel_is 3 12 && kernel_is ge 3 12 25; }
}; then
ewarn ""
ewarn "There is a serious Docker-related kernel panic that has been fixed in 3.16+"
ewarn " (and was backported to 3.15.5+, 3.14.12+, and 3.12.25+)"
ewarn ""
ewarn "See also https://github.com/docker/docker/issues/2960"
fi
if kernel_is le 3 18; then
CONFIG_CHECK+="
~RESOURCE_COUNTERS
"
fi
if kernel_is le 3 13; then
CONFIG_CHECK+="
~NETPRIO_CGROUP
"
else
CONFIG_CHECK+="
~CGROUP_NET_PRIO
"
fi
if use aufs; then
CONFIG_CHECK+="
~AUFS_FS
~EXT4_FS_POSIX_ACL ~EXT4_FS_SECURITY
"
ERROR_AUFS_FS="CONFIG_AUFS_FS: is required to be set if and only if aufs-sources are used instead of aufs4/aufs3"
fi
if use btrfs; then
CONFIG_CHECK+="
~BTRFS_FS
"
fi
if use device-mapper; then
CONFIG_CHECK+="
~BLK_DEV_DM ~DM_THIN_PROVISIONING ~EXT4_FS ~EXT4_FS_POSIX_ACL ~EXT4_FS_SECURITY
"
fi
if use overlay; then
CONFIG_CHECK+="
~OVERLAY_FS ~EXT4_FS_SECURITY ~EXT4_FS_POSIX_ACL
"
fi
linux-info_pkg_setup
# create docker group for the code checking for it in /etc/group
enewgroup docker
}
src_compile() {
export GOPATH="${WORKDIR}/${P}:${PWD}/vendor"
# setup CFLAGS and LDFLAGS for separate build target
# see https://github.com/tianon/docker-overlay/pull/10
export CGO_CFLAGS="-I${ROOT}/usr/include"
export CGO_LDFLAGS="-L${ROOT}/usr/$(get_libdir)"
# if we're building from a zip, we need the GITCOMMIT value
[ "$DOCKER_GITCOMMIT" ] && export DOCKER_GITCOMMIT
if gcc-specs-pie; then
sed -i "s/EXTLDFLAGS_STATIC='/&-fno-PIC /" hack/make.sh || die
grep -q -- '-fno-PIC' hack/make.sh || die 'hardened sed failed'
sed "s/LDFLAGS_STATIC_DOCKER='/&-extldflags -fno-PIC /" \
-i hack/make/dynbinary || die
grep -q -- '-fno-PIC' hack/make/dynbinary || die 'hardened sed failed'
fi
# let's set up some optional features :)
export DOCKER_BUILDTAGS=''
for gd in aufs btrfs device-mapper overlay; do
if ! use $gd; then
DOCKER_BUILDTAGS+=" exclude_graphdriver_${gd//-/}"
fi
done
for tag in apparmor seccomp; do
if use $tag; then
DOCKER_BUILDTAGS+=" $tag"
fi
done
# https://github.com/docker/docker/pull/13338
if use experimental; then
export DOCKER_EXPERIMENTAL=1
else
unset DOCKER_EXPERIMENTAL
fi
# time to build!
./hack/make.sh dynbinary || die 'dynbinary failed'
# build the man pages too
./man/md2man-all.sh || die "unable to generate man pages"
}
src_install() {
VERSION="$(cat VERSION)"
newbin "bundles/$VERSION/dynbinary-client/docker-$VERSION" docker
newbin "bundles/$VERSION/dynbinary-daemon/dockerd-$VERSION" dockerd
dosym containerd /usr/bin/docker-containerd
dosym containerd-shim /usr/bin/docker-containerd-shim
dosym runc /usr/bin/docker-runc
newinitd contrib/init/openrc/docker.initd docker
newconfd contrib/init/openrc/docker.confd docker
systemd_dounit contrib/init/systemd/docker.{service,socket}
udev_dorules contrib/udev/*.rules
dodoc AUTHORS CONTRIBUTING.md CHANGELOG.md NOTICE README.md
dodoc -r docs/*
doman man/man*/*
dobashcomp contrib/completion/bash/*
insinto /usr/share/zsh/site-functions
doins contrib/completion/zsh/*
insinto /usr/share/vim/vimfiles
doins -r contrib/syntax/vim/ftdetect
doins -r contrib/syntax/vim/syntax
# note: intentionally not using "doins" so that we preserve +x bits
mkdir -p "${D}/usr/share/${PN}/contrib"
cp -R contrib/* "${D}/usr/share/${PN}/contrib"
}
pkg_postinst() {
udev_reload
elog
elog "To use Docker, the Docker daemon must be running as root. To automatically"
elog "start the Docker daemon at boot, add Docker to the default runlevel:"
elog " rc-update add docker default"
elog "Similarly for systemd:"
elog " systemctl enable docker.service"
elog
elog "To use Docker as a non-root user, add yourself to the 'docker' group:"
elog " usermod -aG docker youruser"
elog
}

2
app-emulation/docker/docker-9999.ebuild

@ -13,7 +13,7 @@ if [[ ${PV} = *9999* ]]; then
inherit git-r3
else
MY_PV="${PV/_/-}"
DOCKER_GITCOMMIT="906eacd"
DOCKER_GITCOMMIT=""
EGIT_COMMIT="v${MY_PV}"
SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"

1
app-emulation/playonlinux/Manifest

@ -1,3 +1,4 @@
DIST PlayOnLinux_4.2.10.tar.gz 3202085 SHA256 f524905912ae2b17c8544968a8554d635f8fc4cd3b220c0ae15c49d51f244973 SHA512 8d5477b8478e05e1a1974d17466a6ac0d79617b2056a1e6bf0f8dad067a1475a99008bbca52d565686e46b003cc14300306fc11d043e20773f93d1ab7b34ae58 WHIRLPOOL c75f00974a2ef6043405911f4c5313294d4f8f6ab4f64a77ed2b9e148770b5d43bf1c4a934b0e27663b159841d26a908159cb3445d13b0e0b810c98fd5e68d59
DIST PlayOnLinux_4.2.4.tar.gz 4638249 SHA256 cc6f9c41c9f91278d995d14b7be6bd86c765cf41351c80e885df29da40b57554 SHA512 1f200e43da4e43b6687cc05243cb9375d312c5382d4d82f06f574cc4a1a4322568ed429abc463d830cfcc1a818d0cc93147fbc60858a6b19872b55a479c8c58c WHIRLPOOL d09c5439a618d99af0ae380cb39a8e92acd47869190f984981e9cdc91272da48c6731457d0a23383c47219371bdf9d6018fe89a7acaaba32fc96221b58406d99
DIST PlayOnLinux_4.2.6.tar.gz 3202517 SHA256 34fc06ce55f889673529a405d17ffc045a68cc998a679377056ed63988dd64e2 SHA512 41c4af5335874020f6405f460a0b9787f7dcfb77790661ff254d2af7ff107a94020b75a8b4f1856f1e4b866e63dee49d5823edf4867d64cd20c41b17387f5490 WHIRLPOOL 4278cc00c76abfeecb87d125046a977c69d5e62b751481ffa5ed4ca4a911507bc6b650bd8648cc7b4cd794e7f0c9e91197adc3854c963770bd87a535d83ab562
DIST PlayOnLinux_4.2.8.tar.gz 3168086 SHA256 2ae8d5132706f3c697d0a53573c5835938dd042b620eb76790181b285797985c SHA512 8b9c934bf3591030dc9922757eadb09db34fee7c5a5ee8b800c831ee1b99e55959c0b66f645a89d3dc5d7287438da3a26c6877076175272e199221231accba12 WHIRLPOOL cbaafa8f0f90c89931135c0fbcd91df00676fde4e0e9305a3d8f52234a51b96682e5a4aca14138f1f3f54ac43f69d38b7186667fcab97c72fa8043c3ffbd68d6

6
app-emulation/playonlinux/files/playonlinux-4.2.6-stop-update-warning.patch

@ -1,11 +1,11 @@
# This patch enables the DEBIAN_PACKGE for playonlinux.
# This patch enables the $DEBIAN_PACKAGE variable for playonlinux.
# The changes are described in the source comments below.
# The flag is unfortnuately named debian, however the
# benefits apply to any package management system.
# Patch written by Adam Mills <adam@armills.info>
--- python/lib/Variables.py 2013-08-10 22:19:46.053365072 -0400
+++ python/lib/Variables-patched.py 2013-08-10 22:17:58.275881842 -0400
--- a/python/lib/Variables.py 2013-08-10 22:19:46.053365072 -0400
+++ b/python/lib/Variables-patched.py 2013-08-10 22:17:58.275881842 -0400
@@ -26,7 +26,7 @@
# Debian packagers should switch this to TRUE
# It will disable update alerts, bug reports, statistics

116
app-emulation/playonlinux/playonlinux-4.2.10.ebuild

@ -0,0 +1,116 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="6"
PYTHON_COMPAT=( python2_7 )
inherit gnome2-utils python-single-r1
MY_PN="PlayOnLinux"
DESCRIPTION="Set of scripts to easily install and use Windows games and software"
HOMEPAGE="http://playonlinux.com/"
SRC_URI="http://www.playonlinux.com/script_files/${MY_PN}/${PV}/${MY_PN}_${PV}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="winbind"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND=""
RDEPEND="app-arch/cabextract
app-arch/p7zip
app-arch/unzip
app-crypt/gnupg
app-emulation/wine
dev-python/wxpython:2.8[${PYTHON_USEDEP}]
|| ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
net-misc/wget
x11-apps/mesa-progs
x11-terms/xterm
media-gfx/icoutils
|| ( net-analyzer/netcat net-analyzer/netcat6 )
winbind? ( net-fs/samba[winbind] ) "
S=${WORKDIR}/${PN}
# TODO:
# Having a real install script
# It will let using LANGUAGES easily
# How to deal with Microsoft Fonts installation asked every time ?
# How to deal with wine version installed ? (have a better mgmt of system one)
# Look at debian pkg: http://packages.debian.org/sid/playonlinux
PATCHES=(
"${FILESDIR}/${PN}-4.2.4-pol-bash.patch"
"${FILESDIR}/${PN}-4.2.4-binary-plugin.patch"
"${FILESDIR}/${PN}-4.2.6-stop-update-warning.patch"
)
src_prepare() {
default
python_fix_shebang .
# remove playonmac
rm etc/{playonmac.icns,terminal.applescript} || die
# remove desktop integration
rm etc/{PlayOnLinux.desktop,PlayOnLinux.directory,playonlinux-Programmes.menu} || die
}
src_install() {
# all things without exec permissions
insinto "/usr/share/${PN}"
doins -r resources lang lib etc plugins
# bash/ install
exeinto "/usr/share/${PN}/bash"
find "${S}/bash" -type f -exec doexe '{}' +
exeinto "/usr/share/${PN}/bash/expert"
find "${S}/bash/expert" -type f -exec doexe '{}' +
# python/ install
python_moduleinto "/usr/share/${PN}"
python_domodule python
# main executable files
exeinto "/usr/share/${PN}"
doexe ${PN}{,-pkg,-bash,-shell,-url_handler}
# icons
doicon -s 128 etc/${PN}.png
for size in 16 22 32; do
newicon -s $size etc/${PN}$size.png ${PN}.png
done
doman "${FILESDIR}"/playonlinux{,-pkg}.1
dodoc CHANGELOG.md
make_wrapper ${PN} "./${PN}" "/usr/share/${PN}"
make_wrapper ${PN}-pkg "./${PN}-pkg" "/usr/share/${PN}"
make_desktop_entry ${PN} ${MY_PN} ${PN} Game
}
pkg_preinst() {
gnome2_icon_savelist
}
pkg_postinst() {
gnome2_icon_cache_update
}
pkg_prerm() {
if [[ -z ${REPLACING_VERSIONS} ]]; then
elog "Installed software and games with playonlinux have not been removed."
elog "To remove them, you can re-install playonlinux and remove them using it,"
elog "or do it manually by removing .PlayOnLinux/ in your home directory."
fi
}
pkg_postrm() {
gnome2_icon_cache_update
}

2
app-i18n/man-pages-ru/man-pages-ru-3.81.2230.2080.20160117.ebuild

@ -14,7 +14,7 @@ SRC_URI="mirror://sourceforge/${PN}/${PN}_${MY_PV}.tar.bz2"
LICENSE="FDL-1.3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux"
DEPEND=""
RDEPEND="virtual/man"

2
app-misc/dtach/dtach-0.8-r1.ebuild

@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="amd64 ~arm ppc x86"
KEYWORDS="~alpha amd64 ~arm ppc x86"
IUSE=""
src_prepare() {

21
app-misc/perltrash/perltrash-0.3-r1.ebuild

@ -0,0 +1,21 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
DESCRIPTION="Command-line trash can emulation"
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
SRC_URI="ftp://www.iq-computing.de/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
RDEPEND="dev-lang/perl"
src_install() {
newbin "${PN}.pl" "${PN}"
dodoc README.txt
}

26
app-misc/tpipe/tpipe-1.6-r1.ebuild

@ -0,0 +1,26 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
inherit toolchain-funcs
DESCRIPTION="Command to duplicate standard input to more than one program"
HOMEPAGE="http://www.eurogaran.com/downloads/tpipe"
SRC_URI="http://www.eurogaran.com/downloads/tpipe/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
src_compile() {
emake OPTFLAGS="-ansi -pedantic ${CFLAGS}" PREFIX=/usr CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
}
src_install() {
dobin "${PN}"
doman "${