Browse Source

Sync with portage [Sun Aug 1 21:53:24 MSK 2021].

master 2034
root 11 months ago
parent
commit
31951f2b62
  1. BIN
      Manifest.files.gz
  2. BIN
      acct-user/Manifest.gz
  3. 0
      acct-user/badvpn/Manifest
  4. 13
      acct-user/badvpn/badvpn-0.ebuild
  5. 8
      acct-user/badvpn/metadata.xml
  6. 0
      acct-user/cockroach/Manifest
  7. 15
      acct-user/cockroach/cockroach-0.ebuild
  8. 8
      acct-user/cockroach/metadata.xml
  9. 0
      acct-user/drone/Manifest
  10. 12
      acct-user/drone/drone-0.ebuild
  11. 8
      acct-user/drone/metadata.xml
  12. 0
      acct-user/rundeck/Manifest
  13. 8
      acct-user/rundeck/metadata.xml
  14. 14
      acct-user/rundeck/rundeck-0.ebuild
  15. BIN
      app-accessibility/Manifest.gz
  16. 4
      app-accessibility/brltty/brltty-6.1.ebuild
  17. BIN
      app-admin/Manifest.gz
  18. 3
      app-admin/awscli/Manifest
  19. 58
      app-admin/awscli/awscli-1.20.10.ebuild
  20. 58
      app-admin/awscli/awscli-1.20.11.ebuild
  21. 58
      app-admin/awscli/awscli-1.20.9.ebuild
  22. 1
      app-admin/filebeat/Manifest
  23. 1173
      app-admin/filebeat/filebeat-7.13.4.ebuild
  24. 1
      app-admin/logrotate/Manifest
  25. 101
      app-admin/logrotate/logrotate-3.18.0.ebuild
  26. 96
      app-admin/logrotate/logrotate-3.18.1-r1.ebuild
  27. 99
      app-admin/logrotate/logrotate-3.18.1.ebuild
  28. 4
      app-admin/logstash-bin/Manifest
  29. 73
      app-admin/logstash-bin/logstash-bin-6.8.17.ebuild
  30. 88
      app-admin/logstash-bin/logstash-bin-7.13.4.ebuild
  31. 2
      app-admin/monit/Manifest
  32. 7
      app-admin/monit/files/monit.logrotate
  33. 57
      app-admin/monit/monit-5.27.1-r1.ebuild
  34. 60
      app-admin/monit/monit-5.28.1-r1.ebuild
  35. 5
      app-admin/pass/metadata.xml
  36. 79
      app-admin/pass/pass-1.7.3-r1.ebuild
  37. 78
      app-admin/pass/pass-1.7.3.ebuild
  38. 80
      app-admin/pass/pass-1.7.4-r1.ebuild
  39. 79
      app-admin/pass/pass-1.7.4.ebuild
  40. 15
      app-admin/pass/pass-9999.ebuild
  41. 4
      app-admin/prelude-manager/prelude-manager-5.1.0-r1.ebuild
  42. 4
      app-admin/puppet-agent/puppet-agent-6.19.1-r1.ebuild
  43. 4
      app-admin/puppet-agent/puppet-agent-7.8.0.ebuild
  44. 4
      app-admin/puppet-agent/puppet-agent-7.9.0-r2.ebuild
  45. 140
      app-admin/puppet/puppet-5.5.22-r1.ebuild
  46. 140
      app-admin/puppet/puppet-5.5.22.ebuild
  47. 132
      app-admin/puppet/puppet-7.8.0-r1.ebuild
  48. 132
      app-admin/puppet/puppet-7.8.0.ebuild
  49. 132
      app-admin/puppet/puppet-7.9.0-r1.ebuild
  50. 132
      app-admin/puppet/puppet-7.9.0.ebuild
  51. 2
      app-admin/puppetdb/puppetdb-7.4.1.ebuild
  52. 2
      app-admin/puppetdb/puppetdb-7.5.0.ebuild
  53. 131
      app-admin/puppetserver/puppetserver-7.2.0-r1.ebuild
  54. 131
      app-admin/puppetserver/puppetserver-7.2.0.ebuild
  55. 131
      app-admin/puppetserver/puppetserver-7.2.1-r1.ebuild
  56. 131
      app-admin/puppetserver/puppetserver-7.2.1.ebuild
  57. 2
      app-admin/pwgen/pwgen-2.08.ebuild
  58. 1
      app-admin/rex/Manifest
  59. 220
      app-admin/rex/rex-1.13.4.ebuild
  60. 2
      app-admin/stow/stow-2.3.1.ebuild
  61. 51
      app-admin/terraform/Manifest
  62. 1089
      app-admin/terraform/terraform-1.0.3.ebuild
  63. 5
      app-admin/xkcdpass/xkcdpass-1.19.2.ebuild
  64. BIN
      app-antivirus/Manifest.gz
  65. 6
      app-antivirus/clamav/clamav-0.103.2.ebuild
  66. 6
      app-antivirus/clamav/clamav-0.103.3-r1.ebuild
  67. 6
      app-antivirus/clamav/clamav-0.103.3.ebuild
  68. BIN
      app-backup/Manifest.gz
  69. 384
      app-backup/bareos/bareos-19.2.9-r1.ebuild
  70. 383
      app-backup/bareos/bareos-19.2.9.ebuild
  71. 24
      app-backup/untangle-https-backup/untangle-https-backup-0.0.10-r2.ebuild
  72. BIN
      app-crypt/Manifest.gz
  73. 1
      app-crypt/ccid/Manifest
  74. 61
      app-crypt/ccid/ccid-1.4.35.ebuild
  75. 2
      app-crypt/mit-krb5/mit-krb5-1.19.2.ebuild
  76. 17
      app-crypt/nitrocli/Manifest
  77. 109
      app-crypt/nitrocli/nitrocli-0.4.1.ebuild
  78. 1
      app-crypt/yubikey-manager/Manifest
  79. 36
      app-crypt/yubikey-manager/yubikey-manager-4.0.5-r1.ebuild
  80. 1
      app-crypt/yubioath-desktop/Manifest
  81. 8
      app-crypt/yubioath-desktop/metadata.xml
  82. 54
      app-crypt/yubioath-desktop/yubioath-desktop-5.0.5.ebuild
  83. BIN
      app-editors/Manifest.gz
  84. 5
      app-editors/hteditor/metadata.xml
  85. 1
      app-editors/mousepad/Manifest
  86. 42
      app-editors/mousepad/mousepad-0.5.6.ebuild
  87. 1
      app-editors/sublime-text/metadata.xml
  88. BIN
      app-emacs/Manifest.gz
  89. 1
      app-emacs/vterm/Manifest
  90. 0
      app-emacs/vterm/files/vterm-0.0.1_pre20200713-dont-compile.patch
  91. 22
      app-emacs/vterm/files/vterm-0.0.1_pre20210618-dont-compile.patch
  92. 4
      app-emacs/vterm/vterm-0.0.1_pre20200713.ebuild
  93. 45
      app-emacs/vterm/vterm-0.0.1_pre20210618.ebuild
  94. BIN
      app-emulation/Manifest.gz
  95. 1200
      app-emulation/distrobuilder/Manifest
  96. 1240
      app-emulation/distrobuilder/distrobuilder-1.2.ebuild
  97. 5
      app-emulation/dosemu/metadata.xml
  98. 4
      app-emulation/flannel/flannel-0.11.0.ebuild
  99. 4
      app-emulation/libvirt/libvirt-7.0.0-r3.ebuild
  100. 4
      app-emulation/libvirt/libvirt-7.1.0-r1.ebuild

BIN
Manifest.files.gz

BIN
acct-user/Manifest.gz

0
dev-haskell/haskell-platform/Manifest → acct-user/badvpn/Manifest

13
acct-user/badvpn/badvpn-0.ebuild

@ -0,0 +1,13 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit acct-user
DESCRIPTION="A user for net-vpn/badvpn"
ACCT_USER_ID=116
ACCT_USER_GROUPS=( badvpn )
acct-user_add_deps

8
acct-user/badvpn/metadata.xml

@ -0,0 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>williamh@gentoo.org</email>
<name>William Hubbs</name>
</maintainer>
</pkgmetadata>

0
acct-user/cockroach/Manifest

15
acct-user/cockroach/cockroach-0.ebuild

@ -0,0 +1,15 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit acct-user
DESCRIPTION="A user for dev-db/cockroach"
ACCT_USER_ID=110
ACCT_USER_GROUPS=( cockroach )
ACCT_USER_HOME=/var/lib/cockroach
ACCT_USER_SHELL=/bin/sh
acct-user_add_deps

8
acct-user/cockroach/metadata.xml

@ -0,0 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>williamh@gentoo.org</email>
<name>William Hubbs</name>
</maintainer>
</pkgmetadata>

0
acct-user/drone/Manifest

12
acct-user/drone/drone-0.ebuild

@ -0,0 +1,12 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit acct-user
DESCRIPTION="A user for dev-util/drone"
ACCT_USER_ID=112
ACCT_USER_GROUPS=( drone )
ACCT_USER_HOME=/var/lib/drone

8
acct-user/drone/metadata.xml

@ -0,0 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>williamh@gentoo.org</email>
<name>William Hubbs</name>
</maintainer>
</pkgmetadata>

0
acct-user/rundeck/Manifest

8
acct-user/rundeck/metadata.xml

@ -0,0 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>williamh@gentoo.org</email>
<name>William Hubbs</name>
</maintainer>
</pkgmetadata>

14
acct-user/rundeck/rundeck-0.ebuild

@ -0,0 +1,14 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit acct-user
DESCRIPTION="A user for app-misc/rundeck-bin"
ACCT_USER_ID=109
ACCT_USER_HOME=/var/lib/rundeck
ACCT_USER_SHELL=/bin/bash
ACCT_USER_GROUPS=( rundeck )
acct-user_add_deps

BIN
app-accessibility/Manifest.gz

4
app-accessibility/brltty/brltty-6.1.ebuild

@ -207,8 +207,10 @@ src_install() {
}
pkg_postinst() {
tmpfiles_process ${PN}.tmpfiles.conf
elog
elog "please be sure ${ROOT}/etc/brltty.conf is correct for your system."
elog "please be sure ${EROOT}/etc/brltty.conf is correct for your system."
elog
elog "To make brltty start on boot, type this command as root:"
elog

BIN
app-admin/Manifest.gz

3
app-admin/awscli/Manifest

@ -2,6 +2,8 @@ DIST awscli-1.19.104.tar.gz 2024567 BLAKE2B 82662ffe6a05dd329210ff84962e1ad37ece
DIST awscli-1.19.112.tar.gz 2028010 BLAKE2B c5f973a2a0cf002038cdc46d0760f5e5fad942b1383f21819459d51fd3e3a17617e23d45d284345fac1760a812ffc81842068e8517bb500559a330ea8183968e SHA512 4ad9e960826baa057a2e72ddc2afce1012b766b5f691236435347c3e4ce210ee0b14003c16615262ec707d0c65b7f7f71a15fcf80a0fdfefb21ab6a28cfb1d55
DIST awscli-1.20.0.tar.gz 2028152 BLAKE2B d746335fc3414e773fbf3cb60b68ea1242162c7fb6f9e8222bec1bff992ec08e7239b9279de70551d05a99b2bd2743e8e2b8f65e01655574a542660fbb4a6ad7 SHA512 0aa478e9c28afa922958881f2f7795c6925e342964fb171176c81bce1fc4a0529dc9eb2fefaa05b670376781671e1531bbfe5114d0f0a748c964c5ace2c79ee4
DIST awscli-1.20.1.tar.gz 2028927 BLAKE2B bd535f1eba64987c8389c8003b90a1361e95db00a62f13138b35d0f4b6a5130b2e52e38663f4560bf58fe6b86e668ee142a0228001d8cde583d096ce81612264 SHA512 b704ff3f482dd2ccfdf78d01ccff214c9cb9f7b12b1af0a7c615b9567a931a8bc47a444dd8f136a958346750a60fb03a084993a7deb0c234448a9889918c97e6
DIST awscli-1.20.10.tar.gz 2047053 BLAKE2B 1ad45d2703e82c2be1a2847c2312d7199ef55aa7df33568be890c6ce72e03e05cddafeb1cce5c76a5f363bd397f744f1c229fbd5ea518fc53d24f2711e628207 SHA512 9c56ccc0191b319aa7035bce72da9cf1f9e97c9600a202e706244a5eaff419f305c7d68dbcbc96bb622b219efcd56ad6691b149fbf3daf036ebf627987b306f5
DIST awscli-1.20.11.tar.gz 2047295 BLAKE2B d27c2fa2c1f665fe8f691e6d7ddd19a52b0f28e3d648f96f78e5b7f8c58f06252c99e49e739f45e8e70b126d5d3fbcf7f08fb54f837c47c2d3708152496435ec SHA512 d4ae3becbc9fdd863396504c43e4c683827706a7016e73fbd5e412cb8654ec5a3c0e10ee2c4d90455dd5427cfd73fe183d723f43030e4e35916389313dad06d8
DIST awscli-1.20.2.tar.gz 2029411 BLAKE2B dad47f749af3c1e7bbeb291eb92889c7dc9bdc9e81ddb1fd3769897f94ba549123589a2ef8a34b88d8370cc6bb5ad45cc7b9fa06ec474620303a78ec3d64100e SHA512 6384a02a7bd3a8ea38cf46725daa25e7656e12c1f3f6465043efc223a82c605dbc916a26debc214ff6d364e81013e729acac424ccccc535785e8a3b68cfce2f6
DIST awscli-1.20.3.tar.gz 2029411 BLAKE2B 6d8573709072ea3955696de0c65a32610446737a216f6c5dd4ecae4cffcb48ecac531cfc598517c037066d066cf0de01510c0740949450ad3a5925af79bd8c16 SHA512 2324800964de8b1af4ae39dcee15e8fc2bd5e11a239c245590a86fac6574d80b290fb9d967df82d6fdd412cd8b783fd209780e5e58846a16302fa13c6f3b93fb
DIST awscli-1.20.4.tar.gz 2043470 BLAKE2B 58722fe4277a7950665913e8b9ae99de8017cfe8c4974a3524f917533499e830d2eea2ac0994022796b979869468b5f3a767727b4384f78e325e423ed003b1b3 SHA512 3066438ac58eb2afb83ae6fef516e09965ceea1e97897e4f5b5760046f28a2f822b16b90c0a9ee6a58c6cdabbfb2f0ce044caf41396093188290e2a7c1e8c4f3
@ -9,3 +11,4 @@ DIST awscli-1.20.5.tar.gz 2043880 BLAKE2B f4b833baf883479ed63e09de998b41e0e0e880
DIST awscli-1.20.6.tar.gz 2044686 BLAKE2B 6513afc020855a103c5a4ee2b2aa6fc7355f2ebc445d3a89403045a8111a6beef7b934640de020a43fdd670fd4efb2f02dc907826b6a8f3335f6119267dfba10 SHA512 f53a56ae1aed266a4c6bd9236b15a070feaca804ea5276dbe0ad01e006866a17f2ab965ff086640cf62e002da0033c9091c56de1eb4b89a25cbeed329fd63e08
DIST awscli-1.20.7.tar.gz 2045304 BLAKE2B d8f086d8d2eb36645e77fa3d9ae7c196ed3a3fddcc2a0218696f92bd69e10b453be1340b965a8d8e6697bbd3c45013d72de3ed0d31b5823515a5a0092a812858 SHA512 a41bd3ebc34a65add66ef95d5194ba07907a08f7368b0fcd6551af2070c46c4a509af47d30aeadabddce19d1a61200a58faf40a7e2f759e64915cfb2826666ab
DIST awscli-1.20.8.tar.gz 2046203 BLAKE2B 12fb4b26f030667f43778fc713fc83becb2bb78b9f5b7b9de1faae1b74207e27487bc4731e234767b11ce152cfbfb5b41fcf66e4d4793b0a754a7634219d455a SHA512 11861a471a3d43305dbc2d18b50848849736c6e55a0ed6ae0d7bafe73389a6011100b6b0ccbec243ea2f2846e8e689412d04a68bcf8324027a03f31062807dec
DIST awscli-1.20.9.tar.gz 2046575 BLAKE2B 68a99843ead460aa0de60368f1cd8d91c32840fb8a9d251aad0cd787a2e6fe968716436cf32c94b779f6718356b5303f417b850d6a8a31ab1519c385b5c93799 SHA512 655e6eef77a0759e77d2b2c1db922048cdd270d693d9bae08dea6576f3eb5fc4e20a050364ab3dfbaf3a54d9a8fc08c97a6329f30fcf51f38a4de456e76e2b5d

58
app-admin/awscli/awscli-1.20.10.ebuild

@ -0,0 +1,58 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
PYTHON_COMPAT=( python3_{8..10} )
inherit bash-completion-r1 distutils-r1
DESCRIPTION="Universal Command Line Environment for AWS"
HOMEPAGE="https://pypi.org/project/awscli/"
#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/aws-cli-${PV}"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
# botocore is x.(y+1).z
BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1)).$(ver_cut 3-)"
RDEPEND="
>=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
dev-python/colorama[${PYTHON_USEDEP}]
dev-python/docutils[${PYTHON_USEDEP}]
dev-python/rsa[${PYTHON_USEDEP}]
>=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
dev-python/mock[${PYTHON_USEDEP}]
)
"
distutils_enable_tests --install nose
PATCHES=(
"${FILESDIR}"/awscli-1.19.47-py39.patch
)
python_test() {
distutils_install_for_testing
# integration tests require AWS credentials and Internet access
nosetests -v tests/{functional,unit} ||
die "Tests failed for ${EPYTHON}"
}
python_install_all() {
newbashcomp bin/aws_bash_completer aws
insinto /usr/share/zsh/site-functions
newins bin/aws_zsh_completer.sh _aws
distutils-r1_python_install_all
rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
}

58
app-admin/awscli/awscli-1.20.11.ebuild

@ -0,0 +1,58 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
PYTHON_COMPAT=( python3_{8..10} )
inherit bash-completion-r1 distutils-r1
DESCRIPTION="Universal Command Line Environment for AWS"
HOMEPAGE="https://pypi.org/project/awscli/"
#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/aws-cli-${PV}"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
# botocore is x.(y+1).z
BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1)).$(ver_cut 3-)"
RDEPEND="
>=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
dev-python/colorama[${PYTHON_USEDEP}]
dev-python/docutils[${PYTHON_USEDEP}]
dev-python/rsa[${PYTHON_USEDEP}]
>=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
dev-python/mock[${PYTHON_USEDEP}]
)
"
distutils_enable_tests --install nose
PATCHES=(
"${FILESDIR}"/awscli-1.19.47-py39.patch
)
python_test() {
distutils_install_for_testing
# integration tests require AWS credentials and Internet access
nosetests -v tests/{functional,unit} ||
die "Tests failed for ${EPYTHON}"
}
python_install_all() {
newbashcomp bin/aws_bash_completer aws
insinto /usr/share/zsh/site-functions
newins bin/aws_zsh_completer.sh _aws
distutils-r1_python_install_all
rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
}

58
app-admin/awscli/awscli-1.20.9.ebuild

@ -0,0 +1,58 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
PYTHON_COMPAT=( python3_{8..10} )
inherit bash-completion-r1 distutils-r1
DESCRIPTION="Universal Command Line Environment for AWS"
HOMEPAGE="https://pypi.org/project/awscli/"
#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/aws-cli-${PV}"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
# botocore is x.(y+1).z
BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1)).$(ver_cut 3-)"
RDEPEND="
>=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
dev-python/colorama[${PYTHON_USEDEP}]
dev-python/docutils[${PYTHON_USEDEP}]
dev-python/rsa[${PYTHON_USEDEP}]
>=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
dev-python/mock[${PYTHON_USEDEP}]
)
"
distutils_enable_tests --install nose
PATCHES=(
"${FILESDIR}"/awscli-1.19.47-py39.patch
)
python_test() {
distutils_install_for_testing
# integration tests require AWS credentials and Internet access
nosetests -v tests/{functional,unit} ||
die "Tests failed for ${EPYTHON}"
}
python_install_all() {
newbashcomp bin/aws_bash_completer aws
insinto /usr/share/zsh/site-functions
newins bin/aws_zsh_completer.sh _aws
distutils-r1_python_install_all
rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
}

1
app-admin/filebeat/Manifest

@ -35,6 +35,7 @@ DIST filebeat-7.10.2.tar.gz 87244727 BLAKE2B 77e5967d4ee6b5390ebe19c3c9de9e5cbf6
DIST filebeat-7.12.0.tar.gz 94231781 BLAKE2B 3e90888bbf204c8e96066f894ba211feb893d89915dbad9ab023dd7a12551c3f1f839b1d266170637646b1cdfbed3652abae09e5b97babb68efa429fc7b3a682 SHA512 46049bf6e98bc7f29bd312f39afa185fcaec9d11bd7349ab58b2a21095dda25c0dafabaaefe618a47e084191ed8c1a24bc7e7ead32628c15934f8aeffe2e3c81
DIST filebeat-7.12.1.tar.gz 94237879 BLAKE2B 7f7c1ed0ded8bc52b1830d3448d910bae5b2e775a9b1264271a8e3420fa95d0e4c1e7ee3545d198583af2b90b390f3f8bca0c871ca2ecdd077fcbe284648ba42 SHA512 3e2c49ddab59461f82abc5e3ea0f12941f2ed73a6f23c2f062ec88c85d577ce2b5efb234a110e62e9949490bec4f355f3118508572b93883adc7122d76d33cb1
DIST filebeat-7.13.2.tar.gz 96332174 BLAKE2B d196700f7ccd54a01f3711e8c10356bf16dc499c10fc4534d0a103f2f89824bef8ef844d50a747f9418fe3d610871effc9f831657bb252010f939449c8e63490 SHA512 6ebbfa9b87c2f8cd7a7f949bf56104b6065bed4aa5b543be1997d46cc1143d02a1c7b035a1e885aaf1e5dd41379d83d42ca11e63326d24fd5456ead4f126a3a9
DIST filebeat-7.13.4.tar.gz 96335617 BLAKE2B b417ffaf0bb47df78cd2d31be09d4fb2b5a0b41ad90bc59bd53928cecd0f6e0245426c55be9e977b71225adfb957c1ef8768be434d41e44b699efcce0d904006 SHA512 85e63941466b83690f743cec58be29bdbe133da73975b2c6390589d2245484fae53eb25732260c0db77d35ae6f37fc2f7f003d45cfd2ceb281a51d36897c7b68
DIST filebeat-7.9.3.tar.gz 82872010 BLAKE2B e437905a13e556e1bec9b59a8837eb4649f063e4ddb9815a3e18efdc291758e39b5abc0465295f8526f042aecdfc2b8e49ebb6980aeb8b3b13be9d4431863401 SHA512 35c2c8038f0f540e467feef341f3248eadda5e5b1a80c247bcd54c073153a7839f797be327b65c4eee255f4d656e36c57d112b7ff0e637342ccc13f4f59366d7
DIST github.com%2F!azure%2Fazure-amqp-common-go%2Fv3%2F@v%2Fv3.0.0.mod 372 BLAKE2B 80a7e0aac984acb79239b3309290cd8ef1eeca8d9f53b3c91628cbe6dd112706d2313c47e33ac52ea9e8a6417289dacae8e2e72a03e679836d3ed89cb86c0aee SHA512 6db1a52bbab1332ab7e761532cb110394afa1dd69cc5f7443c3fb733c7d95fa712cf6bf8a78fc3f51d89b2d368a248e532bab06bc93e2e663b8f836c91aef0de
DIST github.com%2F!azure%2Fazure-amqp-common-go%2Fv3%2F@v%2Fv3.0.0.zip 29788 BLAKE2B c1e493471bca24ac64c8119e624ea077a74678a492b036deb907ede12b5e93c3ef699820cb2ec9468a98d00e83d84c6bb45cf274b4812a0f319a0248610a4d2c SHA512 a412fbe597ab0c47223d733303ed2277656fe35866f52e4ed1f25cc03b691f15f5592cb07b3c5fb39d4cb98c6d73dbc8e1e7869cea17241a33dfc29db0a1d121

1173
app-admin/filebeat/filebeat-7.13.4.ebuild
File diff suppressed because it is too large
View File

1
app-admin/logrotate/Manifest

@ -1,2 +1 @@
DIST logrotate-3.18.0.tar.gz 224873 BLAKE2B f73ffa2d58a5125393e6c96e158e39e0b4cadef01e6eebd172220227a7e1363e6731bc2ac511fa028078054b55d42b131cdc30232ac5762ce4c6cbff79c19681 SHA512 d1bca267fbec4acbb83ffba4d3ac4c864f4269d8513e5614e7dbe6f3b1f176685218bffdb5d62f559ee73f84cf9a8a257c9f63e30af058d12d0034240f247586
DIST logrotate-3.18.1.tar.gz 225226 BLAKE2B 6f40dfe89f9c6202263f16204a9cff07b921abc9a298b58649bb4968c9f498626741be334c47d4092da564ed75642b687ff6ef8781f69f5e25364f8635646d9d SHA512 c40f920686aee014c652f087c64f2a85e9e866a8717d1bd3f32a9dd7959a02962e6174de28ae685428b442e12079d0c8d91485611ca34a873ffae872a54ec9fe

101
app-admin/logrotate/logrotate-3.18.0.ebuild

@ -1,101 +0,0 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit systemd tmpfiles
DESCRIPTION="Rotates, compresses, and mails system logs"
HOMEPAGE="https://github.com/logrotate/logrotate"
SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
IUSE="acl +cron selinux"
COMMON_DEPEND="
>=dev-libs/popt-1.5
selinux? ( sys-libs/libselinux )
acl? ( virtual/acl )"
DEPEND="${COMMON_DEPEND}
>=sys-apps/sed-4"
RDEPEND="${COMMON_DEPEND}
selinux? ( sec-policy/selinux-logrotate )
cron? ( virtual/cron )"
STATEFILE="/var/lib/misc/logrotate.status"
OLDSTATEFILE="/var/lib/logrotate.status"
move_old_state_file() {
elog "logrotate state file is now located at ${STATEFILE}"
elog "See bug #357275"
if [[ -e "${OLDSTATEFILE}" ]] ; then
elog "Moving your current state file to new location: ${STATEFILE}"
mv -n "${OLDSTATEFILE}" "${STATEFILE}" || die
fi
}
install_cron_file() {
exeinto /etc/cron.daily
newexe "${S}"/examples/logrotate.cron "${PN}"
}
PATCHES=(
"${FILESDIR}/${PN}-3.15.0-ignore-hidden.patch"
)
src_prepare() {
sed -i -e 's#/usr/sbin/logrotate#/usr/bin/logrotate#' "${S}"/examples/logrotate.{cron,service} || die
default
}
src_configure() {
econf \
$(use_with acl) \
$(use_with selinux) \
--with-state-file-path="${STATEFILE}"
}
src_test() {
emake test
}
src_install() {
insinto /usr
dobin logrotate
doman logrotate.8
dodoc ChangeLog.md
insinto /etc
doins "${FILESDIR}"/logrotate.conf
use cron && install_cron_file
systemd_dounit examples/logrotate.{service,timer}
newtmpfiles "${FILESDIR}/${PN}.tmpfiles" "${PN}".conf
keepdir /etc/logrotate.d
}
pkg_postinst() {
elog
elog "The ${PN} binary is now installed under /usr/bin. Please"
elog "update your links"
elog
move_old_state_file
elog "If you are running systemd you might need to run:"
elog "systemd-tmpfiles --create /usr/lib/tmpfiles.d/logrotate.conf"
elog "in order to create the new location of the logrotate state file"
elog
if [[ -z ${REPLACING_VERSIONS} ]] ; then
elog "If you wish to have logrotate e-mail you updates, please"
elog "emerge virtual/mailx and configure logrotate in"
elog "/etc/logrotate.conf appropriately"
elog
elog "Additionally, /etc/logrotate.conf may need to be modified"
elog "for your particular needs. See man logrotate for details."
fi
}

96
app-admin/logrotate/logrotate-3.18.1-r1.ebuild

@ -0,0 +1,96 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit systemd tmpfiles
DESCRIPTION="Rotates, compresses, and mails system logs"
HOMEPAGE="https://github.com/logrotate/logrotate"
SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
IUSE="acl +cron selinux"
DEPEND="
>=dev-libs/popt-1.5
selinux? ( sys-libs/libselinux )
acl? ( virtual/acl )"
RDEPEND="${DEPEND}
selinux? ( sec-policy/selinux-logrotate )
cron? ( virtual/cron )"
STATEFILE="${EPREFIX}/var/lib/misc/logrotate.status"
OLDSTATEFILE="${EPREFIX}/var/lib/logrotate.status"
move_old_state_file() {
elog "logrotate state file is now located at ${STATEFILE}"
elog "See bug #357275"
if [[ -e "${OLDSTATEFILE}" ]] ; then
elog "Moving your current state file to new location: ${STATEFILE}"
mv -n "${OLDSTATEFILE}" "${STATEFILE}" || die
fi
}
install_cron_file() {
exeinto /etc/cron.daily
newexe "${S}"/examples/logrotate.cron "${PN}"
}
PATCHES=(
"${FILESDIR}/${PN}-3.15.0-ignore-hidden.patch"
)
src_prepare() {
sed -i -e 's#/usr/sbin/logrotate#/usr/bin/logrotate#' examples/logrotate.{cron,service} || die
default
}
src_configure() {
econf \
$(use_with acl) \
$(use_with selinux) \
--with-state-file-path="${STATEFILE}"
}
src_test() {
emake test
}
src_install() {
dobin logrotate
doman logrotate.8
dodoc ChangeLog.md
insinto /etc
doins "${FILESDIR}"/logrotate.conf
use cron && install_cron_file
systemd_dounit examples/logrotate.{service,timer}
newtmpfiles "${FILESDIR}"/${PN}.tmpfiles ${PN}.conf
keepdir /etc/logrotate.d
}
pkg_postinst() {
elog
elog "The ${PN} binary is now installed under /usr/bin. Please"
elog "update your links"
elog
move_old_state_file
tmpfiles_process ${PN}.conf
if [[ -z ${REPLACING_VERSIONS} ]] ; then
elog "If you wish to have logrotate e-mail you updates, please"
elog "emerge virtual/mailx and configure logrotate in"
elog "/etc/logrotate.conf appropriately"
elog
elog "Additionally, /etc/logrotate.conf may need to be modified"
elog "for your particular needs. See man logrotate for details."
fi
}

99
app-admin/logrotate/logrotate-3.18.1.ebuild

@ -1,99 +0,0 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit systemd tmpfiles
DESCRIPTION="Rotates, compresses, and mails system logs"
HOMEPAGE="https://github.com/logrotate/logrotate"
SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
IUSE="acl +cron selinux"
DEPEND="
>=dev-libs/popt-1.5
selinux? ( sys-libs/libselinux )
acl? ( virtual/acl )"
RDEPEND="${DEPEND}
selinux? ( sec-policy/selinux-logrotate )
cron? ( virtual/cron )"
STATEFILE="${EPREFIX}/var/lib/misc/logrotate.status"
OLDSTATEFILE="${EPREFIX}/var/lib/logrotate.status"
move_old_state_file() {
elog "logrotate state file is now located at ${STATEFILE}"
elog "See bug #357275"
if [[ -e "${OLDSTATEFILE}" ]] ; then
elog "Moving your current state file to new location: ${STATEFILE}"
mv -n "${OLDSTATEFILE}" "${STATEFILE}" || die
fi
}
install_cron_file() {
exeinto /etc/cron.daily
newexe "${S}"/examples/logrotate.cron "${PN}"
}
PATCHES=(
"${FILESDIR}/${PN}-3.15.0-ignore-hidden.patch"
)
src_prepare() {
sed -i -e 's#/usr/sbin/logrotate#/usr/bin/logrotate#' examples/logrotate.{cron,service} || die
default
}
src_configure() {
econf \
$(use_with acl) \
$(use_with selinux) \
--with-state-file-path="${STATEFILE}"
}
src_test() {
emake test
}
src_install() {
dobin logrotate
doman logrotate.8
dodoc ChangeLog.md
insinto /etc
doins "${FILESDIR}"/logrotate.conf
use cron && install_cron_file
systemd_dounit examples/logrotate.{service,timer}
newtmpfiles "${FILESDIR}"/${PN}.tmpfiles ${PN}.conf
keepdir /etc/logrotate.d
}
pkg_postinst() {
elog
elog "The ${PN} binary is now installed under /usr/bin. Please"
elog "update your links"
elog
move_old_state_file
elog "If you are running systemd you might need to run:"
elog "systemd-tmpfiles --create /usr/lib/tmpfiles.d/logrotate.conf"
elog "in order to create the new location of the logrotate state file"
elog
if [[ -z ${REPLACING_VERSIONS} ]] ; then
elog "If you wish to have logrotate e-mail you updates, please"
elog "emerge virtual/mailx and configure logrotate in"
elog "/etc/logrotate.conf appropriately"
elog
elog "Additionally, /etc/logrotate.conf may need to be modified"
elog "for your particular needs. See man logrotate for details."
fi
}

4
app-admin/logstash-bin/Manifest

@ -1,10 +1,14 @@
DIST logstash-6.8.15.tar.gz 176912362 BLAKE2B 68178b2cbf0ad3ecafc83fddf4c50ef767862fbb90ba7a0dd0527de4f8d3bddc485a99a7e774c6d0efd5b3eb4bf701be042cfc58dcb546c7436db39ff4594841 SHA512 bb42b1284f6ca8d4b10cac96b57cae0f28a33047164f9f9a352ed906a960e11fea3d9c58b23cdd607e0d76eee7aa07fbb6ce8870323e3cc6cba472578d99fb01
DIST logstash-6.8.16.tar.gz 176912473 BLAKE2B ec7d5fb92a2ef55499b395a855bc5cfd3c953180d5bd443bd70ff792f12c51a6635d1cc60cf115cab6b934c6201f889f8fbb3b3e35a4841b177d42d0d6864c3f SHA512 c272fb8b0e03c37a057f7789989645077279492abca58a690fbc50e8e5e428a8f3c765e7d68d37ddaf927650b563d1ab0f637eb8a5213f4f0475bbfed1264caf
DIST logstash-6.8.17.tar.gz 179116623 BLAKE2B fa25a3149fded215586d97b3bd2a2b2b168292d45e32f1b69987c9e6e9e6f35100643df09d03f51da042b27acfd57bfcfdb1f4f18fddf7b9d21e01ef84668cc7 SHA512 00cf51cbce906d2594b0a17548d362fe678f458a2e7f9c167d4387953a848a588dbba070d370002a5e4d7ca2df2e3910805a27e3c0263ab29d99042229af0c3a
DIST logstash-7.12.0-linux-x86_64.tar.gz 368429061 BLAKE2B 7bf60eeeec072e99aec807c8cb64cfd5cd46270d297c717fee539531286f487ef254738a439947e40bfc039778d20fa746566aa4d0c031a8f1a22deaaab9ce74 SHA512 ba32cb97e81cc3f4369c752b860aea7a85d212921954e5829f0b63526584d01c79731dd094905d91ed35f9887ae70bfffd5324b25dc3f23e60745462493e8195
DIST logstash-7.12.1-linux-x86_64.tar.gz 368465800 BLAKE2B eea395286408de50cf61b2a69f6a673f81c4021370eab9b04fb1a9ad993a5b625145d6710e5045f9572a6a923455fe8613c2262bd488f6e76d467850b1bfa5c5 SHA512 9ef32dbeb4269d904a775a1cf5833b09cc5b8b71c03f953641fd5de5c27ba51ec878d9e74cdd98255d37fcd39d592deea72832bdce26cbb2827db4ae3b294834
DIST logstash-7.13.2-linux-x86_64.tar.gz 360899712 BLAKE2B 327c5a2820cc42ec0d63bd5d8e1983f37e217e7fe28eebe326a7437b938a3602b387e0138c0055b3b23f8d657013e79a8d7b9b0ad698075667a0c944c07e7dd8 SHA512 706a107fefc587262c27d754ddddce482affc6b12e240895d56ec61e97887f1edf7b0a0888e089827c622917d772f3b9231b6aadf352f5e78c7eee98cfdbfb2b
DIST logstash-7.13.4-linux-x86_64.tar.gz 361126551 BLAKE2B e972b2c6b992573f0320de0487141c17fa6cd1889d7d266f79958fbc261a4e8564b9f9fc88b654de7e476c6c2747f47e169d0fd3601888035193a2cb844fd710 SHA512 2dba64af5f6b0724a75a8f4f3dc9fb067e27785fd5d0b9ef0571c77df6ebaa89418a165b7489ad47676847c4a9f928cbfc8d3ddc885db21053d0bda9dd524f49
DIST logstash-oss-6.8.15.tar.gz 176782145 BLAKE2B 20cdd28d9c6e43edb3cc6d60b961155880aaf2e22d100b6641246a56194ba87aef3c41e039be2ab6bca75e646b83a3f42c935472776aa87a4baa774cca74458d SHA512 c74f189af58ca936b3d3e19970f29a78b8f041f5771163c5ed28466e84cf456f4814a9f4c5a9def2706c39daaebaca948c14e683a6aa82b2e1c1e7ee57592dc2
DIST logstash-oss-6.8.16.tar.gz 176782454 BLAKE2B afdea56bbaa2623548948722f5dcd85172e0d3580c302fde91e1f6d0af66e82538465da9aeb428bbb9e66c7a8bdd29ce69279098d5c3ee9a7c2ac1efdbedb628 SHA512 d994472606cbb474471441a238c6bfacf9c1cdf1adf20129a8bc256daab9ea49adaa8c425c9a41520846465393a2c112ec6c83478579620ebbf446e528accf20
DIST logstash-oss-6.8.17.tar.gz 178986613 BLAKE2B 5e318903fb134f6096fb983d3651d5d81c2bc9d62421aa7468ee7cb82a5e7895a517911a759d82f1f2c939c3ce67df4e26c1296c0871cb1cfb8078627e68e5f3 SHA512 0f43f9f0dc4a253c6d5a6f07234a22bc67b8866dd6f25837372c1d3c9cca2ddb1b94b632c4528324eeb23019d5d1ae7374661dec8011e55210555e01bec77c2c
DIST logstash-oss-7.12.0-linux-x86_64.tar.gz 368251521 BLAKE2B 0959b29335dba2728d2e7a76ee482fb713f9d504a52bea1dcde99f042cfd52d9e18067cb3fffe6ca28b2eddddfd4ded1a19de616f4ddd3b6889e373a908706a0 SHA512 5d7bd5ec3ea5907771bb7590277e54be3407cebe6bc89dd7f5d73b02e9e8907855d19500787b21c8ffcff9cdbbb68a4bbb286131d03ce5585ec89e5c2a76dc60
DIST logstash-oss-7.12.1-linux-x86_64.tar.gz 368287628 BLAKE2B 72e758e6962cc5a24c2a5f6ea4c268be1bc0b5a0ae1d73cb056d0d321b20495df346233e58661f11a37fc5e6c0750f28501af24511a7a29c2e698ce933c7380f SHA512 cefdfdaf2f1d0190d35bc5da2244a5bc09659e9f225cfd05acbdacd0f5f89cc13b928704491d18ac0d54c3500f8c15dc7ca64341bf0d7ed56a49c10eb82a55d4
DIST logstash-oss-7.13.2-linux-x86_64.tar.gz 360703237 BLAKE2B 130b68f77fb5b52db71d478801afe498ab157f2b38c56e67455b28bc7358faaae9663c79b515031544136e6dc126d8d96b6fab8f7802bf84d5125850540feaae SHA512 0d4cc38740b9a9b44a528a148ea8f2032a27af275bf4508700ec62ae3d74987c4fbbda72b4b6fb4a4059e9be3a7949813ad401187d43335e99b9a280350fba93
DIST logstash-oss-7.13.4-linux-x86_64.tar.gz 360925283 BLAKE2B 68482538d4b2589044215495ab7d41b4820650908d979438b197c5ee4ff82dfc53580fba7c834c62964e9b12ff23e6d9ecfc6e333a2cb6f077d6d4c953527173 SHA512 d57c30c763ba3323380c7276a49895ce3adbe90700061bdf1ce8c6abe98c4ac0c5789ac2a725f15d8d4f89c80dec691479027887b8976dcd618aa91f7af13d8e

73
app-admin/logstash-bin/logstash-bin-6.8.17.ebuild

@ -0,0 +1,73 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit java-pkg-2
MY_PN="${PN%-bin}"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Tool for managing events and logs"
HOMEPAGE="https://www.elastic.co/products/logstash"
SRC_URI="x-pack? ( https://artifacts.elastic.co/downloads/${MY_PN}/${MY_P}.tar.gz )
!x-pack? ( https://artifacts.elastic.co/downloads/${MY_PN}/${MY_PN}-oss-${PV}.tar.gz )"
# source: LICENSE.txt and NOTICE.txt
LICENSE="Apache-2.0 MIT x-pack? ( Elastic )"
SLOT="0"
KEYWORDS="~amd64"
IUSE="x-pack"
RESTRICT="strip"
QA_PREBUILT="opt/logstash/vendor/jruby/lib/jni/*/libjffi*.so"
RDEPEND="acct-group/logstash
acct-user/logstash
virtual/jre:1.8"
S="${WORKDIR}/${MY_P}"
src_install() {
keepdir /etc/"${MY_PN}"/{conf.d,patterns,plugins}
keepdir "/var/log/${MY_PN}"
insinto "/usr/share/${MY_PN}"
newins "${FILESDIR}/agent.conf.sample" agent.conf
rm -v config/{pipelines.yml,startup.options} || die
insinto /etc/${MY_PN}
doins -r config/.
doins "${FILESDIR}/pipelines.yml"
rm -rv config data || die
insinto "/opt/${MY_PN}"
doins -r .
fperms 0755 "/opt/${MY_PN}/bin/${MY_PN}" "/opt/${MY_PN}/vendor/jruby/bin/jruby" "/opt/${MY_PN}/bin/logstash-plugin"
newconfd "${FILESDIR}/${MY_PN}.confd-r2" "${MY_PN}"
newinitd "${FILESDIR}/${MY_PN}.initd-r2" "${MY_PN}"
insinto /usr/share/eselect/modules
doins "${FILESDIR}"/logstash-plugin.eselect
}
pkg_postinst() {
ewarn "Self installed plugins are removed during Logstash upgrades (Bug #622602)"
ewarn "Install the plugins via eselect module that will automatically re-install"
ewarn "all self installed plugins after Logstash upgrades."
elog
elog "Installing plugins:"
elog "eselect logstash-plugin install logstash-output-gelf"
elog
elog "Reinstalling self installed plugins (installed via eselect module):"
eselect logstash-plugin reinstall
elog
elog "Sample configuration:"
elog "${EROOT}/usr/share/${MY_PN}"
elog
elog "The default pipeline configuration expects the configuration(s) to be found in:"
elog "${EROOT}/etc/logstash/conf.d/*.conf"
}

88
app-admin/logstash-bin/logstash-bin-7.13.4.ebuild

@ -0,0 +1,88 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit java-pkg-2
MY_PN="${PN%-bin}"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Tool for managing events and logs"
HOMEPAGE="https://www.elastic.co/products/logstash"
SRC_URI="x-pack? ( https://artifacts.elastic.co/downloads/${MY_PN}/${MY_P}-linux-x86_64.tar.gz )
!x-pack? ( https://artifacts.elastic.co/downloads/${MY_PN}/${MY_PN}-oss-${PV}-linux-x86_64.tar.gz )"
# source: LICENSE.txt and NOTICE.txt
LICENSE="Apache-2.0 MIT x-pack? ( Elastic )"
SLOT="0"
KEYWORDS="~amd64"
IUSE="x-pack"
RESTRICT="strip"
QA_PREBUILT="opt/logstash/vendor/jruby/lib/jni/*/libjffi*.so"
RDEPEND="acct-group/logstash
acct-user/logstash
virtual/jre"
S="${WORKDIR}/${MY_P}"
src_prepare() {
default
local d
for d in aarch64-Linux arm-Linux Darwin i386-Linux i386-SunOS \
i386-Windows mips64el-Linux ppc64-AIX ppc64le-Linux ppc64-Linux \
ppc-AIX sparcv9-Linux sparcv9-SunOS x86_64-DragonFlyBSD \
x86_64-FreeBSD x86_64-OpenBSD x86_64-SunOS x86_64-Windows; do
rm -r vendor/jruby/lib/jni/$d || die
done
# remove bundled java
rm -r jdk || die
}
src_install() {
keepdir /etc/"${MY_PN}"/{conf.d,patterns,plugins}
keepdir "/var/log/${MY_PN}"
insinto "/usr/share/${MY_PN}"
newins "${FILESDIR}/agent.conf.sample" agent.conf
rm -v config/{pipelines.yml,startup.options} || die
insinto /etc/${MY_PN}
doins -r config/.
doins "${FILESDIR}/pipelines.yml"
rm -rv config data || die
insinto "/opt/${MY_PN}"
doins -r .
fperms 0755 "/opt/${MY_PN}/bin/${MY_PN}" "/opt/${MY_PN}/vendor/jruby/bin/jruby" "/opt/${MY_PN}/bin/logstash-plugin"
newconfd "${FILESDIR}/${MY_PN}.confd-r2" "${MY_PN}"
newinitd "${FILESDIR}/${MY_PN}.initd-r2" "${MY_PN}"
insinto /usr/share/eselect/modules
doins "${FILESDIR}"/logstash-plugin.eselect
}
pkg_postinst() {
ewarn "Self installed plugins are removed during Logstash upgrades (Bug #622602)"
ewarn "Install the plugins via eselect module that will automatically re-install"
ewarn "all self installed plugins after Logstash upgrades."
elog
elog "Installing plugins:"
elog "eselect logstash-plugin install logstash-output-gelf"
elog
elog "Reinstalling self installed plugins (installed via eselect module):"
eselect logstash-plugin reinstall
elog
elog "Sample configuration:"
elog "${EROOT}/usr/share/${MY_PN}"
elog
elog "The default pipeline configuration expects the configuration(s) to be found in:"
elog "${EROOT}/etc/logstash/conf.d/*.conf"
}

2
app-admin/monit/Manifest

@ -1,3 +1,3 @@
DIST monit-5.27.1.tar.gz 1459360 BLAKE2B ef8030112c401ab08653692c702f2ec6d34c11605c2f6fbb5310f8e08d7fb238cf1b2d0271358b7160e05ad8dae3931d458329c422ae826681c11fe46fac01b4 SHA512 1e71a529a920a37576242a99fe8067d9b88f64136b111c152527aca4aa5d3cac3c32c1f58a793a56361b8e286f025bfb1f063f4c38d25ebafc7927fbf9170673
DIST monit-5.27.2.tar.gz 1463790 BLAKE2B f00733261fd941f47ec04e63ed9e3617991cd8a069a14e59941e85d3a342537892019864d4716f821428adb57979aa270fcba9d57f573d49e897dfcd77cc133a SHA512 a45cbbf0905b165767e21d66103b460ea48948824d043881aba3de752e34a67bfb3b97f75153e3672d87a34a702d66ceee28160110654aa52fb82c668aa135b9
DIST monit-5.28.0.tar.gz 1480041 BLAKE2B 3ac9930efc89de8b4f65dd197c4f4289b3410afac38950c83b459436720d2c786e89d8bad22e4a7688af9c6111021500b9f3c6f0a8e8cee3a6b0e2f5058ec148 SHA512 3805a8cd5ad2ef9c94832a7fe3a09cf508eb857c92cda129d914db8656613e26eac5fefdaa4530b3403b4f6eb0c4cccdc620c12461dbebcda738ba9535ffa885
DIST monit-5.28.1.tar.gz 1470342 BLAKE2B 134f63f4560cf26a563cb8e1f063b291dd6d87159878a1918aef62d8ffe6138a64b4e34c1713b46cb80bfd04eddb0abab725aa7cbe59331dac9e41d0f286f883 SHA512 2683084aea88567309b4693247c27312e1cb4225175cb8643a1f980ed8fc8ecd549818e157e1bb6c0feafc306bc9217bbd2c0c501cb75ea2425b646955076e5a

7
app-admin/monit/files/monit.logrotate

@ -0,0 +1,7 @@
/var/log/monit.log {
rotate 15
daily
postrotate
/usr/bin/monit reload >/dev/null 2>&1
endscript
}

57
app-admin/monit/monit-5.27.1-r1.ebuild

@ -1,57 +0,0 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit bash-completion-r1 pam systemd
DESCRIPTION="Monitoring and managing daemons or similar programs running on a Unix system"
HOMEPAGE="http://mmonit.com/monit/"
SRC_URI="http://mmonit.com/monit/dist/${P}.tar.gz"
LICENSE="AGPL-3"
SLOT="0"
KEYWORDS="amd64 ppc ~ppc64 x86 ~amd64-linux"
IUSE="ipv6 pam ssl"
RDEPEND="sys-libs/zlib:=
virtual/libcrypt:=
pam? ( sys-libs/pam )
ssl? ( dev-libs/openssl:0= )
"
DEPEND="${RDEPEND}"
BDEPEND="
sys-devel/bison
sys-devel/flex
"
src_prepare() {
default
sed -i -e '/^INSTALL_PROG/s/-s//' Makefile.in || die
}
src_configure() {
local myeconfargs=(
$(use_with ipv6)
$(use_with pam)
$(use_with ssl)
)
econf "${myeconfargs[@]}"
}
src_install() {
default
insinto /etc; insopts -m600; doins monitrc
newinitd "${FILESDIR}"/monit.initd-5.0-r1 monit
systemd_dounit "${FILESDIR}"/${PN}.service
use pam && newpamd "${FILESDIR}"/${PN}.pamd ${PN}
dobashcomp system/bash/monit
}
pkg_postinst() {
elog "Sample configurations are available at:"
elog "http://mmonit.com/monit/documentation/"
}

60
app-admin/monit/monit-5.28.1-r1.ebuild

@ -0,0 +1,60 @@
# Copyright 2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit bash-completion-r1 pam systemd
DESCRIPTION="Monitoring and managing daemons or similar programs running on a Unix system"
HOMEPAGE="http://mmonit.com/monit/"
SRC_URI="http://mmonit.com/monit/dist/${P}.tar.gz"
LICENSE="AGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux"
IUSE="ipv6 pam ssl"
RDEPEND="sys-libs/zlib:=
virtual/libcrypt:=
pam? ( sys-libs/pam )
ssl? ( dev-libs/openssl:0= )
"
DEPEND="${RDEPEND}"
BDEPEND="
sys-devel/bison
sys-devel/flex
"
src_prepare() {
default
sed -i -e '/^INSTALL_PROG/s/-s//' Makefile.in || die
}
src_configure() {
local myeconfargs=(
$(use_with ipv6)
$(use_with pam)
$(use_with ssl)
)
econf "${myeconfargs[@]}"
}
src_install() {
default
insinto /etc/logrotate.d
newins "${FILESDIR}"/monit.logrotate monit
insinto /etc; insopts -m600; doins monitrc
newinitd "${FILESDIR}"/monit.initd-5.0-r1 monit
systemd_dounit "${FILESDIR}"/${PN}.service
use pam && newpamd "${FILESDIR}"/${PN}.pamd ${PN}
dobashcomp system/bash/monit
}
pkg_postinst() {
elog "Sample configurations are available at:"
elog "http://mmonit.com/monit/documentation/"
}

5
app-admin/pass/metadata.xml

@ -12,11 +12,8 @@
<flag name="git">
Use <pkg>dev-vcs/git</pkg> for password revisions.
</flag>
<flag name="fish-completion">
Enable fish completion support.
</flag>
<flag name="dmenu">
Add support for x11-misc/dmenu with the 'passmenu' program.
Add support for <pkg>x11-misc/dmenu</pkg> with the 'passmenu' program.
</flag>
<flag name="importers">
Allow importing passwords from other password managers using various contributed scripts.

79
app-admin/pass/pass-1.7.3-r1.ebuild

@ -0,0 +1,79 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit bash-completion-r1 elisp-common
DESCRIPTION="Stores, retrieves, generates, and synchronizes passwords securely"
HOMEPAGE="https://www.passwordstore.org/"
SRC_URI="https://git.zx2c4.com/password-store/snapshot/password-store-${PV}.tar.xz"
S="${WORKDIR}/password-store-${PV}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 ~ppc64 x86 ~x64-macos"
IUSE="+git X emacs dmenu importers elibc_Darwin"
RDEPEND="
app-crypt/gnupg
media-gfx/qrencode
>=app-text/tree-1.7.0
git? ( dev-vcs/git )
X? ( x11-misc/xclip )
elibc_Darwin? ( app-misc/getopt )
dmenu? ( x11-misc/dmenu x11-misc/xdotool )
emacs? ( >=app-editors/emacs-23.1:* >=app-emacs/f-0.11.0 >=app-emacs/s-1.9.0 >=app-emacs/with-editor-2.5.11 )
"
src_prepare() {
default
use elibc_Darwin || return
# use coreutils
sed -i -e 's/openssl base64/base64/g' src/platform/darwin.sh || die
# host getopt isn't cool, and we aren't brew (rip out brew reference)
sed -i -e '/^GETOPT=/s/=.*$/=getopt-long/' src/platform/darwin.sh || die
# make sure we can find "mount"
sed -i -e 's:mount -t:/sbin/mount -t:' src/platform/darwin.sh || die
}
src_compile() {
use emacs && elisp-compile contrib/emacs/*.el
}
src_install() {
emake install \
DESTDIR="${D}" \
PREFIX="${EPREFIX}/usr" \
BASHCOMPDIR="$(get_bashcompdir)" \
WITH_BASHCOMP=yes \
WITH_ZSHCOMP=yes \
WITH_FISHCOMP=yes
use dmenu && dobin contrib/dmenu/passmenu
if use emacs; then
elisp-install ${PN} contrib/emacs/*.{el,elc}
elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
fi
if use importers; then
exeinto /usr/share/${PN}/importers
doexe contrib/importers/*
fi
}
pkg_postinst() {
use emacs && elisp-site-regen
if use importers; then
einfo "To import passwords from other password managers, you may use the"
einfo "various importer scripts found in:"
einfo " ${EROOT}/usr/share/${PN}/importers/"
fi
}
pkg_postrm() {
use emacs && elisp-site-regen
}

78
app-admin/pass/pass-1.7.3.ebuild

@ -1,78 +0,0 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit bash-completion-r1 elisp-common
DESCRIPTION="Stores, retrieves, generates, and synchronizes passwords securely"
HOMEPAGE="https://www.passwordstore.org/"
SRC_URI="https://git.zx2c4.com/password-store/snapshot/password-store-${PV}.tar.xz"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="amd64 ~arm arm64 ~ppc64 x86 ~x64-macos"
IUSE="+git X zsh-completion fish-completion emacs dmenu importers elibc_Darwin"
RDEPEND="
app-crypt/gnupg
media-gfx/qrencode
>=app-text/tree-1.7.0
git? ( dev-vcs/git )
X? ( x11-misc/xclip )
elibc_Darwin? ( app-misc/getopt )
zsh-completion? ( app-shells/gentoo-zsh-completions )
fish-completion? ( app-shells/fish )
dmenu? ( x11-misc/dmenu x11-misc/xdotool )
emacs? ( >=app-editors/emacs-23.1:* >=app-emacs/f-0.11.0 >=app-emacs/s-1.9.0 >=app-emacs/with-editor-2.5.11 )
"
S="${WORKDIR}/password-store-${PV}"
src_prepare() {
default
use elibc_Darwin || return
# use coreutils'
sed -i -e 's/openssl base64/base64/g' src/platform/darwin.sh || die
# host getopt isn't cool, and we aren't brew (rip out brew reference)
sed -i -e '/^GETOPT=/s/=.*$/=getopt-long/' src/platform/darwin.sh || die
# make sure we can find "mount"
sed -i -e 's:mount -t:/sbin/mount -t:' src/platform/darwin.sh || die
}
src_compile() {
use emacs && elisp-compile contrib/emacs/*.el
}
src_install() {
emake install \
DESTDIR="${D}" \
PREFIX="${EPREFIX}/usr" \
BASHCOMPDIR="$(get_bashcompdir)" \
WITH_BASHCOMP=yes \
WITH_ZSHCOMP=$(usex zsh-completion) \
WITH_FISHCOMP=$(usex fish-completion)
use dmenu && dobin contrib/dmenu/passmenu
if use emacs; then
elisp-install ${PN} contrib/emacs/*.{el,elc}
elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
fi
if use importers; then
exeinto /usr/share/${PN}/importers
doexe contrib/importers/*
fi
}
pkg_postinst() {
use emacs && elisp-site-regen
if use importers; then
einfo "To import passwords from other password managers, you may use the"
einfo "various importer scripts found in:"
einfo " ${EROOT%/}/usr/share/${PN}/importers/"
fi
}
pkg_postrm() {
use emacs && elisp-site-regen
}

80
app-admin/pass/pass-1.7.4-r1.ebuild

@ -0,0 +1,80 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit bash-completion-r1 elisp-common
DESCRIPTION="Stores, retrieves, generates, and synchronizes passwords securely"
HOMEPAGE="https://www.passwordstore.org/"
SRC_URI="https://git.zx2c4.com/password-store/snapshot/password-store-${PV}.tar.xz"
S="${WORKDIR}/password-store-${PV}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
IUSE="+git wayland X emacs dmenu importers elibc_Darwin"
RDEPEND="
app-crypt/gnupg
media-gfx/qrencode
>=app-text/tree-1.7.0
git? ( dev-vcs/git )
wayland? ( gui-apps/wl-clipboard )
X? ( x11-misc/xclip )
elibc_Darwin? ( app-misc/getopt )
dmenu? ( x11-misc/dmenu x11-misc/xdotool )
emacs? ( >=app-editors/emacs-23.1:* >=app-emacs/f-0.11.0 >=app-emacs/s-1.9.0 >=app-emacs/with-editor-2.5.11 )
"
src_prepare() {
default
use elibc_Darwin || return
# use coreutils'
sed -i -e 's/openssl base64/base64/g' src/platform/darwin.sh || die
# host getopt isn't cool, and we aren't brew (rip out brew reference)
sed -i -e '/^GETOPT=/s/=.*$/=getopt-long/' src/platform/darwin.sh || die
# make sure we can find "mount"
sed -i -e 's:mount -t:/sbin/mount -t:' src/platform/darwin.sh || die
}
src_compile() {
use emacs && elisp-compile contrib/emacs/*.el
}
src_install() {
emake install \
DESTDIR="${D}" \
PREFIX="${EPREFIX}/usr" \
BASHCOMPDIR="$(get_bashcompdir)" \
WITH_BASHCOMP=yes \
WITH_ZSHCOMP=yes \
WITH_FISHCOMP=yes
use dmenu && dobin contrib/dmenu/passmenu
if use emacs; then
elisp-install ${PN} contrib/emacs/*.{el,elc}
elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
fi
if use importers; then
exeinto /usr/share/${PN}/importers
doexe contrib/importers/*
fi
}
pkg_postinst() {
use emacs && elisp-site-regen
if use importers; then
einfo "To import passwords from other password managers, you may use the"
einfo "various importer scripts found in:"
einfo " ${EROOT}/usr/share/${PN}/importers/"
fi
}
pkg_postrm() {
use emacs && elisp-site-regen
}

79
app-admin/pass/pass-1.7.4.ebuild

@ -1,79 +0,0 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit bash-completion-r1 elisp-common
DESCRIPTION="Stores, retrieves, generates, and synchronizes passwords securely"
HOMEPAGE="https://www.passwordstore.org/"
SRC_URI="https://git.zx2c4.com/password-store/snapshot/password-store-${PV}.tar.xz"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
IUSE="+git wayland X zsh-completion fish-completion emacs dmenu importers elibc_Darwin"
RDEPEND="
app-crypt/gnupg
media-gfx/qrencode
>=app-text/tree-1.7.0
git? ( dev-vcs/git )
wayland? ( gui-apps/wl-clipboard )
X? ( x11-misc/xclip )
elibc_Darwin? ( app-misc/getopt )
zsh-completion? ( app-shells/gentoo-zsh-completions )
fish-completion? ( app-shells/fish )
dmenu? ( x11-misc/dmenu x11-misc/xdotool )
emacs? ( >=app-editors/emacs-23.1:* >=app-emacs/f-0.11.0 >=app-emacs/s-1.9.0 >=app-emacs/with-editor-2.5.11 )
"
S="${WORKDIR}/password-store-${PV}"
src_prepare() {
default
use elibc_Darwin || return
# use coreutils'
sed -i -e 's/openssl base64/base64/g' src/platform/darwin.sh || die
# host getopt isn't cool, and we aren't brew (rip out brew reference)
sed -i -e '/^GETOPT=/s/=.*$/=getopt-long/' src/platform/darwin.sh || die
# make sure we can find "mount"
sed -i -e 's:mount -t:/sbin/mount -t:' src/platform/darwin.sh || die
}
src_compile() {
use emacs && elisp-compile contrib/emacs/*.el
}
src_install() {
emake install \
DESTDIR="${D}" \
PREFIX="${EPREFIX}/usr" \
BASHCOMPDIR="$(get_bashcompdir)" \
WITH_BASHCOMP=yes \
WITH_ZSHCOMP=$(usex zsh-completion) \
WITH_FISHCOMP=$(usex fish-completion)
use dmenu && dobin contrib/dmenu/passmenu
if use emacs; then
elisp-install ${PN} contrib/emacs/*.{el,elc}
elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
fi
if use importers; then
exeinto /usr/share/${PN}/importers
doexe contrib/importers/*
fi
}
pkg_postinst() {
use emacs && elisp-site-regen
if use importers; then
einfo "To import passwords from other password managers, you may use the"
einfo "various importer scripts found in:"
einfo " ${EROOT}/usr/share/${PN}/importers/"
fi
}
pkg_postrm() {
use emacs && elisp-site-regen
}

15
app-admin/pass/pass-9999.ebuild

@ -10,16 +10,16 @@ if [[ ${PV} = 9999* ]]; then
inherit git-r3
else
SRC_URI="https://git.zx2c4.com/password-store/snapshot/password-store-${PV}.tar.xz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
S="${WORKDIR}/password-store-${PV}"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
fi
DESCRIPTION="Stores, retrieves, generates, and synchronizes passwords securely"
HOMEPAGE="https://www.passwordstore.org/"
SLOT="0"
LICENSE="GPL-2"
IUSE="+git wayland X zsh-completion fish-completion emacs dmenu importers elibc_Darwin"
SLOT="0"
IUSE="+git wayland X emacs dmenu importers elibc_Darwin"
RDEPEND="
app-crypt/gnupg
@ -29,8 +29,6 @@ RDEPEND="
wayland? ( gui-apps/wl-clipboard )
X? ( x11-misc/xclip )
elibc_Darwin? ( app-misc/getopt )
zsh-completion? ( app-shells/gentoo-zsh-completions )
fish-completion? ( app-shells/fish )
dmenu? ( x11-misc/dmenu x11-misc/xdotool )
emacs? ( >=app-editors/emacs-23.1:* >=app-emacs/f-0.11.0 >=app-emacs/s-1.9.0 >=app-emacs/with-editor-2.5.11 )
"
@ -57,13 +55,16 @@ src_install() {
PREFIX="${EPREFIX}/usr" \
BASHCOMPDIR="$(get_bashcompdir)" \
WITH_BASHCOMP=yes \
WITH_ZSHCOMP=$(usex zsh-completion) \
WITH_FISHCOMP=$(usex fish-completion)
WITH_ZSHCOMP=yes \
WITH_FISHCOMP=yes
use dmenu && dobin contrib/dmenu/passmenu
if use emacs; then
elisp-install ${PN} contrib/emacs/*.{el,elc}
elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
fi
if use importers; then
exeinto /usr/share/${PN}/importers
doexe contrib/importers/*

4
app-admin/prelude-manager/prelude-manager-5.1.0-r1.ebuild

@ -64,3 +64,7 @@ src_install() {
newinitd "${FILESDIR}/${PN}.initd" "${PN}"
}
pkg_postinst() {
tmpfiles_process ${PN}.conf
}

4
app-admin/puppet-agent/puppet-agent-6.19.1-r1.ebuild

@ -74,3 +74,7 @@ src_install() {
dosym ../../opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
dosym ../../../../usr/lib64/xcrypt/libcrypt.so.1 /opt/puppetlabs/puppet/lib/libcrypt.so.1
}
pkg_postinst() {
tmpfiles_process puppet-agent.conf
}

4
app-admin/puppet-agent/puppet-agent-7.8.0.ebuild

@ -72,3 +72,7 @@ src_install() {
dosym ../../opt/puppetlabs/bin/puppet /usr/bin/puppet
dosym ../../../../usr/lib64/xcrypt/libcrypt.so.1 /opt/puppetlabs/puppet/lib/libcrypt.so.1
}
pkg_postinst() {
tmpfiles_process puppet-agent.conf
}

4
app-admin/puppet-agent/puppet-agent-7.9.0-r2.ebuild

@ -72,3 +72,7 @@ src_install() {
dosym ../../opt/puppetlabs/bin/puppet /usr/bin/puppet
dosym ../../../../lib/libcrypt.so.1 /opt/puppetlabs/puppet/lib/libcrypt.so.1
}
pkg_postinst() {
tmpfiles_process puppet-agent.conf
}

140
app-admin/puppet/puppet-5.5.22-r1.ebuild

@ -0,0 +1,140 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
USE_RUBY="ruby25 ruby26 ruby27"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_TASK_DOC="doc:all"
RUBY_FAKEGEM_EXTRAINSTALL="locales"
inherit ruby-fakegem systemd tmpfiles
DESCRIPTION="A system automation and configuration management software."
HOMEPAGE="https://puppet.com/"
SRC_URI="https://downloads.puppetlabs.com/puppet/${P}.tar.gz"
LICENSE="Apache-2.0 GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 x86"
IUSE="augeas diff doc emacs ldap rrdtool selinux shadow sqlite vim-syntax"
RESTRICT="test"
ruby_add_rdepend "
>=dev-ruby/hiera-3.2.1:0
=dev-ruby/facter-3*
>=dev-ruby/fast_gettext-1.1.2:0
>=dev-ruby/locale-2.1:0
>=dev-ruby/multi_json-1.10:0
augeas? ( dev-ruby/ruby-augeas )
diff? ( dev-ruby/diff-lcs )
doc? ( dev-ruby/rdoc )
ldap? ( dev-ruby/ruby-ldap )
shadow? ( dev-ruby/ruby-shadow )
sqlite? ( dev-ruby/sqlite3 )
virtual/ruby-ssl
dev-ruby/hocon"
ruby_add_bdepend "
doc? ( dev-ruby/yard )
test? (
dev-ruby/mocha
dev-ruby/rack
dev-ruby/rspec-its
)"
# this should go in the above lists, but isn't because of test deps not being keyworded
# dev-ruby/rspec-collection_matchers
RDEPEND+=" ${RDEPEND}
rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
selinux? (
sys-libs/libselinux[ruby]
sec-policy/selinux-puppet
)
vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
>=app-portage/eix-0.18.0
acct-user/puppet
acct-group/puppet"
PDEPEND="emacs? ( >=app-emacs/puppet-mode-0.3-r1 )"
all_ruby_prepare() {
# Avoid spec that require unpackaged json-schema.
rm spec/lib/matchers/json.rb $( grep -Rl matchers/json spec) || die
# fix systemd path
eapply -p0 "${FILESDIR}/puppet-systemd.patch"
# Avoid specs that can only run in the puppet.git repository. This
# should be narrowed down to the specific specs.
rm spec/integration/parser/compiler_spec.rb || die
# Avoid failing spec that need further investigation.
rm spec/unit/module_tool/metadata_spec.rb || die
}
each_ruby_install() {
each_fakegem_install
# dosym "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${P}" "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${PN}"
}
all_ruby_install() {
all_fakegem_install
# systemd stuffs
systemd_dounit "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
# tmpfiles stuff
newtmpfiles "${FILESDIR}/tmpfiles.d" "puppet.conf"
# openrc init stuff
newinitd "${FILESDIR}"/puppet.init-4.x puppet
newinitd "${FILESDIR}"/puppetmaster.init-4.x puppetmaster
newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
keepdir /etc/puppetlabs/puppet/ssl
keepdir /var/lib/puppet/facts
keepdir /var/lib/puppet/files
fowners -R puppet:puppet /var/lib/puppet
fperms 0750 /var/lib/puppet
fperms 0750 /etc/puppetlabs
fperms 0750 /etc/puppetlabs/puppet
fperms 0750 /etc/puppetlabs/puppet/ssl
fowners -R :puppet /etc/puppetlabs
fowners -R :puppet /var/lib/puppet
if use ldap ; then
insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
fi
# ext and examples files
for f in $(find ext examples -type f) ; do
docinto "$(dirname ${f})"; dodoc "${f}"
done
}
pkg_postinst() {
tmpfiles_process puppet.conf
elog
elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
elog "cause puppet to hang while installing packages."
elog
elog "Portage Puppet module with Gentoo-specific resources:"
elog "http://forge.puppetlabs.com/gentoo/portage"
elog
for v in ${REPLACING_VERSIONS}; do
if [ "$(ver_cut 1 "$v")" -eq "4" ]; then
elog
elog "Please see the following url for the release notes for puppet-5"
elog "https://docs.puppet.com/puppet/5.0/release_notes.html#if-youre-upgrading-from-puppet-4x"
elog
fi
done
}

140
app-admin/puppet/puppet-5.5.22.ebuild

@ -1,140 +0,0 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
USE_RUBY="ruby25 ruby26 ruby27"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_TASK_DOC="doc:all"
RUBY_FAKEGEM_EXTRAINSTALL="locales"
inherit ruby-fakegem
DESCRIPTION="A system automation and configuration management software."
HOMEPAGE="https://puppet.com/"
SRC_URI="https://downloads.puppetlabs.com/puppet/${P}.tar.gz"
LICENSE="Apache-2.0 GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 x86"
IUSE="augeas diff doc emacs ldap rrdtool selinux shadow sqlite vim-syntax"
RESTRICT="test"
ruby_add_rdepend "
>=dev-ruby/hiera-3.2.1:0
=dev-ruby/facter-3*
>=dev-ruby/fast_gettext-1.1.2:0
>=dev-ruby/locale-2.1:0
>=dev-ruby/multi_json-1.10:0
augeas? ( dev-ruby/ruby-augeas )
diff? ( dev-ruby/diff-lcs )
doc? ( dev-ruby/rdoc )
ldap? ( dev-ruby/ruby-ldap )
shadow? ( dev-ruby/ruby-shadow )
sqlite? ( dev-ruby/sqlite3 )
virtual/ruby-ssl
dev-ruby/hocon"
ruby_add_bdepend "
doc? ( dev-ruby/yard )
test? (
dev-ruby/mocha
dev-ruby/rack
dev-ruby/rspec-its
)"
# this should go in the above lists, but isn't because of test deps not being keyworded
# dev-ruby/rspec-collection_matchers
RDEPEND+=" ${RDEPEND}
rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
selinux? (
sys-libs/libselinux[ruby]
sec-policy/selinux-puppet
)
vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
>=app-portage/eix-0.18.0
acct-user/puppet
acct-group/puppet"
PDEPEND="emacs? ( >=app-emacs/puppet-mode-0.3-r1 )"
all_ruby_prepare() {
# Avoid spec that require unpackaged json-schema.
rm spec/lib/matchers/json.rb $( grep -Rl matchers/json spec) || die
# fix systemd path
eapply -p0 "${FILESDIR}/puppet-systemd.patch"
# Avoid specs that can only run in the puppet.git repository. This
# should be narrowed down to the specific specs.
rm spec/integration/parser/compiler_spec.rb || die
# Avoid failing spec that need further investigation.
rm spec/unit/module_tool/metadata_spec.rb || die
}
each_ruby_install() {
each_fakegem_install
# dosym "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${P}" "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${PN}"
}
all_ruby_install() {
all_fakegem_install
# systemd stuffs
insinto /usr/lib/systemd/system
doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
# tmpfiles stuff
insinto /usr/lib/tmpfiles.d
newins "${FILESDIR}/tmpfiles.d" "puppet.conf"
# openrc init stuff
newinitd "${FILESDIR}"/puppet.init-4.x puppet
newinitd "${FILESDIR}"/puppetmaster.init-4.x puppetmaster
newconfd "${FILESDIR}"/puppetmaster.confd puppe