Sync with portage [Wed Dec 23 00:48:02 MSK 2015].
This commit is contained in:
parent
2baff58759
commit
3a62a93913
17 changed files with 295 additions and 31 deletions
|
@ -1,19 +0,0 @@
|
|||
diff -Naur rpl-1.4.0-clean/src/replace.h rpl-1.4.0/src/replace.h
|
||||
--- rpl-1.4.0-clean/src/replace.h 2002-07-24 10:41:45.000000000 -0500
|
||||
+++ rpl-1.4.0/src/replace.h 2006-02-19 16:38:32.000000000 -0500
|
||||
@@ -77,7 +77,7 @@
|
||||
|
||||
/* This is a simple macro to call malloc() and die if it returns null */
|
||||
#define MALLOC_FAIL_STRING ("\n" PACKAGE " Unable to allocate memory!")
|
||||
-#define MALLOC_AND_CHECK( x, y ) (void*)(x)=malloc((y));if(x==NULL){fprintf(stderr,"\n%s --> %s:%d\n", MALLOC_FAIL_STRING, __FILE__, __LINE__ );exit(EX_OSERR);}
|
||||
+#define MALLOC_AND_CHECK( x, y ) (x)=malloc((y));if(x==NULL){fprintf(stderr,"\n%s --> %s:%d\n", MALLOC_FAIL_STRING, __FILE__, __LINE__ );exit(EX_OSERR);}
|
||||
|
||||
|
||||
/* Function Prototypes */
|
||||
@@ -90,4 +90,4 @@
|
||||
|
||||
static void EchoFeedback(int, int, int, char*);
|
||||
|
||||
-static void SetPerms(struct stat, int, int, char*, int* );
|
||||
\ No newline at end of file
|
||||
+static void SetPerms(struct stat, int, int, char*, int* );
|
29
app-text/rpl/rpl-1.5.5-r1.ebuild
Normal file
29
app-text/rpl/rpl-1.5.5-r1.ebuild
Normal file
|
@ -0,0 +1,29 @@
|
|||
# Copyright 1999-2015 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Id$
|
||||
|
||||
EAPI=5
|
||||
|
||||
PYTHON_COMPAT=( python2_7 )
|
||||
|
||||
inherit distutils-r1
|
||||
|
||||
DESCRIPTION="Intelligent recursive search/replace utility"
|
||||
HOMEPAGE="http://rpl.sourceforge.net/"
|
||||
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
|
||||
|
||||
LICENSE="GPL-2"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
|
||||
IUSE=""
|
||||
|
||||
python_prepare_all() {
|
||||
iconv -f latin1 -t utf8 -o setup.py.new setup.py || die
|
||||
mv setup.py.new setup.py || die
|
||||
distutils-r1_python_prepare_all
|
||||
}
|
||||
|
||||
python_install_all() {
|
||||
distutils-r1_python_install_all
|
||||
doman ${PN}.1
|
||||
}
|
|
@ -1,2 +1,3 @@
|
|||
DIST mysql-extras-20151105-2051Z.tar.bz2 1490187 SHA256 129d79c2064b08b0afad69e04e27991bf4103c20ccea39c133239b1dd822a49f SHA512 af34a44275b06c1626eb5952b3643b5663b8a1fb1d9ff18a67d51c02daaa51c4476df407d38ab607cc41842b47e5dd7b4cef8ae380a41eb80923df8052b9e521 WHIRLPOOL 01702ca4e2033fbc70db3ab2dd166b2e31072ea0f6bdd42d00c27ae0c0afab5c8451c4dcc90cce6d46f9ea056017e273f7c719e1cfabf969293bdcd15241f5b3
|
||||
DIST percona-server-5.6.27-75.0.tar.gz 54907367 SHA256 7dc4a4efadaee25e11fd78838f4ad2c0d7921ac9cc3b95068626f918c0add8d7 SHA512 c58fe18e3af7c88d9a3269c0b6a20c367bc80af6b3c1ab072fb380787f6b0ad44c8471134e366b7a9572fc4d16a4260d81a26f384aadab4bca99efcf521d3201 WHIRLPOOL 403a7efdbfb8bdaa5cecf72930be351b8762f17ce7166dffcff307e86a69f742546c85ff5badefab182dd001080ed49e71d2d5d587b74801cc22ccba682ac418
|
||||
DIST percona-server-5.6.27-76.0.tar.gz 54946650 SHA256 36d5c1c9a94712874b4d6e12c7e48d1f13c1fffb0ff976bc93aedbb4f73a0fef SHA512 64e2b1643bb06aefd59a1e1caddd31931b4b39ce5cd575ec3ec92f8c824887d112aa17573b10d596996579088c34e729eed83c37d63dd8cbef6755f0c0086805 WHIRLPOOL b203ba373ce312c1e10f0f96ba0fe8722ddc29c218bd075539f868426ad20c4d02c2307756c98fd2c7e21b45398d92c1b2b5145218b503bb0962bcafd908de12
|
||||
|
|
173
dev-db/percona-server/percona-server-5.6.27.76.0.ebuild
Normal file
173
dev-db/percona-server/percona-server-5.6.27.76.0.ebuild
Normal file
|
@ -0,0 +1,173 @@
|
|||
# Copyright 1999-2015 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Id$
|
||||
|
||||
EAPI="5"
|
||||
MY_EXTRAS_VER="20151105-2051Z"
|
||||
SUBSLOT="18"
|
||||
PYTHON_COMPAT=( python2_7 )
|
||||
inherit python-any-r1 mysql-multilib-r1
|
||||
|
||||
IUSE="pam tokudb tokudb-backup-plugin"
|
||||
|
||||
# REMEMBER: also update eclass/mysql*.eclass before committing!
|
||||
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-linux"
|
||||
HOMEPAGE="http://www.percona.com/software/percona-server"
|
||||
DESCRIPTION="An enhanced, drop-in replacement for MySQL from the Percona team"
|
||||
|
||||
# When MY_EXTRAS is bumped, the index should be revised to exclude these.
|
||||
EPATCH_EXCLUDE=''
|
||||
|
||||
COMMON_DEPEND="server? ( pam? ( virtual/pam:0= ) )
|
||||
tokudb? ( app-arch/snappy )
|
||||
tokudb-backup-plugin? ( dev-util/valgrind )
|
||||
"
|
||||
|
||||
DEPEND="${COMMON_DEPEND}
|
||||
|| ( >=sys-devel/gcc-3.4.6 >=sys-devel/gcc-apple-4.0 )
|
||||
test? ( $(python_gen_any_dep 'dev-python/mysql-python[${PYTHON_USEDEP}]') )"
|
||||
RDEPEND="${COMMON_DEPEND}"
|
||||
|
||||
REQUIRED_USE="tokudb? ( jemalloc ) tokudb-backup-plugin? ( tokudb )"
|
||||
|
||||
# Please do not add a naive src_unpack to this ebuild
|
||||
# If you want to add a single patch, copy the ebuild to an overlay
|
||||
# and create your own mysql-extras tarball, looking at 000_index.txt
|
||||
|
||||
python_check_deps() {
|
||||
has_version "dev-python/mysql-python[${PYTHON_USEDEP}]"
|
||||
}
|
||||
|
||||
src_configure() {
|
||||
local MYSQL_CMAKE_NATIVE_DEFINES=( -DWITH_PAM=$(usex pam)
|
||||
$(mysql-cmake_use_plugin tokudb TOKUDB)
|
||||
)
|
||||
if use tokudb ; then
|
||||
# TokuDB Backup plugin requires valgrind unconditionally
|
||||
MYSQL_CMAKE_NATIVE_DEFINES+=(
|
||||
$(usex tokudb-backup-plugin '' -DTOKUDB_BACKUP_DISABLED=1)
|
||||
)
|
||||
fi
|
||||
mysql-multilib-r1_src_configure
|
||||
}
|
||||
|
||||
# Official test instructions:
|
||||
# USE='extraengine perl openssl static-libs' \
|
||||
# FEATURES='test userpriv -usersandbox' \
|
||||
# ebuild percona-server-X.X.XX.ebuild \
|
||||
# digest clean package
|
||||
multilib_src_test() {
|
||||
|
||||
if ! multilib_is_native_abi ; then
|
||||
einfo "Server tests not available on non-native abi".
|
||||
return 0;
|
||||
fi
|
||||
|
||||
if ! use server ; then
|
||||
einfo "Skipping server tests due to minimal build."
|
||||
return 0
|
||||
fi
|
||||
|
||||
local TESTDIR="${CMAKE_BUILD_DIR}/mysql-test"
|
||||
local retstatus_unit
|
||||
local retstatus_tests
|
||||
|
||||
# Bug #213475 - MySQL _will_ object strenously if your machine is named
|
||||
# localhost. Also causes weird failures.
|
||||
[[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost"
|
||||
|
||||
if [[ $UID -eq 0 ]]; then
|
||||
die "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
|
||||
fi
|
||||
has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
|
||||
|
||||
einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
|
||||
addpredict /this-dir-does-not-exist/t9.MYI
|
||||
|
||||
# Run CTest (test-units)
|
||||
cmake-utils_src_test
|
||||
retstatus_unit=$?
|
||||
[[ $retstatus_unit -eq 0 ]] || eerror "test-unit failed"
|
||||
|
||||
# Ensure that parallel runs don't die
|
||||
export MTR_BUILD_THREAD="$((${RANDOM} % 100))"
|
||||
# Enable parallel testing, auto will try to detect number of cores
|
||||
# You may set this by hand.
|
||||
# The default maximum is 8 unless MTR_MAX_PARALLEL is increased
|
||||
export MTR_PARALLEL="${MTR_PARALLEL:-auto}"
|
||||
|
||||
# create directories because mysqladmin might right out of order
|
||||
mkdir -p "${T}"/var-tests{,/log}
|
||||
|
||||
# These are failing in Percona 5.6 for now and are believed to be
|
||||
# false positives:
|
||||
#
|
||||
# main.information_schema, binlog.binlog_statement_insert_delayed,
|
||||
# main.mysqld--help-notwin, binlog.binlog_mysqlbinlog_filter
|
||||
# perfschema.binlog_edge_mix, perfschema.binlog_edge_stmt
|
||||
# funcs_1.is_columns_mysql funcs_1.is_tables_mysql funcs_1.is_triggers
|
||||
# engines/funcs.db_alter_character_set engines/funcs.db_alter_character_set_collate
|
||||
# engines/funcs.db_alter_collate_ascii engines/funcs.db_alter_collate_utf8
|
||||
# engines/funcs.db_create_character_set engines/funcs.db_create_character_set_collate
|
||||
# fails due to USE=-latin1 / utf8 default
|
||||
#
|
||||
# main.mysql_client_test:
|
||||
# segfaults at random under Portage only, suspect resource limits.
|
||||
#
|
||||
# main.percona_bug1289599
|
||||
# Looks to be a syntax error in the test file itself
|
||||
#
|
||||
# main.variables main.myisam main.merge_recover
|
||||
# fails due to ulimit not able to open enough files (needs 5000)
|
||||
#
|
||||
# main.mysqlhotcopy_archive main.mysqlhotcopy_myisam
|
||||
# Called with bad parameters should be reported upstream
|
||||
#
|
||||
|
||||
for t in main.mysql_client_test \
|
||||
binlog.binlog_statement_insert_delayed main.information_schema \
|
||||
main.mysqld--help-notwin binlog.binlog_mysqlbinlog_filter \
|
||||
perfschema.binlog_edge_mix perfschema.binlog_edge_stmt \
|
||||
funcs_1.is_columns_mysql funcs_1.is_tables_mysql funcs_1.is_triggers \
|
||||
main.variables main.myisam main.merge_recover \
|
||||
engines/funcs.db_alter_character_set engines/funcs.db_alter_character_set_collate \
|
||||
engines/funcs.db_alter_collate_ascii engines/funcs.db_alter_collate_utf8 \
|
||||
engines/funcs.db_create_character_set engines/funcs.db_create_character_set_collate \
|
||||
main.percona_bug1289599 main.mysqlhotcopy_archive main.mysqlhotcopy_myisam ; do
|
||||
mysql-multilib-r1_disable_test "$t" "False positives in Gentoo"
|
||||
done
|
||||
|
||||
if ! use extraengine ; then
|
||||
# bug 401673, 530766
|
||||
for t in federated.federated_plugin ; do
|
||||
mysql-multilib-r1_disable_test "$t" "Test $t requires USE=extraengine (Need federated engine)"
|
||||
done
|
||||
fi
|
||||
|
||||
# Run mysql tests
|
||||
pushd "${TESTDIR}" || die
|
||||
|
||||
# Set file limits higher so tests run
|
||||
ulimit -n 3000
|
||||
python_setup
|
||||
# run mysql-test tests
|
||||
perl mysql-test-run.pl --force --vardir="${T}/var-tests" \
|
||||
--testcase-timeout=30 --reorder
|
||||
retstatus_tests=$?
|
||||
[[ $retstatus_tests -eq 0 ]] || eerror "tests failed"
|
||||
has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
|
||||
|
||||
popd || die
|
||||
|
||||
# Cleanup is important for these testcases.
|
||||
pkill -9 -f "${S}/ndb" 2>/dev/null
|
||||
pkill -9 -f "${S}/sql" 2>/dev/null
|
||||
|
||||
failures=""
|
||||
[[ $retstatus_unit -eq 0 ]] || failures="${failures} test-unit"
|
||||
[[ $retstatus_tests -eq 0 ]] || failures="${failures} tests"
|
||||
has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
|
||||
|
||||
[[ -z "$failures" ]] || die "Test failures: $failures"
|
||||
einfo "Tests successfully completed"
|
||||
}
|
|
@ -3,7 +3,7 @@
|
|||
# $Id$
|
||||
|
||||
EAPI=4
|
||||
inherit flag-o-matic toolchain-funcs eutils multilib
|
||||
inherit flag-o-matic toolchain-funcs eutils multilib versionator
|
||||
|
||||
DESCRIPTION="a simple, small, C++ XML parser that can be easily integrating into other programs"
|
||||
HOMEPAGE="http://www.grinninglizard.com/tinyxml/index.html"
|
||||
|
@ -20,9 +20,8 @@ DEPEND="doc? ( app-doc/doxygen )"
|
|||
S="${WORKDIR}/${PN}"
|
||||
|
||||
src_prepare() {
|
||||
local major_v minor_v
|
||||
major_v=$(echo ${PV} | cut -d \. -f 1)
|
||||
minor_v=$(echo ${PV} | cut -d \. -f 2-3)
|
||||
local major_v=$(get_major_version)
|
||||
local minor_v=$(get_version_component_range 2-3)
|
||||
|
||||
sed -e "s:@MAJOR_V@:$major_v:" \
|
||||
-e "s:@MINOR_V@:$minor_v:" \
|
||||
|
|
|
@ -3,3 +3,4 @@ DIST pycharm-community-4.0.6.tar.gz 121278114 SHA256 7aa0ed3d743ed6886329671d2e5
|
|||
DIST pycharm-community-4.5.3.tar.gz 121605129 SHA256 205247b94965d9499e55d13ec701364475ff823d9353d967744750f6ceadc38d SHA512 0ae316890d6e348024f974a81cca9669c61f005a7af0cd0ef4d2f051fcb71cebbe372446f3a660f9c2a87837d7986809493499b34311a175542751d4f8597753 WHIRLPOOL e3895326751e6fd97a6ec60fc3933fc07b61337668dd18662ab22bb85f41fac1fca2511bf8eccfa0946dffa5f51f9cb24fda6019c88c88e07f281e390e6a37d9
|
||||
DIST pycharm-community-4.5.4.tar.gz 121580731 SHA256 6bdd344eb88ee50cf29e98278c87faad0d1a23a7ec84c1794b956d2633024228 SHA512 e0c90fd84d60e1ac644c2b29aef484c1768cf8832c70cbc1a7905b64e0ef0fd7ec50665b9b15fcdaad762852e42103487b59fc4c8d1e711fd3a30123f8c959eb WHIRLPOOL d3725d9f3d983edf111f8aeb903bced2df643e9b39dcff59f21c176a16d9304dfe833ee542e204d1a4f5cdfadb33025587a669f190202bbae83cd9d102250c08
|
||||
DIST pycharm-community-5.0.1.tar.gz 134214228 SHA256 8e8b276954b8cc5e5afa79918c50cf60fc21bf5cddce6a6fa2e232627c8da392 SHA512 4f5d193b30e3d30c1bff7f2212ef061595e1f31587c16f2a527d85962ac500d86b4be8abe631f219386ec893693999248fdf92f3bbcd115f3593513e60df2fdd WHIRLPOOL b3b5d49541c4a9c1f6acecac017fc84794b6b33b0d8995a58143258641fe9737c226fe2d488b9f9ace364265885542cb51c07e12d34e7f70027b8d15d9104f31
|
||||
DIST pycharm-community-5.0.2.tar.gz 136420461 SHA256 eadc36ae55237b783fbc528b6007e1755606ef7a95b7cc8dec27f44a829e545b SHA512 f8eabd233a70ea27f8eeb8b2307b749673c64a3b1a897c773665959dccfbc43a1f62afab4e9be117e29cfa7d0608ec3cf1a87b4b0d2da44b9c83cf8205d1cdbb WHIRLPOOL acd6948edd78ec17beb9f264985619c662d113b7d8f6c9c549b958d780e974019466eb5e1060705be5f1e75581c106a92bf95ad958357197f4fc0bc3db79f8b9
|
||||
|
|
38
dev-util/pycharm-community/pycharm-community-5.0.2.ebuild
Normal file
38
dev-util/pycharm-community/pycharm-community-5.0.2.ebuild
Normal file
|
@ -0,0 +1,38 @@
|
|||
# Copyright 1999-2015 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Id$
|
||||
|
||||
EAPI=5
|
||||
|
||||
inherit eutils readme.gentoo
|
||||
|
||||
DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
|
||||
HOMEPAGE="http://www.jetbrains.com/pycharm/"
|
||||
SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
|
||||
|
||||
LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64"
|
||||
IUSE=""
|
||||
|
||||
RDEPEND=">=virtual/jre-1.6"
|
||||
DEPEND=""
|
||||
|
||||
RESTRICT="mirror strip"
|
||||
QA_PREBUILT="/opt/${PN}/bin/fsnotifier
|
||||
/opt/${PN}/bin/fsnotifier64"
|
||||
|
||||
MY_PN=${PN/-community/}
|
||||
|
||||
src_install() {
|
||||
insinto /opt/${PN}
|
||||
doins -r *
|
||||
|
||||
fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
|
||||
|
||||
dosym /opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
|
||||
newicon "bin/${MY_PN}.png" ${PN}.png
|
||||
make_desktop_entry ${PN} "${PN}" "${PN}"
|
||||
|
||||
readme.gentoo_src_install
|
||||
}
|
|
@ -1 +1 @@
|
|||
Tue, 22 Dec 2015 17:14:04 +0000
|
||||
Tue, 22 Dec 2015 20:43:44 +0000
|
||||
|
|
|
@ -1 +1 @@
|
|||
Tue, 22 Dec 2015 17:14:04 +0000
|
||||
Tue, 22 Dec 2015 20:43:45 +0000
|
||||
|
|
14
metadata/md5-cache/app-text/rpl-1.5.5-r1
Normal file
14
metadata/md5-cache/app-text/rpl-1.5.5-r1
Normal file
|
@ -0,0 +1,14 @@
|
|||
DEFINED_PHASES=compile configure install prepare test
|
||||
DEPEND=python_targets_python2_7? ( >=dev-lang/python-2.7.5-r2:2.7 ) >=dev-lang/python-exec-2:=[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]
|
||||
DESCRIPTION=Intelligent recursive search/replace utility
|
||||
EAPI=5
|
||||
HOMEPAGE=http://rpl.sourceforge.net/
|
||||
IUSE=python_targets_python2_7
|
||||
KEYWORDS=~amd64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos
|
||||
LICENSE=GPL-2
|
||||
RDEPEND=python_targets_python2_7? ( >=dev-lang/python-2.7.5-r2:2.7 ) >=dev-lang/python-exec-2:=[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]
|
||||
REQUIRED_USE=|| ( python_targets_python2_7 )
|
||||
SLOT=0
|
||||
SRC_URI=mirror://sourceforge/rpl/rpl-1.5.5.tar.gz
|
||||
_eclasses_=distutils-r1 4e8ac1ba76ddacd8f7c0289aa586a34c eutils d9bd2ddd85a58e470b49ca997e255a4c multibuild 742139c87a9fa3766f0c2b155e5522bf multilib 3972ca401cf7dbb430df9995f5d8d580 multiprocessing e32940a7b2a9992ad217eccddb84d548 python-r1 98eaa2ec9918bbf0571252d6c6d894f2 python-utils-r1 832cb17726d498a182de6b9ee2adc0dc toolchain-funcs 7a212e5e01adfa4805c9978366e6ee85
|
||||
_md5_=041fad471ff58c664db2be0feea239e7
|
16
metadata/md5-cache/dev-db/percona-server-5.6.27.76.0
Normal file
16
metadata/md5-cache/dev-db/percona-server-5.6.27.76.0
Normal file
|
@ -0,0 +1,16 @@
|
|||
DEFINED_PHASES=compile config configure install postinst preinst prepare pretend setup test unpack
|
||||
DEPEND=server? ( pam? ( virtual/pam:0= ) ) tokudb? ( app-arch/snappy ) tokudb-backup-plugin? ( dev-util/valgrind ) || ( >=sys-devel/gcc-3.4.6 >=sys-devel/gcc-apple-4.0 ) test? ( || ( ( >=dev-lang/python-2.7.5-r2:2.7 dev-python/mysql-python[python_targets_python2_7(-),python_single_target_python2_7(+)] ) ) ) virtual/pkgconfig sys-devel/make >=dev-util/cmake-2.8.12 userland_GNU? ( >=sys-apps/findutils-4.4.0 ) kernel_linux? ( sys-process/procps:0= dev-libs/libaio:0= ) >=sys-apps/sed-4 >=sys-apps/texinfo-4.7-r1 !dev-db/mariadb-native-client[mysqlcompat] jemalloc? ( dev-libs/jemalloc:0= ) tcmalloc? ( dev-util/google-perftools:0= ) systemtap? ( >=dev-util/systemtap-1.3:0= ) openssl? ( >=dev-libs/openssl-1.0.0:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,static-libs?] ) libressl? ( dev-libs/libressl:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,static-libs?] ) >=sys-libs/zlib-1.2.3:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,static-libs?] sys-libs/ncurses:0= virtual/yacc static? ( sys-libs/ncurses[static-libs] )
|
||||
DESCRIPTION=An enhanced, drop-in replacement for MySQL from the Percona team
|
||||
EAPI=5
|
||||
HOMEPAGE=http://www.percona.com/software/percona-server
|
||||
IUSE=pam tokudb tokudb-backup-plugin abi_x86_32 abi_x86_64 abi_x86_x32 abi_mips_n32 abi_mips_n64 abi_mips_o32 abi_ppc_32 abi_ppc_64 abi_s390_32 abi_s390_64 debug embedded extraengine jemalloc latin1 libressl +openssl +perl profiling selinux +server systemtap static static-libs tcmalloc test yassl
|
||||
KEYWORDS=~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-linux
|
||||
LICENSE=GPL-2
|
||||
PDEPEND=perl? ( >=dev-perl/DBD-mysql-2.9004 ) ~virtual/mysql-5.6
|
||||
RDEPEND=server? ( pam? ( virtual/pam:0= ) ) tokudb? ( app-arch/snappy ) tokudb-backup-plugin? ( dev-util/valgrind ) kernel_linux? ( sys-process/procps:0= dev-libs/libaio:0= ) >=sys-apps/sed-4 >=sys-apps/texinfo-4.7-r1 !dev-db/mariadb-native-client[mysqlcompat] jemalloc? ( dev-libs/jemalloc:0= ) tcmalloc? ( dev-util/google-perftools:0= ) systemtap? ( >=dev-util/systemtap-1.3:0= ) openssl? ( >=dev-libs/openssl-1.0.0:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,static-libs?] ) libressl? ( dev-libs/libressl:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,static-libs?] ) >=sys-libs/zlib-1.2.3:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,static-libs?] sys-libs/ncurses:0= selinux? ( sec-policy/selinux-mysql ) abi_x86_32? ( !app-emulation/emul-linux-x86-db[-abi_x86_32(-)] ) !dev-db/mysql !dev-db/mariadb !dev-db/mariadb-galera !dev-db/mysql-cluster server? ( !prefix? ( dev-db/mysql-init-scripts ) ) !<virtual/mysql-5.6-r4
|
||||
REQUIRED_USE=tokudb? ( jemalloc ) tokudb-backup-plugin? ( tokudb ) !server? ( !extraengine !embedded ) ?? ( tcmalloc jemalloc ) static? ( !libressl !openssl yassl )
|
||||
RESTRICT=libressl? ( test )
|
||||
SLOT=0/18
|
||||
SRC_URI=http://www.percona.com/redir/downloads/Percona-Server-5.6/Percona-Server-5.6.27-76.0/source/tarball/percona-server-5.6.27-76.0.tar.gz mirror://gentoo/mysql-extras-20151105-2051Z.tar.bz2 https://dev.gentoo.org/~grknight/distfiles/mysql-extras-20151105-2051Z.tar.bz2 https://dev.gentoo.org/~robbat2/distfiles/mysql-extras-20151105-2051Z.tar.bz2 https://dev.gentoo.org/~jmbsvicetto/distfiles/mysql-extras-20151105-2051Z.tar.bz2
|
||||
_eclasses_=cmake-utils b657a2689df4f46725711250cf9c8a32 eutils d9bd2ddd85a58e470b49ca997e255a4c flag-o-matic 85dc1eac3c64d8141374490ed64122e5 multibuild 742139c87a9fa3766f0c2b155e5522bf multilib 3972ca401cf7dbb430df9995f5d8d580 multilib-build 8fe2e81aeb36cdf8a6cc5f50443879cc multilib-minimal 0224dee31c0f98405d572e14ad6dee65 mysql-multilib-r1 9188bf475326daec6d70732fde054270 mysql_fx 198902d1634b4462a8070f8c933df0e8 prefix e7f2b9c6e57342e5d25eac22fce23062 python-any-r1 0ee3a2b43a7ff470ba57bc6e0ee386b3 python-utils-r1 832cb17726d498a182de6b9ee2adc0dc systemd 3165c885f3c71ffae7a867d931fb0e07 toolchain-funcs 7a212e5e01adfa4805c9978366e6ee85 user 906f3c8eb3a2350a4f1191a89baa3e46 versionator 99ae9d758cbe7cfed19170e7d48f5a9c
|
||||
_md5_=f5bea68a5ff505635ef51d83b9cf5389
|
|
@ -8,5 +8,5 @@ KEYWORDS=amd64 ~arm ~arm64 ~ia64 ppc ~ppc64 sparc x86 ~x64-macos ~x86-macos
|
|||
LICENSE=ZLIB
|
||||
SLOT=0
|
||||
SRC_URI=mirror://sourceforge/tinyxml/tinyxml_2_6_2.tar.gz
|
||||
_eclasses_=eutils d9bd2ddd85a58e470b49ca997e255a4c flag-o-matic 85dc1eac3c64d8141374490ed64122e5 multilib 3972ca401cf7dbb430df9995f5d8d580 toolchain-funcs 7a212e5e01adfa4805c9978366e6ee85
|
||||
_md5_=03b3973bda86a4d6728dadaa99a37a37
|
||||
_eclasses_=eutils d9bd2ddd85a58e470b49ca997e255a4c flag-o-matic 85dc1eac3c64d8141374490ed64122e5 multilib 3972ca401cf7dbb430df9995f5d8d580 toolchain-funcs 7a212e5e01adfa4805c9978366e6ee85 versionator 99ae9d758cbe7cfed19170e7d48f5a9c
|
||||
_md5_=e9a00f8c4862f57cfd77dde619cdffb0
|
||||
|
|
12
metadata/md5-cache/dev-util/pycharm-community-5.0.2
Normal file
12
metadata/md5-cache/dev-util/pycharm-community-5.0.2
Normal file
|
@ -0,0 +1,12 @@
|
|||
DEFINED_PHASES=install postinst
|
||||
DESCRIPTION=Intelligent Python IDE with unique code assistance and analysis
|
||||
EAPI=5
|
||||
HOMEPAGE=http://www.jetbrains.com/pycharm/
|
||||
KEYWORDS=~amd64
|
||||
LICENSE=Apache-2.0 BSD CDDL MIT-with-advertising
|
||||
RDEPEND=>=virtual/jre-1.6
|
||||
RESTRICT=mirror strip
|
||||
SLOT=0
|
||||
SRC_URI=http://download.jetbrains.com/python/pycharm-community-5.0.2.tar.gz
|
||||
_eclasses_=eutils d9bd2ddd85a58e470b49ca997e255a4c multilib 3972ca401cf7dbb430df9995f5d8d580 readme.gentoo cbc4807273837f5fccb5372e385e99eb toolchain-funcs 7a212e5e01adfa4805c9978366e6ee85
|
||||
_md5_=5fd6b6497b87470db3d6f93457543580
|
|
@ -1 +1 @@
|
|||
Tue, 22 Dec 2015 17:14:04 +0000
|
||||
Tue, 22 Dec 2015 20:43:45 +0000
|
||||
|
|
|
@ -1 +1 @@
|
|||
Tue Dec 22 17:13:08 UTC 2015
|
||||
Tue Dec 22 20:42:49 UTC 2015
|
||||
|
|
|
@ -1 +1 @@
|
|||
Tue, 22 Dec 2015 17:30:01 +0000
|
||||
Tue, 22 Dec 2015 21:30:01 +0000
|
||||
|
|
|
@ -1 +1 @@
|
|||
1450804501 Tue 22 Dec 2015 05:15:01 PM UTC
|
||||
1450817102 Tue 22 Dec 2015 08:45:02 PM UTC
|
||||
|
|
Loading…
Add table
Reference in a new issue