Sync with portage [Mon Jan 30 16:56:24 MSK 2012].

This commit is contained in:
root 2012-01-30 16:56:24 +04:00
parent 45a5db85f3
commit 401ad6003f
31 changed files with 484 additions and 34 deletions

View file

@ -1,2 +1,3 @@
DIST znotes-0.4.3.tar.gz 103097 RMD160 ba55c5294991586baf176e14891bbd8134db416f SHA1 0acfbe194c5e9818053337289a55ec3a430582e8 SHA256 41be96c465332d7231c44d27a550427f9dab6df7ca77794626bfbc18c375851e
DIST znotes-0.4.4.tar.gz 111286 RMD160 de89844b2a4cfe0c6a0bbd52149e1d5bcf038170 SHA1 9910ac7a3af1753d90234c40f87236fde4d2b896 SHA256 0b0c21a28d446d3649153575f658d7eb07e37c963dff9aed1eb184eb5089be47
DIST znotes-0.4.5.tar.gz 171884 RMD160 7f1e44fbbbd1a4b242c6bde47bbffdd4a314d348 SHA1 8cd1e31d52455f0a5bd4cde2fc27d7a59262c3b3 SHA256 ac692253e74bda8f989db40042c26b6db2bb60a5f9c30cdbfcd824af0de1c5b2

View file

@ -0,0 +1,26 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/app-editors/znotes/znotes-0.4.5.ebuild,v 1.1 2012/01/30 07:49:35 johu Exp $
EAPI=4
inherit qt4-r2
DESCRIPTION="Simple Notes"
HOMEPAGE="http://znotes.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="x11-libs/qt-core:4
x11-libs/qt-gui:4"
RDEPEND="${DEPEND}"
DOCS="CHANGELOG THANKS"
src_configure() {
lrelease znotes.pro || die "lrelease failed"
qt4-r2_src_configure
}

View file

@ -3,7 +3,7 @@ Fix build failure caused by KVM-specific code in arches not supporting KVM:
i8259.o: In function `kvm_i8259_set_irq':
/tmp/portage/app-emulation/qemu-kvm-9999/work/qemu-kvm-9999/hw/i8259.c:689: undefined reference to `apic_set_irq_delivered'
diff --git a/hw/i8259.c b/hw/i8259.c
index 0632ea2..2f6789d 100644
index 21a4efc..bb3bb18 100644
--- a/hw/i8259.c
+++ b/hw/i8259.c
@@ -21,6 +21,7 @@
@ -14,15 +14,14 @@ index 0632ea2..2f6789d 100644
#include "hw.h"
#include "pc.h"
#include "isa.h"
@@ -682,12 +683,14 @@ static int kvm_kernel_pic_load_from_user(PicState *s)
@@ -591,11 +592,13 @@ static int kvm_kernel_pic_load_from_user(PICCommonState *s)
static void kvm_i8259_set_irq(void *opaque, int irq, int level)
{
+#ifdef CONFIG_KVM
int pic_ret;
if (kvm_set_irq(irq, level, &pic_ret)) {
if (pic_ret != 0)
apic_set_irq_delivered();
apic_report_irq_delivered(pic_ret);
return;
}
+#endif

View file

@ -1 +1,2 @@
DIST QTeXEngine-0.2-opensource.zip 150479 RMD160 76ff1f2f96cd6df0ea5e6965013e0db452c55f09 SHA1 b484a4da7a0f3103e188539bfa6c1910dc9b55ca SHA256 d02bfb4754134c570aaa1a839b7d2483dffd4ea5aa767a1922667e26af13ac56
DIST QTeXEngine-0.3-opensource.zip 146118 RMD160 6f75f8e6355515cf5eb8a7b90b9acca8aa889129 SHA1 971410ebc6b73f31a11cf473f4d9171c278271f0 SHA256 fc60c18bd0af5947d2d7dbc3d1b5b16ed251d9f317cc548228347f081a0b67d5

View file

@ -0,0 +1,21 @@
--- config.pri
+++ config.pri
@@ -2,7 +2,7 @@
CONFIG += release
# Comment the lines bellow if you want to build QTeXEngine statically
-#CONFIG += QTeXEngineDll
+CONFIG += QTeXEngineDll
--- test/test.pro
+++ test/test.pro
@@ -7,6 +7,6 @@
DESTDIR = ./
INCLUDEPATH += ../src
-LIBS += ../libQTeXEngine.a
+LIBS += ../libQTeXEngine.so
SOURCES += test.cpp

View file

@ -0,0 +1,44 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-tex/qtexengine/qtexengine-0.3.ebuild,v 1.1 2012/01/30 08:22:27 johu Exp $
EAPI=4
inherit eutils qt4-r2
MY_PN=QTeXEngine
DESCRIPTION="TeX support for Qt"
HOMEPAGE="http://soft.proindependent.com/qtexengine/"
SRC_URI="mirror://berlios/qtiplot/${MY_PN}-${PV}-opensource.zip"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
SLOT="0"
LICENSE="GPL-3"
IUSE=""
RDEPEND="x11-libs/qt-core:4
x11-libs/qt-gui:4"
DEPEND="${RDEPEND}
app-arch/unzip"
S=${WORKDIR}/${MY_PN}
PATCHES=(
"${FILESDIR}/${P}-dynlib.patch"
)
src_compile() {
emake sub-src-all
}
src_test() {
emake sub-test-all
}
src_install() {
dolib.so lib${MY_PN}.so*
insinto /usr/include
doins src/${MY_PN}.h
dodoc CHANGES.txt
dohtml -r ./doc/html/*
}

View file

@ -1,2 +1,2 @@
DIST scummvm-1.3.1.tar.bz2 10479934 RMD160 181838d1a89028a5b66ed4d2ed8c65a4444623c4 SHA1 5f92d22f934448b1ca731fd694422c263134bf62 SHA256 b25dc7f7e26ed6df3d901043efb2337a525df4dd3cd1589e772733cfa90037f6
DIST scummvm-1.4.0.tar.bz2 15580242 RMD160 ad4e43f46ec10dc7c3becb52b172ac501fd38941 SHA1 92196b062771407d13617caef5efd4895c4e4b5d SHA256 494b12e90749aaa76304aa066c90eede8a5b4a8417900be9702a3e6ab484743d
DIST scummvm-1.4.1.tar.bz2 15703475 RMD160 058aa7c3cf160d9a722ad348fbc361d464e3f3e5 SHA1 f43d1fce764d6e49a9e1d4c069507346212d9b36 SHA256 fa0a7f0d59524611be0c5b9be9ac7f8e7a72bab1826732e056f88332aa3139da

View file

@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-1.3.1.ebuild,v 1.3 2011/08/22 14:10:15 chainsaw Exp $
# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-1.4.1.ebuild,v 1.1 2012/01/30 08:36:51 mr_bones_ Exp $
EAPI=2
inherit eutils flag-o-matic games
@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/scummvm/${P/_/}.tar.bz2"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 ~ppc ~ppc64 x86 ~x86-fbsd"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
IUSE="alsa debug flac fluidsynth mp3 ogg vorbis"
RESTRICT="test" # it only looks like there's a test there #77507
@ -56,7 +56,6 @@ src_configure() {
use x86 && append-ldflags -Wl,-z,noexecstack
# NOT AN AUTOCONF SCRIPT SO DONT CALL ECONF
# mpeg2 support needs vorbis (bug #79149) so turn it off if -oggvorbis
./configure \
--backend=sdl \
--host=$CHOST \
@ -75,7 +74,7 @@ src_configure() {
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
emake DESTDIR="${D}" install || die
dodoc AUTHORS NEWS README TODO
doicon icons/scummvm.svg
make_desktop_entry scummvm ScummVM scummvm "Game;AdventureGame"

View file

@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.25.ebuild,v 1.1 2012/01/26 11:49:30 chainsaw Exp $
# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.25-r1.ebuild,v 1.1 2012/01/30 08:56:24 chainsaw Exp $
EAPI=4
@ -18,7 +18,7 @@ SRC_URI="mirror://alsaproject/lib/${MY_P}.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="doc debug alisp python static-libs"
IUSE="doc debug alisp python"
DEPEND=">=media-sound/alsa-headers-1.0.25
doc? ( >=app-doc/doxygen-1.2.6 )"
@ -41,7 +41,6 @@ src_configure() {
use elibc_uclibc && myconf="--without-versioned"
econf \
$(use_enable static-libs static) \
--enable-shared \
--disable-resmgr \
--enable-rawmidi \

22
metadata/cache/app-editors/znotes-0.4.5 vendored Normal file
View file

@ -0,0 +1,22 @@
x11-libs/qt-core:4 x11-libs/qt-gui:4
x11-libs/qt-core:4 x11-libs/qt-gui:4
0
mirror://sourceforge/znotes/znotes-0.4.5.tar.gz
http://znotes.sourceforge.net/
GPL-3
Simple Notes
~amd64 ~x86
base eutils multilib portability qt4-r2 toolchain-funcs user
4
compile configure install prepare unpack

22
metadata/cache/dev-tex/qtexengine-0.3 vendored Normal file
View file

@ -0,0 +1,22 @@
x11-libs/qt-core:4 x11-libs/qt-gui:4 app-arch/unzip
x11-libs/qt-core:4 x11-libs/qt-gui:4
0
mirror://berlios/qtiplot/QTeXEngine-0.3-opensource.zip
http://soft.proindependent.com/qtexengine/
GPL-3
TeX support for Qt
~amd64 ~x86 ~amd64-linux ~x86-linux
base eutils multilib portability qt4-r2 toolchain-funcs user
4
compile configure install prepare test unpack

View file

@ -1,12 +1,12 @@
>=media-libs/libsdl-1.2.2[audio,joystick,video] >media-libs/libmpeg2-0.3.1 sys-libs/zlib ogg? ( media-libs/libogg media-libs/libvorbis ) vorbis? ( media-libs/libogg media-libs/libvorbis ) alsa? ( media-libs/alsa-lib ) mp3? ( media-libs/libmad ) flac? ( media-libs/flac ) fluidsynth? ( media-sound/fluidsynth ) x86? ( dev-lang/nasm )
>=media-libs/libsdl-1.2.2[audio,joystick,video] >media-libs/libmpeg2-0.3.1 sys-libs/zlib ogg? ( media-libs/libogg media-libs/libvorbis ) vorbis? ( media-libs/libogg media-libs/libvorbis ) alsa? ( media-libs/alsa-lib ) mp3? ( media-libs/libmad ) flac? ( media-libs/flac ) fluidsynth? ( media-sound/fluidsynth )
0
mirror://sourceforge/scummvm/scummvm-1.3.1.tar.bz2
mirror://sourceforge/scummvm/scummvm-1.4.1.tar.bz2
test
http://scummvm.sourceforge.net/
GPL-2 LGPL-2.1
Reimplementation of the SCUMM game engine used in Lucasarts adventures
amd64 ~ppc ~ppc64 x86 ~x86-fbsd
~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd
base eutils flag-o-matic games multilib portability toolchain-funcs user
alsa debug flac fluidsynth mp3 ogg vorbis

View file

@ -8,7 +8,7 @@ LGPL-2.1
Advanced Linux Sound Architecture Library
~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux
autotools base eutils libtool multilib portability python toolchain-funcs user
doc debug alisp python static-libs
doc debug alisp python

22
metadata/cache/sys-libs/zlib-1.2.6 vendored Normal file
View file

@ -0,0 +1,22 @@
minizip? ( || ( =sys-devel/automake-1.11* ) >=sys-devel/autoconf-2.61 sys-devel/libtool )
!<dev-libs/libxml2-2.7.7
0
http://zlib.net/zlib-1.2.6.tar.gz http://www.gzip.org/zlib/zlib-1.2.6.tar.gz http://www.zlib.net/current/beta/zlib-1.2.6.tar.gz
http://www.zlib.net/
ZLIB
Standard (de)compression library
~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd
autotools eutils libtool multilib portability toolchain-funcs user
minizip static-libs
compile install unpack

View file

@ -1,7 +1,7 @@
app-arch/bzip2 cups? ( dev-libs/libgcrypt >=net-print/cups-1.3.11 ) >=dev-lang/v8-3.7.6 dev-libs/dbus-glib dev-libs/elfutils >=dev-libs/icu-4.4.1 >=dev-libs/libevent-1.4.13 dev-libs/libxml2[icu] dev-libs/libxslt >=dev-libs/nss-3.12.3 gnome? ( >=gnome-base/gconf-2.24.0 ) gnome-keyring? ( >=gnome-base/gnome-keyring-2.28.2 ) >=media-libs/alsa-lib-1.0.19 media-libs/flac virtual/jpeg media-libs/libpng >=media-libs/libwebp-0.1.2 media-libs/speex pulseaudio? ( media-sound/pulseaudio ) sys-libs/zlib x11-libs/gtk+:2 x11-libs/libXinerama x11-libs/libXScrnSaver x11-libs/libXtst kerberos? ( virtual/krb5 ) >=dev-lang/nacl-toolchain-newlib-0_p7311 dev-lang/perl dev-lang/yasm dev-python/simplejson >=dev-util/gperf-3.0.3 >=dev-util/pkgconfig-0.23 >=sys-devel/bison-2.4.3 sys-devel/flex >=sys-devel/make-3.81-r2 test? ( dev-python/pyftpdlib ) >=sys-apps/sed-4 >=app-admin/eselect-python-20091230 || ( =dev-lang/python-2.7* =dev-lang/python-2.6* ) test? ( !prefix? ( x11-base/xorg-server[xvfb] ) x11-apps/xhost )
app-arch/bzip2 cups? ( dev-libs/libgcrypt >=net-print/cups-1.3.11 ) >=dev-lang/v8-3.7.6 dev-libs/dbus-glib dev-libs/elfutils >=dev-libs/icu-4.4.1 >=dev-libs/libevent-1.4.13 dev-libs/libxml2[icu] dev-libs/libxslt >=dev-libs/nss-3.12.3 gnome? ( >=gnome-base/gconf-2.24.0 ) gnome-keyring? ( >=gnome-base/gnome-keyring-2.28.2 ) >=media-libs/alsa-lib-1.0.19 media-libs/flac virtual/jpeg media-libs/libpng >=media-libs/libwebp-0.1.2 media-libs/speex pulseaudio? ( media-sound/pulseaudio ) sys-libs/zlib x11-libs/gtk+:2 x11-libs/libXinerama x11-libs/libXScrnSaver x11-libs/libXtst kerberos? ( virtual/krb5 ) !=www-client/chromium-9999 x11-misc/xdg-utils virtual/ttf-fonts >=app-admin/eselect-python-20091230 || ( =dev-lang/python-2.7* =dev-lang/python-2.6* )
0
http://commondatastorage.googleapis.com/chromium-browser-official/chromium-17.0.963.38.tar.bz2
http://commondatastorage.googleapis.com/chromium-browser-official/chromium-17.0.963.44.tar.bz2
http://chromium.org/
BSD

View file

@ -1 +1 @@
Mon, 30 Jan 2012 06:36:46 +0000
Mon, 30 Jan 2012 09:06:47 +0000

View file

@ -1 +1 @@
Mon, 30 Jan 2012 06:36:47 +0000
Mon, 30 Jan 2012 09:06:47 +0000

View file

@ -1 +1 @@
Mon, 30 Jan 2012 06:36:48 +0000
Mon, 30 Jan 2012 09:06:49 +0000

View file

@ -1 +1 @@
Mon Jan 30 06:36:46 UTC 2012
Mon Jan 30 09:06:47 UTC 2012

View file

@ -1 +1 @@
Mon, 30 Jan 2012 07:00:01 +0000
Mon, 30 Jan 2012 09:30:01 +0000

View file

@ -1 +1 @@
1327905301 Mon Jan 30 06:35:01 2012 UTC
1327914301 Mon Jan 30 09:05:01 2012 UTC

View file

@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/libproxy-0.4.7.ebuild,v 1.7 2012/01/10 21:12:09 ranger Exp $
# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/libproxy-0.4.7.ebuild,v 1.8 2012/01/30 06:47:46 nirbheek Exp $
EAPI="4"
PYTHON_DEPEND="python? 2:2.6"
@ -19,6 +19,7 @@ IUSE="gnome kde mono networkmanager perl python test"
# FIXME: Disable webkit support due problems like bug #366791
# FIXME: Also disable xulrunner support due bug #360893, will be readded
# in the future when only spidermonkey mozjs is provided.
# NOTE: USE=xulrunner also causes problems like bug 373397, re-add carefully.
RDEPEND="gnome? ( >=dev-libs/glib-2.26:2 )
kde? ( >=kde-base/kdelibs-4.4.5 )

View file

@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/isabelle/isabelle-2011.1.ebuild,v 1.2 2012/01/09 13:49:21 gienah Exp $
# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/isabelle/isabelle-2011.1.ebuild,v 1.3 2012/01/30 06:54:53 gienah Exp $
EAPI="4"
@ -109,7 +109,7 @@ src_install() {
dodir /etc/isabelle
insinto /etc/isabelle
doins -r etc
doins -r etc/*
dosym /etc/isabelle "${TARGETDIR}/etc"
dosym "${LIBDIR}/heaps" "${TARGETDIR}/heaps"

View file

@ -1,6 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer>
<email>gienah@gentoo.org></email>
</maintainer>
<herd>sci-mathematics</herd>
<longdescription lang='en'>
Isabelle is a generic proof assistant. It allows mathematical

View file

@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-1.99-r2.ebuild,v 1.8 2011/11/18 00:04:29 vapier Exp $
# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-1.99-r2.ebuild,v 1.9 2012/01/30 09:14:59 scarabeus Exp $
EAPI=4
@ -249,7 +249,7 @@ src_install() {
"bin/grub2-mkimage"
)
for e in ${PAX[@]}; do
pax-mark -mp "${ED}/${e}"
pax-mark -mpes "${ED}/${e}"
done
# can't be in docs array as we use default_src_install in different builddir

View file

@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.48 2012/01/15 02:19:54 floppym Exp $
# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.49 2012/01/30 09:14:59 scarabeus Exp $
EAPI=4
@ -242,7 +242,7 @@ src_install() {
"bin/grub2-mkimage"
)
for e in ${PAX[@]}; do
pax-mark -mp "${ED}/${e}"
pax-mark -mpes "${ED}/${e}"
done
# can't be in docs array as we use default_src_install in different builddir

View file

@ -1,3 +1,4 @@
DIST zlib-1.2.3.tar.bz2 425209 RMD160 cfba9984b354dcc38da49331457e6bfc861c6f51 SHA1 967e280f284d02284b0cd8872a8e2e04bfdc7283 SHA256 e3b9950851a19904d642c4dec518623382cf4d2ac24f70a76510c944330d28ca
DIST zlib-1.2.5.1.tar.gz 548499 RMD160 9f7d449167427c8add0b61a76a51bee164856592 SHA1 731b09322e18a3853e6b6b98b44175d7aed1e407 SHA256 c1f24a64f808528293cf04ba09a2dffbc3dd65ad7ebcee4737124ff8923756da
DIST zlib-1.2.5.tar.bz2 486374 RMD160 c6c4c2a2a205061b21487e69234106f5517b4b32 SHA1 543fa9abff0442edca308772d6cef85557677e02 SHA256 239aead2f22f16bfcfa6a6a5150dcbd6d6f2e4d1eaa8727b5769ea014120b307
DIST zlib-1.2.6.tar.gz 557220 RMD160 71845aad5ad9a0e290fa13c7325f45fa3682c7cb SHA1 38690375d8d42398ce33b2df726e25cacf096496 SHA256 21235e08552e6feba09ea5e8d750805b3391c62fb81c71a235c0044dc7a8a61b

View file

@ -0,0 +1,93 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/zlib-1.2.6.ebuild,v 1.1 2012/01/30 06:47:57 vapier Exp $
AUTOTOOLS_AUTO_DEPEND="no"
inherit autotools eutils toolchain-funcs
DESCRIPTION="Standard (de)compression library"
HOMEPAGE="http://www.zlib.net/"
SRC_URI="http://zlib.net/${P}.tar.gz
http://www.gzip.org/zlib/${P}.tar.gz
http://www.zlib.net/current/beta/${P}.tar.gz"
LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
IUSE="minizip static-libs"
DEPEND="minizip? ( ${AUTOTOOLS_DEPEND} )"
RDEPEND="!<dev-libs/libxml2-2.7.7" #309623
src_unpack() {
unpack ${A}
cd "${S}"
if use minizip ; then
cd contrib/minizip
eautoreconf
fi
}
echoit() { echo "$@"; "$@"; }
src_compile() {
case ${CHOST} in
*-mingw*|mingw*)
emake -f win32/Makefile.gcc STRIP=true PREFIX=${CHOST}- || die
sed \
-e 's|@prefix@|/usr|g' \
-e 's|@exec_prefix@|${prefix}|g' \
-e 's|@libdir@|${exec_prefix}/'$(get_libdir)'|g' \
-e 's|@sharedlibdir@|${exec_prefix}/'$(get_libdir)'|g' \
-e 's|@includedir@|${prefix}/include|g' \
-e 's|@VERSION@|'${PV}'|g' \
zlib.pc.in > zlib.pc || die
;;
*) # not an autoconf script, so can't use econf
echoit ./configure --shared --prefix=/usr --libdir=/usr/$(get_libdir) || die
emake || die
;;
esac
if use minizip ; then
cd contrib/minizip
econf $(use_enable static-libs static)
emake || die
fi
}
sed_macros() {
# clean up namespace a little #383179
# we do it here so we only have to tweak 2 files
sed -i -r 's:\<(O[FN])\>:_Z_\1:g' "$@" || die
}
src_install() {
case ${CHOST} in
*-mingw*|mingw*)
emake -f win32/Makefile.gcc install \
BINARY_PATH="${D}/usr/bin" \
LIBRARY_PATH="${D}/usr/$(get_libdir)" \
INCLUDE_PATH="${D}/usr/include" \
SHARED_MODE=1 \
|| die
insinto /usr/share/pkgconfig
doins zlib.pc || die
;;
*)
emake install DESTDIR="${D}" LDCONFIG=: || die
gen_usr_ldscript -a z
sed_macros "${D}"/usr/include/*.h
;;
esac
dodoc FAQ README ChangeLog doc/*.txt
if use minizip ; then
cd contrib/minizip
emake install DESTDIR="${D}" || die
sed_macros "${D}"/usr/include/minizip/*.h
dodoc *.txt
fi
use static-libs || rm -f "${D}"/usr/$(get_libdir)/*.{a,la}
}

View file

@ -1,5 +1,4 @@
DIST chromium-16.0.912.77.tar.bz2 154287236 RMD160 1eb85bf3435675fdd28b486d3a41a5db2a36df1e SHA1 b743e60fcd3f5034ba38cfb9534023bab0bc5ace SHA256 fc84e9a96d00a95c44beb6539b9ffe7224dc3ca51afef6486e0e7ad705445a32
DIST chromium-17.0.963.38.tar.bz2 165295836 RMD160 6cc287ca937ab6f93bdd6b189ed9140adbe7cba8 SHA1 75c2f6e51da873baeb25b7bcddc578e4bcbe03ec SHA256 977da1b8dc09c879c0452ff34ce07bb31ce7e10194330f9ce412c45c54cfedc7
DIST chromium-17.0.963.44.tar.bz2 165319178 RMD160 c0429f1af13812c0e89d4e5920e2c8dd621c92aa SHA1 bb8cdbf9b3b815e0096f023a58518a16f3715e4c SHA256 085084b309fd5b288f6186cfc8b57a3ab3c9493d6a0bda26c57cf1099c3f4352
DIST chromium-18.0.1010.0.tar.bz2 172091081 RMD160 776a68eeaf26be01dc87857df2402848c649c6de SHA1 6a30523007ee06feee7174b79d1cfa2d8dfaad2b SHA256 9df8652d8d6e8e6d7fe5b6f8872f4fed11bb1708c5d1787029e9c62da6d7fd44
DIST chromium-18.0.1017.2.tar.bz2 172847602 RMD160 61dc69a8ce1764d4552b353c149a8e28d75e9619 SHA1 67a54e644e518b5546ba3b42b276baef6d2e2f4e SHA256 6b02073d64235eda236b8c454526362b628dc91a866322ca44b1dbfc8a9c6134

View file

@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-17.0.963.38.ebuild,v 1.1 2012/01/19 02:09:39 floppym Exp $
# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-17.0.963.44-r1.ebuild,v 1.1 2012/01/30 07:58:08 phajdan.jr Exp $
EAPI="4"
PYTHON_DEPEND="2:2.6"
@ -188,6 +188,9 @@ src_prepare() {
# Revert WebKit changeset responsible for Gentoo bug #393471.
epatch "${FILESDIR}/${PN}-revert-jpeg-swizzle-r0.patch"
# Backport upstream fix for Gentoo bug #389479.
epatch "${FILESDIR}/${PN}-dev-shm-r0.patch"
epatch_user
# Remove most bundled libraries. Some are still needed.
@ -380,8 +383,9 @@ src_test() {
# NetUtilTest: bug #361885.
# NetUtilTest.GenerateFileName: some locale-related mismatch.
# UDP: unstable, active development. We should revisit this later.
# CertDatabaseNSSTest.ImportCACertHierarchyTree: works in 18.x, broken here.
LC_ALL="${mylocale}" VIRTUALX_COMMAND=out/Release/net_unittests virtualmake \
'--gtest_filter=-NetUtilTest.IDNToUnicode*:NetUtilTest.FormatUrl*:NetUtilTest.GenerateFileName:*UDP*'
'--gtest_filter=-NetUtilTest.IDNToUnicode*:NetUtilTest.FormatUrl*:NetUtilTest.GenerateFileName:*UDP*:CertDatabaseNSSTest.ImportCACertHierarchyTree'
LC_ALL="${mylocale}" VIRTUALX_COMMAND=out/Release/printing_unittests virtualmake
}

View file

@ -0,0 +1,193 @@
Backport http://codereview.chromium.org/8800025 to fix issues with noexec /dev/shm
diff --git a/base/file_util.h b/base/file_util.h
index 90ec1ae..78827e9 100644
--- a/base/file_util.h
+++ b/base/file_util.h
@@ -259,7 +259,7 @@ BASE_EXPORT bool IsDirectoryEmpty(const FilePath& dir_path);
BASE_EXPORT bool GetTempDir(FilePath* path);
// Get a temporary directory for shared memory files.
// Only useful on POSIX; redirects to GetTempDir() on Windows.
-BASE_EXPORT bool GetShmemTempDir(FilePath* path);
+BASE_EXPORT bool GetShmemTempDir(FilePath* path, bool executable);
// Get the home directory. This is more complicated than just getenv("HOME")
// as it knows to fall back on getpwent() etc.
@@ -279,7 +279,10 @@ BASE_EXPORT bool CreateTemporaryFileInDir(const FilePath& dir,
// Returns a handle to the opened file or NULL if an error occured.
BASE_EXPORT FILE* CreateAndOpenTemporaryFile(FilePath* path);
// Like above but for shmem files. Only useful for POSIX.
-BASE_EXPORT FILE* CreateAndOpenTemporaryShmemFile(FilePath* path);
+// The executable flag says the file needs to support using
+// mprotect with PROT_EXEC after mapping.
+BASE_EXPORT FILE* CreateAndOpenTemporaryShmemFile(FilePath* path,
+ bool executable);
// Similar to CreateAndOpenTemporaryFile, but the file is created in |dir|.
BASE_EXPORT FILE* CreateAndOpenTemporaryFileInDir(const FilePath& dir,
FilePath* path);
diff --git a/base/file_util_android.cc b/base/file_util_android.cc
index eff3a46..6807d8d 100644
--- a/base/file_util_android.cc
+++ b/base/file_util_android.cc
@@ -8,7 +8,7 @@
namespace file_util {
-bool GetShmemTempDir(FilePath* path) {
+bool GetShmemTempDir(FilePath* path, bool executable) {
*path = FilePath("/data/local/tmp");
return true;
}
diff --git a/base/file_util_mac.mm b/base/file_util_mac.mm
index 95d4f25..bb4975d 100644
--- a/base/file_util_mac.mm
+++ b/base/file_util_mac.mm
@@ -1,4 +1,4 @@
-// Copyright (c) 2010 The Chromium Authors. All rights reserved.
+// Copyright (c) 2011 The Chromium Authors. All rights reserved.
// Use of this source code is governed by a BSD-style license that can be
// found in the LICENSE file.
@@ -22,7 +22,7 @@ bool GetTempDir(FilePath* path) {
return true;
}
-bool GetShmemTempDir(FilePath* path) {
+bool GetShmemTempDir(FilePath* path, bool executable) {
return GetTempDir(path);
}
diff --git a/base/file_util_posix.cc b/base/file_util_posix.cc
index 582f70e..5c14abd 100644
--- a/base/file_util_posix.cc
+++ b/base/file_util_posix.cc
@@ -481,9 +481,9 @@ bool CreateTemporaryFile(FilePath* path) {
return true;
}
-FILE* CreateAndOpenTemporaryShmemFile(FilePath* path) {
+FILE* CreateAndOpenTemporaryShmemFile(FilePath* path, bool executable) {
FilePath directory;
- if (!GetShmemTempDir(&directory))
+ if (!GetShmemTempDir(&directory, executable))
return NULL;
return CreateAndOpenTemporaryFileInDir(directory, path);
@@ -910,15 +910,52 @@ bool GetTempDir(FilePath* path) {
}
#if !defined(OS_ANDROID)
-bool GetShmemTempDir(FilePath* path) {
+
#if defined(OS_LINUX)
- *path = FilePath("/dev/shm");
- return true;
-#else
- return GetTempDir(path);
-#endif
+// Determine if /dev/shm files can be mapped and then mprotect'd PROT_EXEC.
+// This depends on the mount options used for /dev/shm, which vary among
+// different Linux distributions and possibly local configuration. It also
+// depends on details of kernel--ChromeOS uses the noexec option for /dev/shm
+// but its kernel allows mprotect with PROT_EXEC anyway.
+
+namespace {
+
+bool DetermineDevShmExecutable() {
+ bool result = false;
+ FilePath path;
+ int fd = CreateAndOpenFdForTemporaryFile(FilePath("/dev/shm"), &path);
+ if (fd >= 0) {
+ ScopedFD shm_fd_closer(&fd);
+ Delete(path, false);
+ size_t pagesize = sysconf(_SC_PAGESIZE);
+ void *mapping = mmap(NULL, pagesize, PROT_READ, MAP_SHARED, fd, 0);
+ if (mapping != MAP_FAILED) {
+ if (mprotect(mapping, pagesize, PROT_READ | PROT_EXEC) == 0)
+ result = true;
+ munmap(mapping, pagesize);
+ }
+ }
+ return result;
}
+
+}; // namespace
+#endif // defined(OS_LINUX)
+
+bool GetShmemTempDir(FilePath* path, bool executable) {
+#if defined(OS_LINUX)
+ bool use_dev_shm = true;
+ if (executable) {
+ static const bool s_dev_shm_executable = DetermineDevShmExecutable();
+ use_dev_shm = s_dev_shm_executable;
+ }
+ if (use_dev_shm) {
+ *path = FilePath("/dev/shm");
+ return true;
+ }
#endif
+ return GetTempDir(path);
+}
+#endif // !defined(OS_ANDROID)
FilePath GetHomeDir() {
const char* home_dir = getenv("HOME");
diff --git a/base/file_util_unittest.cc b/base/file_util_unittest.cc
index 00cacd6..a9f9377 100644
--- a/base/file_util_unittest.cc
+++ b/base/file_util_unittest.cc
@@ -1545,7 +1545,7 @@ TEST_F(FileUtilTest, CreateNewTemporaryDirInDirTest) {
TEST_F(FileUtilTest, GetShmemTempDirTest) {
FilePath dir;
- EXPECT_TRUE(file_util::GetShmemTempDir(&dir));
+ EXPECT_TRUE(file_util::GetShmemTempDir(&dir, false));
EXPECT_TRUE(file_util::DirectoryExists(dir));
}
diff --git a/base/file_util_win.cc b/base/file_util_win.cc
index 8d9fbde..a6720a5 100644
--- a/base/file_util_win.cc
+++ b/base/file_util_win.cc
@@ -556,7 +556,7 @@ bool GetTempDir(FilePath* path) {
return true;
}
-bool GetShmemTempDir(FilePath* path) {
+bool GetShmemTempDir(FilePath* path, bool executable) {
return GetTempDir(path);
}
@@ -576,7 +576,7 @@ bool CreateTemporaryFile(FilePath* path) {
return false;
}
-FILE* CreateAndOpenTemporaryShmemFile(FilePath* path) {
+FILE* CreateAndOpenTemporaryShmemFile(FilePath* path, bool executable) {
base::ThreadRestrictions::AssertIOAllowed();
return CreateAndOpenTemporaryFile(path);
}
diff --git a/base/shared_memory_posix.cc b/base/shared_memory_posix.cc
index 030061a..a66c859 100644
--- a/base/shared_memory_posix.cc
+++ b/base/shared_memory_posix.cc
@@ -123,7 +123,7 @@ bool SharedMemory::Create(const SharedMemoryCreateOptions& options) {
DCHECK(!options.open_existing);
// Q: Why not use the shm_open() etc. APIs?
// A: Because they're limited to 4mb on OS X. FFFFFFFUUUUUUUUUUU
- fp = file_util::CreateAndOpenTemporaryShmemFile(&path);
+ fp = file_util::CreateAndOpenTemporaryShmemFile(&path, options.executable);
// Deleting the file prevents anyone else from mapping it in
// (making it private), and prevents the need for cleanup (once
@@ -317,7 +317,7 @@ bool SharedMemory::FilePathForMemoryName(const std::string& mem_name,
DCHECK_EQ(std::string::npos, mem_name.find('\0'));
FilePath temp_dir;
- if (!file_util::GetShmemTempDir(&temp_dir))
+ if (!file_util::GetShmemTempDir(&temp_dir, false))
return false;
#if !defined(OS_MACOSX)
--
1.7.6.1