Sync with portage [Mon May 6 15:53:02 MSK 2013].

mhiretskiy
root 11 years ago
parent 6320add8f2
commit 42f7f1ed17

@ -0,0 +1,23 @@
#!/sbin/runscript
# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/files/redis.initd-2,v 1.1 2013/05/06 08:45:00 djc Exp $
REDIS_DIR=${REDIS_DIR:-/var/lib/redis}
REDIS_CONF=${REDIS_CONF:-/etc/redis.conf}
REDIS_OPTS=${REDIS_OPTS:-"${REDIS_CONF}"}
REDIS_USER=${REDIS_USER:-redis}
REDIS_GROUP=${REDIS_GROUP:-redis}
command=/usr/sbin/redis-server
start_stop_daemon_args="--chdir \"${REDIS_DIR}\"
--user ${REDIS_USER} --group ${REDIS_GROUP}"
command_args="${REDIS_OPTS}"
pidfile=${REDIS_PID:-/var/run/redis/redis.pid}
depend() {
use net localmount logger
after keepalived
}
start_pre() {
checkpath -d -m 0775 -o ${REDIS_USER}:${REDIS_GROUP} $(dirname ${REDIS_PID})
}

@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/redis-2.6.13.ebuild,v 1.1 2013/05/03 08:07:23 djc Exp $
# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/redis-2.6.13.ebuild,v 1.2 2013/05/06 08:44:59 djc Exp $
EAPI=5
@ -88,7 +88,7 @@ src_install() {
fperms 0644 /etc/{redis,sentinel}.conf
newconfd "${FILESDIR}/redis.confd" redis
newinitd "${FILESDIR}/redis.initd" redis
newinitd "${FILESDIR}/redis.initd-2" redis
nonfatal dodoc 00-RELEASENOTES BUGS CONTRIBUTING MANIFESTO README

@ -1,2 +1,3 @@
DIST jsch-0.1.41.zip 281985 SHA256 4a42313dafc8a72395aeb977613ed22a5d774bcca0fd3c25ba234fa907520fc5 SHA512 ac1387b534cb3680a8bd255afaa08c5ae9da73a0190c9c8c53e06e25b897382477a6e225caf7dc0d317f98afa16bf9006362bd4915967c0b5b6db6b8389e4e6e WHIRLPOOL a688fc11f4449087baa7621e31285a5b856214d6f022e49a8b08595004c2a4840c3d3e11e248bec8fae83520c41e5ee546f7fefaa4e53ce248136f7aa6a78e9d
DIST jsch-0.1.44.zip 283903 SHA256 a6000c003097cab81ed37dfcf3cad7747ed181111850fddd9090b9cc7dd52ab2 SHA512 8d3e546af1c20231ff9765e9daeeafdc4adf0eb176188459608aeeb0c8155b803e5489154d6db3dcea9cd26bc13203ae088a2c01c9472cd6a3fb03b0fe2e6656 WHIRLPOOL eac2f99c0a5763c9bb68beafd2d45304aa000a6186561002018da219405028d75aa720bb1eaa4635479448c32a20ebaa82c00cf53622ac339442e9407c1b9402
DIST jsch-0.1.49.zip 312322 SHA256 c017dfd2533b86dd751a8b1caea0ab4f19bfb9199c207c94fbdddcfd2ba9bbfe SHA512 6f21db4b561da65d4d22ecaecdc784aaca26b2dc625646a18a27b5dd7ef0eef5596786553e65b2d7f118b4993c4bb4e9561616052d15edf1a1ee1a3a7fd6b4ed WHIRLPOOL 4d09f8d122d1948400825d286718a2ee5cb42df55fbda059ff6c1260c88a5e6318ae9704d2bd7afc1f655b55d9347b39d158a01eaab1d77c506a6b99f117217e

@ -0,0 +1,45 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-java/jsch/jsch-0.1.49.ebuild,v 1.1 2013/05/06 09:29:48 fordfrog Exp $
EAPI="2"
JAVA_PKG_IUSE="doc source examples"
inherit java-pkg-2 java-ant-2 java-osgi
DESCRIPTION="JSch is a pure Java implementation of SSH2."
HOMEPAGE="http://www.jcraft.com/jsch/"
SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="zlib"
RDEPEND=">=virtual/jdk-1.5
zlib? ( dev-java/jzlib:0 )"
DEPEND=">=virtual/jdk-1.5
app-arch/unzip
${RDEPEND}"
EANT_BUILD_TARGET="dist"
JAVA_ANT_REWRITE_CLASSPATH="true"
src_compile() {
if use zlib; then
EANT_EXTRA_ARGS="-Djzlib.available=true"
EANT_GENTOO_CLASSPATH="jzlib"
fi
java-pkg-2_src_compile
}
src_install() {
java-osgi_newjar dist/lib/jsch*.jar "com.jcraft.jsch" "JSch" \
"com.jcraft.jsch, com.jcraft.jsch.jce;x-internal:=true, \
com.jcraft.jsch.jcraft;x-internal:=true"
dodoc README ChangeLog || die
use doc && java-pkg_dojavadoc javadoc
use source && java-pkg_dosrc src/*
use examples && java-pkg_doexamples examples
}

@ -1 +1 @@
DIST uniconvertor-1.1.5.tar.gz 246998 SHA256 c3a9ecb70779911470e01c6b1950b07fc2fe1880777a1e70e44251323f4d5882
DIST uniconvertor-1.1.5.tar.gz 246998 SHA256 c3a9ecb70779911470e01c6b1950b07fc2fe1880777a1e70e44251323f4d5882 SHA512 dd659ae7e85e08f9f8998747ac707c4b42493858cc58b1f4eddbb0742928918fb7a620645c2f886e074c67dcaaf6004381876b933919a9b9287087bb425baf88 WHIRLPOOL 17157fe9a8875fb181f547eaf5f0ec789fcce3ed0b18be52578235ff3d271ef3e60c8c0bf35b1fe95cab0b03b8123e7a0cb1305a0b91a58e450e43166d1c2275

@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>graphics</herd>
<upstream>
<remote-id type="google-code">uniconvertor</remote-id>
</upstream>
<herd>graphics</herd>
<upstream>
<remote-id type="google-code">uniconvertor</remote-id>
</upstream>
</pkgmetadata>

@ -0,0 +1,32 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/media-gfx/uniconvertor/uniconvertor-1.1.5-r1.ebuild,v 1.1 2013/05/06 09:14:56 jlec Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_5,2_6,2_7} )
inherit distutils-r1
DESCRIPTION="Commandline tool for popular vector formats convertion"
HOMEPAGE="http://sk1project.org/modules.php?name=Products&product=uniconvertor"
SRC_URI="http://uniconvertor.googlecode.com/files/${P}.tar.gz"
KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~x86-solaris"
SLOT="0"
LICENSE="GPL-2 LGPL-2"
IUSE=""
DEPEND=">=media-libs/sk1libs-0.9.1[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}
app-text/ghostscript-gpl"
PATCHES=( "${FILESDIR}/uniconvertor-1.1.5_export_raster.py_fix_import.patch" )
python_prepare_all() {
sed -i \
-e "s/'GNU_GPL_v2', 'GNU_LGPL_v2', 'COPYRIGHTS',//" \
setup.py || die
distutils-r1_python_prepare_all
}

@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/media-libs/sk1libs/sk1libs-0.9.1-r3.ebuild,v 1.1 2013/04/24 12:07:21 jlec Exp $
# $Header: /var/cvsroot/gentoo-x86/media-libs/sk1libs/sk1libs-0.9.1-r3.ebuild,v 1.2 2013/05/06 09:42:47 jlec Exp $
EAPI=5
PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy{1_8,1_9} )
PYTHON_COMPAT=( python{2_5,2_6,2_7} )
inherit distutils-r1 python-r1
@ -21,7 +21,7 @@ DEPEND="
media-fonts/ttf-bitstream-vera
media-libs/freetype:2
virtual/jpeg
>=media-libs/lcms-1.15:0[python]
>=media-libs/lcms-1.15:0[python,${PYTHON_USEDEP}]
sys-libs/zlib
"
RDEPEND="${DEPEND}

@ -1 +1 @@
Mon, 06 May 2013 08:06:55 +0000
Mon, 06 May 2013 10:36:53 +0000

@ -1 +1 @@
Mon, 06 May 2013 08:06:55 +0000
Mon, 06 May 2013 10:36:53 +0000

@ -11,4 +11,4 @@ REQUIRED_USE=tcmalloc? ( !jemalloc ) jemalloc? ( !tcmalloc )
SLOT=0
SRC_URI=http://redis.googlecode.com/files/redis-2.6.13.tar.gz
_eclasses_=autotools 16761a2f972abd686713e5967ff3c754 eutils 384ae111f3649d456ed1754e3e1c4f6e flag-o-matic d900015de4e092f26d8c0a18b6bd60de libtool 177b3e32837e245539b46f16c43afed8 multilib 892e597faee02a5b94eb02ab512e7622 multiprocessing a2130e6fc4aa4c6a24b265ca0cbcc2b6 toolchain-funcs 69a2016af67775a812f4c03ba4b0e03e user d0a4d0735a6c0183d707ca919bd72f28
_md5_=0c9b432cdbfc22a06e3933f699885644
_md5_=1a58c2dc1ad73c1770ce2e4b059fdc9c

@ -0,0 +1,13 @@
DEFINED_PHASES=compile configure install preinst prepare setup
DEPEND=>=virtual/jdk-1.5 app-arch/unzip >=virtual/jdk-1.5 zlib? ( dev-java/jzlib:0 ) >=dev-java/java-config-2.1.9-r1 source? ( app-arch/zip ) >=dev-java/ant-core-1.8.2 >=dev-java/javatoolkit-0.3.0-r2 >=dev-lang/python-2.4
DESCRIPTION=JSch is a pure Java implementation of SSH2.
EAPI=2
HOMEPAGE=http://www.jcraft.com/jsch/
IUSE=zlib elibc_FreeBSD doc source examples elibc_FreeBSD elibc_FreeBSD
KEYWORDS=~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris
LICENSE=BSD
RDEPEND=>=virtual/jdk-1.5 zlib? ( dev-java/jzlib:0 ) >=dev-java/java-config-2.1.9-r1 source? ( app-arch/zip )
SLOT=0
SRC_URI=mirror://sourceforge/jsch/jsch-0.1.49.zip
_eclasses_=eutils 384ae111f3649d456ed1754e3e1c4f6e java-ant-2 65ba8d80c13cf56bad5ccec21a6b3c37 java-osgi fb81d0ede6b5759b64ec19226fe6d2f2 java-pkg-2 65bbb59987d777c1106ae8aa4bf36e7b java-utils-2 52b7cfbf4f7225fcea7e7f18b6d83328 multilib 892e597faee02a5b94eb02ab512e7622 toolchain-funcs 69a2016af67775a812f4c03ba4b0e03e user d0a4d0735a6c0183d707ca919bd72f28 versionator 6601b4c5b3f019a993db59a50e1854e4
_md5_=239ea86b900c3e7c09b337f13239a1e3

@ -0,0 +1,13 @@
DEFINED_PHASES=compile configure install prepare test
DEPEND=>=media-libs/sk1libs-0.9.1[python_targets_python2_5(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,-python_single_target_python2_5(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-)] python_targets_python2_5? ( dev-lang/python:2.5 ) python_targets_python2_6? ( dev-lang/python:2.6 ) python_targets_python2_7? ( dev-lang/python:2.7 ) dev-python/python-exec[python_targets_python2_5(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,-python_single_target_python2_5(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-)]
DESCRIPTION=Commandline tool for popular vector formats convertion
EAPI=5
HOMEPAGE=http://sk1project.org/modules.php?name=Products&product=uniconvertor
IUSE=python_targets_python2_5 python_targets_python2_6 python_targets_python2_7
KEYWORDS=~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~x86-solaris
LICENSE=GPL-2 LGPL-2
RDEPEND=>=media-libs/sk1libs-0.9.1[python_targets_python2_5(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,-python_single_target_python2_5(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-)] app-text/ghostscript-gpl python_targets_python2_5? ( dev-lang/python:2.5 ) python_targets_python2_6? ( dev-lang/python:2.6 ) python_targets_python2_7? ( dev-lang/python:2.7 ) dev-python/python-exec[python_targets_python2_5(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,-python_single_target_python2_5(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-)]
SLOT=0
SRC_URI=http://uniconvertor.googlecode.com/files/uniconvertor-1.1.5.tar.gz
_eclasses_=distutils-r1 10e59ecabebf0c37ad5cd8827434b108 eutils 384ae111f3649d456ed1754e3e1c4f6e multibuild 32fd04fe3ee97494341710886fd70dfe multilib 892e597faee02a5b94eb02ab512e7622 multiprocessing a2130e6fc4aa4c6a24b265ca0cbcc2b6 python-r1 052a2872c3d341495152eb93212374e9 python-utils-r1 345dcecf1ef156d1d86a98f16d3c385c toolchain-funcs 69a2016af67775a812f4c03ba4b0e03e user d0a4d0735a6c0183d707ca919bd72f28
_md5_=cb75adf52aeab64ef129d8e208118629

@ -1,13 +1,13 @@
DEFINED_PHASES=compile configure install prepare test
DEPEND=media-fonts/ttf-bitstream-vera media-libs/freetype:2 virtual/jpeg >=media-libs/lcms-1.15:0[python] sys-libs/zlib python_targets_python2_5? ( dev-lang/python:2.5 ) python_targets_python2_6? ( dev-lang/python:2.6 ) python_targets_python2_7? ( dev-lang/python:2.7 ) python_targets_pypy1_9? ( dev-python/pypy:1.9 ) dev-python/python-exec[python_targets_python2_5(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_pypy1_9(-)?,-python_single_target_python2_5(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_pypy1_9(-)]
DEPEND=media-fonts/ttf-bitstream-vera media-libs/freetype:2 virtual/jpeg >=media-libs/lcms-1.15:0[python,python_targets_python2_5(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,-python_single_target_python2_5(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-)] sys-libs/zlib python_targets_python2_5? ( dev-lang/python:2.5 ) python_targets_python2_6? ( dev-lang/python:2.6 ) python_targets_python2_7? ( dev-lang/python:2.7 ) dev-python/python-exec[python_targets_python2_5(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,-python_single_target_python2_5(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-)]
DESCRIPTION=sk1 vector graphics lib
EAPI=5
HOMEPAGE=http://sk1project.org
IUSE=python_targets_python2_5 python_targets_python2_6 python_targets_python2_7 python_targets_pypy1_9
IUSE=python_targets_python2_5 python_targets_python2_6 python_targets_python2_7
KEYWORDS=~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~x86-solaris
LICENSE=LGPL-2
RDEPEND=media-fonts/ttf-bitstream-vera media-libs/freetype:2 virtual/jpeg >=media-libs/lcms-1.15:0[python] sys-libs/zlib app-arch/bzip2 app-arch/gzip app-text/ghostscript-gpl media-libs/netpbm python_targets_python2_5? ( dev-lang/python:2.5 ) python_targets_python2_6? ( dev-lang/python:2.6 ) python_targets_python2_7? ( dev-lang/python:2.7 ) python_targets_pypy1_9? ( dev-python/pypy:1.9 ) dev-python/python-exec[python_targets_python2_5(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_pypy1_9(-)?,-python_single_target_python2_5(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_pypy1_9(-)]
RDEPEND=media-fonts/ttf-bitstream-vera media-libs/freetype:2 virtual/jpeg >=media-libs/lcms-1.15:0[python,python_targets_python2_5(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,-python_single_target_python2_5(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-)] sys-libs/zlib app-arch/bzip2 app-arch/gzip app-text/ghostscript-gpl media-libs/netpbm python_targets_python2_5? ( dev-lang/python:2.5 ) python_targets_python2_6? ( dev-lang/python:2.6 ) python_targets_python2_7? ( dev-lang/python:2.7 ) dev-python/python-exec[python_targets_python2_5(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,-python_single_target_python2_5(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-)]
SLOT=0
SRC_URI=http://uniconvertor.googlecode.com/files/sk1libs-0.9.1.tar.gz
_eclasses_=distutils-r1 10e59ecabebf0c37ad5cd8827434b108 eutils 384ae111f3649d456ed1754e3e1c4f6e multibuild 32fd04fe3ee97494341710886fd70dfe multilib 892e597faee02a5b94eb02ab512e7622 multiprocessing a2130e6fc4aa4c6a24b265ca0cbcc2b6 python-r1 052a2872c3d341495152eb93212374e9 python-utils-r1 345dcecf1ef156d1d86a98f16d3c385c toolchain-funcs 69a2016af67775a812f4c03ba4b0e03e user d0a4d0735a6c0183d707ca919bd72f28
_md5_=cb81d9b7947b6ce7af3e0135e4c3cfce
_md5_=118863413fdd8a9796119d530a17b3f4

@ -11,4 +11,4 @@ REQUIRED_USE=sasl? ( ldap )
SLOT=0
SRC_URI=mirror://kernel/linux/daemons/autofs/v5/autofs-5.0.7.tar.bz2 http://dev.gentoo.org/~jlec/distfiles/autofs-5.0.7-patches-2.tar.lzma
_eclasses_=autotools 16761a2f972abd686713e5967ff3c754 autotools-utils 7c11ec0c4b75b50282ec943ef9df2b17 eutils 384ae111f3649d456ed1754e3e1c4f6e libtool 177b3e32837e245539b46f16c43afed8 linux-info dd8fdcccc30f117673b4cba4ed4f74a7 multilib 892e597faee02a5b94eb02ab512e7622 multiprocessing a2130e6fc4aa4c6a24b265ca0cbcc2b6 toolchain-funcs 69a2016af67775a812f4c03ba4b0e03e user d0a4d0735a6c0183d707ca919bd72f28 versionator 6601b4c5b3f019a993db59a50e1854e4
_md5_=07ce173844f95db21ada90b77ece549b
_md5_=066cdea66d661bd9d6a98beea754271e

@ -1,12 +0,0 @@
DEFINED_PHASES=compile install postinst postrm prepare test
DEPEND=dev-python/setuptools net-zope/zope-fixers dev-lang/python
DESCRIPTION=Interfaces for Python
EAPI=3
HOMEPAGE=http://pypi.python.org/pypi/zope.interface
KEYWORDS=alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris
LICENSE=ZPL
RDEPEND=dev-lang/python
SLOT=0
SRC_URI=mirror://pypi/z/zope.interface/zope.interface-3.6.2.tar.gz
_eclasses_=distutils 77fc6005d2dfcc7bdb5ec363a49d9912 multilib 892e597faee02a5b94eb02ab512e7622 python dd56675d8e9f7e85d815a28c87383141 toolchain-funcs 69a2016af67775a812f4c03ba4b0e03e
_md5_=74b640dc054e045fb4bf8ff8edcf38cb

@ -1,12 +0,0 @@
DEFINED_PHASES=compile install postinst postrm prepare test
DEPEND=dev-python/setuptools net-zope/zope-fixers dev-lang/python
DESCRIPTION=Interfaces for Python
EAPI=3
HOMEPAGE=http://pypi.python.org/pypi/zope.interface
KEYWORDS=alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris
LICENSE=ZPL
RDEPEND=dev-lang/python
SLOT=0
SRC_URI=mirror://pypi/z/zope.interface/zope.interface-3.7.0.tar.gz
_eclasses_=distutils 77fc6005d2dfcc7bdb5ec363a49d9912 multilib 892e597faee02a5b94eb02ab512e7622 python dd56675d8e9f7e85d815a28c87383141 toolchain-funcs 69a2016af67775a812f4c03ba4b0e03e
_md5_=3a58de8d77a66ac05072b59706053e07

@ -1,12 +0,0 @@
DEFINED_PHASES=compile install postinst postrm prepare test
DEPEND=dev-python/setuptools net-zope/zope-fixers dev-lang/python
DESCRIPTION=Interfaces for Python
EAPI=3
HOMEPAGE=http://pypi.python.org/pypi/zope.interface
KEYWORDS=~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris
LICENSE=ZPL
RDEPEND=dev-lang/python
SLOT=0
SRC_URI=mirror://pypi/z/zope.interface/zope.interface-4.0.3.tar.gz
_eclasses_=distutils 77fc6005d2dfcc7bdb5ec363a49d9912 multilib 892e597faee02a5b94eb02ab512e7622 python dd56675d8e9f7e85d815a28c87383141 toolchain-funcs 69a2016af67775a812f4c03ba4b0e03e
_md5_=f45b77e55c15f68c6d7430feadcf527e

@ -1,13 +0,0 @@
DEFINED_PHASES=compile configure install prepare test
DEPEND=dev-python/setuptools[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_pypy1_9(-)?,python_targets_pypy2_0(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy1_9(-),-python_single_target_pypy2_0(-)] net-zope/zope-fixers[python_targets_python3_2(-)?,-python_single_target_python3_2(-),python_targets_python3_3(-)?,-python_single_target_python3_3(-)] python_targets_python2_6? ( dev-lang/python:2.6 ) python_targets_python2_7? ( dev-lang/python:2.7 ) python_targets_python3_2? ( dev-lang/python:3.2 ) python_targets_python3_3? ( dev-lang/python:3.3 ) python_targets_pypy1_9? ( dev-python/pypy:1.9 ) python_targets_pypy2_0? ( dev-python/pypy:2.0 ) dev-python/python-exec[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_pypy1_9(-)?,python_targets_pypy2_0(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy1_9(-),-python_single_target_pypy2_0(-)]
DESCRIPTION=Interfaces for Python
EAPI=5
HOMEPAGE=http://pypi.python.org/pypi/zope.interface
IUSE=python_targets_python2_6 python_targets_python2_7 python_targets_python3_2 python_targets_python3_3 python_targets_pypy1_9 python_targets_pypy2_0
KEYWORDS=~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris
LICENSE=ZPL
RDEPEND=python_targets_python2_6? ( dev-lang/python:2.6 ) python_targets_python2_7? ( dev-lang/python:2.7 ) python_targets_python3_2? ( dev-lang/python:3.2 ) python_targets_python3_3? ( dev-lang/python:3.3 ) python_targets_pypy1_9? ( dev-python/pypy:1.9 ) python_targets_pypy2_0? ( dev-python/pypy:2.0 ) dev-python/python-exec[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_pypy1_9(-)?,python_targets_pypy2_0(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy1_9(-),-python_single_target_pypy2_0(-)]
SLOT=0
SRC_URI=mirror://pypi/z/zope.interface/zope.interface-4.0.3.tar.gz
_eclasses_=distutils-r1 10e59ecabebf0c37ad5cd8827434b108 eutils 384ae111f3649d456ed1754e3e1c4f6e flag-o-matic d900015de4e092f26d8c0a18b6bd60de multibuild 32fd04fe3ee97494341710886fd70dfe multilib 892e597faee02a5b94eb02ab512e7622 multiprocessing a2130e6fc4aa4c6a24b265ca0cbcc2b6 python-r1 052a2872c3d341495152eb93212374e9 python-utils-r1 345dcecf1ef156d1d86a98f16d3c385c toolchain-funcs 69a2016af67775a812f4c03ba4b0e03e user d0a4d0735a6c0183d707ca919bd72f28
_md5_=105cbd66722817d1b588728de72cb472

@ -1 +1 @@
Mon, 06 May 2013 08:06:57 +0000
Mon, 06 May 2013 10:36:55 +0000

@ -1 +1 @@
Mon May 6 08:06:55 UTC 2013
Mon May 6 10:36:53 UTC 2013

@ -1 +1 @@
Mon, 06 May 2013 08:30:01 +0000
Mon, 06 May 2013 11:00:01 +0000

@ -1 +1 @@
1367827501 Mon May 6 08:05:01 2013 UTC
1367836501 Mon May 6 10:35:01 2013 UTC

@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-5.0.7-r1.ebuild,v 1.2 2013/05/04 17:18:38 vapier Exp $
# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-5.0.7-r1.ebuild,v 1.3 2013/05/06 08:45:14 jlec Exp $
EAPI=5
@ -55,7 +55,7 @@ PATCHES=(
# Upstream reference: http://thread.gmane.org/gmane.linux.kernel.autofs/5371
"${FILESDIR}"/${PN}-5.0.5-fix-install-deadlink.patch
"${FILESDIR}"/${PN}-5.0.5-add-missing-endif-HAVE_SASL-in-modules-lookup_ldap.c.patch #361899
"${FILESDIR}"/${P}-add-missing-endif-HAVE_SASL-in-modules-lookup_ldap.c.patch #361899, #468606
"${FILESDIR}"/${PN}-5.0.6-revert-ldap.patch #381315
"${FILESDIR}"/${PN}-5.0.7-mount-sloppy.patch #453778
)

@ -0,0 +1,45 @@
--- ./modules/lookup_ldap.c
+++ ./modules/lookup_ldap.c
@@ -591,10 +591,12 @@ static LDAP *do_connect(unsigned logopt, const char *uri, struct lookup_context
{
LDAP *ldap;
+#ifdef HAVE_SASL
if (ctxt->extern_cert && ctxt->extern_key) {
set_env(logopt, ENV_LDAPTLS_CERT, ctxt->extern_cert);
set_env(logopt, ENV_LDAPTLS_KEY, ctxt->extern_key);
}
+#endif
ldap = init_ldap_connection(logopt, uri, ctxt);
if (ldap) {
@@ -1372,10 +1374,12 @@ static void free_context(struct lookup_context *ctxt)
defaults_free_searchdns(ctxt->sdns);
if (ctxt->dclist)
free_dclist(ctxt->dclist);
+#ifdef HAVE_SASL
if (ctxt->extern_cert)
free(ctxt->extern_cert);
if (ctxt->extern_key)
free(ctxt->extern_key);
+#endif
free(ctxt);
return;
modules/lookup_ldap.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/modules/lookup_ldap.c b/modules/lookup_ldap.c
index dbec753..ce1e2e5 100644
--- a/modules/lookup_ldap.c
+++ b/modules/lookup_ldap.c
@@ -28,7 +28,9 @@
#include <arpa/nameser.h>
#include <resolv.h>
#include <lber.h>
+#ifdef HAVE_SASL
#include <libxml/tree.h>
+#endif
#define MODULE_LOOKUP
#include "automount.h"

@ -1,5 +1,2 @@
DIST zope.interface-3.6.2.tar.gz 94977 SHA256 e305424a0ff48e0a86c1f4ddc118858e82284e21bb607854ab370b3a38ee5d55 SHA512 f568ad3442bd97aa454c8d001edfff11bbe2703c33bc8fbe8d69eb9222661b37cbef4fdc11b07a04dd153b034aa9286174cf0cda86e1faa6ba72cbc5d5a686c2 WHIRLPOOL 3e1816254ef8148e6e736916a1c91289f9e93318ef8054e0e94e2547931baf671ef46cedd56c398d1f0428249ee26d9b5ab2fc82432beb967966cc96635bfb6d
DIST zope.interface-3.7.0.tar.gz 96568 SHA256 e0e43d848a19839402077a6eec2307afc966a3c971274d61c949bf35c5309a1b SHA512 bd5785c535d07d60805b5c607a9799974faf612fd6c38a216904d9677768db6be6463337af4124074fe96d7bd1642660f3b50eca5aff1039bfbe018a33d6b110 WHIRLPOOL d4b2c5a8610a0edc7771ea540611ccddef6583027b3c11f52a96499ce154c8e33dfa2baf6b19c94b0b3604dc58c1f71b9e894e4d0fdef9e2b76efd436ef0fb5e
DIST zope.interface-3.8.0.tar.gz 111537 SHA256 1d5411ff82fd3a73bad6efb38deddb3f98d61d590344deb0cdd308e8aa94d3ff SHA512 7874d46cf23c4525e4bab3c91408966cc2f813ec91ff65c9428ca0e355f5334206e87eee1e7d37705ca3f2294dd162aa4ab239222ab45fee575c2dee6bd0e776 WHIRLPOOL 3ec7ff66eb7e96e6070e223b435fe5efeb0e0b7024482e5b3217b35466f4aa9a0176ba905287b80c63838ace7bcfa51632aa81a6fe3c6972c292ad6c5dea672f
DIST zope.interface-4.0.3.tar.gz 140124 SHA256 be6f0f8b897b8e0521441b923c3e2abc50d5ac2531a376d8d3a0bb69b3207bb9 SHA512 7b1c3d56735451018021b24847dffc1702ce8a358de1d9cf07c92953734b1bb4cbc348789bd04f745766b1c75a0c87ffff9b777fc68ddcb87acf8c05d87dc46a WHIRLPOOL b764a90cc888ed4b9473b5a2ec2b1b119425a9577a2f68e527cf04dc213014fd6783ea81c1b7cce6ebc9c11fcf15e87008588cf651a4c5792e0dbf882c129ad9
DIST zope.interface-4.0.5.zip 173379 SHA256 1a7c84716bbd9981915b64a81d8a3f076a5934a8c8df4224655469b3564940cc SHA512 1b5e3ff4796c97704e528601bbabc47ea9bc1e55e6f607c7951e50a26d2118617f2f9974d7314e6bcdac701a2d3f4c541cd563e83abbff720d2c62182686ea4d WHIRLPOOL 488e5bab20712cd31876e3e70420371478e744aca260039ed39ca854716755d45d47006a73743ea72a372b30c4020e6ea9a9089efae7213acd39486bfb6c454d

@ -1,40 +0,0 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-interface/zope-interface-3.6.2.ebuild,v 1.6 2011/08/25 12:42:30 jer Exp $
EAPI="3"
SUPPORT_PYTHON_ABIS="1"
# Test suite requires optional extension modules not available with Jython.
PYTHON_TESTS_RESTRICTED_ABIS="*-jython"
DISTUTILS_SRC_TEST="setup.py"
inherit distutils
MY_PN="${PN/-/.}"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Interfaces for Python"
HOMEPAGE="http://pypi.python.org/pypi/zope.interface"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="ZPL"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""
# net-zope/zope-fixers is required for building with Python 3.
DEPEND="dev-python/setuptools
net-zope/zope-fixers"
RDEPEND=""
S="${WORKDIR}/${MY_P}"
PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
DOCS="CHANGES.txt src/zope/interface/*.txt"
PYTHON_MODNAME="${PN/-//}"
src_install() {
distutils_src_install
python_clean_installation_image
}

@ -1,40 +0,0 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-interface/zope-interface-3.7.0.ebuild,v 1.8 2012/03/06 21:30:04 ranger Exp $
EAPI="3"
SUPPORT_PYTHON_ABIS="1"
# Test suite requires optional extension modules not available with Jython.
PYTHON_TESTS_RESTRICTED_ABIS="*-jython"
DISTUTILS_SRC_TEST="setup.py"
inherit distutils
MY_PN="${PN/-/.}"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Interfaces for Python"
HOMEPAGE="http://pypi.python.org/pypi/zope.interface"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="ZPL"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""
# net-zope/zope-fixers is required for building with Python 3.
DEPEND="dev-python/setuptools
net-zope/zope-fixers"
RDEPEND=""
S="${WORKDIR}/${MY_P}"
PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
DOCS="CHANGES.txt src/zope/interface/*.txt"
PYTHON_MODNAME="${PN/-//}"
src_install() {
distutils_src_install
python_clean_installation_image
}

@ -1,44 +0,0 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-interface/zope-interface-4.0.3-r1.ebuild,v 1.2 2013/03/30 13:06:41 floppym Exp $
EAPI=5
# Tests fail with py3.1
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy{1_9,2_0} )
inherit distutils-r1 flag-o-matic
MY_PN="${PN/-/.}"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Interfaces for Python"
HOMEPAGE="http://pypi.python.org/pypi/zope.interface"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="ZPL"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""
# net-zope/zope-fixers is required for building with Python 3.
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
net-zope/zope-fixers[$(python_gen_usedep 'python3*')]"
RDEPEND=""
S="${WORKDIR}/${MY_P}"
DOCS=( CHANGES.txt README.txt )
python_compile() {
if [[ ${EPYTHON} != python3* ]]; then
local CFLAGS CXXFLAGS
append-flags -fno-strict-aliasing
fi
distutils-r1_python_compile
}
python_test() {
esetup.py test
}

@ -1,41 +0,0 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-interface/zope-interface-4.0.3.ebuild,v 1.2 2013/02/02 05:42:26 patrick Exp $
EAPI="3"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="2.5"
# Test suite requires optional extension modules not available with Jython.
PYTHON_TESTS_RESTRICTED_ABIS="*-jython"
DISTUTILS_SRC_TEST="setup.py"
inherit distutils
MY_PN="${PN/-/.}"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Interfaces for Python"
HOMEPAGE="http://pypi.python.org/pypi/zope.interface"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="ZPL"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""
# net-zope/zope-fixers is required for building with Python 3.
DEPEND="dev-python/setuptools
net-zope/zope-fixers"
RDEPEND=""
S="${WORKDIR}/${MY_P}"
PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
DOCS="CHANGES.txt"
PYTHON_MODNAME="${PN/-//}"
src_install() {
distutils_src_install
python_clean_installation_image
}
Loading…
Cancel
Save