Sync with portage [Wed Feb 8 11:45:15 MSK 2012].

mhiretskiy
root 12 years ago
parent d340a884f2
commit 7e6ec6829f

@ -1 +1,2 @@
DIST pyspf-2.0.5.tar.gz 38818 RMD160 83fa42570bffbf1ec1934db2d534fad1f4b3b8c6 SHA1 8401e96afe6a141a24286f24108f40adcdd3b4f8 SHA256 a9e143fefc6bafd9f6e39b1b62eaaafae8bf96bdc25961ff1d55d01b173bf0b0
DIST pyspf-2.0.6.tar.gz 43448 RMD160 920847c0166c0ae1c4ac8a992128d6cd3dcaf372 SHA1 6d678e6e31eaa59c00cb19d4a28e4b59f7cf6792 SHA256 ed20f35d8c1d60516b195ec08ce7c8479d450be28fd37baaab58dbf570ceb429

@ -0,0 +1,24 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-python/pyspf/pyspf-2.0.6.ebuild,v 1.1 2012/02/08 06:00:48 patrick Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
DESCRIPTION="Python implementation of the Sender Policy Framework (SPF) protocol"
HOMEPAGE="http://pypi.python.org/pypi/pyspf"
SRC_URI="mirror://sourceforge/pymilter/${P}.tar.gz"
LICENSE="PSF-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="dev-python/pydns"
RDEPEND="dev-python/pydns"
PYTHON_MODNAME="spf.py"

@ -1 +1,2 @@
DIST python-gnutls-1.2.0.tar.gz 43115 RMD160 0ff4734d0d12c4eaae89989a9eb35f0655bf0e1c SHA1 47fbd96a787913be58cc2999455ee97091d721e1 SHA256 483469a5e0af09c2bd04c67600734e0f5c9b19573321d379f05a38701ef16fe9
DIST python-gnutls-1.2.2.tar.gz 43694 RMD160 296b6488057ceb3c6bed0d2f4f5d53c507063a14 SHA1 eb35fcba13bf0b60e9f20685b1bcd80c707bfbc0 SHA256 d7a61ea9cd78494f4090cd12106152335c71bacf86be6dd4b3a799634e0767d3

@ -0,0 +1,32 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-python/python-gnutls/python-gnutls-1.2.2.ebuild,v 1.1 2012/02/08 06:11:37 patrick Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
inherit distutils
DESCRIPTION="Python bindings for GnuTLS"
HOMEPAGE="http://pypi.python.org/pypi/python-gnutls http://ag-projects.com/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~ppc-macos ~x64-macos ~x86-macos"
IUSE="examples"
DEPEND="net-libs/gnutls"
RDEPEND="${DEPEND}"
RESTRICT_PYTHON_ABIS="3.*"
PYTHON_MODNAME="gnutls"
src_install() {
distutils_src_install
if use examples; then
insinto /usr/share/doc/${PF}
doins -r examples
fi
}

@ -1,2 +1,3 @@
DIST spyder-2.0.12.zip 1794855 RMD160 571565d243af70c9ba8c89d62481c2cb3b1bceff SHA1 a592caf81f4c1f72d637a5269f5c60f8f43e57ee SHA256 07d68efb162f06a98ea31469624d7932ed2fce884efd1870e1bc641e76ecc2d9
DIST spyder-2.1.2.zip 1921837 RMD160 d04ff71bb5fc8c80cc71c89c2cdc56646e00ed25 SHA1 0d675de517af704e5c94cbe839d4694a37811d95 SHA256 437dff12976ecbb69520d227a1fe718b058e40075b57fa85debd1bb90bee93dd
DIST spyder-2.1.6.zip 1946220 RMD160 5f920918c8cee319af2f2729f953d094b7efbf62 SHA1 111be1b1053663e4e24a5c666a0d1339d5c156dd SHA256 b9a6830d340e0fb5eb13a18ffc6eebb1c982211e610b406b248394893024b7c1

@ -0,0 +1,61 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/spyder-2.1.6.ebuild,v 1.1 2012/02/08 06:34:59 patrick Exp $
EAPI="3"
PYTHON_DEPEND="2:2.5"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="2.4 3.* *-jython *-pypy-*"
inherit distutils eutils
DESCRIPTION="Python IDE with matlab-like features"
HOMEPAGE="http://code.google.com/p/spyderlib/ http://pypi.python.org/pypi/spyder"
SRC_URI="http://spyderlib.googlecode.com/files/${P}.zip"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc ipython matplotlib numpy pep8 +pyflakes pylint +rope scipy sphinx"
RDEPEND=">=dev-python/PyQt4-4.4[webkit]
ipython? ( dev-python/ipython )
matplotlib? ( dev-python/matplotlib )
numpy? ( dev-python/numpy )
pep8? ( dev-python/pep8 )
pyflakes? ( >=dev-python/pyflakes-0.3 )
pylint? ( dev-python/pylint )
rope? ( >=dev-python/rope-0.9.3 )
scipy? ( sci-libs/scipy )
sphinx? ( dev-python/sphinx )"
DEPEND="${RDEPEND}
doc? ( dev-python/sphinx )"
PYTHON_MODNAME="spyderlib spyderplugins"
src_prepare() {
distutils_src_prepare
epatch "${FILESDIR}/${PN}-2.1.2-disable_sphinx_dependency.patch"
}
src_compile() {
distutils_src_compile
if use doc; then
einfo "Generation of documentation"
PYTHONPATH="build-$(PYTHON -f --ABI)" \
sphinx-build doc doc_output || die "Generation of documentation failed"
fi
}
src_install() {
distutils_src_install
doicon spyderlib/images/spyder.svg || die
make_desktop_entry spyder Spyder spyder "Development;IDE"
if use doc; then
pushd doc_output > /dev/null
insinto /usr/share/doc/${PF}/html
doins -r [a-z]* _images _static || die "Installation of documentation failed"
popd > /dev/null
fi
}

@ -1,2 +1,3 @@
DIST sqlalchemy-migrate-0.6.1.tar.gz 100766 RMD160 b2273abd3d915c7ed76c2edefadf293828cd270e SHA1 17168b5fa066bd56fd93f26345525377e8a83d8a SHA256 4c46ffeb09d6b1fe14787ef97168111e8f8101a62eccdb93ba8d0bde829bd73e
DIST sqlalchemy-migrate-0.7.1.tar.gz 101369 RMD160 c673e34f9fb0b58c702a97a05813abf610d17486 SHA1 42dd3d5d84815350c83fbeb6ab8b72580813182d SHA256 11ebee99663118d94dadf41035f73bb2d7ac0e4492c29b59824a8aaddb28b9f8
DIST sqlalchemy-migrate-0.7.2.tar.gz 105862 RMD160 e4c596b590e543081f78feab54599024b5b9b3e8 SHA1 d88f0159e3f58fed8c50ba83f0b19559b0524cb5 SHA256 7f55c768ee26f143fedb11b365a4c57c3bbdb5211e049c7f04b8ae8107c28333

@ -0,0 +1,28 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-python/sqlalchemy-migrate/sqlalchemy-migrate-0.7.2.ebuild,v 1.1 2012/02/08 06:43:08 patrick Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
DESCRIPTION="SQLAlchemy Schema Migration Tools"
HOMEPAGE="http://code.google.com/p/sqlalchemy-migrate/ http://pypi.python.org/pypi/sqlalchemy-migrate"
SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~x86"
IUSE=""
DEPEND="dev-python/decorator
dev-python/setuptools
>=dev-python/sqlalchemy-0.5
dev-python/tempita"
RDEPEND="${DEPEND}"
# for tests: unittest2 and scripttest
PYTHON_MODNAME="migrate"

@ -1 +1,2 @@
DIST subunit-0.0.6.tar.gz 388872 RMD160 46dfc19f1415a063dca906174df45da5495b9710 SHA1 3db4e29a43ff4efe273a8a396e066fbdb1a9d878 SHA256 98f5e72107322dc1c502543384e1ed790671d319a5096eab4f4d20641555de77
DIST subunit-0.0.7.tar.gz 394777 RMD160 769c031817cce8e7aa87299a728fc9ab7bdddd33 SHA1 e34ec8b576c683a010aa767c7dc8c02690e8b7cf SHA256 7fd486f9a7f434b0a2b544b6f4bf32889b977e72d864db059f19fe8ef32e8e94

@ -0,0 +1,35 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/subunit-0.0.7.ebuild,v 1.1 2012/02/08 06:57:46 patrick Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
PYTHON_EXPORT_PHASE_FUNCTIONS="1"
inherit python
DESCRIPTION="A streaming protocol for test results"
HOMEPAGE="https://launchpad.net/subunit http://pypi.python.org/pypi/python-subunit"
SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
LICENSE="Apache-2.0 BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE=""
RDEPEND=">=dev-python/testtools-0.9.4"
DEPEND="${RDEPEND}
dev-lang/perl
dev-libs/check
dev-util/cppunit
dev-util/pkgconfig"
RESTRICT_PYTHON_ABIS="3.*"
pkg_postinst() {
python_mod_optimize subunit
}
pkg_postrm() {
python_mod_cleanup subunit
}

@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/media-libs/libmikmod/libmikmod-3.2.0_beta2-r4.ebuild,v 1.1 2012/02/07 19:21:17 slyfox Exp $
# $Header: /var/cvsroot/gentoo-x86/media-libs/libmikmod/libmikmod-3.2.0_beta2-r4.ebuild,v 1.2 2012/02/08 06:50:52 slyfox Exp $
EAPI=2
MY_P=${P/_/-}
@ -32,6 +32,10 @@ src_prepare() {
"${FILESDIR}"/${P}-CVE-2010-2546-2971.patch \
"${FILESDIR}"/${P}-pa-workaround.patch
# forge automake regenerate that ancient Makefile.in
# by creating empty Makefile.am. Fixes bug #401329
touch libmikmod/Makefile.am
AT_M4DIR=${S} eautoreconf
}

@ -0,0 +1,11 @@
--- oyranos-0.3.2/makefile.in
+++ oyranos-0.3.2/makefile.in
@@ -995,7 +995,7 @@
echo current git version is:
n=0; for i in `cd $(SRCDIR); git rev-list master`; do if [ $${n} -eq 0 ]; then echo git id:$${i}; fi; n=1; done
echo run tests/test_oyranos
- OY_MODULE_PATHS=. LD_LIBRARY_PATH=./:$(libdir):$${LD_LIBRARY_PATH} tests/test_oyranos
+ OY_MODULE_PATHS=. LD_LIBRARY_PATH=./:$(libdir):$${LD_LIBRARY_PATH} tests/test_oyranos "Version matching" "Internationalisation" "Elektra" "basic oyOption_s" "default oyOptions_s settings" "Profiles reading" "Registration matching" "Generic Object Observation"
examples: all
cd examples && ($(MAKE) clean; PATH="$(PATH):$(bindir):.." LD_LIBRARY_PATH=./:$(libdir):$${LD_LIBRARY_PATH} PKG_CONFIG_PATH="$(PKG_CONFIG_PATH):$(DESTDIR)$(libdir)/pkgconfig:.." INCLUDE="-I$(includedir) -I$(SRCDIR) -I../ -I$(SRCDIR)/$(GENDIR)" SRCDIR=$(SRCDIR)/examples/ CFLAGS="$(CFLAGS)" LIBS="-L$(libdir) -L../" intl="$(intl)" $(MAKE))

@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/media-libs/oyranos/oyranos-0.3.2.ebuild,v 1.2 2012/02/06 05:49:52 mr_bones_ Exp $
# $Header: /var/cvsroot/gentoo-x86/media-libs/oyranos/oyranos-0.3.2.ebuild,v 1.3 2012/02/08 05:49:19 xmw Exp $
EAPI=4
@ -23,27 +23,31 @@ RDEPEND="app-admin/elektra
media-libs/libpng:0
media-libs/libraw
media-libs/libXcm
X? (
x11-libs/fltk:1
X? ( x11-libs/fltk:1
x11-libs/libXfixes
x11-libs/libXrandr
x11-libs/libXxf86vm
xinerama? ( x11-libs/libXinerama )
)"
xinerama? ( x11-libs/libXinerama ) )"
DEPEND="${RDEPEND}
app-doc/doxygen"
app-doc/doxygen
test? ( media-libs/icc-profiles-basiccolor-printing2009
media-libs/icc-profiles-openicc )"
src_prepare() {
einfo remove bundled elektra yajl
rm -rf elektra* yajl || die
#keep bundled libXNVCtrl
epatch "${FILESDIR}"/${P}-buildsystem.patch
epatch "${FILESDIR}"/${P}-buildsystem.patch \
"${FILESDIR}"/${P}-test.patch
if ! use X ; then
sed -e '/FLTK_GUI =/s:=.*:=:' \
-i makefile.in || die
fi
sed -e '/#include/s:alpha/oyranos_alpha.h:oyranos_alpha.h:' \
-i examples/libraw/oyranos_file.cpp || die
}
src_configure() {

@ -0,0 +1,22 @@
dev-python/pydns >=app-admin/eselect-python-20091230 =dev-lang/python-2*
dev-python/pydns >=app-admin/eselect-python-20091230 =dev-lang/python-2*
0
mirror://sourceforge/pymilter/pyspf-2.0.6.tar.gz
http://pypi.python.org/pypi/pyspf
PSF-2
Python implementation of the Sender Policy Framework (SPF) protocol
~amd64 ~x86
distutils multilib python toolchain-funcs
3
compile install postinst postrm prepare

@ -0,0 +1,22 @@
net-libs/gnutls >=app-admin/eselect-python-20091230 dev-lang/python
net-libs/gnutls >=app-admin/eselect-python-20091230 dev-lang/python
0
mirror://pypi/p/python-gnutls/python-gnutls-1.2.2.tar.gz
http://pypi.python.org/pypi/python-gnutls http://ag-projects.com/
LGPL-2.1
Python bindings for GnuTLS
~amd64 ~ppc ~x86 ~ppc-macos ~x64-macos ~x86-macos
distutils multilib python toolchain-funcs
examples
2
compile install postinst postrm prepare

@ -0,0 +1,22 @@
>=dev-python/PyQt4-4.4[webkit] ipython? ( dev-python/ipython ) matplotlib? ( dev-python/matplotlib ) numpy? ( dev-python/numpy ) pep8? ( dev-python/pep8 ) pyflakes? ( >=dev-python/pyflakes-0.3 ) pylint? ( dev-python/pylint ) rope? ( >=dev-python/rope-0.9.3 ) scipy? ( sci-libs/scipy ) sphinx? ( dev-python/sphinx ) doc? ( dev-python/sphinx ) >=app-admin/eselect-python-20091230 || ( =dev-lang/python-2.7* =dev-lang/python-2.6* =dev-lang/python-2.5* )
>=dev-python/PyQt4-4.4[webkit] ipython? ( dev-python/ipython ) matplotlib? ( dev-python/matplotlib ) numpy? ( dev-python/numpy ) pep8? ( dev-python/pep8 ) pyflakes? ( >=dev-python/pyflakes-0.3 ) pylint? ( dev-python/pylint ) rope? ( >=dev-python/rope-0.9.3 ) scipy? ( sci-libs/scipy ) sphinx? ( dev-python/sphinx ) >=app-admin/eselect-python-20091230 || ( =dev-lang/python-2.7* =dev-lang/python-2.6* =dev-lang/python-2.5* )
0
http://spyderlib.googlecode.com/files/spyder-2.1.6.zip
http://code.google.com/p/spyderlib/ http://pypi.python.org/pypi/spyder
MIT
Python IDE with matlab-like features
~amd64 ~x86
distutils eutils multilib portability python toolchain-funcs user
doc ipython matplotlib numpy pep8 +pyflakes pylint +rope scipy sphinx
3
compile install postinst postrm prepare

@ -0,0 +1,22 @@
dev-python/decorator dev-python/setuptools >=dev-python/sqlalchemy-0.5 dev-python/tempita >=app-admin/eselect-python-20091230 =dev-lang/python-2*
dev-python/decorator dev-python/setuptools >=dev-python/sqlalchemy-0.5 dev-python/tempita >=app-admin/eselect-python-20091230 =dev-lang/python-2*
0
http://sqlalchemy-migrate.googlecode.com/files/sqlalchemy-migrate-0.7.2.tar.gz
http://code.google.com/p/sqlalchemy-migrate/ http://pypi.python.org/pypi/sqlalchemy-migrate
MIT
SQLAlchemy Schema Migration Tools
~alpha ~amd64 ~arm ~hppa ~ppc ~x86
distutils multilib python toolchain-funcs
3
compile install postinst postrm prepare

@ -0,0 +1,22 @@
>=dev-python/testtools-0.9.4 dev-lang/perl dev-libs/check dev-util/cppunit dev-util/pkgconfig >=app-admin/eselect-python-20091230 =dev-lang/python-2*
>=dev-python/testtools-0.9.4 >=app-admin/eselect-python-20091230 =dev-lang/python-2*
0
http://launchpad.net/subunit/trunk/0.0.7/+download/subunit-0.0.7.tar.gz
https://launchpad.net/subunit http://pypi.python.org/pypi/python-subunit
Apache-2.0 BSD
A streaming protocol for test results
~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd
multilib python toolchain-funcs
3
compile configure install postinst postrm prepare test

@ -1,4 +1,4 @@
app-admin/elektra dev-libs/libxml2 dev-libs/yajl media-gfx/exiv2 media-libs/lcms:0 media-libs/libpng:0 media-libs/libraw media-libs/libXcm X? ( x11-libs/fltk:1 x11-libs/libXfixes x11-libs/libXrandr x11-libs/libXxf86vm xinerama? ( x11-libs/libXinerama ) ) app-doc/doxygen
app-admin/elektra dev-libs/libxml2 dev-libs/yajl media-gfx/exiv2 media-libs/lcms:0 media-libs/libpng:0 media-libs/libraw media-libs/libXcm X? ( x11-libs/fltk:1 x11-libs/libXfixes x11-libs/libXrandr x11-libs/libXxf86vm xinerama? ( x11-libs/libXinerama ) ) app-doc/doxygen test? ( media-libs/icc-profiles-basiccolor-printing2009 media-libs/icc-profiles-openicc )
app-admin/elektra dev-libs/libxml2 dev-libs/yajl media-gfx/exiv2 media-libs/lcms:0 media-libs/libpng:0 media-libs/libraw media-libs/libXcm X? ( x11-libs/fltk:1 x11-libs/libXfixes x11-libs/libXrandr x11-libs/libXxf86vm xinerama? ( x11-libs/libXinerama ) )
0
mirror://sourceforge/oyranos/Oyranos/Oyranos%200.3/oyranos-0.3.2.tar.bz2

@ -1 +1 @@
Wed, 08 Feb 2012 05:36:47 +0000
Wed, 08 Feb 2012 07:06:47 +0000

@ -1 +1 @@
Wed, 08 Feb 2012 05:36:47 +0000
Wed, 08 Feb 2012 07:06:47 +0000

@ -1 +1 @@
Wed, 08 Feb 2012 05:36:49 +0000
Wed, 08 Feb 2012 07:06:48 +0000

@ -1 +1 @@
Wed Feb 8 05:36:47 UTC 2012
Wed Feb 8 07:06:47 UTC 2012

@ -1 +1 @@
Wed, 08 Feb 2012 06:00:01 +0000
Wed, 08 Feb 2012 07:30:01 +0000

@ -1 +1 @@
1328679301 Wed Feb 8 05:35:01 2012 UTC
1328684701 Wed Feb 8 07:05:01 2012 UTC

@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-nntp/inn/files/innd,v 1.2 2007/02/26 22:03:41 swegener Exp $
# $Header: /var/cvsroot/gentoo-x86/net-nntp/inn/files/innd,v 1.3 2012/02/08 06:41:07 slyfox Exp $
depend() {
need net
@ -9,13 +9,13 @@ depend() {
start() {
ebegin "Starting innd"
start-stop-daemon --start --chuid news --exec /usr/lib/news/bin/rc.news
start-stop-daemon --start --user news --exec /usr/lib/news/bin/rc.news
eend $?
}
stop() {
ebegin "Stopping innd"
start-stop-daemon --start --chuid news --exec /usr/lib/news/bin/rc.news -- stop
start-stop-daemon --start --user news --exec /usr/lib/news/bin/rc.news -- stop
sleep 2
eend $?
}

Loading…
Cancel
Save