Sync with portage [Wed Sep 30 09:56:36 MSK 2020].

akrasnyh 1773
root 4 years ago
parent f6b9212d8c
commit 8bedbe5a8d

Binary file not shown.

Binary file not shown.

@ -1,3 +1 @@
DIST doxygen-1.8.15.src.tar.gz 5097791 BLAKE2B 08903bf06666911df0810ea0a7b86066e7682833b03ae5660094112c5c6506f072c5818185ce8166d09328e62092461acdb4516b58fe9369119f5f6bdd64331a SHA512 a5512e78be66c1591d8ec7e284d5d25c92a97218c79e6fed3c538c723a8dfef4ff7085970bf271a6b639e907157cd4df9fb55d3c975f8d3302fb1012a4d92079
DIST doxygen-1.8.16.src.tar.gz 5497317 BLAKE2B ec1ba4242bd3ef669f92101044049f10a6e5c2d69f5a7c8eb47915fdc0846ce4758eb8c1ab28ec61635bf36f83049f603f3b70033f7e22be18685cb1d9826462 SHA512 46a0189aa82d5a687bdd99a904f0c061fccca407d15867d14c8c4d13e8b21a8989e7ccd6af30840803b589ed20dd86084a4db880fba0d3bfa1fdcdd8d23e12de
DIST doxygen-1.8.17.src.tar.gz 5138888 BLAKE2B 79d7d64fe2104f3fc802e9ee8f5fcd13ed4f0e23fe3e8d8013d1724d917d5f4e7d8c2df672e253aa2c8d67e839a6169632ebd87bc281b8ee70d217f486e402f7 SHA512 2fd087d127e301ea48355ea52c9af4f2091df06551cf64da80df81f0758194b296efb1e8d3962867a6a6d2da5a3fc323842f7766a445748005b30097ded30a75

@ -1,139 +0,0 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python3_6 )
CMAKE_MAKEFILE_GENERATOR="emake"
inherit cmake-utils eutils llvm python-any-r1
if [[ ${PV} = *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/doxygen/doxygen.git"
SRC_URI=""
else
SRC_URI="http://doxygen.nl/files/${P}.src.tar.gz"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
DESCRIPTION="Documentation system for most programming languages"
HOMEPAGE="http://www.doxygen.org"
LICENSE="GPL-2"
SLOT="0"
IUSE="clang debug doc dot doxysearch latex qt5 sqlite userland_GNU"
RDEPEND="app-text/ghostscript-gpl
dev-lang/perl
media-libs/libpng:0=
virtual/libiconv
clang? ( <sys-devel/clang-10:= )
dot? (
media-gfx/graphviz
media-libs/freetype
)
doxysearch? ( dev-libs/xapian:= )
latex? (
dev-texlive/texlive-bibtexextra
dev-texlive/texlive-fontsextra
dev-texlive/texlive-fontutils
dev-texlive/texlive-latex
dev-texlive/texlive-latexextra
)
qt5? (
dev-qt/qtgui:5
dev-qt/qtwidgets:5
dev-qt/qtxml:5
)
sqlite? ( dev-db/sqlite:3 )
"
REQUIRED_USE="doc? ( latex )"
DEPEND="sys-devel/flex
sys-devel/bison
doc? ( ${PYTHON_DEPS} )
${RDEPEND}"
# src_test() defaults to make -C testing but there is no such directory (bug #504448)
RESTRICT="test"
PATCHES=(
"${FILESDIR}/${PN}-1.8.9.1-empty-line-sigsegv.patch" #454348
"${FILESDIR}/${PN}-1.8.15-link_with_pthread.patch"
"${FILESDIR}/${PN}-1.8.15-llvm7.patch" #666692
"${FILESDIR}/${PN}-1.8.14-xml-c++.patch" #doxygen/doxygen#6892
)
DOCS=( LANGUAGE.HOWTO README.md )
LLVM_MAX_SLOT=9
pkg_setup() {
use clang && llvm_pkg_setup
use doc && python-any-r1_pkg_setup
}
src_prepare() {
cmake-utils_src_prepare
# Ensure we link to -liconv
if use elibc_FreeBSD && has_version dev-libs/libiconv || use elibc_uclibc; then
local pro
for pro in */*.pro.in */*/*.pro.in; do
echo "unix:LIBS += -liconv" >> "${pro}" || die
done
fi
# Call dot with -Teps instead of -Tps for EPS generation - bug #282150
sed -i -e '/addJob("ps"/ s/"ps"/"eps"/g' src/dot.cpp || die
# fix pdf doc
sed -i.orig -e "s:g_kowal:g kowal:" \
doc/maintainers.txt || die
if is-flagq "-O3" ; then
ewarn
ewarn "Compiling with -O3 is known to produce incorrectly"
ewarn "optimized code which breaks doxygen."
ewarn
elog
elog "Continuing with -O2 instead ..."
elog
replace-flags "-O3" "-O2"
fi
}
src_configure() {
local mycmakeargs=(
-Duse_libclang=$(usex clang)
-Dbuild_doc=$(usex doc)
-Dbuild_search=$(usex doxysearch)
-Dbuild_wizard=$(usex qt5)
-Duse_sqlite3=$(usex sqlite)
)
use doc && mycmakeargs+=(
-DDOC_INSTALL_DIR="share/doc/${P}"
)
cmake-utils_src_configure
}
src_compile() {
cmake-utils_src_compile
if use doc; then
export VARTEXFONTS="${T}/fonts" # bug #564944
if ! use dot; then
sed -i -e "s/HAVE_DOT = YES/HAVE_DOT = NO/" \
{Doxyfile,doc/Doxyfile} \
|| die "disabling dot failed"
fi
cmake-utils_src_make -C "${BUILD_DIR}" docs
fi
}
src_install() {
cmake-utils_src_install
}

@ -1,140 +0,0 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python3_6 )
CMAKE_MAKEFILE_GENERATOR="emake"
inherit cmake-utils eutils llvm python-any-r1
if [[ ${PV} = *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/doxygen/doxygen.git"
SRC_URI=""
else
SRC_URI="http://doxygen.nl/files/${P}.src.tar.gz"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
DESCRIPTION="Documentation system for most programming languages"
HOMEPAGE="http://www.doxygen.org"
LICENSE="GPL-2"
SLOT="0"
IUSE="clang debug doc dot doxysearch latex qt5 sqlite userland_GNU"
RDEPEND="app-text/ghostscript-gpl
dev-lang/perl
media-libs/libpng:0=
virtual/libiconv
clang? ( <sys-devel/clang-10:= )
dot? (
media-gfx/graphviz
media-libs/freetype
)
doxysearch? ( dev-libs/xapian:= )
latex? (
dev-texlive/texlive-bibtexextra
dev-texlive/texlive-fontsextra
dev-texlive/texlive-fontutils
dev-texlive/texlive-latex
dev-texlive/texlive-latexextra
)
qt5? (
dev-qt/qtgui:5
dev-qt/qtwidgets:5
dev-qt/qtxml:5
)
sqlite? ( dev-db/sqlite:3 )
"
REQUIRED_USE="doc? ( latex )"
DEPEND="sys-devel/flex
sys-devel/bison
doc? ( ${PYTHON_DEPS} )
${RDEPEND}"
# src_test() defaults to make -C testing but there is no such directory (bug #504448)
RESTRICT="test"
PATCHES=(
"${FILESDIR}/${PN}-1.8.9.1-empty-line-sigsegv.patch" #454348
"${FILESDIR}/${PN}-1.8.16-link_with_pthread.patch"
"${FILESDIR}/${PN}-1.8.15-llvm7.patch" #666692
"${FILESDIR}/${PN}-1.8.16-ghostscript-compatilibility.patch" #695710
"${FILESDIR}/${PN}-1.8.16-fix-external-tag-files-with-TOC.patch" #701930
)
DOCS=( LANGUAGE.HOWTO README.md )
LLVM_MAX_SLOT=9
pkg_setup() {
use clang && llvm_pkg_setup
use doc && python-any-r1_pkg_setup
}
src_prepare() {
cmake-utils_src_prepare
# Ensure we link to -liconv
if use elibc_FreeBSD && has_version dev-libs/libiconv || use elibc_uclibc; then
local pro
for pro in */*.pro.in */*/*.pro.in; do
echo "unix:LIBS += -liconv" >> "${pro}" || die
done
fi
# Call dot with -Teps instead of -Tps for EPS generation - bug #282150
sed -i -e '/addJob("ps"/ s/"ps"/"eps"/g' src/dot.cpp || die
# fix pdf doc
sed -i.orig -e "s:g_kowal:g kowal:" \
doc/maintainers.txt || die
if is-flagq "-O3" ; then
ewarn
ewarn "Compiling with -O3 is known to produce incorrectly"
ewarn "optimized code which breaks doxygen."
ewarn
elog
elog "Continuing with -O2 instead ..."
elog
replace-flags "-O3" "-O2"
fi
}
src_configure() {
local mycmakeargs=(
-Duse_libclang=$(usex clang)
-Dbuild_doc=$(usex doc)
-Dbuild_search=$(usex doxysearch)
-Dbuild_wizard=$(usex qt5)
-Duse_sqlite3=$(usex sqlite)
-DGIT_EXECUTABLE="false"
)
use doc && mycmakeargs+=(
-DDOC_INSTALL_DIR="share/doc/${P}"
)
cmake-utils_src_configure
}
src_compile() {
cmake-utils_src_compile
if use doc; then
export VARTEXFONTS="${T}/fonts" # bug #564944
if ! use dot; then
sed -i -e "s/HAVE_DOT = YES/HAVE_DOT = NO/" \
{Doxyfile,doc/Doxyfile} \
|| die "disabling dot failed"
fi
cmake-utils_src_make -C "${BUILD_DIR}" docs
fi
}
src_install() {
cmake-utils_src_install
}

@ -1,25 +0,0 @@
From f217b5c36b39a294b920437ff66055ee1a3fa5b7 Mon Sep 17 00:00:00 2001
From: albert-github <albert.tests@gmail.com>
Date: Tue, 19 Mar 2019 10:42:24 +0100
Subject: [PATCH] issue #6892 xml not well-formed (invalid token) for c++
the `declname` and `defname` should also be converted (compare as well the routine `generateXMLForMember`)
---
src/xmlgen.cpp | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/xmlgen.cpp b/src/xmlgen.cpp
index 420a653fc..568e48886 100644
--- a/src/xmlgen.cpp
+++ b/src/xmlgen.cpp
@@ -360,8 +360,8 @@ static void writeTemplateArgumentList(ArgumentList *al,
}
if (!a->name.isEmpty())
{
- t << indentStr << " <declname>" << a->name << "</declname>" << endl;
- t << indentStr << " <defname>" << a->name << "</defname>" << endl;
+ t << indentStr << " <declname>" << convertToXML(a->name) << "</declname>" << endl;
+ t << indentStr << " <defname>" << convertToXML(a->name) << "</defname>" << endl;
}
if (!a->defval.isEmpty())
{

@ -1,32 +0,0 @@
--- a/addon/doxysearch/CMakeLists.txt 2019-04-03 18:43:47.995610511 +0200
+++ b/addon/doxysearch/CMakeLists.txt 2019-04-03 18:45:27.730609191 +0200
@@ -18,6 +18,7 @@
${ZLIB_LIBRARIES}
${WIN_EXTRA_LIBS}
qtools
+ pthread
)
add_executable(doxysearch.cgi
@@ -27,6 +28,7 @@
${XAPIAN_LIBRARIES}
${ZLIB_LIBRARIES}
${WIN_EXTRA_LIBS}
+ pthread
)
install(TARGETS doxyindexer doxysearch.cgi DESTINATION bin)
--- a/addon/doxywizard/CMakeLists.txt 2019-04-03 18:43:59.139610364 +0200
+++ b/addon/doxywizard/CMakeLists.txt 2019-04-03 18:45:14.151609371 +0200
@@ -102,9 +102,9 @@
)
if(Qt5Core_FOUND)
- target_link_libraries(doxywizard Qt5::Core Qt5::Gui Qt5::Widgets Qt5::Xml)
+ target_link_libraries(doxywizard Qt5::Core Qt5::Gui Qt5::Widgets Qt5::Xml pthread)
else()
- target_link_libraries(doxywizard ${QT_LIBRARIES} ${QT_QTMAIN_LIBRARY})
+ target_link_libraries(doxywizard ${QT_LIBRARIES} ${QT_QTMAIN_LIBRARY} pthread)
endif()
install(TARGETS doxywizard DESTINATION bin)

@ -1,50 +0,0 @@
From 4a72a9b07e805b4ba27560e8e921bcee0002ef4c Mon Sep 17 00:00:00 2001
From: albert-github <albert.tests@gmail.com>
Date: Mon, 9 Sep 2019 13:28:28 +0200
Subject: [PATCH] issue #7248: Including external tag files with TOC produces a
broken index.qhp
Ignore automatically generated anchor names when importing a tag file.
Upstream: https://github.com/doxygen/doxygen/pull/7250
---
src/tagreader.cpp | 19 ++++++++++++++++++-
1 file changed, 18 insertions(+), 1 deletion(-)
diff --git a/src/tagreader.cpp b/src/tagreader.cpp
index 56dbe7df9..d79d9b5c5 100644
--- a/src/tagreader.cpp
+++ b/src/tagreader.cpp
@@ -494,6 +494,23 @@ class TagFileParser : public QXmlDefaultHandler
void endDocAnchor()
{
+ // Check whether or not the tag is automatically generate, in that case ignore the tag.
+ switch(m_state)
+ {
+ case InClass:
+ case InFile:
+ case InNamespace:
+ case InGroup:
+ case InPage:
+ case InMember:
+ case InPackage:
+ case InDir:
+ if (QString(m_curString).startsWith("autotoc_md")) return;
+ break;
+ default:
+ warn("Unexpected tag 'docanchor' found");
+ return;
+ }
switch(m_state)
{
case InClass: m_curClass->docAnchors.append(new TagAnchorInfo(m_fileName,m_curString,m_title)); break;
@@ -504,7 +521,7 @@ class TagFileParser : public QXmlDefaultHandler
case InMember: m_curMember->docAnchors.append(new TagAnchorInfo(m_fileName,m_curString,m_title)); break;
case InPackage: m_curPackage->docAnchors.append(new TagAnchorInfo(m_fileName,m_curString,m_title)); break;
case InDir: m_curDir->docAnchors.append(new TagAnchorInfo(m_fileName,m_curString,m_title)); break;
- default: warn("Unexpected tag 'docanchor' found"); break;
+ default: warn("Unexpected tag 'docanchor' found"); break; // Not really necessary anymore
}
}

@ -1,39 +0,0 @@
From f08e87623368134c6541af12995b811ef9aff069 Mon Sep 17 00:00:00 2001
From: albert-github <albert.tests@gmail.com>
Date: Tue, 12 Nov 2019 11:42:22 +0100
Subject: [PATCH] issue #7290 error: Problem running ghostscript gs -q -g562x56
-r384x384x -sDEVICE=ppmraw -sOutputFile=_form0.pnm -dNOPAUSE -dBATCH --
_form0.ps. Check your installation!
@maehr had a talk with Robin Watts and Ken Sharp at IRC and there seem to be basically 3 different problems:
* `-r%dx%d` (the dimension for `r` shouldn't be `-r384x384x`, but `-r384x384`),
* misuse / unnecessary use of `--` and
* since 9.50 the command needs more control access (that might be worked around by either whitelisting the file via `--permit-file-read=_form0.eps` (only works from 9.50 and upwards) or generally accepting any file with `-dNOSAFER` (works since quite some time). The second option is considered to be unsafe if we would process any file, but in this case we process self produced / controlled files. I don't know if doxygen has any threat model that it assumes. ).
> Ken Sharp: Yeah the %dx is wrong, as Robin says its sheer luck that works
the -- isn't needed and is what's causing the first problem
and file control is the new bugbear
The suggestions have been implemented and test / docs works now with old and new version.
---
src/formula.cpp | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/formula.cpp b/src/formula.cpp
index 534f56ac..3d8e6ce1 100644
--- a/src/formula.cpp
+++ b/src/formula.cpp
@@ -193,8 +193,8 @@ void FormulaList::generateBitmaps(const char *path)
// used.
char gsArgs[4096];
- sprintf(gsArgs,"-q -g%dx%d -r%dx%dx -sDEVICE=ppmraw "
- "-sOutputFile=%s.pnm -dNOPAUSE -dBATCH -- %s.ps",
+ sprintf(gsArgs,"-q -g%dx%d -r%dx%d -sDEVICE=ppmraw "
+ "-sOutputFile=%s.pnm -dNOPAUSE -dBATCH -dNOSAFER %s.ps",
gx,gy,(int)(scaleFactor*72),(int)(scaleFactor*72),
formBase.data(),formBase.data()
);
--
2.24.1

Binary file not shown.

@ -1,2 +1 @@
DIST gflags-2.2.0.tar.gz 96408 BLAKE2B 571f07dd0972cec201eae8ce66d5e0592abb6ddb81bcf3c539f38861f0cd379de2db20ba99eab885ba030235938816d7a61e589b74a61743de7cdb2710646854 SHA512 e2106ca70ff539024f888bca12487b3bf7f4f51928acf5ae3e1022f6bbd5e3b7882196ec50b609fd52f739e1f7b13eec7d4b3535d8216ec019a3577de6b4228d
DIST gflags-2.2.1.tar.gz 96985 BLAKE2B 065dac9cf5d878e4179cb6d56ddf240052a552b72036fd06cb83197d9772a9b97fa544f809c6e1efd6f9ad8cd0222872fc6292c44bc013c5f70e235bcc5b290c SHA512 e919cbdcff1f993ddbfa9c06d8e595566a4717c27ff62f388a64c0e6b4683a93211c24ce78485eae84c2c76053341574064e6c56af185fc2782e2816b26e1fc9

@ -1,37 +0,0 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit cmake-multilib
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/gflags/gflags.git"
else
SRC_URI="https://github.com/gflags/gflags/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 ~sparc x86 ~amd64-linux ~x86-linux"
fi
DESCRIPTION="Google's C++ argument parsing library"
HOMEPAGE="http://gflags.github.io/gflags/"
LICENSE="BSD"
SLOT="0/2.2"
IUSE="static-libs test"
RESTRICT="!test? ( test )"
# AUTHORS.txt only links the google group
DOCS=( ChangeLog.txt README.md )
multilib_src_configure() {
local mycmakeargs=(
-DBUILD_SHARED_LIBS=ON
-DBUILD_STATIC_LIBS=$(usex static-libs)
-DBUILD_TESTING=$(usex test)
# avoid installing .cmake/packages, e.g.:
# >>> /tmp/portage/dev-cpp/gflags-9999/homedir/.cmake/packages/gflags/a7fca4708532331c2d656af0fdc8b8b9
-DREGISTER_INSTALL_PREFIX=OFF
)
cmake-utils_src_configure
}

@ -1,37 +0,0 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
inherit cmake-multilib
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/gflags/gflags"
else
SRC_URI="https://github.com/gflags/gflags/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
fi
DESCRIPTION="Google's C++ argument parsing library"
HOMEPAGE="http://gflags.github.io/gflags/"
LICENSE="BSD"
SLOT="0/2.2"
IUSE="static-libs test"
RESTRICT="!test? ( test )"
# AUTHORS.txt only links the google group
DOCS=( ChangeLog.txt README.md )
multilib_src_configure() {
local mycmakeargs=(
-DBUILD_SHARED_LIBS=ON
-DBUILD_STATIC_LIBS=$(usex static-libs)
-DBUILD_TESTING=$(usex test)
# avoid installing .cmake/packages, e.g.:
# >>> /tmp/portage/dev-cpp/gflags-9999/homedir/.cmake/packages/gflags/a7fca4708532331c2d656af0fdc8b8b9
-DREGISTER_INSTALL_PREFIX=OFF
)
cmake-utils_src_configure
}

Binary file not shown.

@ -1 +1 @@
Wed, 30 Sep 2020 05:08:30 +0000
Wed, 30 Sep 2020 06:08:29 +0000

@ -1 +1 @@
Wed, 30 Sep 2020 05:08:30 +0000
Wed, 30 Sep 2020 06:08:29 +0000

Binary file not shown.

@ -1,15 +0,0 @@
DEFINED_PHASES=compile configure install prepare setup test
DEPEND=sys-devel/flex sys-devel/bison doc? ( || ( dev-lang/python:3.6 ) ) app-text/ghostscript-gpl dev-lang/perl media-libs/libpng:0= virtual/libiconv clang? ( <sys-devel/clang-10:= ) dot? ( media-gfx/graphviz media-libs/freetype ) doxysearch? ( dev-libs/xapian:= ) latex? ( dev-texlive/texlive-bibtexextra dev-texlive/texlive-fontsextra dev-texlive/texlive-fontutils dev-texlive/texlive-latex dev-texlive/texlive-latexextra ) qt5? ( dev-qt/qtgui:5 dev-qt/qtwidgets:5 dev-qt/qtxml:5 ) sqlite? ( dev-db/sqlite:3 ) sys-devel/make >=dev-util/cmake-3.9.6 !!sys-devel/llvm:0
DESCRIPTION=Documentation system for most programming languages
EAPI=6
HOMEPAGE=http://www.doxygen.org
IUSE=clang debug doc dot doxysearch latex qt5 sqlite userland_GNU
KEYWORDS=~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris
LICENSE=GPL-2
RDEPEND=app-text/ghostscript-gpl dev-lang/perl media-libs/libpng:0= virtual/libiconv clang? ( <sys-devel/clang-10:= ) dot? ( media-gfx/graphviz media-libs/freetype ) doxysearch? ( dev-libs/xapian:= ) latex? ( dev-texlive/texlive-bibtexextra dev-texlive/texlive-fontsextra dev-texlive/texlive-fontutils dev-texlive/texlive-latex dev-texlive/texlive-latexextra ) qt5? ( dev-qt/qtgui:5 dev-qt/qtwidgets:5 dev-qt/qtxml:5 ) sqlite? ( dev-db/sqlite:3 )
REQUIRED_USE=doc? ( latex )
RESTRICT=test
SLOT=0
SRC_URI=http://doxygen.nl/files/doxygen-1.8.15.src.tar.gz
_eclasses_=cmake-utils 77cd39e6009811bf97a59d91ffd5b54f desktop 7fd20552ce4cc97e8acb132a499a7dd8 edos2unix 33e347e171066657f91f8b0c72ec8773 epatch ed88001f77c6dd0d5f09e45c1a5b480e estack 686eaab303305a908fd57b2fd7617800 eutils 2d5b3f4b315094768576b6799e4f926e flag-o-matic 09a8beb8e6a8e02dc1e1bd83ac353741 l10n 8cdd85e169b835d518bc2fd59f780d8e llvm 21d8c0949a2693d7109cc6a25fabfcaf ltprune db8b7ce9d0e663594bcb4a4e72131a79 multilib 98584e405e2b0264d37e8f728327fed1 multiprocessing cac3169468f893670dac3e7cb940e045 ninja-utils 132cbb376048d079b5a012f5467c4e7f preserve-libs ef207dc62baddfddfd39a164d9797648 python-any-r1 54a3178500786b0a7ede4a23b7f2a6ad python-utils-r1 e41e32d357e5bdd388b5be2ce24f3883 toolchain-funcs 605c126bed8d87e4378d5ff1645330cb vcs-clean 2a0f74a496fa2b1552c4f3398258b7bf wrapper 4251d4c84c25f59094fd557e0063a974 xdg-utils ff2ff954e6b17929574eee4efc5152ba
_md5_=d2223968e71ff317d14a596c04b06a1f

@ -1,15 +0,0 @@
DEFINED_PHASES=compile configure install prepare setup test
DEPEND=sys-devel/flex sys-devel/bison doc? ( || ( dev-lang/python:3.6 ) ) app-text/ghostscript-gpl dev-lang/perl media-libs/libpng:0= virtual/libiconv clang? ( <sys-devel/clang-10:= ) dot? ( media-gfx/graphviz media-libs/freetype ) doxysearch? ( dev-libs/xapian:= ) latex? ( dev-texlive/texlive-bibtexextra dev-texlive/texlive-fontsextra dev-texlive/texlive-fontutils dev-texlive/texlive-latex dev-texlive/texlive-latexextra ) qt5? ( dev-qt/qtgui:5 dev-qt/qtwidgets:5 dev-qt/qtxml:5 ) sqlite? ( dev-db/sqlite:3 ) sys-devel/make >=dev-util/cmake-3.9.6 !!sys-devel/llvm:0
DESCRIPTION=Documentation system for most programming languages
EAPI=6
HOMEPAGE=http://www.doxygen.org
IUSE=clang debug doc dot doxysearch latex qt5 sqlite userland_GNU
KEYWORDS=~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris
LICENSE=GPL-2
RDEPEND=app-text/ghostscript-gpl dev-lang/perl media-libs/libpng:0= virtual/libiconv clang? ( <sys-devel/clang-10:= ) dot? ( media-gfx/graphviz media-libs/freetype ) doxysearch? ( dev-libs/xapian:= ) latex? ( dev-texlive/texlive-bibtexextra dev-texlive/texlive-fontsextra dev-texlive/texlive-fontutils dev-texlive/texlive-latex dev-texlive/texlive-latexextra ) qt5? ( dev-qt/qtgui:5 dev-qt/qtwidgets:5 dev-qt/qtxml:5 ) sqlite? ( dev-db/sqlite:3 )
REQUIRED_USE=doc? ( latex )
RESTRICT=test
SLOT=0
SRC_URI=http://doxygen.nl/files/doxygen-1.8.16.src.tar.gz
_eclasses_=cmake-utils 77cd39e6009811bf97a59d91ffd5b54f desktop 7fd20552ce4cc97e8acb132a499a7dd8 edos2unix 33e347e171066657f91f8b0c72ec8773 epatch ed88001f77c6dd0d5f09e45c1a5b480e estack 686eaab303305a908fd57b2fd7617800 eutils 2d5b3f4b315094768576b6799e4f926e flag-o-matic 09a8beb8e6a8e02dc1e1bd83ac353741 l10n 8cdd85e169b835d518bc2fd59f780d8e llvm 21d8c0949a2693d7109cc6a25fabfcaf ltprune db8b7ce9d0e663594bcb4a4e72131a79 multilib 98584e405e2b0264d37e8f728327fed1 multiprocessing cac3169468f893670dac3e7cb940e045 ninja-utils 132cbb376048d079b5a012f5467c4e7f preserve-libs ef207dc62baddfddfd39a164d9797648 python-any-r1 54a3178500786b0a7ede4a23b7f2a6ad python-utils-r1 e41e32d357e5bdd388b5be2ce24f3883 toolchain-funcs 605c126bed8d87e4378d5ff1645330cb vcs-clean 2a0f74a496fa2b1552c4f3398258b7bf wrapper 4251d4c84c25f59094fd557e0063a974 xdg-utils ff2ff954e6b17929574eee4efc5152ba
_md5_=67c53e41f6ef033777952a99f07f0a83

@ -1,13 +0,0 @@
DEFINED_PHASES=compile configure install prepare test
DEPEND=sys-devel/make >=dev-util/cmake-3.9.6
DESCRIPTION=Google's C++ argument parsing library
EAPI=6
HOMEPAGE=http://gflags.github.io/gflags/
IUSE=static-libs test abi_x86_32 abi_x86_64 abi_x86_x32 abi_mips_n32 abi_mips_n64 abi_mips_o32 abi_s390_32 abi_s390_64
KEYWORDS=~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 ~sparc x86 ~amd64-linux ~x86-linux
LICENSE=BSD
RESTRICT=!test? ( test )
SLOT=0/2.2
SRC_URI=https://github.com/gflags/gflags/archive/v2.2.0.tar.gz -> gflags-2.2.0.tar.gz
_eclasses_=cmake-multilib b396704c8c04bb210b7b45dff5c67fea cmake-utils 77cd39e6009811bf97a59d91ffd5b54f desktop 7fd20552ce4cc97e8acb132a499a7dd8 edos2unix 33e347e171066657f91f8b0c72ec8773 epatch ed88001f77c6dd0d5f09e45c1a5b480e estack 686eaab303305a908fd57b2fd7617800 eutils 2d5b3f4b315094768576b6799e4f926e flag-o-matic 09a8beb8e6a8e02dc1e1bd83ac353741 l10n 8cdd85e169b835d518bc2fd59f780d8e ltprune db8b7ce9d0e663594bcb4a4e72131a79 multibuild b2c915190b051f55a23b9354b9849847 multilib 98584e405e2b0264d37e8f728327fed1 multilib-build 9a65133006c608964888346a412cc454 multilib-minimal 8bddda43703ba94d8341f4e247f97566 multiprocessing cac3169468f893670dac3e7cb940e045 ninja-utils 132cbb376048d079b5a012f5467c4e7f preserve-libs ef207dc62baddfddfd39a164d9797648 toolchain-funcs 605c126bed8d87e4378d5ff1645330cb vcs-clean 2a0f74a496fa2b1552c4f3398258b7bf wrapper 4251d4c84c25f59094fd557e0063a974 xdg-utils ff2ff954e6b17929574eee4efc5152ba
_md5_=07cd907126aba6d997b5d21c19e62b07

@ -1,13 +0,0 @@
DEFINED_PHASES=compile configure install prepare test
DEPEND=sys-devel/make >=dev-util/cmake-3.9.6
DESCRIPTION=Google's C++ argument parsing library
EAPI=6
HOMEPAGE=http://gflags.github.io/gflags/
IUSE=static-libs test abi_x86_32 abi_x86_64 abi_x86_x32 abi_mips_n32 abi_mips_n64 abi_mips_o32 abi_s390_32 abi_s390_64
KEYWORDS=~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux
LICENSE=BSD
RESTRICT=!test? ( test )
SLOT=0/2.2
SRC_URI=https://github.com/gflags/gflags/archive/v2.2.1.tar.gz -> gflags-2.2.1.tar.gz
_eclasses_=cmake-multilib b396704c8c04bb210b7b45dff5c67fea cmake-utils 77cd39e6009811bf97a59d91ffd5b54f desktop 7fd20552ce4cc97e8acb132a499a7dd8 edos2unix 33e347e171066657f91f8b0c72ec8773 epatch ed88001f77c6dd0d5f09e45c1a5b480e estack 686eaab303305a908fd57b2fd7617800 eutils 2d5b3f4b315094768576b6799e4f926e flag-o-matic 09a8beb8e6a8e02dc1e1bd83ac353741 l10n 8cdd85e169b835d518bc2fd59f780d8e ltprune db8b7ce9d0e663594bcb4a4e72131a79 multibuild b2c915190b051f55a23b9354b9849847 multilib 98584e405e2b0264d37e8f728327fed1 multilib-build 9a65133006c608964888346a412cc454 multilib-minimal 8bddda43703ba94d8341f4e247f97566 multiprocessing cac3169468f893670dac3e7cb940e045 ninja-utils 132cbb376048d079b5a012f5467c4e7f preserve-libs ef207dc62baddfddfd39a164d9797648 toolchain-funcs 605c126bed8d87e4378d5ff1645330cb vcs-clean 2a0f74a496fa2b1552c4f3398258b7bf wrapper 4251d4c84c25f59094fd557e0063a974 xdg-utils ff2ff954e6b17929574eee4efc5152ba
_md5_=69ff2d5b19580da92fd7bb8515785c60

@ -1 +1 @@
Wed, 30 Sep 2020 05:08:30 +0000
Wed, 30 Sep 2020 06:08:29 +0000

@ -1 +1 @@
Wed 30 Sep 2020 05:08:30 AM UTC
Wed 30 Sep 2020 06:08:29 AM UTC

@ -1 +1 @@
Wed, 30 Sep 2020 05:30:01 +0000
Wed, 30 Sep 2020 06:30:01 +0000

@ -1 +1 @@
34a199467e61cb9d1cfb33ea98b098d4ae204d26 1601435865 2020-09-30T03:17:45+00:00
002f6bf2ecb3d4bc368cf9ff8bb914e0e248df96 1601444888 2020-09-30T05:48:08+00:00

@ -1 +1 @@
1601442301 Wed 30 Sep 2020 05:05:01 AM UTC
1601445902 Wed 30 Sep 2020 06:05:02 AM UTC

@ -1 +1 @@
Wed, 30 Sep 2020 05:08:30 +0000
Wed, 30 Sep 2020 06:08:29 +0000

Loading…
Cancel
Save