Sync with portage [Fri May 5 16:39:28 MSK 2017].

mhiretskiy 869
root 7 years ago
parent cd590d1999
commit 9bcaaf3239

@ -1 +1,2 @@
DIST pypcap-1.1.5.tar.gz 47978 SHA256 04f289783f4920baab4a2144821d0be7e8a2bde7259284dd4a7e775d0016ced0 SHA512 15df8f966abb6e29f3dfbd0c7f39bb2c3616b4352667e62dc08da287c427e611ec32ac543103d0e5864e5beb86bb9353bf1417bc6680a46e79e06496d4bba353 WHIRLPOOL 4d3473ef08faa9a5e4e53e8518187071fc4b4be4a51cf1fe7ddab871501d03c44d7e88b7c21a80cbf9b4dfb653225b600b0c1651ba6a83d92a2970bc59513934
DIST pypcap-1.1.6.tar.gz 57984 SHA256 c81a16091191c0931a9a39125d7f2cc5c0ebbf04745d970fbafc7d70c9c1dd61 SHA512 3d81364202256b19300b45b570537eead9835d8d58f54f51ed8ae43df1a270c0753c16b2050a999fa0f281e46ac66f71b96b6b4c910f2c18a5efae29a3b4e854 WHIRLPOOL d3d559de1ceb4fd14ef2aea040d4c37de07b2e1d385f992f6d5ac2e277994ded95caaef0bbcc9dfec6eb2c915915ff521f8b770200c4e26d03b1c76936796418

@ -0,0 +1,19 @@
--- a/pcap_ex.c
+++ b/pcap_ex.c
@@ -11,6 +11,7 @@
# include <string.h>
# include <signal.h>
# include <unistd.h>
+# include <stdlib.h>
#endif
#include <pcap.h>
@@ -290,7 +291,7 @@
char ebuf[PCAP_ERRBUF_SIZE];
int ret = -1;
- mktemp(path);
+ mkstemp(path);
if ((f = fopen(path, "w")) != NULL) {
hdr.magic = 0xa1b2c3d4;
hdr.version_major = PCAP_VERSION_MAJOR;

@ -0,0 +1,31 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 pypy )
inherit distutils-r1
DESCRIPTION="Simplified object-oriented Python extension module for libpcap"
HOMEPAGE="https://github.com/pynetwork/pypcap https://pypi.python.org/pypi/pypcap"
SRC_URI="https://github.com/pynetwork/pypcap/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~x86-fbsd"
RDEPEND="
net-libs/libpcap
"
DEPEND="
${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
"
PATCHES=(
"${FILESDIR}"/${PN}-1.1.6-mktemp.patch
)
python_compile() {
local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
distutils-r1_python_compile
}

@ -1 +1,2 @@
DIST grfcodec-6.0.5-source.tar.xz 166788 SHA256 db149e98095de107a8d6f715f03376380f201ea158e0cdc53585d9a1b5cbe8a2 SHA512 b578c6d53b69a1d43d59039f26a028e1437536102150fc2bddfff349ef3c7f720ee31e682ccc5df892c2660e167663c2ab12c3fa63c720022ab14d0645d0bf99 WHIRLPOOL d36ea24172724821fdcb10bf80630ba8adf822675b78e6df414395b1b210fa792c864bfb7e11d8c1e9a38e89d33d9aec91ec3f6c4a5951e9f8301f8b3fbacb38
DIST grfcodec-6.0.6-source.tar.xz 166820 SHA256 53ef18b810114d8f41b87aad8bafea0e98b1df55a6d4c5e27551337cedab4d21 SHA512 543123c794bfdb5b6556f7a897bcd2f3bdd09be8ad6a4ff07b138e0cac62621a4801c732bb20099c1bb383ad5822fc4ade276d49acf2744c811edd10d7699480 WHIRLPOOL 7b374769db83b68e12ff458533eab47072c72d5793d5aa7e40b02e34d5c6e42231c3bac1b21d2970e7314a8118cd102501658f2ced5d06607ca2b5c8b203a43b

@ -0,0 +1,51 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
if [ "${PV%9999}" != "${PV}" ] ; then
SCM=mercurial
EHG_REPO_URI="http://hg.openttdcoop.org/${PN}"
fi
inherit toolchain-funcs ${SCM}
DESCRIPTION="A suite of programs to modify openttd/Transport Tycoon Deluxe's GRF files"
HOMEPAGE="http://dev.openttdcoop.org/projects/grfcodec"
[[ -z ${SCM} ]] && SRC_URI="http://binaries.openttd.org/extra/${PN}/${PV}/${P}-source.tar.xz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
IUSE=""
RDEPEND="media-libs/libpng:0"
DEPEND="
${RDEPEND}
!games-util/nforenum
dev-lang/perl
dev-libs/boost
"
src_prepare() {
default
# Set up Makefile.local so that we respect CXXFLAGS/LDFLAGS
cat > Makefile.local <<-__EOF__
CXX=$(tc-getCXX)
BOOST_INCLUDE=/usr/include
CXXFLAGS=${CXXFLAGS}
LDOPT=${LDFLAGS}
UPX=
V=1
FLAGS=
EXE=
__EOF__
sed -i -e 's/-O2//g' Makefile || die
}
src_install() {
dobin grfcodec grfid grfstrip nforenum
doman docs/*.1
dodoc changelog.txt docs/*.txt
}

@ -1 +1 @@
Fri, 05 May 2017 12:08:52 +0000
Fri, 05 May 2017 12:38:53 +0000

@ -1 +1 @@
Fri, 05 May 2017 12:08:52 +0000
Fri, 05 May 2017 12:38:53 +0000

@ -0,0 +1,14 @@
DEFINED_PHASES=compile configure install prepare test
DEPEND=net-libs/libpcap dev-python/setuptools[python_targets_pypy(-)?,python_targets_python2_7(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-)] python_targets_pypy? ( >=virtual/pypy-5:0= ) python_targets_python2_7? ( >=dev-lang/python-2.7.5-r2:2.7 ) >=dev-lang/python-exec-2:=[python_targets_pypy(-)?,python_targets_python2_7(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-)]
DESCRIPTION=Simplified object-oriented Python extension module for libpcap
EAPI=6
HOMEPAGE=https://github.com/pynetwork/pypcap https://pypi.python.org/pypi/pypcap
IUSE=python_targets_pypy python_targets_python2_7
KEYWORDS=~amd64 ~x86 ~x86-fbsd
LICENSE=BSD
RDEPEND=net-libs/libpcap python_targets_pypy? ( >=virtual/pypy-5:0= ) python_targets_python2_7? ( >=dev-lang/python-2.7.5-r2:2.7 ) >=dev-lang/python-exec-2:=[python_targets_pypy(-)?,python_targets_python2_7(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-)]
REQUIRED_USE=|| ( python_targets_pypy python_targets_python2_7 )
SLOT=0
SRC_URI=https://github.com/pynetwork/pypcap/archive/v1.1.6.tar.gz -> pypcap-1.1.6.tar.gz
_eclasses_=distutils-r1 039ba10839816478cfb070fdeb053906 multibuild 72647e255187a1fadc81097b3657e5c3 multilib 0236be304ee52e7f179ed2f337075515 multiprocessing 284a473719153462f3e974d86c8cb81c python-r1 0c067f080a047742ffac024b16895b45 python-utils-r1 c11fc374357e6ad9ddfe2e9f931e4d29 toolchain-funcs 6eb35f81556258a4bc9182ad3dfd58ee xdg-utils b9389dfad0ee8f8e0b2a41b79fcf7120
_md5_=40146cd79bdd345fb1db5e6d5644f662

@ -0,0 +1,12 @@
DEFINED_PHASES=install prepare
DEPEND=media-libs/libpng:0 !games-util/nforenum dev-lang/perl dev-libs/boost
DESCRIPTION=A suite of programs to modify openttd/Transport Tycoon Deluxe's GRF files
EAPI=6
HOMEPAGE=http://dev.openttdcoop.org/projects/grfcodec
KEYWORDS=~amd64 ~arm ~ppc ~ppc64 ~x86
LICENSE=GPL-2+
RDEPEND=media-libs/libpng:0
SLOT=0
SRC_URI=http://binaries.openttd.org/extra/grfcodec/6.0.6/grfcodec-6.0.6-source.tar.xz
_eclasses_=multilib 0236be304ee52e7f179ed2f337075515 toolchain-funcs 6eb35f81556258a4bc9182ad3dfd58ee
_md5_=1c6a6181c9a6a0d6f1aeaa1a310d19d4

@ -0,0 +1,13 @@
DEFINED_PHASES=compile install prepare
DEPEND=media-libs/fontconfig x11-libs/libX11 x11-libs/libXft xinerama? ( x11-libs/libXinerama ) virtual/pkgconfig xinerama? ( x11-proto/xineramaproto ) x11-proto/xproto
DESCRIPTION=a generic, highly customizable, and efficient menu for the X Window System
EAPI=6
HOMEPAGE=http://tools.suckless.org/dmenu/
IUSE=xinerama
KEYWORDS=~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd
LICENSE=MIT
RDEPEND=media-libs/fontconfig x11-libs/libX11 x11-libs/libXft xinerama? ( x11-libs/libXinerama )
SLOT=0
SRC_URI=http://dl.suckless.org/tools/dmenu-4.7.tar.gz
_eclasses_=multilib 0236be304ee52e7f179ed2f337075515 toolchain-funcs 6eb35f81556258a4bc9182ad3dfd58ee
_md5_=735c855ab5881afa07184408a5a402f6

@ -7,5 +7,5 @@ IUSE=xinerama savedconfig
LICENSE=MIT
RDEPEND=media-libs/fontconfig x11-libs/libX11 x11-libs/libXft xinerama? ( x11-libs/libXinerama )
SLOT=0
_eclasses_=epatch 8233751dc5105a6ae8fcd86ce2bb0247 estack 43ddf5aaffa7a8d0482df54d25a66a1f eutils 9c113d6a64826c40154cad7be15d95ea git-r3 cbafa3261c37c7e3af44bb16a34ea390 ltprune 2770eed66a9b8ef944714cd0e968182e multilib 0236be304ee52e7f179ed2f337075515 portability 2b88d3ecc35035a3b8ab628b49cafb0e savedconfig e6948c872ff47e15a10e5ad1be15c18e toolchain-funcs 6eb35f81556258a4bc9182ad3dfd58ee
_md5_=d620c8b7432808d7687e533100219128
_eclasses_=git-r3 cbafa3261c37c7e3af44bb16a34ea390 multilib 0236be304ee52e7f179ed2f337075515 portability 2b88d3ecc35035a3b8ab628b49cafb0e savedconfig e6948c872ff47e15a10e5ad1be15c18e toolchain-funcs 6eb35f81556258a4bc9182ad3dfd58ee
_md5_=b7c9be6f58047bd66bdb2c249a45ad76

@ -1 +1 @@
Fri, 05 May 2017 12:08:52 +0000
Fri, 05 May 2017 12:38:53 +0000

@ -1 +1 @@
Fri May 5 12:08:52 UTC 2017
Fri May 5 12:38:53 UTC 2017

@ -1 +1 @@
Fri, 05 May 2017 12:30:01 +0000
Fri, 05 May 2017 13:00:01 +0000

@ -1 +1 @@
99503c16a8c1539869fbd8c3b61804f25cd1ee51 1493982953 2017-05-05T11:15:53+00:00
862a2711bc6621a45b845d326c9efedef267adca 1493987742 2017-05-05T12:35:42+00:00

@ -1 +1 @@
1493985901 Fri 05 May 2017 12:05:01 PM UTC
1493987701 Fri 05 May 2017 12:35:01 PM UTC

@ -1 +1 @@
Fri, 05 May 2017 12:08:52 +0000
Fri, 05 May 2017 12:38:53 +0000

@ -1 +1,2 @@
DIST dmenu-4.6.tar.gz 15057 SHA256 4a7a24008a621c3cd656155ad91ab8136db8f0d3b9ec56dafeec518cabda96b3 SHA512 e54fd10c0b1274eb90173aea442f0bfc496f4dda861a36d94f939e1fd835594f9aa12f3d0f90043d64e519d919b9a5273ab65012230ac022f727ee6bb64862e3 WHIRLPOOL b4354552356ab5ab93b20c44a313f0d8e626c22c589cf4376f82f876dc742b961a07bad45d12b5fe749b03354dfa76acf36e4089a701754e341ec0383232fa5d
DIST dmenu-4.7.tar.gz 15597 SHA256 a75635f8dc2cbc280deecb906ad9b7594c5c31620e4a01ba30dc83984881f7b9 SHA512 67a184f3ddb018e7b372e049052662955403e3367639b9c2284939d6f105ae74c995fe38f126d8ff75886831c8add8b50e338a1bfb0d8620b7fb1457cf88a00c WHIRLPOOL 6acb632c06374c92bce2a2951bebbcd81c9f5529c6a44859e86d92d8aace52c847a542bb2a0c34d69cb0a8e4cdb525bbe9d82885c0ae8f79004c90094d21069b

@ -0,0 +1,57 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit toolchain-funcs
DESCRIPTION="a generic, highly customizable, and efficient menu for the X Window System"
HOMEPAGE="http://tools.suckless.org/dmenu/"
SRC_URI="http://dl.suckless.org/tools/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
IUSE="xinerama"
RDEPEND="
media-libs/fontconfig
x11-libs/libX11
x11-libs/libXft
xinerama? ( x11-libs/libXinerama )
"
DEPEND="${RDEPEND}
virtual/pkgconfig
xinerama? ( x11-proto/xineramaproto )
x11-proto/xproto
"
PATCHES=(
"${FILESDIR}"/${PN}-4.7-gentoo.patch
)
src_prepare() {
default
sed -i \
-e 's|^ @| |g' \
-e 's|${CC} -o|$(CC) $(CFLAGS) -o|g' \
-e '/^ echo/d' \
Makefile || die
}
src_compile() {
emake CC=$(tc-getCC) \
"FREETYPEINC=$( $(tc-getPKG_CONFIG) --cflags x11 fontconfig xft 2>/dev/null )" \
"FREETYPELIBS=$( $(tc-getPKG_CONFIG) --libs x11 fontconfig xft 2>/dev/null )" \
"XINERAMAFLAGS=$(
usex xinerama "-DXINERAMA $(
$(tc-getPKG_CONFIG) --cflags xinerama 2>/dev/null
)" ''
)" \
"XINERAMALIBS=$(
usex xinerama "$( $(tc-getPKG_CONFIG) --libs xinerama 2>/dev/null)" ''
)"
}
src_install() {
emake DESTDIR="${D}" PREFIX="/usr" install
}

@ -1,8 +1,8 @@
# Copyright 1999-2014 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit eutils git-r3 savedconfig toolchain-funcs
inherit git-r3 savedconfig toolchain-funcs
DESCRIPTION="a generic, highly customizable, and efficient menu for the X Window System"
HOMEPAGE="http://tools.suckless.org/dmenu/"
@ -24,18 +24,19 @@ DEPEND="${RDEPEND}
xinerama? ( x11-proto/xineramaproto )
x11-proto/xproto
"
PATCHES=(
"${FILESDIR}"/${P}-gentoo.patch
)
src_prepare() {
default
sed -i \
-e 's|^ @| |g' \
-e 's|${CC} -o|$(CC) $(CFLAGS) -o|g' \
-e '/^ echo/d' \
Makefile || die
epatch "${FILESDIR}"/${P}-gentoo.patch
eapply_user
restore_config config.def.h
}

@ -0,0 +1,38 @@
--- a/config.mk
+++ b/config.mk
@@ -5,8 +5,8 @@
PREFIX = /usr/local
MANPREFIX = ${PREFIX}/share/man
-X11INC = /usr/X11R6/include
-X11LIB = /usr/X11R6/lib
+X11INC = -I/usr/X11R6/include
+X11LIB = -L/usr/X11R6/lib
# Xinerama, comment if you don't want it
XINERAMALIBS = -lXinerama
@@ -14,18 +14,18 @@
# freetype
FREETYPELIBS = -lfontconfig -lXft
-FREETYPEINC = /usr/include/freetype2
+FREETYPEINC = -I/usr/include/freetype2
# OpenBSD (uncomment)
#FREETYPEINC = ${X11INC}/freetype2
# includes and libs
-INCS = -I${X11INC} -I${FREETYPEINC}
-LIBS = -L${X11LIB} -lX11 ${XINERAMALIBS} ${FREETYPELIBS}
+INCS = ${X11INC} ${FREETYPEINC}
+LIBS = ${X11LIB} -lX11 ${XINERAMALIBS} ${FREETYPELIBS}
# flags
-CPPFLAGS = -D_DEFAULT_SOURCE -D_BSD_SOURCE -D_XOPEN_SOURCE=700 -D_POSIX_C_SOURCE=200809L -DVERSION=\"${VERSION}\" ${XINERAMAFLAGS}
-CFLAGS = -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
-LDFLAGS = -s ${LIBS}
+CPPFLAGS += -D_BSD_SOURCE -D_XOPEN_SOURCE=700 -D_POSIX_C_SOURCE=200809L -DVERSION=\"${VERSION}\" ${XINERAMAFLAGS}
+CFLAGS += -ansi -pedantic -Wall $(INCS) $(CPPFLAGS)
+LDFLAGS += ${LIBS}
# compiler and linker
CC = cc
Loading…
Cancel
Save