Sync with portage [Tue Oct 18 12:49:04 MSK 2016].

mhiretskiy 589
root 8 years ago
parent 3a1e15c0d8
commit aa679f481a

@ -2,3 +2,4 @@ DIST nano-2.4.3.tar.gz 1878096 SHA256 32d627072b6026678e4f4095c047adec92ac7ec542
DIST nano-2.5.3.tar.gz 1967760 SHA256 b2b060129b9feff2d4870d803a441178c96531de9aed144ec0b83bd63ccb12ee SHA512 1d859f0bd88b9d907cfcaa84edc212bcaea4335c203922eb5b7378c2b45d88dffe1f3e4cb499a824d33781485834ef564997c58cf1fd92610d08f6ce8dcb67d5 WHIRLPOOL a2ca1c41d3cb26756cc9aba5b5fa0aeaea220626b98d0abfa1c5c4d4d57c3a5ef688d5edf00a6a00849ee25a67b2bbab93c4d454f6eb5a204b10fa01de3e298f
DIST nano-2.6.1.tar.gz 1999439 SHA256 56f2ba1c532647bee36abd5f87a714400af0be084cf857a65bc8f41a0dc28fe5 SHA512 224d643ce08b4c031263c1926d767c671d41e58b182b7ad32f9de2a8ed606c5b39da924cbe62052455584e087a8966285da17cb1fbf235680639351c390aec90 WHIRLPOOL da902989aceac4b15438c58603a56e1cc02b61ff0972f56032130af25d40b0d40344b063feb1aa2f1fd3f5bacbb325505865d0d0daf2e215aafbac0527ee41d6
DIST nano-2.6.3.tar.gz 2019354 SHA256 4f4054e12f2181c8e436163e931a0a565612242ff9e566c4d1adeda0f91fd503 SHA512 5079c0da976e3cfef9f3980e37c2501837bc66bb98fadd6fe7f02b061b83c99454678833fd43c74e6796cdc4ee9028ccba7a8a05e0f86e7a6517ba4d4c6bc95e WHIRLPOOL 94520ca9c7a11342133adfd3a1e9e9c77a6c07ab18b1b51bf39918b331abc6bd7ebeb937c2ec8ed3e59b8d0468e40f4e5811e66a8aecd469ad42c595c1b61fe4
DIST nano-2.7.0.tar.gz 2019889 SHA256 5dd1e9cf8e3de676c141a0b23f312e68380ef049926e2913e2114bbe32fbeac3 SHA512 d70719b9623e3b3c5f43dbf4dd1d53be5d498b28416d1c6bc4459887d34531222827dfb23bc6932a6304fe59df8d278810de813b4bc08b38c03f1badeddad12f WHIRLPOOL 5470eb106671d8b483fd7349d01d52c107082bf8bd67d03ff9cec3f656a9e280d1eda97befcf42067dc8732009fe9fcaaadbfa00af98be3ddbe073bd133d6386

@ -0,0 +1,82 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
inherit eutils flag-o-matic
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.sv.gnu.org/nano.git"
inherit git-r3 autotools
else
MY_P=${PN}-${PV/_}
SRC_URI="https://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
DESCRIPTION="GNU GPL'd Pico clone with more functionality"
HOMEPAGE="https://www.nano-editor.org/ https://wiki.gentoo.org/wiki/Nano/Basics_Guide"
LICENSE="GPL-3"
SLOT="0"
IUSE="debug justify +magic minimal ncurses nls slang +spell static unicode"
LIB_DEPEND=">=sys-libs/ncurses-5.9-r1:0=[unicode?]
sys-libs/ncurses:0=[static-libs(+)]
magic? ( sys-apps/file[static-libs(+)] )
nls? ( virtual/libintl )
!ncurses? ( slang? ( sys-libs/slang[static-libs(+)] ) )"
RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )
virtual/pkgconfig
static? ( ${LIB_DEPEND} )"
src_prepare() {
if [[ ${PV} == "9999" ]] ; then
eautoreconf
fi
epatch_user
}
src_configure() {
use static && append-ldflags -static
local myconf=()
case ${CHOST} in
*-gnu*|*-uclibc*) myconf+=( "--with-wordbounds" ) ;; #467848
esac
econf \
--bindir="${EPREFIX}"/bin \
--htmldir=/trash \
$(use_enable !minimal color) \
$(use_enable !minimal multibuffer) \
$(use_enable !minimal nanorc) \
--disable-wrapping-as-root \
$(use_enable magic libmagic) \
$(use_enable spell speller) \
$(use_enable justify) \
$(use_enable debug) \
$(use_enable nls) \
$(use_enable unicode utf8) \
$(use_enable minimal tiny) \
$(usex ncurses --without-slang $(use_with slang)) \
"${myconf[@]}"
}
src_install() {
default
rm -rf "${D}"/trash
dodoc doc/nanorc.sample
dohtml doc/faq.html
insinto /etc
newins doc/nanorc.sample nanorc
if ! use minimal ; then
# Enable colorization by default.
sed -i \
-e '/^# include /s:# *::' \
"${ED}"/etc/nanorc || die
fi
dodir /usr/bin
dosym /bin/nano /usr/bin/nano
}

@ -0,0 +1 @@
DIST ctypes-sh-1.1.tar.gz 437637 SHA256 f7c8276b556101c51838296560d152fdcd96b860254a38d216b92986f31f8297 SHA512 0e136f5b9fc342875d02b1087daed60eed46f411765538f185d1da61430205113db72994ecdb125aded3eae114b3f487e7af398c1326334efdd197ee7de18a61 WHIRLPOOL 7625df5a8d7e5284ee6012e59dc0ff1a2e11ccbec37edb5203d31529715916aefa609d0cd3c7964dfc225d0f476e37213f5936c17c74c2b76fb5ad0a9e02874c

@ -0,0 +1,40 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
inherit autotools toolchain-funcs
DESCRIPTION="Foreign function interface for bash"
HOMEPAGE="http://ctypes.sh/"
SRC_URI="https://github.com/taviso/${PN/-/.}/releases/download/v${PV}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="virtual/libffi
virtual/libelf
app-arch/xz-utils
app-arch/bzip2
app-shells/bash[plugins]"
DEPEND="${RDEPEND}
virtual/pkgconfig"
PATCHES=(
"${FILESDIR}/${P}-makefile-fix.patch"
)
src_prepare() {
default
eautoreconf
}
src_test() {
pushd test
PATH="${S}:${PATH}" \
LD_LIBRARY_PATH="${S}/src/.libs" \
make CC="$(tc-getCC)" || die "make check failed"
popd
}

@ -0,0 +1,18 @@
commit 5e305160cc219fa63658148e3d258cb62dd043a3
Author: rtlanceroad <rtlanceroad@gmail.com>
Date: Wed Jul 27 14:49:21 2016 +0800
fix Makefile.am in src dir
diff --git a/src/Makefile.am b/src/Makefile.am
index 8a9b682..71347bb 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -11,6 +11,6 @@ ctypes_la_LIBADD += libstruct.la
noinst_LTLIBRARIES += libstruct.la
noinst_HEADERS += struct/dutil.h struct/dwarves.h struct/elf_symtab.h struct/gobuffer.h struct/hash.h struct/list.h struct/rbtree.h struct/strings.h
libstruct_la_SOURCES = struct/dutil.c struct/dwarves.c struct/gobuffer.c struct/struct.c struct/strings.c struct/dwarf_loader.c struct/dwarves_fprintf.c struct/elf_symtab.c struct/rbtree.c
-libstruct_la_CFLAGS = -std=gnu99 -D_GNU_SOURCE
+libstruct_la_CFLAGS = -std=gnu99 -D_GNU_SOURCE $(FFI_CFLAGS)
libstruct_la_CPPFLAGS = -I../include -I../lib
endif

@ -0,0 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>chutzpah@gentoo.org</email>
<name>Patrick McLean</name>
</maintainer>
<longdescription lang="en">
ctypes.sh is a bash plugin that provides a foreign function interface directly
in your shell. In other words, it allows you to call routines in shared
libraries from within bash.
</longdescription>
</pkgmetadata>

@ -0,0 +1 @@
DIST bluez-alsa-1.1.0.tar.gz 73676 SHA256 93396e581c196f9283d5907c7b8059ded21f5ec75a58f1c96f01d9ba295f5179 SHA512 167fa45994b57b0b44d5827762638d36ef782d7789c229e5c1ca99b59c13636dc53161cd45bec41e61890acd38b44d20778bc2085385582329a1c666530b21f1 WHIRLPOOL 2faba9fbd57fac2a519fe382c8a98654159a51819fea11da93ea3e198d31e51d3357bf2effa9df31713c2f201717dbd395a721efa81c9000a4da15df7e542a70

@ -0,0 +1,50 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
inherit autotools eutils
DESCRIPTION="Bluetooth Audio ALSA Backend"
HOMEPAGE="https://github.com/Arkq/bluez-alsa"
if [[ ${PV} == "9999" ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/Arkq/${PN}"
else
SRC_URI="https://github.com/Arkq/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
LICENSE="MIT"
SLOT="0"
IUSE="debug"
RDEPEND=">=dev-libs/glib-2.16[dbus]
>=media-libs/alsa-lib-1.0
>=media-libs/sbc-1.2
>=net-wireless/bluez-5"
DEPEND="${RDEPEND}
net-libs/ortp
virtual/pkgconfig"
src_prepare() {
default
eautoreconf
}
src_configure() {
econf \
$(use_enable debug)
}
src_install() {
default
prune_libtool_files --modules
newinitd "${FILESDIR}"/bluealsa-init.d bluealsa
}
pkg_postinst() {
elog "Users can use this service when they are members of the \"audio\" group."
}

@ -0,0 +1,52 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
inherit autotools eutils
DESCRIPTION="Bluetooth Audio ALSA Backend"
HOMEPAGE="https://github.com/Arkq/bluez-alsa"
if [[ ${PV} == "9999" ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/Arkq/${PN}"
else
SRC_URI="https://github.com/Arkq/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
LICENSE="MIT"
SLOT="0"
IUSE="aac debug"
RDEPEND=">=dev-libs/glib-2.16[dbus]
>=media-libs/alsa-lib-1.0
>=media-libs/sbc-1.2
>=net-wireless/bluez-5"
DEPEND="${RDEPEND}
net-libs/ortp
aac? ( >=media-libs/fdk-aac-0.1.1 )
virtual/pkgconfig"
src_prepare() {
default
eautoreconf
}
src_configure() {
econf \
$(use_enable aac) \
$(use_enable debug)
}
src_install() {
default
prune_libtool_files --modules
newinitd "${FILESDIR}"/bluealsa-init.d bluealsa
}
pkg_postinst() {
elog "Users can use this service when they are members of the \"audio\" group."
}

@ -0,0 +1,18 @@
#!/sbin/openrc-run
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
pidfile="/var/run/bluealsa.pid"
command="/usr/bin/bluealsa"
command_args="--disable-hsp"
command_background="true"
depend() {
after bluetooth
need dbus localmount
}
start_pre() {
checkpath -q -D -m 0700 -o :audio /var/run/bluealsa
}

@ -0,0 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>polynomial-c@gentoo.org</email>
<name>Lars Wendler</name>
</maintainer>
<upstream>
<remote-id type="github">Arkq/bluez-alsa</remote-id>
</upstream>
</pkgmetadata>

@ -1 +1 @@
Tue, 18 Oct 2016 05:40:38 +0000
Tue, 18 Oct 2016 08:40:38 +0000

@ -1 +1 @@
Tue, 18 Oct 2016 05:40:38 +0000
Tue, 18 Oct 2016 08:40:38 +0000

@ -0,0 +1,13 @@
DEFINED_PHASES=configure install prepare
DEPEND=!static? ( >=sys-libs/ncurses-5.9-r1:0=[unicode?] sys-libs/ncurses:0= magic? ( sys-apps/file ) nls? ( virtual/libintl ) !ncurses? ( slang? ( sys-libs/slang ) ) ) nls? ( sys-devel/gettext ) virtual/pkgconfig static? ( >=sys-libs/ncurses-5.9-r1:0=[unicode?] sys-libs/ncurses:0=[static-libs(+)] magic? ( sys-apps/file[static-libs(+)] ) nls? ( virtual/libintl ) !ncurses? ( slang? ( sys-libs/slang[static-libs(+)] ) ) )
DESCRIPTION=GNU GPL'd Pico clone with more functionality
EAPI=5
HOMEPAGE=https://www.nano-editor.org/ https://wiki.gentoo.org/wiki/Nano/Basics_Guide
IUSE=debug justify +magic minimal ncurses nls slang +spell static unicode
KEYWORDS=~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris
LICENSE=GPL-3
RDEPEND=!static? ( >=sys-libs/ncurses-5.9-r1:0=[unicode?] sys-libs/ncurses:0= magic? ( sys-apps/file ) nls? ( virtual/libintl ) !ncurses? ( slang? ( sys-libs/slang ) ) )
SLOT=0
SRC_URI=https://www.nano-editor.org/dist/v2.7/nano-2.7.0.tar.gz
_eclasses_=eutils b83a2420b796f7c6eff682679d08fe25 flag-o-matic 8632fcd33a047954f007dee9a137bdcc multilib 165fc17c38d1b11dac2008280dab6e80 toolchain-funcs 6198c04daba0e1307bd844df7d37f423
_md5_=ddfe055fda31409229e983c1c9293954

@ -0,0 +1,12 @@
DEFINED_PHASES=prepare test
DEPEND=virtual/libffi virtual/libelf app-arch/xz-utils app-arch/bzip2 app-shells/bash[plugins] virtual/pkgconfig !<sys-devel/gettext-0.18.1.1-r3 || ( >=sys-devel/automake-1.15:1.15 ) >=sys-devel/autoconf-2.69 >=sys-devel/libtool-2.4
DESCRIPTION=Foreign function interface for bash
EAPI=6
HOMEPAGE=http://ctypes.sh/
KEYWORDS=~amd64 ~x86
LICENSE=MIT
RDEPEND=virtual/libffi virtual/libelf app-arch/xz-utils app-arch/bzip2 app-shells/bash[plugins]
SLOT=0
SRC_URI=https://github.com/taviso/ctypes.sh/releases/download/v1.1/ctypes-sh-1.1.tar.gz
_eclasses_=autotools 07e71b3b5690738ef7e8bc097077e00c libtool 4890219c51da247200223277f993e054 multilib 165fc17c38d1b11dac2008280dab6e80 toolchain-funcs 6198c04daba0e1307bd844df7d37f423
_md5_=e27dc8aad0cb671f585a0ecf5734ad20

@ -0,0 +1,13 @@
DEFINED_PHASES=configure install postinst prepare
DEPEND=>=dev-libs/glib-2.16[dbus] >=media-libs/alsa-lib-1.0 >=media-libs/sbc-1.2 >=net-wireless/bluez-5 net-libs/ortp virtual/pkgconfig !<sys-devel/gettext-0.18.1.1-r3 || ( >=sys-devel/automake-1.15:1.15 ) >=sys-devel/autoconf-2.69 >=sys-devel/libtool-2.4
DESCRIPTION=Bluetooth Audio ALSA Backend
EAPI=6
HOMEPAGE=https://github.com/Arkq/bluez-alsa
IUSE=debug
KEYWORDS=~amd64 ~x86
LICENSE=MIT
RDEPEND=>=dev-libs/glib-2.16[dbus] >=media-libs/alsa-lib-1.0 >=media-libs/sbc-1.2 >=net-wireless/bluez-5
SLOT=0
SRC_URI=https://github.com/Arkq/bluez-alsa/archive/v1.1.0.tar.gz -> bluez-alsa-1.1.0.tar.gz
_eclasses_=autotools 07e71b3b5690738ef7e8bc097077e00c eutils b83a2420b796f7c6eff682679d08fe25 libtool 4890219c51da247200223277f993e054 multilib 165fc17c38d1b11dac2008280dab6e80 toolchain-funcs 6198c04daba0e1307bd844df7d37f423
_md5_=1f5c8407a564f824c19890b9d7689a33

@ -0,0 +1,11 @@
DEFINED_PHASES=configure install postinst prepare unpack
DEPEND=>=dev-libs/glib-2.16[dbus] >=media-libs/alsa-lib-1.0 >=media-libs/sbc-1.2 >=net-wireless/bluez-5 net-libs/ortp aac? ( >=media-libs/fdk-aac-0.1.1 ) virtual/pkgconfig !<sys-devel/gettext-0.18.1.1-r3 || ( >=sys-devel/automake-1.15:1.15 ) >=sys-devel/autoconf-2.69 >=sys-devel/libtool-2.4 >=dev-vcs/git-1.8.2.1
DESCRIPTION=Bluetooth Audio ALSA Backend
EAPI=6
HOMEPAGE=https://github.com/Arkq/bluez-alsa
IUSE=aac debug
LICENSE=MIT
RDEPEND=>=dev-libs/glib-2.16[dbus] >=media-libs/alsa-lib-1.0 >=media-libs/sbc-1.2 >=net-wireless/bluez-5
SLOT=0
_eclasses_=autotools 07e71b3b5690738ef7e8bc097077e00c eutils b83a2420b796f7c6eff682679d08fe25 git-r3 86ff3e88fc8a07b4f595afa27e416341 libtool 4890219c51da247200223277f993e054 multilib 165fc17c38d1b11dac2008280dab6e80 toolchain-funcs 6198c04daba0e1307bd844df7d37f423
_md5_=5bcacc1a12290cfe0c04fe292cd6f7ab

@ -1,14 +0,0 @@
DEFINED_PHASES=compile configure install postinst prepare test
DEPEND=ident? ( net-libs/libident ) ssl? ( gnutls? ( net-libs/gnutls ) !gnutls? ( dev-libs/openssl ) ) pam? ( virtual/pam ) tcpd? ( sys-apps/tcp-wrappers ) zlib? ( sys-libs/zlib ) >=sys-apps/sed-4
DESCRIPTION=A IRC server written from scratch
EAPI=5
HOMEPAGE=http://ngircd.barton.de/
IUSE=debug gnutls ident ipv6 pam ssl tcpd zlib
KEYWORDS=~amd64 x86 ~x64-macos
LICENSE=GPL-2
RDEPEND=ident? ( net-libs/libident ) ssl? ( gnutls? ( net-libs/gnutls ) !gnutls? ( dev-libs/openssl ) ) pam? ( virtual/pam ) tcpd? ( sys-apps/tcp-wrappers ) zlib? ( sys-libs/zlib )
RESTRICT=test
SLOT=0
SRC_URI=ftp://ngircd.barton.de/pub/ngircd/ngircd-20.3.tar.gz
_eclasses_=autotools 07e71b3b5690738ef7e8bc097077e00c autotools-utils 419811142edf3516b0d0cf1a254d93cb eutils b83a2420b796f7c6eff682679d08fe25 libtool 4890219c51da247200223277f993e054 multilib 165fc17c38d1b11dac2008280dab6e80 toolchain-funcs 6198c04daba0e1307bd844df7d37f423 user 80aaa71614ced86f02ee1a513821dc87
_md5_=0ce670379b4009db40a1f431ec0d7373

@ -1,14 +0,0 @@
DEFINED_PHASES=compile configure install postinst prepare test
DEPEND=iconv? ( virtual/libiconv ) ident? ( net-libs/libident ) pam? ( virtual/pam ) ssl? ( !gnutls? ( !libressl? ( dev-libs/openssl:0 ) ) gnutls? ( net-libs/gnutls ) libressl? ( dev-libs/libressl ) ) tcpd? ( sys-apps/tcp-wrappers ) zlib? ( sys-libs/zlib ) >=sys-apps/sed-4
DESCRIPTION=An IRC server written from scratch
EAPI=5
HOMEPAGE=http://ngircd.barton.de/
IUSE=debug gnutls iconv ident ipv6 libressl pam ssl tcpd zlib
KEYWORDS=~amd64 ~x86 ~x64-macos
LICENSE=GPL-2
RDEPEND=iconv? ( virtual/libiconv ) ident? ( net-libs/libident ) pam? ( virtual/pam ) ssl? ( !gnutls? ( !libressl? ( dev-libs/openssl:0 ) ) gnutls? ( net-libs/gnutls ) libressl? ( dev-libs/libressl ) ) tcpd? ( sys-apps/tcp-wrappers ) zlib? ( sys-libs/zlib )
RESTRICT=test
SLOT=0
SRC_URI=http://ngircd.barton.de/pub/ngircd/ngircd-23.tar.gz
_eclasses_=autotools 07e71b3b5690738ef7e8bc097077e00c autotools-utils 419811142edf3516b0d0cf1a254d93cb eutils b83a2420b796f7c6eff682679d08fe25 libtool 4890219c51da247200223277f993e054 multilib 165fc17c38d1b11dac2008280dab6e80 toolchain-funcs 6198c04daba0e1307bd844df7d37f423 user 80aaa71614ced86f02ee1a513821dc87
_md5_=91c1b0f45519c4434a14f5aa2642be56

@ -1 +1 @@
Tue, 18 Oct 2016 05:40:38 +0000
Tue, 18 Oct 2016 08:40:38 +0000

@ -1 +1 @@
Tue Oct 18 05:39:43 UTC 2016
Tue Oct 18 08:39:42 UTC 2016

@ -1 +1 @@
Tue, 18 Oct 2016 06:00:01 +0000
Tue, 18 Oct 2016 09:30:01 +0000

@ -1 +1 @@
1476769201 Tue 18 Oct 2016 05:40:01 AM UTC
1476780002 Tue 18 Oct 2016 08:40:02 AM UTC

@ -1 +1 @@
Tue, 18 Oct 2016 05:40:38 +0000
Tue, 18 Oct 2016 08:40:38 +0000

@ -1,2 +1 @@
DIST ngircd-20.3.tar.gz 479982 SHA256 55d7c74c6df790b11a68c07f39836d581965087efb618d3e9a6bec855364c2f9 SHA512 8bc36a66e893873fade6dcadb07bf561fb25156714ba30168cf2e399e50f4dd80592fd7fcdb6c8d1083fa7c5e839b0da3a27ed4ce2041a2c5ab2b9581def948c WHIRLPOOL 379ef30a2e23dfc3a523d85e9f2c1531b8079d0880b5f46b9cdb803af873fc943d25186ebc0b9294da26140b46a37a4ebd2b86f3c7cf17acd3a802e4a395dd1e
DIST ngircd-23.tar.gz 517686 SHA256 99b8b67a975a9ae9b81c96bdee02133a10f515c718825d34cedcb64f1fc95e73 SHA512 714fbb4af12335e62c615fa1e8de9c7366c4c6da6af9b334019ba900dce072067f7b08199de8c96aad5dd4b9b786b57d536ba9dc92c62b37d2ae11960dbd01b1 WHIRLPOOL 06e1b3a9675277c980898118e71e9a6c08de998c93919f431ecd7505f64dc57617beef885aae5e5c72b27cd1df3c89204dbc2101c1f4a30970fceb78a7825441

@ -1,21 +0,0 @@
#!/sbin/openrc-run
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
depend() {
need net
provide ircd
}
start() {
ebegin "Starting ngIRCd"
start-stop-daemon --start --quiet --exec /usr/sbin/ngircd
eend $?
}
stop() {
ebegin "Stopping ngIRCd"
start-stop-daemon --stop --quiet --exec /usr/sbin/ngircd
eend $?
}

@ -1,80 +0,0 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
inherit autotools-utils eutils user
DESCRIPTION="A IRC server written from scratch"
HOMEPAGE="http://ngircd.barton.de/"
SRC_URI="ftp://ngircd.barton.de/pub/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 x86 ~x64-macos"
IUSE="debug gnutls ident ipv6 pam ssl tcpd zlib"
RDEPEND="
ident? ( net-libs/libident )
ssl? (
gnutls? ( net-libs/gnutls )
!gnutls? ( dev-libs/openssl )
)
pam? ( virtual/pam )
tcpd? ( sys-apps/tcp-wrappers )
zlib? ( sys-libs/zlib )
"
DEPEND="${RDEPEND}
>=sys-apps/sed-4
"
RESTRICT="test"
src_configure() {
if ! use prefix; then
sed -i \
-e "s:;ServerUID = 65534:ServerUID = ngircd:" \
-e "s:;ServerGID = 65534:ServerGID = nogroup:" \
doc/sample-ngircd.conf.tmpl || die
fi
local myeconfargs=(
--docdir="${EPREFIX}"/usr/share/doc/${PF}
--sysconfdir="${EPREFIX}"/etc/ngircd
$(use_enable ipv6)
$(use_with zlib)
$(use_with tcpd tcp-wrappers)
$(use_with ident)
$(use_with pam)
$(use_enable debug)
$(use_enable debug sniffer)
)
if use ssl; then
myeconfargs+=(
$(use_with !gnutls openssl)
$(use_with gnutls)
)
else
myeconfargs+=(
--without-gnutls
--without-ssl
)
fi
autotools-utils_src_configure
}
src_install() {
autotools-utils_src_install
newinitd "${FILESDIR}"/ngircd.init.d ngircd
}
pkg_postinst() {
if ! use prefix; then
enewuser ngircd
chown ngircd "${ROOT}"/etc/ngircd/ngircd.conf
fi
}

@ -1,85 +0,0 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
inherit autotools-utils eutils user
DESCRIPTION="An IRC server written from scratch"
HOMEPAGE="http://ngircd.barton.de/"
SRC_URI="http://ngircd.barton.de/pub/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~x64-macos"
IUSE="debug gnutls iconv ident ipv6 libressl pam ssl tcpd zlib"
RDEPEND="
iconv? ( virtual/libiconv )
ident? ( net-libs/libident )
pam? ( virtual/pam )
ssl? (
!gnutls? (
!libressl? ( dev-libs/openssl:0 )
)
gnutls? ( net-libs/gnutls )
libressl? ( dev-libs/libressl )
)
tcpd? ( sys-apps/tcp-wrappers )
zlib? ( sys-libs/zlib )
"
DEPEND="${RDEPEND}
>=sys-apps/sed-4
"
RESTRICT="test"
src_configure() {
if ! use prefix; then
sed -i \
-e "s:;ServerUID = 65534:ServerUID = ngircd:" \
-e "s:;ServerGID = 65534:ServerGID = nogroup:" \
doc/sample-ngircd.conf.tmpl || die
fi
local myeconfargs=(
--docdir="${EPREFIX}"/usr/share/doc/${PF}
--sysconfdir="${EPREFIX}"/etc/ngircd
$(use_enable debug sniffer)
$(use_enable debug)
$(use_enable ipv6)
$(use_with iconv)
$(use_with ident)
$(use_with pam)
$(use_with tcpd tcp-wrappers)
$(use_with zlib)
)
if use ssl; then
myeconfargs+=(
$(use_with !gnutls openssl)
$(use_with gnutls)
)
else
myeconfargs+=(
--without-gnutls
--without-openssl
)
fi
autotools-utils_src_configure
}
src_install() {
autotools-utils_src_install
newinitd "${FILESDIR}"/ngircd.init.d ngircd
}
pkg_postinst() {
if ! use prefix; then
enewuser ngircd
chown ngircd "${ROOT}"/etc/ngircd/ngircd.conf
fi
}
Loading…
Cancel
Save