parent
ddfe5bf28b
commit
b5b5a08657
@ -1,2 +1,2 @@
|
||||
DIST calamares-2.4.1.tar.gz 2135702 SHA256 ab1ea9c57bfeccea1282813fa67d3ee97ee03f8673af002c13fdda8dc75ef028 SHA512 8720c04cdd6ccc8f18f4a81e9ae213aa1e049f5bcd0af2521161b1adb9faebb217a6a06a30ca37ee7096b200984f271863752cca29f5225196f0306a8ef2ec2c WHIRLPOOL 12be30182b2d2c1c959743d84a0212a9db8ae93ad93c1e377e359a54617914183008b5a4ad6cedce482968bf7b71faa87097c21b8358b3d09ff9258de9223e1a
|
||||
DIST calamares-2.4.tar.gz 2134756 SHA256 5519077c79fe1964dd9bf1ae6aedff202bb3c2e3289398affd7e7946672f7f3e SHA512 5119f2203358a794a66aa26e052bdd58e0d5197d1dcd5cd7be83a3e3f7c466096221e3f4b0cd89b5205fcbf3c1fe1cd19aea77facae4980a78ef1f7943cbaac2 WHIRLPOOL 51a5ccd8403baffc7b1365a456ed807b5f43fc6dc1a789566344c8ef7426e340481dab8707caf836392a666684ea4ebb58bd48695cf27d7f2755426f429da8fb
|
||||
DIST calamares-2.4.2.tar.gz 2137039 SHA256 4620fd4e9c2d9868e6c20a5c600f123e91080f7ef3a7c6ea55314aa57841b96a SHA512 152857f256f15ff72c44087baf8d4d9d452c5692e131334dd429f40c0e212eac01178352fd17f4020a128f880d3a91dbd634500384d53752d4313a08de816112 WHIRLPOOL 1aa6919a461d5b02a43a4cdbd580a9e7fc9bdc3b048f467f082c4d053c83e5bae5f5777439870828d12153789aac2e4f3b4b6868732dd7c70b0baec3ad4d65c3
|
||||
|
@ -1,33 +0,0 @@
|
||||
# Copyright 1999-2015 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Id$
|
||||
|
||||
EAPI=5
|
||||
|
||||
inherit eutils java-pkg-2
|
||||
|
||||
MY_PV_1="${PV/_beta/b}"
|
||||
MY_PV="${MY_PV_1/_rc/}"
|
||||
MY_URI_PV_1="${PV/rc/}"
|
||||
MY_URI_PV="${MY_URI_PV_1//_/%20}"
|
||||
|
||||
DESCRIPTION="Java GUI for managing BibTeX and other bibliographies"
|
||||
HOMEPAGE="http://jabref.sourceforge.net/"
|
||||
SRC_URI="mirror://sourceforge/jabref/JabRef-${MY_PV}.jar"
|
||||
|
||||
LICENSE="GPL-2"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64"
|
||||
|
||||
RDEPEND=">=virtual/jre-1.6"
|
||||
|
||||
S="${WORKDIR}"
|
||||
|
||||
src_unpack() {
|
||||
cp -v "${DISTDIR}/${A}" . || die
|
||||
}
|
||||
|
||||
src_install() {
|
||||
java-pkg_newjar JabRef-${MY_PV}.jar
|
||||
java-pkg_dolauncher ${PN} --jar ${PN}.jar
|
||||
}
|
@ -1,36 +0,0 @@
|
||||
# Copyright 1999-2015 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Id$
|
||||
|
||||
EAPI=5
|
||||
|
||||
inherit eutils java-pkg-2
|
||||
|
||||
MY_PV_1="${PV/_beta/b}"
|
||||
MY_PV="${MY_PV_1/_rc/}"
|
||||
MY_URI_PV_1="${PV/rc/}"
|
||||
MY_URI_PV="${MY_URI_PV_1//_/%20}"
|
||||
|
||||
DESCRIPTION="Java GUI for managing BibTeX and other bibliographies"
|
||||
HOMEPAGE="http://jabref.sourceforge.net/"
|
||||
SRC_URI="mirror://sourceforge/jabref/JabRef-${MY_PV}.jar"
|
||||
|
||||
LICENSE="GPL-2"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64"
|
||||
|
||||
RDEPEND=">=virtual/jre-1.6"
|
||||
|
||||
S="${WORKDIR}"
|
||||
|
||||
src_unpack() {
|
||||
cp -v "${DISTDIR}/${A}" . || die
|
||||
jar xf ${A} images/JabRef-icon-48.png || die
|
||||
}
|
||||
|
||||
src_install() {
|
||||
java-pkg_newjar JabRef-${MY_PV}.jar
|
||||
java-pkg_dolauncher ${PN} --jar ${PN}.jar
|
||||
newicon images/JabRef-icon-48.png JabRef-bin-icon.png
|
||||
make_desktop_entry ${PN} JabRef-bin JabRef-bin-icon Office
|
||||
}
|
@ -1,33 +0,0 @@
|
||||
# Copyright 1999-2015 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Id$
|
||||
|
||||
EAPI=5
|
||||
|
||||
inherit eutils java-pkg-2
|
||||
|
||||
MY_PV_1="${PV/_beta/b}"
|
||||
MY_PV="${MY_PV_1/_rc/}"
|
||||
MY_URI_PV_1="${PV/rc/}"
|
||||
MY_URI_PV="${MY_URI_PV_1//_/%20}"
|
||||
|
||||
DESCRIPTION="Java GUI for managing BibTeX and other bibliographies"
|
||||
HOMEPAGE="http://jabref.sourceforge.net/"
|
||||
SRC_URI="mirror://sourceforge/jabref/JabRef-${MY_PV}.jar"
|
||||
|
||||
LICENSE="GPL-2"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64"
|
||||
|
||||
RDEPEND=">=virtual/jre-1.6"
|
||||
|
||||
S="${WORKDIR}"
|
||||
|
||||
src_unpack() {
|
||||
cp -v "${DISTDIR}/${A}" . || die
|
||||
}
|
||||
|
||||
src_install() {
|
||||
java-pkg_newjar JabRef-${MY_PV}.jar
|
||||
java-pkg_dolauncher ${PN} --jar ${PN}.jar
|
||||
}
|
@ -1,36 +0,0 @@
|
||||
# Copyright 1999-2015 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Id$
|
||||
|
||||
EAPI=5
|
||||
|
||||
inherit eutils java-pkg-2
|
||||
|
||||
MY_PV_1="${PV/_beta/b}"
|
||||
MY_PV="${MY_PV_1/_rc/}"
|
||||
MY_URI_PV_1="${PV/rc/}"
|
||||
MY_URI_PV="${MY_URI_PV_1//_/%20}"
|
||||
|
||||
DESCRIPTION="Java GUI for managing BibTeX and other bibliographies"
|
||||
HOMEPAGE="http://jabref.sourceforge.net/"
|
||||
SRC_URI="mirror://sourceforge/jabref/JabRef-${MY_PV}.jar"
|
||||
|
||||
LICENSE="GPL-2"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64"
|
||||
|
||||
RDEPEND=">=virtual/jre-1.6"
|
||||
|
||||
S="${WORKDIR}"
|
||||
|
||||
src_unpack() {
|
||||
cp -v "${DISTDIR}/${A}" . || die
|
||||
jar xf ${A} images/JabRef-icon-48.png || die
|
||||
}
|
||||
|
||||
src_install() {
|
||||
java-pkg_newjar JabRef-${MY_PV}.jar
|
||||
java-pkg_dolauncher ${PN} --jar ${PN}.jar
|
||||
newicon images/JabRef-icon-48.png JabRef-bin-icon.png
|
||||
make_desktop_entry ${PN} JabRef-bin JabRef-bin-icon Office
|
||||
}
|
@ -1,3 +1,2 @@
|
||||
DIST python-systemd-230.tar.gz 39329 SHA256 656a83ff695f5de7d63411a86ea38601ad5a918595eebd0817d7b8e68642c64d SHA512 3c26c59b9005a45c3aeea8a6838ece9b5aa27dd7394ebe75319c1536b52462a847f18a79fdc8cf3bf6df9a70af63c84d5ff66a9587519dd9a006cc3df4966ce8 WHIRLPOOL 0de7ff6919bdf1c6c9cdafd71944801396157281fae1583bb060da4cf800369f97bb0c9f484f81635ed8b2e170db2bbbecf59adac0470a910167333f93c607e6
|
||||
DIST python-systemd-231.tar.gz 44430 SHA256 2c9cf53d041374898beead0c6f3b042c7d5b52425e6eb4d4b3c583d7eac12eea SHA512 b1567bd8e99025cc3b5aaeaab6539af8a5307068c403c0f1628bebc518ded80d0843b804244d1f252c858229f7f9578ce9aa988ded25f55999b0d355ce8a3455 WHIRLPOOL 4a1e05687080e8613ae607f837f39672727e60fc7bca1bca445f46413ce16280ab3bfaa30e969414d0da41f06420b7ef59043d2624dc50342cbe2d6df6add449
|
||||
DIST python-systemd-232.tar.gz 49211 SHA256 fc904704faa3dc2888a7336f1c660329c152fd4afb583267ef5d63c4a7f663a1 SHA512 3dfe8a17cd52fdcfce519ff1a64989ba153107d64839c95f93d8266239ed57d0d3510616726a1ab14dfa1b6df8216dc1d8e337d6240d1350378ec58148336325 WHIRLPOOL 34d2d0d1e11575b7fd6497f0543265542bbf7d68dd5a1a3e1c036e5a2518709254d04ee73794d72cb4c51d8f769079cede702fe61d1db7baa4993c213b8e9c2d
|
||||
DIST python-systemd-233.tar.gz 49680 SHA256 efb5c440d7ca05ce1fce48c14508177c0002663ea933e16eaf88105f1ad8dfe7 SHA512 92a6cc7123db586e5ae5fbb56e5065b17be9da47ced9dbc5920d80b7db7f56d15b127e72d30889c5b24b119724a33f68be1ef322529620ed95b0f95707e4c2ab WHIRLPOOL a564098a7362fa48b50ac5a28111746d3a35a6602bf313d04f0e5c63078b8c0e2c84e7e648c572dd09ac13122a709bb4f6d9eb2548e08f75a367bd363a594fb1
|
||||
|
@ -1,28 +0,0 @@
|
||||
From a129428dcd92095dc5f3c7ac4b4f096181129063 Mon Sep 17 00:00:00 2001
|
||||
From: Mike Gilbert <floppym@gentoo.org>
|
||||
Date: Sat, 19 Dec 2015 09:42:49 -0500
|
||||
Subject: [PATCH] test_daemon: Define a default value for SO_PASSCRED
|
||||
|
||||
The socket module seems to be missing this in python2.7.
|
||||
---
|
||||
systemd/test/test_daemon.py | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/systemd/test/test_daemon.py b/systemd/test/test_daemon.py
|
||||
index e055048..8c776d5 100644
|
||||
--- a/systemd/test/test_daemon.py
|
||||
+++ b/systemd/test/test_daemon.py
|
||||
@@ -228,7 +228,9 @@ def test_notify_with_socket(tmpdir):
|
||||
path = tmpdir.join('socket').strpath
|
||||
sock = socket.socket(socket.AF_UNIX, socket.SOCK_DGRAM)
|
||||
sock.bind(path)
|
||||
- sock.setsockopt(socket.SOL_SOCKET, socket.SO_PASSCRED, 1)
|
||||
+ # SO_PASSCRED is not defined in python2.7
|
||||
+ SO_PASSCRED = getattr(socket, 'SO_PASSCRED', 16)
|
||||
+ sock.setsockopt(socket.SOL_SOCKET, SO_PASSCRED, 1)
|
||||
os.environ['NOTIFY_SOCKET'] = path
|
||||
|
||||
assert notify('READY=1') == True
|
||||
--
|
||||
2.6.4
|
||||
|
@ -1,63 +0,0 @@
|
||||
From 177ac6d894e362b0d22a2765db280abed71cc07f Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
||||
Date: Thu, 22 Sep 2016 07:46:59 -0400
|
||||
Subject: [PATCH 1/6] tests: skip fdstore tests if not implemented
|
||||
|
||||
Should fix #12.
|
||||
---
|
||||
systemd/test/test_daemon.py | 18 +++++++++++++++---
|
||||
1 file changed, 15 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/systemd/test/test_daemon.py b/systemd/test/test_daemon.py
|
||||
index 215f1f8..e827e1d 100644
|
||||
--- a/systemd/test/test_daemon.py
|
||||
+++ b/systemd/test/test_daemon.py
|
||||
@@ -16,6 +16,15 @@ from systemd.daemon import (booted,
|
||||
import pytest
|
||||
|
||||
@contextlib.contextmanager
|
||||
+def skip_enosys():
|
||||
+ try:
|
||||
+ yield
|
||||
+ except OSError as e:
|
||||
+ if e.errno == errno.ENOSYS:
|
||||
+ pytest.skip()
|
||||
+ raise
|
||||
+
|
||||
+@contextlib.contextmanager
|
||||
def closing_socketpair(family):
|
||||
pair = socket.socketpair(family)
|
||||
try:
|
||||
@@ -200,7 +209,8 @@ def test_listen_fds_default_unset():
|
||||
|
||||
def test_notify_no_socket():
|
||||
assert notify('READY=1') == False
|
||||
- assert notify('FDSTORE=1', fds=[]) == False
|
||||
+ with skip_enosys():
|
||||
+ assert notify('FDSTORE=1', fds=[]) == False
|
||||
assert notify('FDSTORE=1', fds=[1,2]) == False
|
||||
assert notify('FDSTORE=1', pid=os.getpid()) == False
|
||||
assert notify('FDSTORE=1', pid=os.getpid(), fds=(1,)) == False
|
||||
@@ -216,7 +226,8 @@ def test_notify_bad_socket():
|
||||
with pytest.raises(connection_error):
|
||||
notify('READY=1')
|
||||
with pytest.raises(connection_error):
|
||||
- notify('FDSTORE=1', fds=[])
|
||||
+ with skip_enosys():
|
||||
+ notify('FDSTORE=1', fds=[])
|
||||
with pytest.raises(connection_error):
|
||||
notify('FDSTORE=1', fds=[1,2])
|
||||
with pytest.raises(connection_error):
|
||||
@@ -234,7 +245,8 @@ def test_notify_with_socket(tmpdir):
|
||||
os.environ['NOTIFY_SOCKET'] = path
|
||||
|
||||
assert notify('READY=1') == True
|
||||
- assert notify('FDSTORE=1', fds=[]) == True
|
||||
+ with skip_enosys():
|
||||
+ assert notify('FDSTORE=1', fds=[]) == True
|
||||
assert notify('FDSTORE=1', fds=[1,2]) == True
|
||||
assert notify('FDSTORE=1', pid=os.getpid()) == True
|
||||
assert notify('FDSTORE=1', pid=os.getpid(), fds=(1,)) == True
|
||||
--
|
||||
2.10.0
|
||||
|
@ -1,30 +0,0 @@
|
||||
From b9767792b97fe56b37bb59ee3d207ae359f1651c Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
||||
Date: Thu, 22 Sep 2016 09:52:58 -0400
|
||||
Subject: [PATCH 2/6] docs: fix sphinx format warning
|
||||
|
||||
build/lib.linux-x86_64-3.5/systemd/journal.py:docstring of systemd.journal.stream:15: WARNING: Literal block expected; none found.
|
||||
---
|
||||
systemd/journal.py | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/systemd/journal.py b/systemd/journal.py
|
||||
index e930164..a74d62f 100644
|
||||
--- a/systemd/journal.py
|
||||
+++ b/systemd/journal.py
|
||||
@@ -461,9 +461,9 @@ def stream(identifier, priority=LOG_DEBUG, level_prefix=False):
|
||||
|
||||
will produce the following message in the journal::
|
||||
|
||||
- PRIORITY=7
|
||||
- SYSLOG_IDENTIFIER=myapp
|
||||
- MESSAGE=message...
|
||||
+ PRIORITY=7
|
||||
+ SYSLOG_IDENTIFIER=myapp
|
||||
+ MESSAGE=message...
|
||||
|
||||
Using the interface with print might be more convenient:
|
||||
|
||||
--
|
||||
2.10.0
|
||||
|
@ -1,29 +0,0 @@
|
||||
From c3c412f90e481b88ca897e8542ced207c445c757 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
||||
Date: Thu, 22 Sep 2016 09:59:04 -0400
|
||||
Subject: [PATCH 3/6] build-sys: add doc-sync target
|
||||
|
||||
---
|
||||
Makefile | 6 +++++-
|
||||
1 file changed, 5 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index df0555c..23b452e 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -53,7 +53,11 @@ sphinx-%: build
|
||||
check: build
|
||||
(cd $(builddir) && $(PYTHON) -m py.test . ../../docs $(TESTFLAGS))
|
||||
|
||||
+www_target = www.freedesktop.org:/srv/www.freedesktop.org/www/software/systemd/python-systemd
|
||||
+doc-sync:
|
||||
+ rsync -rlv --delete --omit-dir-times build/html/ $(www_target)/
|
||||
+
|
||||
TAGS: $(shell git ls-files systemd/*.[ch])
|
||||
$(ETAGS) $+
|
||||
|
||||
-.PHONY: build install dist clean distclean TAGS
|
||||
+.PHONY: build install dist clean distclean TAGS doc-sync
|
||||
--
|
||||
2.10.0
|
||||
|
@ -1,58 +0,0 @@
|
||||
From 35a5b281adea321ea3f7b7d688a994e735366fb0 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
||||
Date: Thu, 22 Sep 2016 20:12:15 -0400
|
||||
Subject: [PATCH 4/6] tests: add workaround for pre-232 system returning EINVAL
|
||||
on some flags
|
||||
|
||||
---
|
||||
systemd/test/test_journal.py | 20 +++++++++++++++-----
|
||||
1 file changed, 15 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/systemd/test/test_journal.py b/systemd/test/test_journal.py
|
||||
index 0902183..dceec3f 100644
|
||||
--- a/systemd/test/test_journal.py
|
||||
+++ b/systemd/test/test_journal.py
|
||||
@@ -21,6 +21,13 @@ def skip_enosys():
|
||||
pytest.skip()
|
||||
raise
|
||||
|
||||
+@contextlib.contextmanager
|
||||
+def skip_valueerror():
|
||||
+ try:
|
||||
+ yield
|
||||
+ except ValueError:
|
||||
+ pytest.skip()
|
||||
+
|
||||
def test_priorities():
|
||||
p = journal.JournalHandler.mapPriority
|
||||
|
||||
@@ -62,10 +69,12 @@ def test_reader_init_flags():
|
||||
def test_reader_os_root(tmpdir):
|
||||
with pytest.raises(ValueError):
|
||||
journal.Reader(journal.OS_ROOT)
|
||||
- j1 = journal.Reader(path=tmpdir.strpath,
|
||||
- flags=journal.OS_ROOT)
|
||||
- j2 = journal.Reader(path=tmpdir.strpath,
|
||||
- flags=journal.OS_ROOT | journal.CURRENT_USER)
|
||||
+ with skip_valueerror():
|
||||
+ j1 = journal.Reader(path=tmpdir.strpath,
|
||||
+ flags=journal.OS_ROOT)
|
||||
+ with skip_valueerror():
|
||||
+ j2 = journal.Reader(path=tmpdir.strpath,
|
||||
+ flags=journal.OS_ROOT | journal.CURRENT_USER)
|
||||
j3 = journal.Reader(path=tmpdir.strpath,
|
||||
flags=journal.OS_ROOT | journal.SYSTEM_ONLY)
|
||||
|
||||
@@ -91,7 +100,8 @@ def test_reader_init_path_fd(tmpdir):
|
||||
j1 = journal.Reader(path=fd)
|
||||
assert list(j1) == []
|
||||
|
||||
- j2 = journal.Reader(journal.SYSTEM, path=fd)
|
||||
+ with skip_valueerror():
|
||||
+ j2 = journal.Reader(journal.SYSTEM, path=fd)
|
||||
assert list(j2) == []
|
||||
|
||||
j3 = journal.Reader(journal.CURRENT_USER, path=fd)
|
||||
--
|
||||
2.10.0
|
||||
|
@ -1,55 +0,0 @@
|
||||
From 8024fc61719d15b47ace1973b6b901881e17ff2f Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
||||
Date: Thu, 22 Sep 2016 20:41:21 -0400
|
||||
Subject: [PATCH 5/6] _reader: use proper ifdef guard for sd_j_open_files_fd
|
||||
|
||||
---
|
||||
systemd/_reader.c | 10 +++++++---
|
||||
1 file changed, 7 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/systemd/_reader.c b/systemd/_reader.c
|
||||
index 0f6fd3f..3a2c218 100644
|
||||
--- a/systemd/_reader.c
|
||||
+++ b/systemd/_reader.c
|
||||
@@ -283,7 +283,6 @@ static int Reader_init(Reader *self, PyObject *args, PyObject *keywds) {
|
||||
Py_END_ALLOW_THREADS
|
||||
}
|
||||
} else if (_files) {
|
||||
-#ifdef HAVE_JOURNAL_OPEN_FILES
|
||||
_cleanup_Py_DECREF_ PyObject *item0 = NULL;
|
||||
|
||||
item0 = PySequence_GetItem(_files, 0);
|
||||
@@ -293,9 +292,13 @@ static int Reader_init(Reader *self, PyObject *args, PyObject *keywds) {
|
||||
if (!strv_converter(_files, &files))
|
||||
return -1;
|
||||
|
||||
+#ifdef HAVE_JOURNAL_OPEN_FILES
|
||||
Py_BEGIN_ALLOW_THREADS
|
||||
r = sd_journal_open_files(&self->j, (const char**) files, flags);
|
||||
Py_END_ALLOW_THREADS
|
||||
+#else
|
||||
+ r = -ENOSYS;
|
||||
+#endif
|
||||
} else {
|
||||
_cleanup_free_ int *fds = NULL;
|
||||
size_t n_fds;
|
||||
@@ -303,13 +306,14 @@ static int Reader_init(Reader *self, PyObject *args, PyObject *keywds) {
|
||||
if (!intlist_converter(_files, &fds, &n_fds))
|
||||
return -1;
|
||||
|
||||
+#ifdef HAVE_JOURNAL_OPEN_DIRECTORY_FD
|
||||
Py_BEGIN_ALLOW_THREADS
|
||||
r = sd_journal_open_files_fd(&self->j, fds, n_fds, flags);
|
||||
Py_END_ALLOW_THREADS
|
||||
- }
|
||||
#else
|
||||
- r = -ENOSYS;
|
||||
+ r = -ENOSYS;
|
||||
#endif
|
||||
+ }
|
||||
} else {
|
||||
Py_BEGIN_ALLOW_THREADS
|
||||
r = sd_journal_open(&self->j, flags);
|
||||
--
|
||||
2.10.0
|
||||
|
@ -1,27 +0,0 @@
|
||||
From 911591a1188e03942e60f2ab1abf91562904f49e Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
||||
Date: Thu, 22 Sep 2016 20:24:31 -0400
|
||||
Subject: [PATCH 6/6] build-sys: import "pytest" instead of "py.test"
|
||||
|
||||
Fixes the following error in rawhide:
|
||||
/usr/bin/python3: loader for pytest cannot handle py.test
|
||||
---
|
||||
Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 23b452e..b10d6d9 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -51,7 +51,7 @@ sphinx-%: build
|
||||
@echo Output has been generated in build/$*
|
||||
|
||||
check: build
|
||||
- (cd $(builddir) && $(PYTHON) -m py.test . ../../docs $(TESTFLAGS))
|
||||
+ (cd $(builddir) && $(PYTHON) -m pytest . ../../docs $(TESTFLAGS))
|
||||
|
||||
www_target = www.freedesktop.org:/srv/www.freedesktop.org/www/software/systemd/python-systemd
|
||||
doc-sync:
|
||||
--
|
||||
2.10.0
|
||||
|
@ -1,42 +0,0 @@
|
||||
# Copyright 1999-2016 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Id$
|
||||
|
||||
EAPI=6
|
||||
PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
|
||||
|
||||
inherit distutils-r1
|
||||
|
||||
DESCRIPTION="Python module for native access to the systemd facilities"
|
||||
HOMEPAGE="https://github.com/systemd/python-systemd"
|
||||
SRC_URI="https://github.com/systemd/python-systemd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
|
||||
|
||||
LICENSE="LGPL-2.1"
|
||||
SLOT="0"
|
||||
KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
|
||||
IUSE="test"
|
||||
|
||||
COMMON_DEPEND="
|
||||
sys-apps/systemd:0=
|
||||
"
|
||||
DEPEND="${COMMON_DEPEND}
|
||||
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
|
||||
"
|
||||
RDEPEND="${COMMON_DEPEND}
|
||||
!sys-apps/systemd[python(-)]
|
||||
"
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}"/232-0001-tests-skip-fdstore-tests-if-not-implemented.patch
|
||||
"${FILESDIR}"/232-0002-docs-fix-sphinx-format-warning.patch
|
||||
"${FILESDIR}"/232-0003-build-sys-add-doc-sync-target.patch
|
||||
"${FILESDIR}"/232-0004-tests-add-workaround-for-pre-232-system-returning-EI.patch
|
||||
"${FILESDIR}"/232-0005-_reader-use-proper-ifdef-guard-for-sd_j_open_files_f.patch
|
||||
"${FILESDIR}"/232-0006-build-sys-import-pytest-instead-of-py.test.patch
|
||||
)
|
||||
|
||||
python_test() {
|
||||
pushd "${BUILD_DIR}/lib" > /dev/null || die
|
||||
"${PYTHON}" -m pytest -v . || die
|
||||
popd > /dev/null || die
|
||||
}
|
@ -1,3 +1,4 @@
|
||||
DIST wings-1.1.1.tar.bz2 1932572 SHA256 1a75a39a1a4586b242558a879d611adf1566b86785750f48ba60d851c2e40d08 SHA512 e60727328c9431738736466444655f54694973e59ad73e60874450845b080bf65c6b784ee0cb06cdff98f3717841dfbeceb5e36a1c55d98f31f280b972b7a2e3 WHIRLPOOL 9868a2ef5571291fa98db5239d767026d3cb0962c417bea77d7555ed2ff3d7fcded2200cad9347f5c0bb39591037fac9096cb7518f8285d2a3597a607c557d5e
|
||||
DIST wings-1.5.4.tar.bz2 6213585 SHA256 bd04ca1c1237f3a6f29ce3f653015e21142b849b338a3d1ab8633e3c6bcde663 SHA512 fb0cab378703dad4a240f13b96b7522acb4c8466d01bc498e54baf8f4ff1ae497edc08f926889ff669f525ee9c6b787903a47fc78c66f2d9632a5fa45535ac3f WHIRLPOOL 1f0414b05b9b4a29bcc2288c31e68bf3c087b0f093951b4ed9c1f563567b3fa86aca57c595f5d656502d1962dc95902d810228845f284f588b24a1865ef759d4
|
||||
DIST wings-2.0.5.tar.bz2 2455836 SHA256 318b6f9479b04882f2307b60d78a0020d305ce66ee3293e22cc36bde2a7fe360 SHA512 d116c4d23043f79f80ecb76c9a0d2d0dec12169fb382ca0fc84a78c462541072ec7820bfbbaadfae39aee2a07512f346b845d3f4c6e133f2d80b0d12b07907b1 WHIRLPOOL 51bc7cf6a9bbfa02e04adda8d132ba06df848b822d0836fb66c437571a72d6603adab4834444407d4c7e037523485f021d92d030f261fb4e614813540178a1bb
|
||||
DIST wings-2.1.tar.bz2 2647932 SHA256 9a878a76f4003d8ea54b17ed492b7aad68b3f191169e4a140b9ff7d981927a34 SHA512 92a8b7b749117f382add0c724aad1996dfd7b57034557e354d5ebf7f7d7355df84cb708e7decbeadb573d4bc93a1e3c39a7afbde0fe949f07c5016079c712313 WHIRLPOOL 1ba9c19a168ea5b3ecabc720b437cccf78015e42bb2bc81e5efd9f330dcbefa1544b8551b59553249202fb6b5bc4f0f05375d85341f6ec972fa3dbb9f7993142
|
||||
|
@ -0,0 +1,69 @@
|
||||
diff --git a/icons/Makefile b/icons/Makefile
|
||||
index 4e5a43d..8622b38 100644
|
||||
--- a/icons/Makefile
|
||||
+++ b/icons/Makefile
|
||||
@@ -31,7 +31,7 @@ PS_ICONS=$(patsubst %,bluecube/%,$(notdir $(GEN_PS_ICONS)))
|
||||
# ----------------------------------------------------
|
||||
# FLAGS
|
||||
# ----------------------------------------------------
|
||||
-ERL_FLAGS +=
|
||||
+ERL_FLAGS += -pa ../ebin
|
||||
ERL_COMPILE_FLAGS += -Werror +debug_info
|
||||
|
||||
# ----------------------------------------------------
|
||||
diff --git a/icons/collect_bmp.erl b/icons/collect_bmp.erl
|
||||
index 073fe73..e29d232 100644
|
||||
--- a/icons/collect_bmp.erl
|
||||
+++ b/icons/collect_bmp.erl
|
||||
@@ -13,23 +13,21 @@
|
||||
|
||||
-module(collect_bmp).
|
||||
-export([start/0,start/1]).
|
||||
--import(lists, [reverse/1]).
|
||||
+
|
||||
+-include_lib("wings/e3d/e3d_image.hrl").
|
||||
|
||||
start() ->
|
||||
start(["icons","wings_icon.bundle"]).
|
||||
|
||||
start(Args) ->
|
||||
- io:put_chars("Loading"),
|
||||
do_start(Args, []).
|
||||
|
||||
do_start([InDir|[_|_]=T], Files) ->
|
||||
do_start(T, add_files(InDir, Files));
|
||||
do_start([OutFile], Files) ->
|
||||
- wx:new(),
|
||||
Icons = load_icons(Files),
|
||||
- io:nl(),
|
||||
Bin = term_to_binary(Icons, [compressed]),
|
||||
- io:format("Writing ~s\n", [OutFile]),
|
||||
+ %% io:format("Writing ~s\n", [OutFile]),
|
||||
ok = file:write_file(OutFile, Bin).
|
||||
|
||||
add_files(Dir, Acc) ->
|
||||
@@ -42,14 +40,16 @@ load_icons([Name|Ns]) ->
|
||||
load_icons([]) -> [].
|
||||
|
||||
load_icon(Name) ->
|
||||
- Image = wxImage:new(Name),
|
||||
- wxImage:ok(Image) orelse exit({failed_to_load, Name}),
|
||||
- W = wxImage:getWidth(Image),
|
||||
- H = wxImage:getHeight(Image),
|
||||
- RGB = wxImage:getData(Image),
|
||||
- case wxImage:hasAlpha(Image) of
|
||||
- true -> {4,W,H,RGB,wxImage:getAlpha(Image)};
|
||||
- false -> {3,W,H,RGB, <<>>}
|
||||
+ case e3d_image:load(Name) of
|
||||
+ #e3d_image{bytes_pp=4, width=W, height=H} = I ->
|
||||
+ #e3d_image{image=RGB} = e3d_image:convert(I, r8g8b8, 1, upper_left),
|
||||
+ #e3d_image{image=Alpha} = e3d_image:convert(I, a8, 1, upper_left),
|
||||
+ {4,W,H,RGB,Alpha};
|
||||
+ #e3d_image{bytes_pp=3, width=W, height=H} = I ->
|
||||
+ #e3d_image{image=RGB} = e3d_image:convert(I, r8g8b8, 1, upper_left),
|
||||
+ {3,W,H,RGB,<<>>};
|
||||
+ _ ->
|
||||
+ exit({failed_to_load, Name})
|
||||
end.
|
||||
|
||||
|
@ -0,0 +1,59 @@
|
||||
# Copyright 1999-2016 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Id$
|
||||
|
||||
EAPI=6
|
||||
inherit multilib
|
||||
|
||||
DESCRIPTION="Wings 3D is an advanced subdivision modeler"
|
||||
HOMEPAGE="http://www.wings3d.com/"
|
||||
SRC_URI="mirror://sourceforge/wings/${P}.tar.bz2"
|
||||
|
||||
LICENSE="BSD"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
|
||||
RDEPEND="
|
||||
>=dev-lang/erlang-18.1[smp,wxwidgets]
|
||||
dev-libs/cl
|
||||
media-libs/libsdl[opengl]
|
||||
"
|
||||
DEPEND="${RDEPEND}"
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}"/${PN}-2.1-wx.patch
|
||||
)
|
||||
|
||||
src_prepare() {
|
||||
sed -i \
|
||||
-e '/include_lib/s|"wings/|"../|' \
|
||||
$(find . -name '*'.erl) \
|
||||
|| die
|
||||
|
||||
default
|
||||
}
|
||||
|
||||
src_configure() {
|
||||
export ERL_PATH="/usr/$(get_libdir)/erlang/lib/"
|
||||
}
|
||||
|
||||
src_compile() {
|
||||
# Work around parallel make issues
|
||||
emake vsn.mk
|
||||
for subdir in intl_tools src e3d icons plugins_src; do
|
||||
emake -C ${subdir}
|
||||
done
|
||||
}
|
||||
|
||||
src_install() {
|
||||
WINGS_PATH=${ERL_PATH}/${P}
|
||||
dodir ${WINGS_PATH}
|
||||
|
||||
find -name 'Makefile*' -exec rm -f '{}' \;
|
||||
|
||||
insinto ${WINGS_PATH}
|
||||
doins -r e3d ebin icons plugins psd shaders src textures tools
|
||||
|
||||
newbin "${FILESDIR}"/wings.sh-r1 wings
|
||||
dodoc AUTHORS README
|
||||
}
|
@ -1,3 +1,4 @@
|
||||
DIST fldigi-3.23.06.tar.gz 2970900 SHA256 4c21a92f8f7a4070a2fc3687ab7cf0895ff105dfdef7a84efe4a9b4519e6cc21 SHA512 18c07304eb424be4d72301630e748a14ce4efa2868293489f15fa9e36e2ac3ed1de16513b2cdf73f2733798632669008d85f621dee0facf5c1d4391dbe67df16 WHIRLPOOL ebc957d2d3303a681b9638061918875125ce99a5ca277e2717d8bbb1e9d009267554813fa3bf47c391c5e138446b46db50bff989be806270d1e394d76d02de65
|
||||
DIST fldigi-3.23.12.tar.gz 3078572 SHA256 59ba6ad8304849cb92b3ec2251bd389f4dfa7755de07a4d1638f71b17c0b3cce SHA512 3dc2c9545cb39cddf67a12e49a9ba4570b7055e073dc54a4f1a6b0e5811f780fea2109559aba0837ecfb62407eb8d2735f1d84ad70cc0b5335c6f88cb7dee0ad WHIRLPOOL 8cca738b8ffb2966746a9b9e918a68d123a430aa0e9ac66f0a8bcb202388ece9389fc00e9dae14e57118476cf0dd7b4fd41415656e70b033c7c1dfb8850a54d3
|
||||
DIST fldigi-3.23.14.tar.gz 3115714 SHA256 09a1f32bd0e2708a314465990dae80135a86f582b183758513006ef01d4d2790 SHA512 9adfef9e5b9048bbcc43842260bdd1fde16370c0621215d416afc88c3f0c7c28f981a53859711225d0b4452a33a742e3a6add10a65b3c3dbecdba33e8ed3bea0 WHIRLPOOL 3ff920b152c1e7e8c691354fdf31f9c91297de281137efb12ff96364dab3337417f47f8a971d3769af2f9e6743ccba0b681a08568bee3692453184af2b3c5ac1
|
||||
DIST fldigi-3.23.15.tar.gz 3138313 SHA256 b55018b50f8ace203a633f23cab9b4b5a0c6e4bf6d0fcc1258de6497d274aadb SHA512 e5d96bc3c063374a7b12febee9d333a93f82213698718a3f4818247be65cf7be9893ce38c660482e8ee2128a148fa3a5fc74adb407f88668205158d09ab39ecc WHIRLPOOL 641f6e646259a95d1a65b51c64c64142037874b0728e0981ba49a3d061a32e0275821daf5b63d695383b63598f8ed0eb1b3e5e0195d02616227f44ff262da0bd
|
||||
|
@ -0,0 +1,40 @@
|
||||
# Copyright 1999-2016 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Id$
|
||||
|
||||
EAPI=5
|
||||
|
||||
DESCRIPTION="Sound card based multimode software modem for Amateur Radio use"
|
||||
HOMEPAGE="http://www.w1hkj.com/Fldigi.html"
|
||||
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
|
||||
|
||||
LICENSE="GPL-3"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE="hamlib nls portaudio pulseaudio sndfile"
|
||||
|
||||
RDEPEND="x11-libs/fltk:1[threads,xft]
|
||||
media-libs/libsamplerate
|
||||
media-libs/libpng:0
|
||||
x11-misc/xdg-utils
|
||||
dev-perl/RPC-XML
|
||||
dev-perl/Term-ReadLine-Perl
|
||||
hamlib? ( media-libs/hamlib )
|
||||
portaudio? ( >=media-libs/portaudio-19_pre20071207 )
|
||||
pulseaudio? ( media-sound/pulseaudio )
|
||||
sndfile? ( >=media-libs/libsndfile-1.0.10 )"
|
||||
DEPEND="${RDEPEND}
|
||||
nls? ( sys-devel/gettext )
|
||||
virtual/pkgconfig"
|
||||
|
||||
DOCS=( AUTHORS ChangeLog NEWS README )
|
||||
|
||||
src_configure() {
|
||||
econf $(use_with sndfile) \
|
||||
$(use_with portaudio) \
|
||||
$(use_with hamlib) \
|
||||
$(use_enable nls) \
|
||||
$(use_with pulseaudio) \
|
||||
--disable-silent-rules \
|
||||
--without-asciidoc
|
||||
}
|
@ -1 +1 @@
|
||||
Mon, 17 Oct 2016 12:40:39 +0000
|
||||
Mon, 17 Oct 2016 20:40:38 +0000
|
||||
|
@ -1 +1 @@
|
||||
Mon, 17 Oct 2016 12:40:39 +0000
|
||||
Mon, 17 Oct 2016 20:40:38 +0000
|
||||
|
File diff suppressed because one or more lines are too long
File diff suppressed because one or more lines are too long
Some files were not shown because too many files have changed in this diff Show More
Loading…
Reference in new issue