You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/pytest-datadir/pytest-datadir-1.3.1.ebuild

33 lines
698 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} )
inherit distutils-r1
DESCRIPTION="Pytest plugin for manipulating test data directories and files"
HOMEPAGE="https://github.com/gabrielcnr/pytest-datadir"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
distutils_enable_tests pytest
python_test() {
distutils_install_for_testing
pytest -vv || die "Tests fail with ${EPYTHON}"
}
python_install_all() {
distutils-r1_python_install
# Do not install license to /usr
rm "${D}/usr/LICENSE" || die
}