You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-im/telegram-desktop/telegram-desktop-2.1.13.ebuild

146 lines
3.8 KiB

# Copyright 2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
inherit cmake desktop flag-o-matic python-any-r1 xdg-utils
MY_P="tdesktop-${PV}-full"
DESCRIPTION="Official desktop client for Telegram"
HOMEPAGE="https://desktop.telegram.org"
SRC_URI="https://github.com/telegramdesktop/tdesktop/releases/download/v${PV}/${MY_P}.tar.gz"
LICENSE="GPL-3-with-openssl-exception"
SLOT="0"
KEYWORDS="amd64 ~ppc64"
IUSE="+alsa +dbus enchant +hunspell libressl pulseaudio +spell wayland +X"
RDEPEND="
!net-im/telegram-desktop-bin
app-arch/lz4:=
app-arch/xz-utils
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
dev-libs/xxhash
dev-qt/qtcore:5
dev-qt/qtgui:5[jpeg,png,wayland?,X(-)?]
dev-qt/qtimageformats:5
dev-qt/qtnetwork:5
dev-qt/qtsvg:5
dev-qt/qtwidgets:5[png,X(-)?]
media-fonts/open-sans
media-libs/fontconfig:=
>=media-libs/libtgvoip-2.4.4_p20200525[alsa?,pulseaudio?]
media-libs/openal[alsa?,pulseaudio?]
media-libs/opus:=
media-video/ffmpeg:=[alsa?,opus,pulseaudio?]
sys-libs/zlib[minizip]
virtual/libiconv
x11-libs/gtk+:3
dbus? (
dev-qt/qtdbus:5
dev-libs/libdbusmenu-qt[qt5(+)]
)
enchant? ( app-text/enchant:= )
hunspell? ( >=app-text/hunspell-1.7:= )
pulseaudio? ( media-sound/pulseaudio )
"
DEPEND="
${PYTHON_DEPS}
${RDEPEND}
dev-cpp/range-v3
=dev-cpp/ms-gsl-3*
"
BDEPEND="
>=dev-util/cmake-3.16
virtual/pkgconfig
"
REQUIRED_USE="
|| ( alsa pulseaudio )
|| ( X wayland )
spell? (
^^ ( enchant hunspell )
)
"
S="${WORKDIR}/${MY_P}"
pkg_pretend() {
if has ccache ${FEATURES}; then
ewarn
ewarn "ccache does not work with ${PN} out of the box"
ewarn "due to usage of precompiled headers"
ewarn "check bug https://bugs.gentoo.org/715114 for more info"
ewarn
fi
}
src_configure() {
local mycxxflags=(
-Wno-deprecated-declarations
-Wno-error=deprecated-declarations
-Wno-switch
)
append-cxxflags "${mycxxflags[@]}"
# TODO: unbundle header-only libs, ofc telegram uses git versions...
# it fals with tl-expected-1.0.0, so we use bundled for now to avoid git rev snapshots
# EXPECTED VARIANT
local mycmakeargs=(
-DDESKTOP_APP_DISABLE_CRASH_REPORTS=ON
-DDESKTOP_APP_USE_GLIBC_WRAPS=OFF
-DDESKTOP_APP_USE_PACKAGED=ON
-DDESKTOP_APP_USE_PACKAGED_EXPECTED=OFF
-DDESKTOP_APP_USE_PACKAGED_RLOTTIE=OFF
-DDESKTOP_APP_USE_PACKAGED_VARIANT=OFF
-DTDESKTOP_LAUNCHER_BASENAME="${PN}"
-DDESKTOP_APP_DISABLE_DBUS_INTEGRATION="$(usex dbus OFF ON)"
-DDESKTOP_APP_DISABLE_SPELLCHECK="$(usex spell OFF ON)" # enables hunspell (recommended)
-DDESKTOP_APP_USE_ENCHANT="$(usex enchant ON OFF)" # enables enchant and disables hunspell
)
if [[ -n ${MY_TDESKTOP_API_ID} && -n ${MY_TDESKTOP_API_HASH} ]]; then
einfo "Found custom API credentials"
mycmakeargs+=(
-DTDESKTOP_API_ID="${MY_TDESKTOP_API_ID}"
-DTDESKTOP_API_HASH="${MY_TDESKTOP_API_HASH}"
)
else
# https://github.com/telegramdesktop/tdesktop/blob/dev/snap/snapcraft.yaml
# Building with snapcraft API credentials by default
# Custom API credentials can be obtained here:
# https://github.com/telegramdesktop/tdesktop/blob/dev/docs/api_credentials.md
# After getting credentials you can export variables:
# export MY_TDESKTOP_API_ID="17349""
# export MY_TDESKTOP_API_HASH="344583e45741c457fe1862106095a5eb"
# and restart the build"
# you can set above variables (without export) in /etc/portage/env/net-im/telegram-desktop
# portage will use custom variable every build automatically
mycmakeargs+=(
-DTDESKTOP_API_ID="611335"
-DTDESKTOP_API_HASH="d524b414d21f4d37f08684c1df41ac9c"
)
fi
cmake_src_configure
}
pkg_postinst() {
xdg_desktop_database_update
xdg_icon_cache_update
xdg_mimeinfo_database_update
}
pkg_postrm() {
xdg_desktop_database_update
xdg_icon_cache_update
xdg_mimeinfo_database_update
}